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Unauthorized Use or Disclosure
Anritsu Company has prepared the product user documentation for use by Anritsu Company personnel and 
customers as a guide for the proper installation, operation, and maintenance of Anritsu Company equipment and 
software programs. The drawings, specifications, and information contained therein are the property of Anritsu 
Company, and any unauthorized use or disclosure of these drawings, specifications, and information is prohibited; 
they shall not be reproduced, copied, or used in whole or in part as the basis for manufacture or sale of the equipment 
or software programs without the prior written consent of Anritsu Company.

Export Management
The Anritsu products identified herein and their respective manuals may require an Export License or approval by 
the government of the product country of origin for re-export from your country. Before you export these products or 
any of their manuals, please contact Anritsu Company to confirm whether or not these items are export-controlled. 
When disposing of export-controlled items, the products and manuals must be broken or shredded to such a degree 
that they cannot be unlawfully used for military purposes.

Trademark Acknowledgments 
The following trademark acknowledgments are listed for one or more of the products mentioned in this publication:

• Windows, Microsoft Paint, Microsoft Word, Microsoft Access, Microsoft Excel, Microsoft 
PowerPoint, and Visual Studio are registered trademarks of Microsoft Corporation.

• USB Type-C is a registered trademark of the USB Implementers Forum, Inc.

• Intel i7 and i3 are registered trademarks of Intel Corporation

• IQ Fiber Master is trademark of Anritsu company

• All other trademarks mentioned are the property of their respective companies.

Warranty
The Anritsu sensor described in this guide is warranted against defects in materials and workmanship for three (3) 
years from the date of shipment. The accessories are warranted against defects in materials and workmanship for one 
(1) year from the date of shipment. Anritsu’s obligation covers repairing or replacing products which prove to be 
defective during the warranty period. Buyers shall prepay transportation charges for equipment returned to Anritsu 
for warranty repairs. Obligation is limited to the original purchaser. Anritsu is not liable for consequential damages. 

Limitation of Warranty

The foregoing warranty does not apply to Anritsu connectors that have failed due to normal wear. Also, the warranty 
does not apply to defects resulting from improper or inadequate maintenance, unauthorized modification or misuse, 
or operation outside of the environmental specifications of the product. No other warranty is expressed or implied, 
and the remedies provided herein are the Buyer’s sole and exclusive remedies.

Disclaimer of Warranties

To the maximum extent permitted by applicable law, Anritsu Company and its suppliers disclaim all warranties, 
either expressed or implied, including, but not limited to, implied warranties of merchantability and fitness for a 
particular purpose, with regard to the product. The user assumes the entire risk of using the product. Any liability of 
provider or manufacturer will be limited exclusively to product replacement. 

No Liability For Consequential Damages

To the maximum extent permitted by applicable law, in no event shall Anritsu Company or its suppliers be liable for 
any special, incidental, indirect, or consequential damages whatsoever (including, without limitation, damages for 
loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of 
the use of or inability to use the product, even if Anritsu Company has been advised of the possibility of such damages. 
Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or 
incidental damages, the above limitation may not apply to you.
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Safety
To reduce the risk of personal injury or loss related to equipment malfunction, Anritsu Company uses the 
following symbols to indicate safety-related information. You may encounter them on your products and in 
documentation. For your own safety, please read the information carefully before operating the equipment.

Safety Notices Used in Manuals  

Safety Symbols Used on Equipment and in Manuals

The following symbols are used inside or on the equipment near operation locations to provide information 
about safety items and operation precautions and status. Ensure that you clearly understand the meanings of 
the symbols and take the necessary precautions before operating the equipment. Some or all of the following 
symbols may or may not be used on Anritsu equipment. In addition, there may be other labels attached to 
products that are not shown in the diagrams in the manual.

Warning

Danger or Warning indicates a risk from a very hazardous condition or procedure that 
could result in light-to-severe injury or death, or loss related to equipment malfunction. 
Follow all safety precautions and procedures to minimize this risk.

Caution

Caution indicates a risk from a hazardous condition or procedure that could result in 
injury or loss related to equipment malfunction. Follow all safety precautions and 
procedures to minimize this risk.

This indicates a prohibited operation. The prohibited operation is indicated symbolically in or near the 
barred circle.

This indicates a compulsory safety precaution. The required operation is indicated symbolically in or 
near the circle.

This indicates a danger, warning, or caution. The contents are indicated symbolically in or near the 
triangle.

This indicates a note. The contents are described in the box.

This indicates a push button Out position (generally Off condition).

This indicates a push button In position (generally On condition).

This indicates an Off condition.

This indicates On condition.

This indicates Alternating Current (AC).

This indicates Direct Current (DC).
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Safety Symbols and Notices

Warning Always refer to the equipment manual when working near locations where the alert 
mark, shown on the left, is displayed. If equipment operation is conducted without 
heeding the advice in the manual, there is a risk of personal injury. In addition, the 
equipment performance may be reduced.

This alert mark is sometimes used with other marks and descriptions indicating other 
dangers.

Warning
This equipment may present a risk to electric shock. Only qualified service personnel 
should access areas where this alert mark is present. Ensure that precautions are taken 
and that appropriate lockout mechanisms are in place before proceeding to enter the 
areas presenting this risk.

Warning
Unless your equipment is rated for Ingress Protection (IP) or is otherwise ruggedized, it 
is not designed to withstand exposure to extreme environments or water. If your 
equipment gets wet or is dropped, remove external power and any user serviceable 
batteries from the equipment and contact Anritsu support for any additional precautions 
and instructions to bring the equipment back into service. Always follow the 
environmental operating and storage requirements listed in the product technical data 
sheet.

Warning
Before supplying power to this equipment, ensure that proper voltage and current 
source is connected as indicated on the equipment labeling. Your equipment may be 
supplied with an external power adapter or it may be connected directly to the mains 
supply. Be sure to always use the supplied external power adapter and cabling. If your 
equipment connects directly to the mains supply, the input may be auto sensing or 
require a switch setting to match your supplied voltage. If power is supplied to the 
equipment that does not match the input specifications printed on the equipment 
labeling, there is a risk of personal injury and damage to the equipment.

Warning
When supplying power to this equipment, connect the accessory 3-pin power cord to a 
3-pin grounded power outlet. If required, ground the instrument chassis to a suitable 
earth ground. If power is supplied without grounding the equipment, there is a risk of 
receiving a severe or fatal electric shock.

Warning This equipment cannot be repaired by the operator. Do not attempt to remove the 
equipment covers or to disassemble internal components. Only qualified service 
technicians with a knowledge of electrical fire and shock hazards should service this 
equipment. There are high-voltage parts in this equipment that present a risk of severe 
injury or fatal electric shock. In addition, there is a risk of damage to precision 
components.
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Warning
Laser radiation may be present at fiber-optic cable connectors and ports. This laser 
radiation could present a nominal ocular hazard from either direct viewing or by diffuse 
reflection. Do not view the emitted laser radiation directly or indirectly because damage 
to the eye or permanent blindness may result.

Warning

This product may be supplied with a rechargeable battery. Only use batteries that are 
designed for your equipment and that are supplied by Anritsu Company. Using an 
incorrect battery could present a safety hazard and cause personal injury or damage to 
the equipment and other loss. Batteries can potentially leak hazardous compounds into 
the environment. These hazardous compounds present a risk of injury or loss due to 
exposure. Anritsu Company recommends removing the battery for long-term storage of 
the instrument and storing the battery in a leak-proof plastic container. Follow the 
environmental storage requirements specified in the product technical data sheet and 
always comply with your regional disposal regulations.

Warning

NEVER touch parts where the label shown on the left is attached. Such parts are hotter 
than 55 degrees Celsius and you risk receiving a burn.

Caution

Electrostatic Discharge (ESD) can damage the highly sensitive circuits in the 
instrument. ESD is most likely to occur as test devices are being connected to, or 
disconnected from, the instrument’s front and rear panel ports and connectors. You can 
protect the instrument and test devices by wearing a static-discharge wristband. 
Alternatively, you can ground yourself to discharge any static charge by touching 
exposed, unpainted metal of the outer chassis of the grounded instrument before 
touching the instrument’s front and rear panel ports and connectors. Avoid touching the 
test port center conductors unless you are properly grounded and have eliminated the 
possibility of static discharge.

Repair of damage that is found to be caused by electrostatic discharge is not covered 
under warranty.
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Regulatory Compliance

Following compliance notices and declarations of conformity apply to the IQ Fiber Master. 

This equipment is categorized as Class A devices as noted below:

• A device marketed for use in an industrial application and is not intended for use in the home or 
residential area is classified as Class A. Class A equipment, commonly known as ISM (industrial, 
scientific, and medical) equipment, are for professional use in engineering and scientific applications 
commanding specialized training and good understanding of the English language. Products being sold 
in a commercial market for such applications have significantly less stringent emissions limits than 
Class B (residential) devices.

• A device that is marketed for use in the home or a residential area by the customer is classified as a 
Class B device. Class B verification is for devices that are marketed for in-home use, but are not 
permanently connected to a personal computer.Compliance Notifications

Note
Depending on the economic region/area that your equipment is marketed for, certain labels may not 
be applicable. Please refer to the markings affixed to your equipment, the product data sheet, and its 
declaration of conformity on https://www.anritsu.com
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CE Conformity Marking

European Parliament and Council Directive 2012/19/EC

UKCA Conformity Marking

RCM Conformity Marking

KCC Conformity Marking

Canadian ICES-001 and ICES-003 Conformity Marking

Recycle Marking

Anritsu affixes the CE Conformity marking onto its conforming products in 
accordance with Council Directives of The Council Of The European Communities in 
order to indicate that these products conform to the EMC, LVD, RoHS, and RED 
directive of the European Union (EU).

Equipment Marked with the crossed-out Wheelie Bin symbol complies with the 
European Parliament and Council Directive 2012/19/EC (the “WEEE Directive”) in 
the European Union.

For products placed on the EU market after August 13, 2012, please contact your 
local Anritsu representative at the end of the product’s useful life to arrange disposal 
in accordance with your initial contract and the local law.

Anritsu affixes the UKCA Conformity marking onto its conforming products in 
accordance with the United Kingdom conformity assessment body (CAB) in order to 
indicate that these products conform to the market of Great Britain (England, Wales, 
and Scotland).

Anritsu affixes the Regulatory Compliance Mark (RCM) onto its conforming products 
in accordance with the electromagnetic compliance regulations of Australia and New 
Zealand in order to indicate that these products conform to the EMC regulations of 
Australia and New Zealand.

Anritsu affixes the Korean Communications Commissions (KCC) mark onto its 
conforming products in accordance with the electromagnetic compliance regulations 
of Korea

CAN ICES-1(A)/NMB-1(A)

CAN ICES-3(A)/NMB-3(A)

Anritsu affixes the CAN ICES-1(A)/NMB-1(A) and CAN ICES-3(A)/NMB-3(A) 
compliance labels onto its conforming products in accordance with the following 
Canadian Interference-Causing Equipment Standards:
ICES-001 — Industrial, Scientific and Medical (ISM) Radio Frequency Generators
ICES-003 — Information Technology Equipment (ITE).

Anritsu affixes the universal recycle symbol onto its products to indicate that the 
marked part is made from recyclable materials and should be recycled. Materials 
should be recycled in accordance with your local regulatory requirements.
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Proposition 65 Notification

State of California Proposition 65 Notification: https://www.p65warnings.ca.gov 

Notification for California customers: Chemicals known to the state of California to cause cancer, birth defects, 
or other reproductive harm may be present in the product or its related accessories. For information, see: 
https://oag.ca.gov/prop65 

Effective August 31, 2018, the State of California requires customer notification of products manufactured 
after August 31, 2018 that contain substances listed in the Proposition 65 substance list, in amounts exceeding 
Significant Risk Levels/Dosage levels, which are known in the state of California to cause cancer, or birth 
defects, or reproductive harm. This requirement applies to products sold in California or products that may be 
exposed to people in the state of California. 

While Anritsu does not believe there is risk of significant exposure with our products, it is possible that some of 
the listed substances identified by Proposition 65 are present with the electronic components and instruments 
manufactured by Anritsu. Anritsu is providing this warning out of an abundance of caution to fully comply 
with the Proposition 65 Law and as an information service to our customers. 

Please visit https://oehha.ca.gov/proposition-65/chemicals for a complete listing of chemicals considered or 
listed under Proposition 65 (this list and web site are maintained by the Office of Environmental Health 
Hazard Assessment [OEHHA], one of six agencies under the umbrella of the California Environmental 
Protection Agency [CalEPA]).

Perchlorate Material Notification – Special Handling May Apply

Notification for California customers: this product uses a small Lithium battery installed internally on the 
circuit board that may contain perchlorate. Disposal may be regulated due to environmental considerations. 
Please contact your local authorities for disposal or recycling information. For information, see: 
http://www.dtsc.ca.gov/hazardouswaste/perchlorate 

Chinese RoHS Compliance Statement
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Product Compliance, and Safety

Warning Laser radiation may be present at fiber-optic cable connectors and ports. This laser radiation 
could present a nominal ocular hazard from either direct viewing or by diffuse reflection. Do 
not view the emitted laser radiation directly or indirectly because damage to the eye or 
permanent blindness may result. 

This family of product works in conjunction with class 1 laser products. Work should only be 
undertaken by trained individuals. Proper precaution should be taken when using class 1 
lasers and fiber optics.

The CE mark is a registered trademark of the European Community.

The WEEE mark is a registered trademark of the European Community.

The RCM mark is a registered trademark of the Australian Communications and Media 
Authority.

Administrative Measure on the Control of Pollution Caused by Electronic Information 
Products is a Chinese government regulation to control hazardous materials.

Anritsu affixes the Korean Communications Commissions (KCC) mark onto its conforming 
products in accordance with the electromagnetic compliance regulations of Korea.
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Notice
Anritsu Company has prepared this manual for use by Anritsu Company personnel and customers as a guide 
for the proper installation, operation, and maintenance of Anritsu Company equipment and computer 
programs. The drawings, specifications, and information contained therein are the property of Anritsu 
Company, and any unauthorized use  is prohibited; they shall not be reproduced, copied, or used in whole or in 
part as the basis for manufacture or sale of the equipment or software programs without the prior written 
consent of Anritsu Company.

Updates
For additional information and literature covering your product, visit the product page of your instrument on 
http://www.anritsu.com and select the Library tab.

Updates, if any, may be downloaded from the Anritsu Website. 

For the latest service and sales contact information in your area, please visit:
http://www.anritsu.com/contact-us.

Not all instrument models offer every option. Please refer to the Technical Data Sheet of your instrument for 
available options.

http://www.anritsu.com
http://www.anritsu.com/contact-us
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Chapter 1 — General Information

1-1 Introduction
This user guide covers the instrument overview, system functions, and other common features, along with a 
brief guide to the basic measurement concepts and setups. Most of the instrument operations are covered in 
specific chapters of this manual as listed below. Additionally, the MT2780A uses the MX280020A control 
software installed on a PC or laptop for controlling the IQ Fiber Master hardware. 

Note that whenever there is a new release of the control software, an Internet connection is required to verify 
the hardware license of the IQ Fiber Master Analyzer that is connected to your PC or laptop. Once the initial 
verification is confirmed the Internet connection is no longer required in performing necessary 
measurements/analysis.

The IQ Fiber Master User Guide provides setup instructions for the connection and usage of the PIM over 
CPRI and LTE RF over CPRI sensor and analyzer. 

LTE RF over CPRI differs from PIM over CPRI in these ways:

• LTE RF over CPRI (Option 752): Provides full spectral analysis of CPRI IQ streams either in absolute or 
relative frequency, and of LTE UL and DL signals. This function is analogous to a spectrum analyzer.

• PIM over CPRI (Option 754): (Requires options 752) Supports multiple PIM configurations while 
measuring PIM power level. Provides distance-to-PIM (DTP). PIM over CPRI measures PIM against live 
traffic to provide a truer picture of the impact of PIM at a cell site. 

• PIM Analytics (Option 755): (Requires options 752 and 754) Provides, PIM vs. Time, PIM distribution, 
PIM daily, and Heat Map data views. Reports include detailed pass/fail configuration check, long-term 
(24-hour) monitoring, a pass/fail of each UL showing the external or internal nature of failures, and UL 
and PIM spectra for each antenna branch.

Before You Begin

• Charge the instrument battery using the supplied battery charger until fully charged.

The following chapters provide information on the software user interface, such as instrument settings, 
measurement features, and menu overviews, for the featured option:

• Chapter 2, “Instrument Overview” provides information about the physical instrument, connectors, and 
other hardware interfaces.

• Chapter 3, “Making LTE RF over CPRI Measurements (Option 752)” provides information on the 
software user interface, such as instrument settings, measurement features, and menu overviews, for 
the spectrum analyzer.

• Chapter 4, “Making PIM-over-CPRI Measurements (Option 754)” provides information on the software 
user interface, such as instrument settings, measurement features, and menu overviews, for the 
real-time spectrum analyzer.

• Chapter 5, “PIM Analytics (Option 755)” provides information on the software user interface, such as 
instrument settings, measurement features, and menu overviews, for the 5GNR analyzer.

Note The instrument may reboot when the battery charge level is low and external power is removed.
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Additional Documentation

Table 1-1 lists the additional documents available for MT2780A. 

For additional information and literature covering your product, visit the product page of your instrument and 
select the Library tab:

https://www.anritsu.com/en-us/test-measurement/products/mt2780a

Document Conventions

The following conventions are used throughout the MT2780A documentation set.

Instrument Identification

When identifying a frequency option for the MT2780A, that option number is appended after the model 
number; example: MT2780A-0752.

User Interface

The MT2780A user interface consists of menus, buttons, toolbars, and dialog boxes.

User Interface Navigation

Elements in navigation paths are separated as follows: FILE > PREFERENCES > GENERAL.

1-2 Instrument Description 
The IQ Fiber Master MT2780A PIM and RF analyzer is a CPRI-based solution that provides critical PIM 
diagnosis across multiple bands and sectors using live traffic. Cell sites remain active during testing as this 
instrument uses a non-invasive process to report real-time results. Identify PIM levels, locations, and conduct 
RF spectrum analysis to efficiently hunt and debug PIM and interference issues.

Available Options

Table 1-2 lists the frequency options available with the MT2780A. 

1-3 Contacting Anritsu for Sales and Service 
To contact Anritsu, visit the following URL and select the services in your region:

http://www.anritsu.com/contact-us 

Table 1-1. Related Manuals

Document Part Number Description 

11410-01153 MS2780A IQ Fiber Master Technical Data Sheet

Table 1-2. IQ Fiber Master Frequency Options

Model  Frequency Range

MT2780A-0752 Making LTE RF over CPRI Measurements

MT2780A-0754 Making PIM-over-CPRI Measurements

MT2780A-0755 PIM Analytics

https://www.anritsu.com/en-us/test-measurement/products/mt2780a
http://www.anritsu.com/contact-us
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Chapter 2 — Instrument Overview

2-1 Introduction
This chapter provides an overview of the Anritsu MT2780A IQ Fiber Master. It describes the instrument 
hardware features, general system settings, instrument configurations, and the connector panels. 

This guide helps those personnel familiar with computers, test and measurement equipment to understand the 
IQ Fiber Master analyzer, optical tap, and the accompanying software, and to understand detecting and 
locating PIM.

For detailed information on the instrument’s user interface and functions, refer to the relevant chapter for 
your measurement: 

• Chapter 3, “Making LTE RF over CPRI Measurements (Option 752)”

• Chapter 4, “Making PIM-over-CPRI Measurements (Option 754)”

• Chapter 5, “PIM Analytics (Option 755)”
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2-2 IQ Fiber Master and Optical Tap Connector Panels
This section shows the front and back connector panels of MT2780A IQ Fiber Master analyzer and optical tap.

IQ Fiber Master and Optical Tap Front Connector Panel

Optical fiber cables are used to connect IQ Fiber Master and optical tap.

The front panel of the IQ Fiber Master analyzer consists of the following:

• SFP modules 

• Status light indicators

A green STS light signifies a successful connection between the radio and the BBU (base band unit). The SPF 
status lights are turned green if the fiber master is successfully connected to the optical tap.

The front panel of the optical tap consists of the following ports:

• Base Band Unit (BBH)

• Remote Radio Head (RRH)

• Uplink (UL)

• Downlink (DL)

1. Power light

2. Status light

3. Status lights for Small Form Pluggables (SFPs)

4. Receive input of SFP module (input port where the optical fiber is connected)

5. SFP modules (optional; see the Technical Data Sheet 11410-01153 for specific, recommended SPFs)

6. Optical Tap ports (see the Technical Data Sheet 11410-01153 for the optical tap part numbers)

Figure 2-1. IQ Fiber Master Analyzer (top) and Optical Tap (bottom) Front Connector Panel

Note Note that your optical tap connections may differ.

1 2 4

5

3

6
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IQ Fiber Master Back Connector Panel

The back panel of the IQ Fiber Master consists of power, USB and Ethernet ports. The Ethernet port is used to 
connect to the PC running the IQ Fiber Master control software.

1. USB Interface - Type-C®

2. USB Interface - Type A

3. Ethernet Ports (synchronization) (The remaining ports are reserved for future use.)

4. Ethernet Port (primary)

5. Power input port

Figure 2-2. IQ Fiber Master Back Connector Panel

3 4 51 2
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2-3 Installation of IQ Fiber Master Control Software (MX280020A)
The IQ Fiber Master control software MX280020A is installed on a PC or laptop that is connected to the IQ 
Fiber Master analyzer through an Ethernet cable. The IQ Fiber Master Control Software is used to set up the 
monitored CPRI link between the RRH and BBU, configure the different measurement types needed to make 
RF over CPRI, PIM over CPRI and PIM over CPRI Analytics measurements.

PC Requirements

Ensure that the computer (laptop, desktop, or tablet) meets these minimum requirements:

• Windows 10, 64-bit (recommended; Windows 7 minimum)

• 10 GB RAM memory (recommended; 8 GB minimum)

• Intel CORE i7 (recommended; Intel i3-6100 or AMD FX4350 minimum)

• 16 GB long-term storage (recommended; 8 GB minimum) 142 MB free

• USB ports (A and C)

• Internet connection

Follow the steps below to install the IQ Fiber Master Control Software (Windows 10):

1. Navigate to Control Panel>Programs> Uninstall a Program to uninstall the previous version of the 
software.

2. Download the latest version of IQ Fiber Master control software from the company’s product page:

https://www.anritsu.com/en-us/test-measurement/products/mt2780a

3. Launch the IQ fiber master executable file and follow the on-screen instructions.

If you want to familiarize yourself with the PC software, select 3. Run Tests tab, then click Help>Walkthrough. 
You can click the arrows on the bottom right to navigate through the software. If you want to exit the walk 
through click the red X on the bottom right most corner. 

Note
Save a copy of the site config and roster test data files in a different location because all the test data 
files will get deleted if a previous software version is uninstalled.

https://www.anritsu.com/en-us/test-measurement/products/mt2780a
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Connecting the IQ Fiber Master 

To connect the IQ Fiber Master follow the steps below: 

1. Using an Ethernet cable connect the IQ Fiber Master analyzer with a PC or laptop connected to the 
Internet. You may also use an Ethernet hub to connect the computer and analyzer. Contact your local IT 
department in case of any applicable restrictions.

2. Power On the IQ Fiber Master and wait for status light (STS) to turn green.

3. Click the Sensor drop-down menu of the 1. Site Editor tab, and select the connected sensor identified by 
the serial number.

.

4. Click the Connect button.  

Note The sensor serial number will always be preceded by MT2780A.

Figure 2-3. Selecting Sensor Serial Number 

Figure 2-4. Connecting IQ Fiber Master
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5. Click File> Licensing to verify the installed options. The Licensing dialog consists of License Key field, the 
sensor ID in the Machine ID field, and the licensed options: 

6. Check the connection status of the Sensor and SFPs which are shown at the bottom of the application 
window. See “Status Line” on page 2-21 for more about status. 

Figure 2-5. License Key and Machine ID Location

Figure 2-6. Sensor Connection Status

Note
The LOS, LOF and CPRI status lights will be shown as green if the fiber connections to the 
SFPs /Tap are properly connected. Any unused SFP ports will have red status lights.
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Connecting to the Tap

The Fiber Diagram button in 3. Run Tests tab shows the fiber-connectivity diagram using which the IQ Fiber 
Master analyzer and the optical tap are connected through optical fiber cables. The fiber-connectivity diagram 
is based on the Site Config and Roster data files loaded in the Site and Roster Editor tabs. The 
fiber-connectivity diagram is unique to the type of a run test.

Follow the steps below to connect the tap with the IQ Fiber Master:

1. Power on the IQ Fiber Master analyzer and verify if the sensor is connected (refer to the status line at its 
bottom). See Figure 2-7.

Figure 2-7. IQ Fiber Master Sensor and Tap Connected to computer
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2. Refer to Chapter 3, “Making LTE RF over CPRI Measurements (Option 752)”to configure the Site and 
Roster setup (CPRI test), if a pre-configured setup is not available.

3. Click the 3. Run Tests tab and load the site configuration and roster files for the site under test 
(pre-configured or new setup).

4. Select a test scenario listed under Roster Detail section, for example, Test ID #3.

5. Select the Config Check radio button and click Run: config check button on the top of window screen.

Figure 2-8. 3. Run Tests tab: Generating a Fiber Diagram
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6. If Config Check test fails click the Fiber Diagram button to visually verify the fiber connections.

Green lines between the SFP and the tap indicate a good fiber connection, yellow or red lines indicate a wrong 
connection. The graphic also shows the site's Sector names, bands, and test name/number to assure the user 
the correct site is ready for test (if configured).

Figure 2-9. Sample Fiber Connection Diagram
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2-4 MX280020A Control Software GUI Overview
The MS280020A control software is used to interface and control the IQ Fiber Master hardware. It consists of 
main menu, different measurement tabs along with control buttons that are unique to the selected tab.

The control software consists of the following:

• “Main Menu” 

• “File”

• “View”

• “Help”

• “Sensor”

• “Site Editor tab”

• “Roster Editor tab”

• “Run Tests tab”

• “Analyzer tab (Option 754)”

• “PIM vs Time tab (Option 755)”

• “PIM Distribution tab (Option 755)”

• “PIM Daily tab (for PIM Failure) (Option 755)”

• “Heat Map tab (Option 755)”

• “PIM Location tab (Option 754)”

• “Control Buttons”

The display of control buttons is different for the several tabs.

• Site Editor tab – Auto-detect, CPRI Analysis, and Stop

• Roster Editor tab – (no buttons)

• Run Test and the rest of the tabs – Run: (test), Stop, Add to Report, Review Results, Save Report, 
and Fiber Diagram

• “Status Line”

The Status line consists of these fields:

• Connected/Not Connected: Shows whether the sensor is connected.

• Sensor: Contains various messages from the sensor.

• LOS (Loss of Signal): Shows whether the sensor has obtained a signal.

• LOF (Loss of Frame): Shows whether the sensor has lost a frame (from an SFP).

• CPRI: Shows whether CPRI data/traffic is present.

• Temp: Shows the current, internal, sensor temperature.

• Engine: Displays the PIM engine/processor status.
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2-5 Main Menu
The main menu consists of File, View, Help, and Sensor menus.

File

The File menu is used for the following:

• Allows to check the installed options.

• Set preferences. 

• Reset the default settings.

• Quit the application.

Licensing...

For information on licensing refer to “Connecting the IQ Fiber Master” on page 2-5.

Upgrading IQ Fiber Master

If you get a message like this one, you need to upgrade your IQ Fiber Master. 

To upgrade an option the user must first purchase the option and after the order is processed (follow Anritsu 
customer service procedure) the option license is added to the MT2780A IQ Fiber Master license server, the 
user must open the IQ Fiber Master software while connected to their MT2780A Analyzer (HW has the 
licenses programmed in) with an Internet connection, the SW will check the server for active options (which 
can be found under File/Licensing) and will update the option licenses when it is found on the server.

Preferences...

Click File > Preferences to open Preferences dialog. Refer to “Preferences” on page 2-22 for more information 
about IQ Fiber Master preferences. 

Figure 2-10. Upgrade Feature Message

Note Anritsu recommends changing the Save directory to a preferred or other suitable directory.
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Reset to Defaults...

Click File > Reset to Defaults to reset all the saved settings, calibration data etc. You are prompted with a 
warning message before confirming the reset.

Quit

A warning message is displayed when you try to exit the application without saving the test results. Click Keep 
Results button to save the test results, otherwise select Discard Results and Continue to exit without saving.

Figure 2-11. Unstored Result Warning

Figure 2-12. Unstored Result Warning
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View

The View menu is used for the following:

• Allows to select Full Screen window.

• Generate a PIM report

• Load a new style-sheet (i.e. report appearance) or select an existing style sheets.

• Choose the GUI display color settings between Anritsu and Default. 

Report 

• Click View > Report to generate a PIM report consisting of site and instrument details. From the Report 
window you can create a new report, save the generated report, customize the report detail settings, 
preview and print the report. 

Figure 2-13. Report Dialog
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• Click Settings button found on top of the Report window to change the report settings.

See Appendix A, “Reports” for more information about report contents and printing.

Load

Click View>Load to load an existing stylesheet for generating PIM reports.

Anritsu and Default Color Theme

Click View menu and choose an appropriate color theme. 

Figure 2-14. Report Settings Dialog
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Help

Click Help menu to view Help files, check software updates, create or load diagnostics package etc.

Help Contents 

Provides a detailed, searchable list of help topics related to the product. Click Help>Help Contents.

Walkthrough 

Starts the product walk through on how to initiate a test. Click 3. Run Tests tab, then click 
Help>Walkthrough.

About IQ Fiber Master

Displays the release details (version and build information) in a dialog.

Figure 2-15. Help Menu

Figure 2-16. IQ Fiber Master Release Information Dialog
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Check for Updates... 

Checks for updates to the analytics application (this requires an Internet connection). 

Create Diagnostics Package 

Creates a file, which can be loaded later for troubleshooting by technical support personnel, including IQ 
vectors, log files, and configuration data.

Figure 2-17. IQ Fiber Master Check for Updates Dialog
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Load Diagnostics Package 

Loads a previously saved diagnostics file.

Sensor

The Sensor Main Menu choice provides these tasks. 

Figure 2-18. Sensor Main Menu
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Codeload... (Update the Sensor Firmware) 

This command checks and if applicable, updates the sensor with new firmware (this requires an Internet 
connection). Browse to the file’s location and click Load.

When the software update is complete, the analyzer displays this dialog:

Click OK to reboot the sensor (remember to click Connect) or Cancel to defer rebooting the sensor until a later 
time.

Figure 2-19. CodeLoad Firmware Dialog

Figure 2-20. CodeLoad Finished.
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Save Captures

Select One shot radio button to save captures to a specified directory as single one-shot capture (with a variable 
capture period of 1ms to 10s)

Select Continuous radio button to save captures to a specified directory as continuous capture with a delay 
ranging from1 to 99 minutes. 

Idle Capture allows the capturing of data at the specified interval (period) from 1 to 10000 ms.

Figure 2-21. One Shot Capture

Figure 2-22. Capture and Save: Continuous

Figure 2-23. Idle Capture
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Reboot Sensor

This option reboots the sensor.

About Sensor

Displays an information-only dialog containing data about the status of the sensor. 

Figure 2-24. Sensor Reboot Dialog

Note After a sensor is rebooted, click the Connect button.

Figure 2-25. Sensor Information
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Control Buttons

Run: testname

This button runs the test named in its label: Config Check, PIM Level, PIM Location, or Cross Sector. 

Stop

This button stops or suspends the test currently running.

Add to Report

This button is modal: in PIM Level mode, adds all the report segments to the report; and in CPRI Analysis 
mode, is greyed out to show its inactive status. Use this button to save the screenshot to the report.

Review Results

Use this button to display Reports which are fully explained in Appendix A, “Reports”.

Save Report

This button open the report window to allow you to edit the site details, header information etc. Refer to “View” 
on page 2-13 for more information.

Status Line

The Status line consists of these fields:

• Connected/Not Connected: Shows a small green circle and displays the name or serial number of the 
sensor. Shows a small red circle if a sensor is not connected.

• Sensor: Sensor displays OK for a good sensor connection; it shows Remote disconnected when sensor is 
not connected.

• LOS: Displays the status of Loss of Signal. Small green circles mean everything OK.

• LOF: Displays the status of Loss of Frame. Small green circles mean everything OK.

• CPRI: Displays the status of CPRI data/traffic. Small green circles indicate the traffic is present.

• Temp: Displays the current internal sensor temperature in Celsius.

• Engine: Displays the PIM current engine/processor status:

• Idle

• CPRI Analyzer

• Stopped CPRI Analyzer

• Timing Search 

• Measuring PIMPower 

• Stopped PIMPower 

• Checking Config 

• Stopped ConfigCheck

Note Ensure to click Add to Report button to save the screenshot to the report.

Figure 2-26. Status Line
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2-6 Preferences
Click File>Preferences to access various settings such as General, Config Check and Heatmap.Click the Apply 
button to confirm the selections; click X to return to the application.

General 

Click File > General to access General Setting, dB Units and Plot settings.

General Settings

Click File > Preferences > General > General settings to view the settings as shown the figure.

The General Settings consists of the following:

• CPU Throttle: Defines the ability to reduce / set CPU usage from 8 to 100%, where 100% being the 
maximum. Allows the CPU to be fully used in order to provide best performance and to minimize the 
time taken to perform the measurements. However users may need to reduce this value, especially for 
slower processors to improve stability of the PC / laptop or improve the battery life and CPU 
temperature of laptop/PC. Can also reduce this value during long term monitoring where time critical 
measurements are not so important.

• Measurement Interval: Defines the minimum interval between subsequent PIM measurements (on the 
same antenna).

• Observation Time: Defines the amount of data used for each measurement.

• Font Size: Used to change the font size for all text on all tabs

• Save Directory: Defines the directory where reports are to be stored in the computer.

• Test Vectors Directory: Defines the directory where the vectors (IQ data) are saved, these vectors are used 
for 'offline' demo purposes. 

Figure 2-27. General Settings
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dB Units

To modify the dB Unit settings follow the steps below:

• Click File > General > dB Units to view the noise floor for each vendor (and bandwidth).

The Advanced option in the RF over CPRI is used to measure noise floor of the RRH under test. See “Advanced 
(Set the Noise Floor)” on page 3-26 for more about measuring noise floor.

• Check Use dBlsb box to tell the analyzer to use/display units in dBlsb.

• Check Factor per BW box to expand the list of dBm factors.

• Click Reset Defaults button to collapse the list. Note that this holds good only for the other vendors,

But for the default vendors such as ALU and Nokia, checking the Factor per BW box expands and unchecking 
the box collapses the dBm factor list. Similarly checking the Reset Defaults box collapses the list.

Figure 2-28. dB Units for Noise Floor

Note

The default values are reference values and can be adjusted by running the Noise Floor 
(Advanced CPRI Analysis) measurement during a maintenance window (low traffic).



2-6 Preferences Instrument Overview

2-24 PN: 10580-00467  Rev. C MT2780A UG

Plot Settings

To modify the plot settings follow the steps below:

• Click File > General > Plot Settings.

• Click the Pen Width drop-down menu to increase or decrease the pen width.

• Click on the signal color under Colors (Light) section to choose a specific color of each signal for light view 
mode. Click on the color box to choose from the basic colors or slide the triangle to make a custom color.

• Click on the signal color under Colors (Dark) section to choose a specific color of each signal for dark view 
mode.

• Click Reset button to reset the selected width and color settings.

• Click Apply button to apply the settings.

Figure 2-29. General Plot Settings
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Config Check Rules

To modify Config Check test settings follow the steps below:

• Click File > Preferences > Config Check > Rules to view the config check test results parameters.

• Click the + sign to view a short description of the option along with additional fields with values if any.

• Check Show full details in results box to view the complete details of all the rules in the Results pane.

Figure 2-30. Config Check Rules

Figure 2-31. Config Check results with full details



2-6 Preferences Instrument Overview

2-26 PN: 10580-00467  Rev. C MT2780A UG

• Uncheck this box to view only the options listed as shown in Figure 2-32.

• Optical connectivity – Verify that the SFP is present, its data may be read, and it is receiving 
sufficient optical power. Adjust the minimum optical receive power and the maximum operating 
temperature.

• CPRI connectivity – Verify that the CPRI interface is synchronized, is receiving data, and no 
alarms are present. Note that this is the only rule that cannot be turned off.

• IQ Stream Capture – Check that the number of streams successfully captured match the number 
requested.

• RSSI/TSSI – Compare each IQ stream’s RSSI/TSSI with a valid range.

• Bandwidth – Check that the sample rate and AirStd of the IQ stream match the expected values.

• LTE ID Tx Configuration – Check the validity of the LTE identifier and the Tx configuration 
decoded from the broadcast channels.

Figure 2-32. Config Check Results
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Heatmap Rules

Follow the steps below to modify the heatmap settings:

• Click File > Preferences > Heatmap > Rules.

• Check All box to include all the PIM measurements in the heatmap summary.

• Check Internal/External box to include the details of the internal or external PIM in the heatmap 
summary.

• Click Apply button at the bottom of the window to apply the selected option.

Figure 2-33. Heatmap Rules
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2-7 Site Editor tab
The 1. Site Editor tab provides a way to define the equipment to be tested according to the testing protocol at a 
site. Notice the tabs numbered 1 through 3. These remind you of the order to set up a new site or start a new 
batch of measurements. Site Editor is the only tab that contains parameters needed to configure the CPRI 
Analysis test.

.

Note
An Internet connection is required for the first time a computer/laptop is connected and configured 
with MT2780A IQ Fiber Master, because the MT2780A software license will be verified with the 
license server. The Internet connection is not required after the initial configuration is completed.

Figure 2-34. 1. Site Editor tab

Note
Notice that after completing other measurements, the sequential order of the SFPs in Site Editor tab 
may be out of order.
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Control Buttons

Auto-detect: Determines the CPRI line rate, the air std, number of AxC's. The user needs to select the 
number of system fibers and vendor name BEFORE starting auto-detect.

CPRI Analysis: Starts an LTE RF over CPRI test. This button becomes active when a sensor is selected 
and the CPRI link is configured. After configuring your CPRI setup, click this button to 
activate the RF over CPRI spectrum analyzer view. 

Stop: Stops the CPRI Analysis testing. This button becomes active when a CPRI Analysis test 
or one of the Selected Tests is running.

Site Config Buttons

Details...: Site configuration details. 

New: Starts a new site configuration. Be careful to not write over the existing site config name.

Load...: Loads a configuration from a file.

Save...: Saves the file. You may change the path and name if desired.

Apply: Applies the changes so that the testing will use them.

Sensor Buttons

Sensor: Select from the list of connected sensors using this drop-down list.

Connect: Connect the selected Sensor. Activates the Auto-detect and CPRI Analysis buttons.

Disconnect: Disconnect the sensor. (This button is only active after a successful connection).

Editing/Copy to Buttons

Editing Sector: Use this drop-down list to select a sector that needs to be tested.

Copy to: Use this drop-down list to select the sector to which the edited sector is to be copied. 

Copy: Copies the sector selected in the Editing Sector to the Copy to sector.

Note All the Site Configuration files must be saved with si_ prefix for e.g. si_xxxxx.xml.
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CPRI (set up the CPRI interface)

Number of system 
fibers: Select the number based on how many fibers are connected to the sensor, typically three: 

two DL and one UL.

Fiber Mode: Select either Single or Multi Mode.

Fiber: Select the fiber via the SFP module it is connected to. 

UL: Select UL (uplink) or DL (downlink) from this drop-down list.(SFP1 is always a UL)

CPRI: Select the vendor by name or use Custom.

Rate: Set the rate 1 through 8 associated with the fiber.

Carriers: Set the carrier associated with the fiber.

CPRI Settings: Set the Bit width, Reserve bits, and Idle bits.

Air Std: Choose a broadband LTE standard. E1 and E2 are Ericsson optimized 
Down-Sampling/Compression sample rates, and S denotes a Samsung rate.

Figure 2-35. CPRI Settings 

Figure 2-36. LTE Air Standard List Sampling Rate
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These are the standard sampling rates:

• LTE 5 @ 7.68 MHZ

• LTE 10 @ 15.36 MHz

• LTE 15 @ 23.04 MHz

• LTE 20 @ 30.72 MHz

These are the down-sampling (compressed) rates:

• LTE15_E1 @ 19.2 MHz (Ericsson Optimized Sampling Line Rate 8 only : 15 MHz LTE: 
Re-Sample/Compression from 6 to 5 AxC Containers per AxC Group)

• LTE15_E2 @ 15.36 MHz (Ericsson LTE15: Dpwm-Sample/Compression from 6 to 4 AxC 
Containers Per AxC Group)

• LTE20_E1 @ 23.04 MHz (Ericsson LTE20: Down-Sample/Compression from 8 to 6 AxC 
Containers Per AxC Group)

• LTE20_E2 @ 19.2 MHz (Ericsson Optimized Sampling Line Rate 8 only: 20 MHz LTE: 
Re-Sample/Compression from 8 to 5 AxC Containers per AxC Group)

• LTE20_S @ 30.72 MHz (Samsung have adopted the full 30.72 MHz sampling rate for an 
LTE20 air std)

AxC Groups: Activate up to eight antenna-carrier groups. Adjusts the number of table rows. The 
frequency is automatically adjusted.

Clear RF Links: Clears the RF Links.

AxC Table: Enter the Antenna name (if the default names Ant1 through 8 are not appropriate) and 
additional description.
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CPRI Analysis (Option 752)

See Figure 2-37, “Analyzer tab: LTE RF over CPRI Mode (Relative Spectrum)” and “Starting the LTE RF over 
CPRI Mode” on page 3-6 for more information on CPRI Analysis. 

Figure 2-37. Analyzer tab: LTE RF over CPRI Mode (Relative Spectrum)
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RF (set up carriers)

These are the parameters for this section:

Number of RF 
systems: From 1 to 8.

System n: System number, 1 through n, depending upon the number selected in Number of systems. 

Carriers: This field specifies how many carriers will be part of this site.

Carrier n: Depending upon how many are specified by the Carriers field, this heading marks the 
beginning of a carrier.

Band n: Choose a band from the drop-down list. 

DL EARFCN: From 0 up to 99.

Freq: All 3GPP bands supported.

UL EARFCN: From 0 up to 99.

Freq: All 3GPP bands supported.

Clear CPRI Links: Clears the CPRI links.

Figure 2-38. 1. Site Editor tab: Number of RF systems
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Frequency Band: Use this button to display the Frequency Band dialog and set whether the system is UL 
or DL. If you do not know the 3GPP band but know the frequency, you can look it up on 
the dialog

.

Figure 2-39. Frequency Band
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2-8 Roster Editor tab
Use the 2. Roster Editor to set up the various tests for PIM over CPRI for a site including the downlinks (DL) 
and uplink (UL), the antennas, limits, and other measures. Refer to Chapter 4, “Making PIM-over-CPRI 
Measurements (Option 754)” and Chapter 5, “PIM Analytics (Option 755)” for more about the Roster Editor.

Figure 2-40. 2. Roster Editor tab

Note All the Roster files must be saved with tr_ prefix for e.g. tr_xxxxx.xml.
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Site Config Buttons

Load: Loads a site information file. This file is maintained by the Site Editor.

Roster File Buttons

Auto Generate: Will generate a roster based on site information file.

Load: Loads a roster file.

Save: Saves the roster file.

Apply: Applies the changes but does not save the file.

Roster Detail

Site ID: The site ID defined in site configuration details.

Sector Table: 

Sector: The name of the sector which this test runs against.

DL1: The primary downlink frequency.

DL2: The secondary downlink frequency.

UL: The uplink frequency.

Limit: The power limit for the PIM.

Desense: This is the amount of uplink noise floor rise due to PIM. It is an indication of the 
reduction in receive sensitivity of the receiving antenna.

IM: InterModulation scenarios can be manually created and edited, or automatically created 
by reading the Site information file and using the auto generate feature of the Roster Editor 
tab. The IM combinations (for e.g. IM1, IM3 etc.) can be obtained based on the defined 
carriers.

Antennas: Check the antennas to test.

Measure: Check the items that you want the test to measure.

Level: Specifies the dB and dBm value for spectrum and PIM.

Distance: Specifies that DTP will be measured.

Add Test

Click this button to add a test.

Delete Test

Click this button to delete a selected test.
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2-9 Run Tests tab
Use the 3. Run Tests tab to run the PIM over CPRI analysis as specified in the Site and Roster Editor tabs.

Follow the steps below to select and run a test:

1. Load the site and roster files. Refer to “Site Editor tab” on page 2-28 and “Roster Editor tab” on page 2-35 
sections on how to load the files.

2. Select a test under Roster Details section. Note that selected test will be highlighted in green.

3. Under Selected Test section, select Config Check radio button.

4. Click Run: config check button on the top of window to run the selected test.

5. If the config check test results fail click Fiber Diagram button on the top right corner of the window to 
verify the correctness of the optical fiber connection.

6. Fix the connection as shown in the fiber diagram dialog and run the test again.

.

Note
Ensure to run config check test before running any other available tests. Note that until the config 
check test is passed, the remaining tests will be disabled.

Figure 2-41. 3. Run Tests tab
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Control Buttons

Run: test name: This button is active when a connection to a sensor is active, and it changes name and 
function depending upon whether the selected test is one of these:

Stop: Stops the test in progress and resets all the controls to their pretest state.

Add to Report: Adds the results in the Selected Test > Results to the report.

Review Results: Displays the report.

Save Report: Saves the report.

Fiber Diagram: Displays the connection diagram for the site as given by the configuration file.

To run a test:

1. Click Sensor:sensorname to select the sensor to be involved in the test.

2. Click the Connect button. The Selected Test > Config Check control becomes active and so does the
Run: config check button. The Config Check is based on the Test ID selected in Roster Detail section.

3. Click Run: config check button. The Selected Test > PIM Level control becomes active.

The analyzer performs the configuration check, then prepares to run the PIM Level test.

4. Select Selected Test > PIM Level and the Run: button changes to Run: PIM level.

The analyzer performs the test, and prepares the analysis for the selected tests.

5. Click Run:PIM Level. Results of this test display in the bottom of the app.

Figure 2-42. Selected Test List

Figure 2-43. Selected Test Results
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Preliminary Configuration Checking

Configuration checking for any test is accomplished by building and saving, or loading a Site Configuration 
(sector-mapping to optical-fiber) file and a Roster file (test). The Site Editor and Roster Editor tabs maintain 
contents of the files, which can be done ahead of time, if site data are known. 

1. Connect the IQ Fiber Master analyzer with optical tap and PC/laptop. See “Connecting the IQ Fiber 
Master” on page 2-5.

2. Under 1. Site Editor tab, click Load...button to load the Site Config file and click Apply to save the file. 

Figure 2-44. 1. Site Editor tab: Preliminary Configuration Test Suite
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3. Under 2. Roster Editor tab, click Load...button to load the roster file and click Apply to save the file.

4. Click 3. Run Tests tab.

The analyzer checks the tests and posts available or invalid test in the Status column. 

Figure 2-45. 2. Roster Editor tab: Preliminary Configuration Test Suite

Figure 2-46. 3. Run Tests tab: Preliminary Configuration Test Suite
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Final Configuration Checking

After the preliminary configuration check and the fiber connections are complete, the system is ready for the 
final configuration check. 

To final-check a configuration:

1. Select Config Check radio button.

2. Click Run: config check button to check if the parameters pass.

See“Configuration Check” on page 4-4, and “Control Buttons” on page 2-21, for more information about the 
config check test.

Figure 2-47. Configuration Check Status

Figure 2-48. Running a Configuration Check
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2-10 Analyzer tab (Option 754)
The Analyzer tab is modal and the data and options it shows depend upon the path that displayed them. Use 
this tab to view the ongoing (or paused) test. 

PIM over CPRI Tests

See Figure 2-49, “Analyzer tab: PIM over CPRI Mode” and “PIM Measurement” on page 4-8 for more 
information on PIM over CPRI tests.

• The green trace is the actual uplink trace.

• The orange trace is the estimated PIM value.

Figure 2-49. Analyzer tab: PIM over CPRI Mode



Instrument Overview 2-11 PIM vs Time tab (Option 755)

MT2780A UG PN: 10580-00467  Rev. C 2-43

2-11 PIM vs Time tab (Option 755)
Use PIM vs Time tab to compare PIM values to the time it took to detect them. See “PIM vs Time (Long-term 
Monitoring)” on page 5-1 for more information about this report.

Run: PIM Level: This button is active when a connection to a sensor is active, and it changes function 
depending on whether Selected Test > Config Check or Selected Test > PIM Level is 
selected.

Stop: Stops the test in progress and resets all the controls to their pretest state.

Add to Report: Adds the results in the Selected Test > Results to the report.

Review Results: Displays the report.

Save Report: Saves the report.

Fiber Diagram: Displays the connection diagram for the site as given by the configuration file.

Events...: Events log is created and can be saved as a CSV file.

Clear: Clears the all the data in the graph?.

Load File...: Loads a saved file for replaying.

Save File...: Saves the data to a CSV file to enable replaying when needed.

Previous/Next: Allows the user to step back or forward to view a specific day’s worth of data.

Date/Summary: Allows the user to select and display results for a specific day in the drop-down menu. 
Summary provides a summary for ALL days.

Figure 2-50. PIM vs Time tab
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2-12 PIM Distribution tab (Option 755)
Use PIM Distribution tab to display the PIM measurements exceeding the PIM threshold level. See “PIM 
Distribution” on page 5-4 for more information about the distribution report.

Figure 2-51. PIM Distribution tab
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2-13 PIM Daily tab (for PIM Failure) (Option 755)
Use PIM Daily tab to display a report that shows the results for a 24-hour period. See “PIM Daily” on page 5-5 
for more information about the daily report.

Figure 2-52. PIM Daily tab
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2-14 Heat Map tab (Option 755)
Use Heatmap to display the PIM values in a color-coded table with the strongest return in the reddest color. 
For information about heat map refer to “Heat Map” on page 5-6.

.

Figure 2-53. Heat Map tab
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2-15 PIM Location tab (Option 754)
Use PIM Location tab to pinpoint the distance to a PIM source.   

Figure 2-54. PIM Location tab
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Chapter 3 — Making LTE RF over CPRI 
Measurements (Option 752)

The 1. Site Editor tab sets up all the CPRI measurements including the Option 752. This option provides the 
same capabilities for fiber systems that a spectrum analyzer does for RF.

3-1 Preparing the Site’s Details (Site Editor)
The analyzer needs to know specific parameters for the cell site under test. These details can be entered or 
created as described in this section.

Auto-detect a Site’s Configuration

Follow the steps below to configure Auto Detect in 1. Site Editor tab:

1. In 1. Site Editor tab select the sensor from Sensor drop-down menu and click the Connect button.

2. Click New button to clear any pre-existing site configuration, if you may want to create a new site config 
file.

Figure 3-1. 1. Site Editor tab
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3. Under CPRI section select the number of system fibers connected to the SFPs installed in the 
MT2780A(for e.g. three fibers to represent 2 x DLs and 1 x UL). See Figure 2-1, “IQ Fiber Master 
Analyzer (top) and Optical Tap (bottom) Front Connector Panel”.

4. Select the appropriate fiber mode (single mode/multi mode) from the drop-down menu.

5. Select the vendor from the CPRI drop-down menu. Selecting a vendor changes the CPRI settings. 

• If you set the vendor as Custom, click CPRI Settings button to set the Bit Width, Reserve Bits, and 
Idle Bits and click OK button.

6. Click Carrier drop-down menu to select the number of carriers on the fiber.

7. Click the Auto-detect button to detect the CPRI configuration that is displayed on the right side of the 
application. The detected CPRI configuration for each SFP includes the following:

• CPRI line rate

• PCI (Physical Cell ID) for the LTE carrier (DL: Downlink only)

• LTE carrier bandwidth

• Number of antenna branches

• Starting AxC and subsequent AxCs 

• Number of AxC groups

Figure 3-2. 1. Site Editor tab: Auto-detect spectrum
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8. After Auto-detect has completed, follow the steps below to map the CPRI parameters onto the 
appropriate RF carriers:

a. Uncheck the Show auto-detect spectrum box on the right side of the window.

b. Under RF (set up carriers) section select the Number of RF systems: (for e.g. two).

c. Click the + to expand the RF system.

d. Select the required number of Carriers..

e. Select the appropriate 3GPP band number from the Set Band drop-down menu.

f. Select appropriate DL EARFCN and UL EARFCN numbers and/or center frequency. Similarly 
choose the appropriate parameters for all the RF systems.

Figure 3-3. Auto-detect completed dialog box

Figure 3-4. 1. Site Editor tab: Setting Up with Auto Detect

Note There can be more than one carrier in a single band
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9. Map the CPRI parameters to the RF carriers by selecting the Antenna (found under the CPRI section on 
the left) and dragging and-dropping across to the appropriate RF carrier DL or UL box.

10. Click the Save... button to save the current state of the site configuration.

Figure 3-5. 1. Site Editor tab: Setting Up with Auto Detect

Note All the Site Configuration files must be saved with si_ prefix for e.g. si_xxxxx.xml.
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Loading Existing Site Configuration File

Click Site Editor tab and click Load...button next to Site Config to load the existing pre-configured file.

.

Note
When reusing the existing site config file make sure that the physical connections are identical to the 
original setup.

Figure 3-6. 1. Site Editor tab: Loading an Existing Site Config file
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3-2 Starting the LTE RF over CPRI Mode
In Site Editor tab click CPRI Analysis button to activate the LTE RF over CPRI mode.

The the current tab automatically switches to the Analyzer tab and, after a short delay, the IQ streams enabled 
in the Site Editor should be visible, similar to what is shown in Figure 3-7.Note that up to 12 traces can be 
viewed.

. 

Figure 3-7. Analyzer tab: Standard Relative Spectrum View (dark) with side bars
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Right click on the spectrum to view options to choose either Dark or Light view, Show Sidebars or Hide Sidebars 
and Show Marker Table or Hide Marker Table.

Figure 3-8. Analyzer tab: Standard Relative Spectrum View (dark) with Markers and Side bars

Figure 3-9. Analyzer tab
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Figure 3-10. Analyzer tab: Standard Absolute Spectrum View (dark) with Sidebars

Figure 3-11. Analyzer tab: Standard Relative Spectrum view (dark) without sidebars
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Figure 3-12. Analyzer tab: Standard Absolute Spectrum View (dark) without sidebars

Figure 3-13. Analyzer tab: Multi-window spectrum view (dark)
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Figure 3-14. Analyzer tab: Standard Relative Spectrum View (dark) with Markers and no sidebars

Figure 3-15. Analyzer tab: Multi-window spectrum view (dark) with markers per plot



Making LTE RF over CPRI Measurements (Option 752) 3-2 Starting the LTE RF over CPRI Mode

MT2780A UG PN: 10580-00467  Rev. C 3-11

Figure 3-16. Analyzer tab: Multi-window spectrum view (dark) with Markers and no sidebars

Note
The Layout drop-down menu will allow multiple window configurations that can be configured 
individually.
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Figure 3-17. Analyzer tab: Standard Relative Spectrum View (light) with Sidebars

Figure 3-18. Analyzer tab: Standard Absolute Spectrum View (light) with sidebars
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Figure 3-19. Analyzer tab: Standard Relative Spectrum View (light) without sidebars 

Figure 3-20. Analyzer tab: Standard Absolute Spectrum View without sidebars and Markers
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Figure 3-21. Analyzer tab: Multi-window spectrum view (light) with sidebars

Figure 3-22. Analyzer tab: Standard Relative Spectrum View (light) with Markers and sidebars
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Figure 3-23. Analyzer tab: Multi-window Spectrum View with Markers per plot and sidebars

Figure 3-24. Analyzer tab: Standard Relative Spectrum View (light) with markers and no sidebars
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3-3 Analyzer tab
The Analyzer tab consists of the following sidebars:

• Export Image...button

• Traces button

• Markers button

• Menu

• Settings

• Axes

• Plot

• Traces

• Markers

• Playback

• Advanced

Figure 3-25. Analyzer tab: Multi-window Spectrum View (light) with markers and no sidebars
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Settings 

Use the settings menu on the right of the window to adjust the LTE RF over CPRI settings.

(The current options are accessible in the Settings dialog shown in Figure 3-26 on page 3-17.

• Layout – Click the drop-down menu to select a single/multiple plot layout. If 1x1 layout is selected, single 
plot is displayed, if 2x1 layout is selected two plots are displayed.

• Sweep – Define the update rate of the display (note that the update rate that can be achieved depends on 
many other factors). Use the slider with blue rectangle to adjust the sweep time.

• RBW/#FFT – These both define the amount of data used per sweep which are forced to a suitable 
power-of-2 for the FFT. The RBW is calculated assuming a fixed sample rate of 30.72 MHz so the actual 
RBW is lower for narrower channel bandwidths).

• #Points – The number of points calculated for each trace displayed (using the detector defined for that 
trace).

• #Average – The number of trace averages used when enabled (note that this uses exponential averaging, 
not uniform).

• Frequency – When set to Absolute, each trace is displayed at its absolute RF frequency in the display 
(provided that has been set in the site config). When set to Relative, the absolute RF frequencies are 
ignored and all traces are centered at 0Hz when displayed.

Figure 3-26. Settings Dialog
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• Window – Select a suitable window style for applying to the source data prior to the FFT.

• Spectrogram – Allocates the given (lower) portion of the plot’s vertical dimension to be used when the 
spectrogram is enabled.

• Reset to Defaults – This button resets all the parameters to their default values. Note that the currently 
set parameters are displayed under the Export Image button.

• Back: Click this button to go back to the main menu.

Axes

The scale and range of the plots are determined automatically when the LTE RF over CPRI mode is started but 
can be adjusted manually using the Axes menu.

The auto-scale option chooses suitable values for each axis based on the traces currently displayed.

Restricting the frequency range causes the detector to automatically adapt so that the number of points 
calculated remains constant. This effectively improves the frequency resolution of the trace display up to the 
maximum of the RBW (limited by the #FFT points).

Figure 3-27. Selecting a Display Type

Figure 3-28. Axes Settings



Making LTE RF over CPRI Measurements (Option 752) 3-3 Analyzer tab

MT2780A UG PN: 10580-00467  Rev. C 3-19

Plot

The plot menu allows convenient selection of which traces to display on the currently selected plot. The 
available options are shown below:

The traces can be filtered by which SFP they are on, or, if they have been configured, by the center frequency of 
the streams.

Traces

The legend for the traces displayed by the current plot is located in the bottom of the left sidebar. When 
selected for traces, a maximum of 12 traces can be displayed as shown in the Figure 3-30.

Click Show All/Hide All to view/hide all the traces. Click the eye icon to show/hide the trace. 

Figure 3-29. Plot Settings

Figure 3-30. Trace Legend
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Click Traces menu under the Menu sidebar to access the detailed trace settings. Click on a desired trace listed in the left sidebar 
to view the corresponding trace details in the right sidebar as shown in Figure 3-31.

The plot and trace can be selected using the drop-down lists or by clicking the plot (in a multi-plot layout) and 
trace button from the left-hand side.

 The trace menu has the following options:

• Display: Check this box to enable Spectrogram and Persistence boxes.

• Signal source: Select the source CPRI stream from which the trace is generated.

• Detector: Select the appropriate detector to generate the #Points of the trace from the #FFT bins. RMS is 
the default but Sample, Max Peak and Min Peak are available too.

• Trace: Select the appropriate type of trace. The processing applied to the #Points trace before being 
displayed. This allows the trace to be averaged (#Average), max hold, min hold, hold (stop updating) and 
normal.

• Spectrogram: Displays a spectrogram in the bottom portion of the plot, as shown in the example 
screenshot below. This can only be enabled for ONE of the current traces per plot

• Persistence: Displays the combination of min/max trace information.

• Restart This Trace: Restarts the current spectrogram.

• Default Trace Settings: Reverts all of the settings for the current trace to their original defaults 
(RMS/normal, etc.).

• Restart ALL Traces: Restarts all the traces and the current spectrogram.

Figure 3-31. Trace Options
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.

Figure 3-32. Analyzer tab: Spectrogram View
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Markers

Click the Markers button next to Traces button in the left sidebar to view the legend of up to a maximum of 6 
markers. Click the eye icon to enable/disable the marker details listed in the marker table under the selected 
plot. 

Click the Markers menu found on the right sidebar to access the detailed marker settings. Click the desired 
Marker in the left sidebar to view the marker settings in the marker menu on the right sidebar. 

Figure 3-33. Markers Legend

Figure 3-34. Markers Settings
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The plot and marker can be selected using the respective drop-down lists or by clicking the plot (in a multi-plot 
layout) and trace button from the left-hand side.

The marker menu has the following options:

• Display: Check this box to view the marker details listed in the marker table. Select the desired trace, use 
the right mouse button to manually move the marker on the trace.

• Marker Type: Click this drop-down menu to select the type of marker. Frequency Marker is vertical, Power 
Marker is horizontal and Combined Marker includes both horizontal and vertical.

• Trace: Expand this drop-down menu to select a desired trace.

• Marker Delta: Expand this drop-down menu to select a desired marker.

• Adjustments: Adjustments include the following: 

• Location: Enter the desired specific frequency for this marker or click the up/down arrows to 
adjust.

• Sample: The marker frequency may be incremented or decremented in sample steps by clicking the 
left or right arrows.

• Functions: The Functions include the following:

• Peak Search: This button places the selected marker on the strongest signal of the selected trace. 
Click on right/left arrow heads to move the marker to locate the next peak signal.

• Marker to Center: This centers the frequency axis at the marker position such that the marker will 
now appear at the center of the displayed plot.

• Marker to Ref: This adjusts the amplitude axis so that the marker value will be at the top of the 
plot.

• Marker Delta to Span: The span is set to cover the frequency range between the two markers 
involved in the delta marker selection.
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The LTE RF over CPRI spectrum display shows the markers as numbered rectangles above the traces (1). The 
Markers list, at the lower left, of the display shows which markers are visible, the marker table (2), at the 
bottom, shows the frequencies and traces that the marker is involved in, and the Marker parameters (3), at the 
right of the display, govern the various aspects of the markers. 

Enabling a marker displays a vertical line at the marker’s frequency and a cursor at the trace’s value for that 
frequency. Figure 3-35 shows two such markers, 1 and 3. The marker ID is displayed at the top of the plot, 
above its vertical line, and in the color for that marker.

Each marker can calculate a delta to any of the other markers as well as its absolute value (for which it needs 
the delta amplitude adding to the table).

The marker table is displayed at the bottom of the window. 

It can be pinned so that it always shows; unpinned it displays only when the Marker menu is selected.

Figure 3-35. Analyzer tab: LTE RF over CPRI Markers

Figure 3-36. Marker table

1

2

3
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Playback

Traces can be captured and played back (normal, fixed, or slow motion). A ‘snapshot’ screen image can also be 
saved.

Save Capture: Captures the entire trace data, that may not be fully visible on the screen, for playback in 
a file with your choice of name and path.

Load Playback: Lets you choose a file for playback from any accessible location. Note that the saved play 
back file is displayed under LOAD playback button.

Playback Mode: Normal playback mode—simulated live operation where each update is generated by 
randomly selecting a different point from the captured playback data.

Fixed—effectively "stops" the playback at a specific point in the captured playback data 
by using a fixed start sample for each update. The start sample can be varied over one 
CPRI frame (10ms) 0-38400, units are CPRI basic frames (3.84 MHz).

Slow Motion— each update is generated by automatically incrementing the start point of 
the captured playback data by a defined amount. The speed is adjusted by changing the 
size of the increment for each update. Units are in CPRI basic frames and the range of 
values from 2 to 500 (default of 100).

Figure 3-37. Capture and Playback
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Advanced (Set the Noise Floor)

If the calibration factor for the uplink being measured is not known, the Advanced option can measure the 
noise floor of the RRH under test from the CPRI data. The measurement looks for quiet (minimum power, idle) 
periods within the LTE signal, and averages them to calculate the noise floor of the signal. When the 
calibration completes, you may transfer the measured value to the calibration settings.

To measure the noise floor: 

1. Click Advanced menu.

2. Click Noise Floor button.

3. Click Select a Plot.

4. Set the options for the selected Plot.

Max Iterations: Increments of one from 10 to 10000 (default of 5000).

Timeout for Min: Increments of one second, from 1 to 60 seconds (default of 30).

Averaging: Increments of one from 10 to 1000 (default of 250).

5. Click the Reset to Defaults button to reset the set values.

6. Click the Measure Noise Floor button to start the measurement. 

Figure 3-38. Advanced Menu
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7. After the time set in the Timeout for Minimum elapses, Set dBm Calibration button appears. 

8. Click Set dBm Calibration button to apply the noise floor (dBm) to the vendor and LTE air standard as 
specified in the current Site Editor file.

9. Click OK button to update the calibration setting.

Figure 3-39. Advanced Settings After Calibration Completes

Figure 3-40. Setting the Noise Floor with Calculated Noise floor
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10. Click OK button to exit.

11. Go to File > Preferences > General > dB Units to verify the new conversion value and click Apply button..

Figure 3-41. Calibration Updated Dialog box

Figure 3-42. DB Units conversion
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This is the LTE RF over CPRI trace display after the calibration is successful. Note the addition of the 
red line about -108 dBm. 

12. This message displays when the calibration is canceled:

Figure 3-43. Noise Floor Shown After Calibration

Figure 3-44. Calibration Canceled Dialog box

1
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Export Image...

In the Analyzer tab follow the steps below to capture the LTE RF over CPRI trace:

• Click Export Image... button at the top left of the window to view the Image Capture dialog box.

• Click Change Filename... button to change the name or location of the captured file.

• Click Open File Location button to view the location of the file.

• Click one of the radio buttons under Image Selection section to choose the required portion of the 
application interface.

• Click Capture Image button to capture the screenshot of the plot.

• Notice a change in the status after the image capture is completed.

• Click OK button to close the dialog box.

Figure 3-45. Image Capture Status

Figure 3-46. Image Capture for LTE RF over CPRI

Figure 3-47. Image Capture Status
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Zoom

While the LTE RF over CPRI is running, it is possible to zoom into regions of the currently selected plot. 

To zoom:

1. Use the mouse to define the region while holding the left mouse button down.

Default is to zoom frequency-axis (horizontal) only.

Note That this is a video zoom only so it does not change the way the trace is being determined.

Figure 3-48. Analyzer tab: Frequency Axis Zoom (Horizontal Axis)
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2. To zoom the power axis (vertical) only, hold the SHIFT key down in addition to the mouse operation.

Figure 3-49. Analyzer tab: Power Axis Zoom (Vertical Axis)
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3. To zoom both axes simultaneously, hold the CTRL key down in addition to the mouse operation and 
define a box.

4. Double-click on the plot to reset the display to its normal view.

Figure 3-50. Two-Axis Zoom
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3-4 Stopping/Restarting LTE RF over CPRI Mode
Click the red Stop button on the top of the window, to stop the LTE RF over CPRI mode. This completely stops 
the data acquisition and the processing/display of all traces. Or use the red Stop button on the bottom right of the 
window.

Figure 3-51. Stopping LTE RF over CPRI 
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Click the green CPRI Analysis button on the top of the window or green START button in the bottom right to restart the 
processing and data acquisition. 

Figure 3-52. Restarting LTE RF over CPRI 
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Chapter 4 — Making PIM-over-CPRI 
Measurements (Option 754)

Option 754 (requires Option 752) measures the PIM phenomena and Option 755 provides more in-depth 
analysis (analytics). See “Upgrading IQ Fiber Master” on page 2-11 for information about upgrading to this 
option.

Start the PIM analysis with the 1.Site Editor tab to make sure that the analyzer correctly configures the sensor 
and correctly analyzes the data from the IQ and baseband streams. This information contains the vendor 
settings, AxCs, number of IQ streams, and the LTE air standard (bandwidth). Continue with setting up the 
test scenarios on the 2. Roster Editor tab then on the 3. Run Tests tab running tests on a selected scenario, 
optionally ending with PIM Location calculations and Cross Sector analysis.
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4-1 Preparing the Site’s Details (Site Editor)
Refer to Section 3-1 “Preparing the Site’s Details (Site Editor)” on page 3-1. The application needs to know 
specific parameters for the cell site under test. These details can be entered or created as described in this 
section.

Create Roster Files

To create the roster files follow the steps below:

1. Click 2. Roster Editor tab.

2. Load the saved Site Config file to test PIM.

3. Click the Auto Generate button.

4. Click the Save... button on the right most side of the window, to create and save the roster file.

To add or delete a test manually, click the Add Test or Delete Test buttons on the lower left of the window.

Note All the Roster files must be saved with tr_ prefix for e.g. tr_xxxxx.xml.

Figure 4-1. 2. Roster Editor tab
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Loading Existing Site Configuration and Roster Files

To test PIM over CPRI measurements follow the steps below:

1. Click 3. Run Tests tab.

2. Click the Load...button next to the Site Config to load the correct si_xxxx.xml file for the current site.

3. Click the Load... button next to Roster File to load the correct tr_xxxx.xml file for the current site.

4. Select the appropriate test under the Roster Detail table. 

5. Click the Config Check radio button under the Selected test section. Note that the other radio buttons will 
be disabled until the config check is passed. Refer to Section 4-3 “Configuration Check” on page 4-4 for 
more information on the config check.

6. Click Run: config check button on the top of the window.

• Select PIM Level radio button under the Selected Test after the config check is passed.

• Click the Fiber Diagram button on the upper right of the window to verify if the optical fiber 
connections are correct.

• Fix the connections that are shown in yellow/red color. Note that connections shown in green 
are correct.

Note
When reusing the existing site config and roster files make sure that the physical connections are 
identical to the original setup.

Figure 4-2. 3. Run Tests tab: Loading existing site config and roster files
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4-2 Select a Test
When the text or analyzer instructs you to select a test, choose from this list:

4-3 Configuration Check
To perform the configuration check follow the steps below:

1. Click 3. Run Tests tab, load the appropriate site config and test roster files. 

2. Select an appropriate test scenario from the Roster Detail section.

3. Click the Config Check radio button.

4. Click Run: config check button on the top of the window.

Figure 5 Select a Test to Run

Note
Choosing an appropriate test scenario facilitates the specific uplink and down link frequency 
combination(s) for PIM over CPRI measurements 

Figure 4-1. 3. Run Tests tab: Config Check test
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If the config check fails follow the steps below:

1. Click the Fiber Diagram button on the top right, to open the fiber diagram window relevant to the selected 
test.

2. Use the fiber diagram as a reference to fix the connections of the optical fibers between the IQ Fiber 
Analyzer and the optical tap as shown in the Figure 4-4 on page 4-6. 

Figure 4-2. Run: Config Check: Config Check test - Fail

Figure 4-3. 3. Run Tests tab: Fiber Diagram
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3. In the fiber diagram click the SFP icon with a red connection to make the SPF LED to flash..

4. After fixing the incorrect fiber connections click Run: config check button again to verify if the config 
check passes.

Note
Clicking on the SPF with a red connection on the fiber diagram will cause the SPF LED on the 
IQ Fiber Master to flash, and the red connection in the fiber diagram will also flash.

Note
Uplink (UL) fiber is ALWAYS connected to SFP1 on the IQ Fiber Master for PIM over CPRI 
measurement.

Figure 4-4. Fiber Diagram

Figure 4-5. Run: Config Check: Config Check test - Pass
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Report

You may add the results of a configuration check to the report. To add them, click the Add to Report button. The 
configuration results are added to the end of the report. See Appendix A, “Reports” for more information about 
reports.

Figure 4-6. 3. Run Test tab: Add to Report

Figure 4-7. Add to Report - Config Check Test Results
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4-4 PIM Measurement
To run a PIM over CPRI measurement follow the steps below:

1. Select an appropriate test scenario under Roster Detail section.

2. Select PIM Level radio button under the Selected Test section.

3. Click the Run: PIM level button on the top of the window. 

• The PIM Level measurement begins for each antenna port (defined in the Roster Editor). 

The PIM level test will take a little longer than a traditional RF PIM test, because the algorithm is 
synchronizing all of the down link signals to each individual uplink signal and determining if there are down 
link elements appearing in the uplink that are causing PIM.

The first PIM over CPRI measurement will take longer due to the synchronization, but each subsequent 
measurement will be much faster since it doesn’t need to re-synchronize.

Figure 4-8. 3. Run Test tab: PIM Level Measurement
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PIM level test results consists of the following parameters:

• The Impacted UL/Antenna field column defines the results for each individual antenna (AxC) under test

• Pass/Fail result is based on the measured PIM level

• Measured PIM level 

• RSSI 

• Rx Desense is the amount of noise in the uplink due to PIM

• PIM source location determines if PIM is internal or external to the antenna system

Figure 4-9. 3. Run Tests tab: PIM Level Measurement Test Results
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4-5 Analyzer: PIM over CPRI
The PIM over CPRI test shows the (wanted) UL and PIM spectra and can be used as a visual indication of PIM 
impacting the UL carrier.

To see the individual uplink spectrum traces with their PIM components, follow the steps below:

1. Click the Analyzer tab.

By default, the Analyzer tab will display the worst PIM spectrum trace defined by the Antenna (AxC) Select 
radio button. The green trace is the actual RF uplink spectrum, the orange trace is the estimated PIM within 
the uplink spectrum.

2. Select a different Antenna Select radio button at the bottom of the window, to see a different uplink (AxC) 
trace.

Figure 4-10. Analyzer tab: PIM over CPRI
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Main Buttons and Controls

You can see that the Stop button, Review Results, and Save Report buttons are activated (Fiber Diagram is not 
part of this topic). Click Stop to make data available to the report; click the now-active Add to Report button to 
add trace data to the report. See Appendix A for more about reports. 

Context Menu

Right-click in the PIM over CPRI trace display to show the context menu that allows you to alter the 
appearance of the trace display.

Signals

This switches on and off UL and PIM which also removes their entries from the legend.

Legend

Turns the Legend on and off.

Figure 4-11. Trace Context Menu

Figure 4-12. Legend off (Display in Light Phase)
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Light/Dark

Changes the display from colored-traces-on-black (the color scheme in which most of the figures in this 
publication are depicted) to -on-white. The colors of the remainder of the display are unchanged.

Zoom

Zoom Full: Returns the display to its non-zoomed state.

Zoom X-axis: Zooms the display only on the x-axis by the click-and-drag technique in the x-axis 
direction only.

Zoom Y-axis: Zooms the display only on the y-axis by the click-and-drag technique in the y-axis 
direction only.

Zoom Box: Zooms the display in the x- and y axes in a box defined by the click-and-drag technique in 
both the y- and x-axes direction.

Figure 4-13. PIM Display: Light Phase
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Time-Power/Spectrum

These change the display mode between Spectrum (most of the figures in this chapter) and Time-Power.

Points

Changes the number of points displayed from several options, with 1 k the default (with a dot showing which 
option is selected). 

Figure 4-14. Time-Power Display Mode of PIM over CPRI

Figure 4-15. Trace Points Selecting
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AutoScale/Scaling

These change the trace display regardless of what mode it is in:

• AutoScale – Accommodates all of the data points. (Some data might not be displayed in this mode.)

• Set Scaling – (AutoScale must be off) displays a dialog so that the maximum Y-axis value (range -100 
through 200) and the dB per division (range of 1 through 100) can be specified.

Yunits

(Available only with Time-Power.) This option changes the display mode between dB and Linear.
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4-6 PIM Location, Distance, and Calibration

Introduction

To enable PIM location measuring follow the steps below:

1. Perform the config check and a PIM Level tests of the selected roster detail. If the tests detect PIM, it 
enables the PIM Location radio button.

2. Click the Run: PIM location button at the top to start a PIM Location (DTP) measurement. Notice the 
current tab automatically switches to PIM Location tab.

• Notice that the center distance value shown in the figure 4-18 will be large since it is uncalibrated.

• The center position is the antenna.

Figure 4-16. 3. Run Test tab: PIM Location Test
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.

Figure 4-17. PIM Location tab: Live PIM Location- Uncalibrated
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PIM Calibration

1. The software will select the antenna with the strongest PIM measurement by default. The PIM level is 
normalized to zero and a well-defined peak will be evident for a loud PIM source. The initial 
measurement is uncalibrated and will include any delay introduced by the RRH, filters and cabling etc.

2. Place a known PIM source (as shown in the figure 4-19), on the antenna radome to calibrate (zero out) the 
system and account for any delays introduced by the RF path. 

3. After calibrating remove the PIM source from the antenna radome.

4. Click the green Restart Measurement button to find the PIM location of internal or external PIM sources.

• The Live PIM location measurement is shown in blue and the average PIM location measurement 
is shown in gray/green as shown in the figure 4-20.

• A negative distance value indicates an internal PIM source (i.e. between RRH and antenna). 

• A positive distance value indicates an external PIM source.

5. Run the PIM location measurement 20 times to obtain a high confidence measurement.

• The average PIM location measurement value turns green when the number of completed 
measurements reaches 20.

• The software will keep track of the average number of measurements as shown in the figure 4-21.

Note
The antennas with PIM are determined from the PIM measurement and note that antennas 
with no PIM are not included in display

Figure 4-18. PIM Source (Calibration Device)

Figure 4-19. PIM Location

Figure 4-20. PIM Location Progress
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The calibrated data is shown as the red trace, the individual live trace is shown as a blue trace and the average 
of all the completed traces is shown as the green trace.

After the PIM source has been mitigated click the Restart Measurement button to locate a different PIM source.

Figure 4-21. PIM Location tab: PIM Location New Data

Note Calibration steps cannot be saved to the report.

Note
The PIM location measurement is a synchronized time based measurement. It is necessary to 
click Restart Measurement button after locating and mitigating every single PIM source, as it 
requires a re-synchronization for each PIM source.
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6. Click Add to Report to add the revised PIM Location display to the report.

The power delay profile is shown, with the position along the x-axis of the peak indicating the distance 
(given free space propagation) to the dominant PIM source.

Note
In the case of an internal fault, no correction is made to account for velocity factor within the cabling 
as that is specific to the cable type used.

Figure 4-22. PIM Location tab: Add to Report

Note
The Add to Report button is enabled after the PIM Location has completed at least one full 
measurement cycle.

Figure 4-23. PIM Report: PIM Location Data
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Auxiliary PIM Location Information

The figures in this section show various states of the PIM Level testing results. 

The figure below shows a PIM failure (PIM found) and shows that PIM Location is activated.

Select PIM Location, then click Run: PIM Location button for the analyzer to calculate distance to PIM. At this 
point you’ll have sector and distance information to the strongest PIM source.

Figure 4-24. PIM Level Test Results: No PIM

Figure 4-25. PIM Level Test Results: One Antenna with PIM Failure
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Figure 4-26. Selecting PIM Location Test
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Chapter 5 — PIM Analytics (Option 755)

Option 755 (requires Option 752 and 754) provides deeper analysis for the PIM measurements. See “Upgrading 
IQ Fiber Master” on page 2-11 for information about upgrading to this option.

5-1 PIM vs Time (Long-term Monitoring)
PIM vs Time tab shows PIM level against time for all antenna ports that are measuring PIM. The term for 
which the monitoring can run is limited only by the data space available on the computer. A daily graph is 
saved to a user-defined directory (see File>Preferences>General Settings). A summary report for the duration of 
the test is also saved detailing maximum, minimum, and mean PIM with duration, time and date. A saved file 
can be loaded and replayed.

Figure 5-1. PIM vs Time Graph
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Events...

An events log is created and can be saved as a CSV file. Click Events... button to display the report, and click 
Save... button to save the report. (The report is saved independently of the PIM report.)

An Events file may also be loaded. This allows the user to load and check/analyze any previously saved events 
log. It is a CSV file so it may be loaded into Excel or any spreadsheet program.

Figure 5-2. Events List 

Note
Note that the active buttons shown in figure 5-3 are enabled only after the PIM vs Time 
measurement has been stopped (at least one completed PIM measurement cycle is needed).
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Clear

Clears the graph of all data and picks up recording from that moment.

Load File...

Loads a saved file for replaying.

Save File...

Saves data to a file for replaying later. 

Previous/Next

Allows the user to step back or forward to view a specific day’s worth of data

Date/Summary

Allows the user to select and display results for a specific day in the drop-down menu. Summary provides a 
summary for ALL days.

Figure 5-3. PIM vs Time active buttons
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5-2 PIM Distribution
The PIM Distribution tab shows a CDF plot depicting the percentage of measurements that exceed the defined 
PIM level threshold, in dBm, for each antenna port under test.

Figure 5-4. PIM Distribution tab
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5-3 PIM Daily
The PIM Daily tab shows a histogram, over a 24-hour period, for each antenna that has PIM. A summary of 
maximum and minimum PIM with duration is shown at the top left of the graph.

Figure 5-5. PIM Daily tab: PIM Daily Report
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5-4 Heat Map
The heat map represents the relative contribution (in dB) of each transmitting antenna port to the total 
measured PIM power.

Figure 5-6. Heat Map tab
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Click Interpret Heatmap button to view different scenarios and descriptions of the possible effects of how 
individual transmit ports can affect individual receive ports due to PIM. It can be used to complement the PIM 
Location measurement. 

Figure 5-7. Interpret Heapmap: Hot Antennas on top - External PIM; Specific Antenna port below- Internal PIM
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Appendix A — Reports

A-1 PIM over CPRI Reports
View the report at any time by clicking Review Results button. The reports for PIM are not automatically saved 
or written to a PDF format. Click the Add to Report button when an action completes to write its results to the 
report. Click Save... on the Report view or Save Report on the main window to save the report to a PDF file. 
The parts of the report are described in this section. 

New Report 

1. Click the Review Results button to view the current report.

2. Click the New button to start a new report. You can add any results to a new (blank) report. 

All results are appended to the end of the report.

Figure A-1. Add to Report Buttons

Figure A-2. New PIM Report 
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Report Header

The report header contains the Site, Operator, and Instrument details. Note the footer -End of PIM Report- 
which marks the last entry of the report. 

From the online version, you can save, preview, and print the PDF version.

Figure A-3. Report Header--Online Version
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Check Configuration

When a Config Check is performed prior to a PIM over CPRI test, the Results pane of the Run Tests tab display 
the results (which can be detailed or summarized). Click the Add to Report button to add Config Check results 
to the end of the report. Note the TEST 1: alpha highlighted, header line. Similar lines are added for other 
tests.

The Config Check portion of the report contains an SFPn pass/fail header with details (measurements and 
expected values) about Optical Connectivity, CPRI Connectivity, IQ Stream Capture RSSI/TSSI, Bandwidth, 
and LTE ID and TX configuration. Note the line Passed configuration check: Ready for test.

Figure A-4. Config Check Report (top and bottom portions)
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PIM Level

After a PIM Level (PIM over CPRI) test is initiated, click Add to Report to write all of its results to the report. 
Note the time-stamp right after the PIM Level heading. Each time the Add to Report button is clicked a new 
PIM Level heading and data are added to the report.

Pass/Fail

For each UL/Antenna, there are pass/fail status, PIM level, the PIM threshold (dBm or dBFS), and an 
indication of PIM location (internal/external). 

Figure A-5. PIM Report: PIM Level 
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PIM vs. Time

A PIM vs. Time report provides data about when a PIM occurs on the 24-hour clock.

To get a PIM-vs-Time report, 

1. Run the PIM Level test.

2. Choose either a or b: 

a. Click Add to Report and scroll down to the Long Term Monitor figure.

b. Click PIM vs Time tab.

Report Parameters

Start: The time of the start of the PIM recording. The time is only reported to the nearest 
minute.

Stop: The time of the stop of the PIM recording. The time is only reported to the nearest 
minute.

Duration: The time elapsed for the PIM recording. The time given is in hour:minutes:seconds.

Antenna Table: Use the entries in the Antenna table to view detailed data about PIM events.

Figure A-6. PIM Report: PIM versus Time
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PIM Distribution

The PIM distribution tab shows all the PIM sources relative to the threshold. To view a PIM Distribution:

1. Run the PIM Level test.

2. Choose either a or b: 

a. Click Add to Report and scroll down to the Long Term Monitor figure.

b. Click the PIM Distribution tab.

Figure A-7. PIM Report: Distribution 
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PIM Daily (Long-term Monitoring)

To get a meaningful PIM Daily report, the PIM Level test must run long enough.

The graph covers a 24-hour period. 

Figure A-8. PIM Report: Daily (Long-term) Monitoring
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Heat Map

The heat map is most useful for antennas that fail the PIM test. The report contains the heat map matrix with 
summaries.

PIM Location

PIM location is not included in the prepared report. See“PIM Location, Distance, and Calibration” on page 4-15 
for more information about PIM location.

Figure A-9. PIM Report: Heat Map
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A-2 LTE RF over CPRI
Here is a typical LTE RF over CPRI display.

This view cannot be added to PIM report through the app; however, the image may be exported to a PDF file. 

You can zoom in on the x-axis to view more detail at a frequency, either click and drag or use the scroll wheel to 
adjust the zoom

To exit double-click anywhere in the trace area (or use the scroll wheel).

Figure A-10. LTE RF over CPRI display
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