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Warranty

The material contained in this docu-
ment is provided “as is,” and is sub-
ject to being changed, without notice,
in future editions. Further, to the max-
imum extent permitted by applicable
law, Agilent disclaims all warranties,
either express or implied, with regard
to this manual and any information
contained herein, including but not
limited to the implied warranties of
merchantability and fitness for a par-
ticular purpose. Agilent shall not be
liable for errors or for incidental or
consequential damages in connec-
tion with the furnishing, use, or per-
formance of this document or of any
information contained herein. Should
Agilent and the user have a separate
written agreement with warranty
terms covering the material in this
document that conflict with these
terms, the warranty terms in the sep-
arate agreement shall control.

Technology Licenses

The hardware and/or software described in
this document are furnished under a license
and may be used or copied only in accor-
dance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a
U.S. Government prime contract or subcon-
tract, Software is delivered and licensed as
“Commercial computer software” as
defined in DFAR 252.227-7014 (June 1995),
or as a “commercial item” as defined in FAR
2.101(a) or as “Restricted computer soft-
ware"” as defined in FAR 52.227-19 (June
1987) or any equivalent agency regulation or
contract clause. Use, duplication or disclo-
sure of Software is subject to Agilent Tech-
nologies’ standard commercial license
terms, and non-DOD Departments and
Agencies of the U.S. Government will
receive no greater than Restricted Rights as
defined in FAR 52.227-19(c)(1-2) (June

ﬁ%

1987). U.S. Government users will receive
no greater than Limited Rights as defined in
FAR 52.227-14 (June 1987) or DFAR
252.227-7015 (b)(2) (November 1995), as
applicable in any technical data.

Safety Notices

CAUTION

A CAUTION notice denotes a haz-
ard. It calls attention to an operat-
ing procedure, practice, or the like
that, if not correctly performed or
adhered to, could result in damage
to the product or loss of important
data. Do not proceed beyond a
CAUTION notice until the indicated
conditions are fully understood and
met.

A WARNING notice denotes a
hazard. It calls attention to an
operating procedure, practice, or
the like that, if not correctly per-
formed or adhered to, could result
in personal injury or death. Do not
proceed beyond a WARNING
notice until the indicated condi-
tions are fully understood and
met.
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In This Guide...

This User’s Guide provides information in the following
chapters on how to use your instrument.

1 Getting Started

2  Instrument Setup and Use - SONET
3 Instrument Setup and Use - PDH

4  Instrument Setup and Use - DSn

5 Instrument Setup and Use - Ethernet
6 Instrument Details

7 Telecoms Concepts

- 4~ 4
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Conventions Used in this Manual

The conventions used in this manual to illustrate instrument
keys and display information are as follows:

<Menu> This is an example of a hardkey. Hardkeys (located to the right
of the display) are used to give access to different sets of
instrument settings, or select dedicated instrument functions.

Menu Items Menu items appear in text as bold face with the greater than (>)
symbol separating each menu level. For example, if you are
instructed to choose Errors and Alarms from the Test Functions
menu item, it appears as Test Functions > Errors and Alarms.

Field Items Field items you are instructed to select in a window will appear
in bold face, for example select Signal Rate field.

Drop Down Lists The item you must select from a drop down list is also shown in
bold. For example, select Signal Rate field and choose STM-1 or
OC-3 from the drop down list.

4 User Guide

4~ 4

.




@é son_Cobra.book Page 5 Wednesday, September 25, 2002 11:09 AM

A

Contents
1 Getting Started
Product Description 14
Option Guide 17
Front Panel Tour 21
Function Controls 21
Navigation Controls 22
Keypad 22
Status and Alarm LEDs 27
Print Control Key 28
Top Panel Connectors 29
Connectors on Instrument Front/Left Side Panel 36
Connectors on Instrument Front/Right Side Panel 37
Using the Graphical User Interface (GUI) 39
Display Windows 39
Menus 43
Basic User Interface Operations 45
Using Multiple Instruments 51
Using Online Help 53
Context-Sensitive Help b4
Accessing the Index 54
Using Online Help - Which Keys Do | Press? 55
Using a Mouse and Keyboard with the Instrument 57
Safety Information 58
Optical Connector Safety Information 59
Avoiding Problems When Making Measurements 61
Using Smart Test Features 62
Using SignalWizard 64
Understanding the SignalWizard Overview Window 66
Monitoring Path Trace Messages 69
User Guide 5

.

4~ 4




@é son_Cobra.book Page 6 Wednesday, September 25, 2002 11:09 AM

A

In-Service Testing 71
Out-of-Service Testing 72

SONET Measurement Tutorial 73

Step 1: Connect Optical Ports 74

Step 2: Set Up Transmitter 75

Step 3: Set Up the SONET Mapping 76
Step 4: Set the Payload Pattern 77
Step b: Couple Tx and Rx Settings 77
Step 6: Check Receiver Input Power 78
Step 7: Check Setup 79

Step 8: Set Measurement Gating 79
Step 9: Start Measurement 80

Step 10: View Results 80

Step 11: Add an Error and an Alarm to Tx Qutput 81
Step 12: Add a Single Error 81

Step 13: View Alarm Results 81

Ethernet Measurement Tutorials 84

2  Instrument Setup and Use - SONET

Setting up the SONET Transmitter 98

Selecting SONET or SDH Operation 100

Setting Up the SONET Transmit Interface 101

Coupling the Receiver to the Transmitter Settings 104
Selecting the SONET Transmit Clock Source 105

Adding Frequency Offset to the SONET Signal 106
Generating SONET Overhead Signals 107

Generating Trace Messages 108

Generating Synchronization Status Messages 109
Generating Path Signal Labels 110

Generating Automatic Protection Switching (APS) Messages 111
Editing SONET Overhead Bytes 113

Inserting Messages into the Data Communications Channel
(DCC) 115

Adjusting SPE or VT Pointer Values 116

Generating STS-1 SPE and Concatenated Payloads 120
Transmitting SONET Tributary Payloads 127

Transmitting a DSn Payload into a SONET Signal 129

6 User Guide

4~ 4

.




el @

-

@é son_Cobra.book Page 7 Wednesday, September 25, 2002 11:09 AM

ﬁ%

User Guide

Inserting an External DSn Payload into a SONET Signal 130
Transmitting PDH Payloads in a SONET Signal 131
Inserting an External PDH Payload into a SONET Signal 132
Adding SONET Errors and Alarms 133

Switching Off All Test Function Features 134

Setting up the SONET Receiver 135
Setting Up the SONET Receive Interface 136
Coupling the Transmitter to the Receiver Settings 139
Monitoring SONET Overhead Signals 140
Monitoring Trace Messages 141
Monitoring Synchronization Status Messages 141
Monitoring Path Signal Labels 142
Monitoring Automatic Protection Switching (APS) Messages
Monitoring SONET Overhead Bytes 144
Dropping Messages from the Data Communications Channel
(DCC) 145
Monitoring STS-1 SPE and Concatenated Payloads 146
Monitoring SONET Tributary Payloads 153

Monitoring a DSn Payload in a SONET Signal 155
Dropping a DSn Payload from a SONET Signal 156

Monitoring PDH Payloads in a SONET Signal 157

Dropping a 2 Mb/s Payload from a SONET Signal 158
Dropping a Voice Channel to the Internal Speaker 159

Setting Up Thru Mode Operation 160

Transparent Thru Mode 160
Overhead Overwrite Thru Mode 161

Storing and Recalling Instrument Settings 162

Measurements and Results 163
Measuring Optical Power 164
Measuring STS-1 or STS-3 Signal Level 165
Measuring Frequency 166
Viewing and Capturing the Pulse Mask of a SONET Signal
(STS-1) 167
Viewing SONET Alarms 169
Viewing SONET Errors 170

ﬁ%

143

rs



@é son_Cobra.book Page 8 Wednesday, September 25, 2002 11:09 AM

A

Viewing Errors and Alarms Using Trouble Scan 173
Monitoring SPE and VT Pointer Values 175

Measuring Service Disruption Time in a SONET Network 176
Service Disruption Test Results 177

Measuring Round Trip Delay in a SONET Network 178
Viewing the ITU Analysis of SONET Errors and Alarms 179

3 Instrument Setup and Use - PDH

Setting up the PDH Transmitter 182
Setting Up the PDH Transmit Interface 183
Coupling the Receiver to the Transmitter 184
Selecting the PDH Transmit Clock Source 185
Adding Frequency Offset to the PDH Signal 186
Transmitting a Framed PDH Signal 187
Transmitting an Unframed PDH Signal 193
Inserting an External 2 Mb/s Payload into a PDH Signal 194
Adding Errors to a PDH Signal 195
Adding Alarms to a PDH Signal 196
Switching Off All Test Function Features 197

Setting up the PDH Receiver 198
Setting Up the PDH Receive Interface 199
Coupling the Transmitter to the Receiver 200
Monitoring a Framed PDH Signal 201
Monitoring an Unframed PDH Signal 207
Dropping a Voice Channel from a PDH Signal to the Internal
Speaker 208
Dropping a 2 Mb/s Payload from a PDH Signal 209
Monitoring Si and Sa Spare Bits of a 2 Mb/s signal in a PDH
Signal 210
Monitoring Signaling Bits in Structured 2 Mb/s Signal 211

Setting Up Thru Mode Operation 212
Storing and Recalling Instrument Settings 213

Measurements and Results 214

Measuring PDH Signal Level 215
Measuring the Frequency of a PDH Signal 216
Viewing the Pulse Mask of a PDH Signal 217

8 User Guide

4~ 4

.




el @

-

@é son_Cobra.book Page 9 Wednesday, September 25, 2002 11:09 AM

ﬁ%

User Guide

Viewing PDH Errors 219

Viewing Alarms in a PDH Signal 223

Viewing Errors and Alarms Using Trouble Scan 224
Measuring Service Disruption Time in a PDH Network 225
Service Disruption Test Results 226

Measuring Round Trip Delay in a PDH Network 227
Viewing the ITU Analysis of PDH Errors and Alarms 228

Instrument Setup and Use - DSn

Setting up the DSn Transmitter 230

Setting Up the DSn Transmit Interface 231
Coupling the Receiver to the Transmitter 232
Selecting the DSn Transmit Clock Source 233
Adding Frequency Offset to the DSn Signal 234
Transmitting a Framed DSn Signal 235
Transmitting an Unframed DSn Signal 241
Inserting an External 2 Mb/s or DS1 Payload into a DS3 Signal 242
Adding Errors to a DSn Signal 243

Adding Alarms to a DSn Signal 244

Transmitting FEAC Messages in a DS3 Signal 245
Transmitting DS1 Loop Codes 246

Switching Off All Test Function Features 249

Setting up the DSn Receiver 250

Setting Up the DSn Receive Interface 251

Coupling the Transmitter to the Receiver 252

Monitoring a Framed DSn Signal 253

Monitoring an Unframed DSn Signal 259

Dropping a DS1 Payload from a DS3 Signal 260

Dropping a Voice Channel from a DSn Signal to the Internal
Speaker 261

Monitoring FEAC Messages in a DS3 Signal 262

Monitoring Spare Bits of a 2 Mb/s signal in a DS3 Signal ~ 263
Monitoring Signaling Bits in Structured DS1 or 2 Mb/s Signal 264
Monitoring DS1 Loop Codes 265

.



el @

10

@é son_Cobra.book Page 10 Wednesday, September 25, 2002 11:09 AM

Setting Up Thru Mode Operation 266
Storing and Recalling Instrument Settings 267

Measurements and Results 268

Measuring DSn Signal Level 269

Measuring the Frequency of a DSn Signal 270

Viewing the Pulse Mask of a DSn Signal 271

Viewing DSn Errors 273

Viewing Alarms in a DSn Signal 277

Viewing Errors and Alarms Using Trouble Scan 278
Measuring Service Disruption Time in a DSn Network 279
Service Disruption Test Results 280

Measuring Round Trip Delay in a DSn Network 282
Viewing the ITU Analysis of DSn Errors and Alarms 283

Instrument Setup and Use - Ethernet

Setting up the Transceiver 286

Test Mode Selection 286
Loopback Test 288

Loopthru 290

Setup Mode Selection 291
Settings Available 292

Ethernet Frame Type Selection 296
Negotiation Status 296

Physical Interfaces 298

Measurements and Results 303
RFC 2544 Conformance Tests 304

Manual Tests - Functions and Results 311

Transmit Duration 311

Error Add 312

Data Throughput (Port Data Rate) 313
Viewing Results 314

Transmitter and Receiver Results 314
LED Port Status Indicators 318

Frame Capture 322

Frame Capture Criteria 322

User Guide

ﬁ%

-t

rs



@é son_Cobra.book Page 11 Wednesday, September 25, 2002 11:09 AM

el @

Frame Capture Settings Choices 323
Viewing Ethernet Errors Using Results Summary 325

Transmitter and Receiver Start/Stop 326

Transmitter Start/Stop 326
Receiver Measurement Run/Stop 327
Learning Stream 327

6 Instrument Details

Logging, Instrument Control and File Management Tools 330

Measurement Logging 331

Setting the Measurement Timing 332
Setting Time and Date 334

Viewing Results Graphically 335
System Options 341

System Preferences 342
Manufacturing Data 344

Keyboard Lock 344

Self Test 345

Remote Control 349

User’'s Own Help Files 353

File Management 357

Print Control Key (Printer Setup and Capturing Screendumps) 362
Saving and Printing Screendumps 363
Recommended Printers 363

Technical Support 364

Operators Maintenance 365
Instrument Reboot (Cold Start) 367
CD-ROM Resources 368
Frequently Asked Questions 368

User Guide 1

- 4~ 4

-

.




el @

@é son_Cobra.book Page 12 Wednesday, September 25, 2002 11:09 AM

12

7

Telecoms Concepts

SONET Concepts 374

SONET STS-1 Frame Structure 375
SONET Payload Structure 376
SONET Overhead Bytes 377
Section Overhead (SOH) 378

Line Overhead (LOH) 379

STS Path Qverhead (STS POH) 386

VT Path Overhead (VT POH for VT-1.5, VT-2 or VT-6) 389

Ethernet Concepts 392

Ethernet in Telecommunications Transmission Networks 393

Introduction 394

Testing Ethernet Services 408
An Example 423

Summary 425

Theoretical Frame Rate 426

Introducing ITU Performance Analysis 428
ITU G.821 (08/96) 429
ITU G.826 (02/99)/G.828 (02/00) 430
ITU M.2101 (06/00)/M.2101.1(04/97) 432
ITUM.2100 433
ITUM.2110 434
ITUM.2120 436

Signal Rates 439
Summary of Errors and Alarms 440

Service Disruption 442

Test Configuration for Measuring Service Disruption Time
Contributors to Protection Switching Time 444
Protection Switching Time Test Methods 446
Understanding Service Disruption Test Results 453

Glossary 456

ﬁ%

443

User Guide

-t

rs



A

@é son_Cobra.book Page 13 Wednesday, September 25, 2002 11:09 AM

°

1
Getting Started

Product Description 14

Option Guide 17

Front Panel Tour 21

Top Panel Connectors 29

Using the Graphical User Interface (GUI) 39

Using Multiple Instruments 51

Using Online Help 53

Using a Mouse and Keyboard with the Instrument 57
Safety Information 58

Optical Connector Safety Information 59

Avoiding Problems When Making Measurements 61
Using Smart Test Features 62

Using SignalWizard 64

SONET Measurement Tutorial 73

Ethernet Measurement Tutorials 84

This chapter provides general information on how to install and
configure the instrument. It includes a brief description of the
product and safety requirements for the user to follow. Also, it
includes tutorials on how to use the instrument to carry out a
simple BER measurement.
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1  Getting Started

Product Description

The instrument provides all the test capability you need to
install and verify the performance of today’s high-capacity
transmission systems and networks in one portable package.

In addition, there is an Ethernet module that can fully test the
data capabilities of the new generation of multi-service network
elements.

SONET/SDH Capability

* Global test coverage (SONET, SDH, PDH and T-Carrier).
e Full integrated all-rate testing:
e 52 Mb/s to 10 Gb/s optical.
e 52/155 Mb/s; DS1/3; 2/8/34/140 Mb/s electrical.
¢ Full range of standard and concatenated mappings.
¢ All standard error and alarm measurements, plus:
¢ optical power, electrical level, pulse mask, frequency.
¢ service disruption time, pointer movements, delay.
¢ Simultaneous all-channel testing (up to 192 STSs/AUs).
* Intrusive and non-intrusive Thru-mode.
¢ Comprehensive SONET/SDH overhead testing.

14 User Guide
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¢ Electrical interfaces
(DS1/3; 2/8/34/140 Mb/s; 52/155 Mb/s)

e VT/TU payload testing

e DS1/3 and 2/34/140 Mb/s service mappings
¢ DSn and PDH (En) testing

¢ Pulse mask testing (up to 52 Mb/s electrical)
¢ Service disruption measurement

¢ Round trip delay measurement

¢ Electrical level measurement

¢ Graphical error and alarm result displays

* (.821,M2100, M2101, M2101.1, M2110, M.2120 performance
analysis

¢ Fast access to key measurement tasks using Smart Test.
¢ Line and payload frequency offset.
¢ Transmit and Receive can be independently configured.
* Broad range of graphical results tools.
¢ Comprehensive online help facilities:

* Online User manual.

¢ Context-sensitive help for each control field.

¢ Ability to add your own help documents.

See “Option Guide" on page 17, for more product details.

Ethernet Capability

¢ Test data services at Layer 1 and Layer 2

e Multi-port testing - 8x10/100 Mb/s and 2x1 Gigabit Ethernet
¢ Simultaneous operation of all ports

¢ Simultaneous SONET/SDH and Ethernet operation

¢ Extremely simple to set-up and operate

¢ Hot-swap GBIC modules for wavelength choice

¢ Automated RFC 2544 benchmark testing

¢ Full rate traffic generation and reception

User Guide 15
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Getting Started

¢ (Can be used for end-to-end or loopback testing

¢ Unique “Loopthru” mode allows loopback testing even at
Layer 2

* Measure the “Transmission” elements of Ethernet:

e Throughput

e Latency

e Frame Loss

e Errors
¢ User selectable full/restricted/fixed auto negotiation
* User selectable VLAN/priority tagging and flow control
¢ Frame capture facility
¢ Comprehensive online help facilities:

* Online User manual

¢ Context-sensitive help for each control field

¢ Ability to add your own help documents

See “Option Guide" on page 17, for more product details.

User Guide
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Option Guide

Getting Started

This guide explains the features offered with each instrument
mainframe and its associated options.

For more information, see:

1

“Mainframes and Potential Test Rate Capability" on page 17

“Optical Interfaces" on page 18
“Optical Connectors (product options)" on page 18

“Alternative Optical Connectors (available accessories)" on
page 19

“Ethernet Options" on page 19
“Other Options" on page 19

“Accessories" on page 20

Mainframes and Potential Test Rate Capability

There are three mainframes:

J2126A - 3-slot chassis
J2127A - 4-slot chassis
J2127A - 6-slot extended chassis

Mainframe Optical Test Interfaces Frequency Range
J2126A 0C-1,0C-3,0C-12, 0C-48 52 Mb/s to 2.5 Gb/s
(see Note 1) STM-0, STM-1, STM-4, STM-16

J2127A 0C-1,0C-3,0C-12, 0C-48, 52 Mb/s to 10 Gb/s

(see Notes 1,2 and 3) 0C-192

STM-0, STM-1, STM-4, STM-16,
STM-64

1. With option 103 fitted, maximum line rate restricted to 0C-12/STM-4.

2. Can be configured with maximum line rate of 0C-48/STM-16 and later
upgraded to 0C-192/STM-64.

3. Can have a 4-slot chassis or extended (6-slot) chassis.

17
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Optical Interfaces

Tx Optical Wavelength Option
Optical interfaces 1310 nm 100
operating up to 2.5 Gb/s
1550 nm 101
1310/1550 nm 102
Optical interfaces 1550 nm 111 (HS*), 121 (SR™)
operating up to 10 Gb/s
1310 nm 120 (SR**)

* HS - High Rx sensitivity optics.

** SR - Short reach optics.

Optical Connectors (product options)

Connector Option
FC/PC Adapters fitted on all optical interfaces 190
SC Adapters fitted on all optical interfaces 191
ST Adapters fitted on all optical interfaces 192

User Guide
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Alternative Optical Connectors (available accessories)

Alternative optical connectors are available for your product,
order the appropriate J7283A (FC/PC), J7284A (SC) or
J7285A (ST) accessory (connector). The number of connectors
required for your product is shown below.

J7283A (FC/PC)  J7284A (SC)  J7285A (ST)

J2126A with option 2 2 2
100/101

J2126A with option 102 3 3 3
J2127A" with option 5 5 5
100/101 and

111/120/121

J2127A* with option 102 6 6 6
and 111/120/121

* Can have a 4-slot chassis or extended (6-slot) chassis.

Ethernet Options

Option
Ethernet testing (8 x 10/100 Mb/s; 2 x 1 Gb/s) 323

1000Base-SX (850 nm) GBIC modules (two) 325
1000Base-LX (1310 nm) GBIC modules (two) 326
Other Options

Certificate of Calibration

Option UK6: Calibration certificate with test data

User Guide 19
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Warranty and Service Plans

Terms and conditions of the applicable warranty for this
product are contained in the sales and related documentation
supplied separately.

Please contact your nearest Agilent Technologies Sales Office
for further information on warranty and extended warranty
options.

For access to Agilent Product information and sales/service
contacts, please visit:
http://www.agilent.com.

Accessories

Additional Documentation

J7280A: Full set of printed manuals:
User Guide, Quick Reference Guide, Remote Control, and
Installation and Verification manual.

Carrying Cases

J7286A: Hard transit case (for J2126A)

J7287A: Hard transit case (for J2127A)

J7288A: Soft carrying case (for J2126/7A)

J7289A: Hard transit case (for J2127A 6-slot extended chassis)
J7290A: Soft carrying case (for J2127A 6-slot extended chassis)

Optical Adapters and Cables

J7283A: FC/PC optical connector (exchangeable)

J7284A: SC optical connector (exchangeable)

J7285A: ST optical connector (exchangeable)

J7281A: DCC port converter cable: 9-pin miniature D-type to
37-pin D-type (RS-449, female)

User Guide
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Keypad
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5 OFC

Press this key to start a new test period or terminate the
current test period. The LED indicator above the key is on
when a test period is in progress.

Press this key to access the Agilent Smart Test
menu.Operates on the foreground instrument.

Press this key to add a single error to the transmitted
signal. Select t0he error type using the Errors and Alarms
Test Functions page. Press <Menu>, choose Test
Functions > Errors and Alarms then press <Select>.
Operates on the foreground instrument.

Press this when you need to refer to the online help. Press
it again to take you back to the instrument display.

User Guide
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Navigation Controls

Keypad

The <Arrow Navigation> keys move the focus
up/down/left/right through menus, drop-down lists and

the instrument display.
Press <Select> to enter any selected menu item or value

you have entered into a field.

o Press <Menu> to display the main menu for the current
application.

A\ J Press <Menu> again, or press <Cancel>, to close the
menu.

— Press <Window> to change the focus between the left
and right windows.

u

— <Cancel> will close any menu or drop down list without
making any changes.

u

The keypad provides text and numeric entry and online help
navigation.

Numeric Entry

In a numeric entry field, enter the number you want using the
keypad. Decimal, binary and hexadecimal entries are all made
directly from the keypad.

User Guide
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r Prov Nact |
Home Back Fwd Page Page
|1 I—lllzabclls d.'llA IlD I
|7m||8m||9m||c llF{}I
l— +l|n @Il' ?llx Il":zl
S —
Special keys used in numeric entries:
Use this key to enter a negative value, for example for a
E-I] frequency offset of -99.9 ppm, press:
<->4+<9>+<9>+<.>+<9>
@ Press < X > for ‘don’t care’ entries.
Use this key to enter an exponent, for example for an error
rate of 9.9E-9 press:
<9>+<.>+<9> + <Exp> + < - >+ <9>
To edit a number press the <Left Arrow> key for
backspace operation, so deleting the preceding entry.
23
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Text Entry

In a text entry field, for example when editing a trace message,
the keypad will be in text mode.

You enter text in the same way as you would enter text into a
cell phone. The keys are labelled “abc2ZABC”, “def3DEF” and so
on. Press the key with the character you want: once for the first
character, twice (pressing the key quickly in succession) for the
second and so on.

To enter numbers or upper case letters quickly, use the <F/up
arrow> key to switch between lower case characters (CapsOff),
upper case (CapsOn) and number (Num). The current mode is
displayed in the Status Line at the bottom right of the screen.

(DE-EA)
B E)
[

o

=)
\—

018
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Special keys used in text entries:

1

Hevire

OO0

This key switches between upper and lower case
characters and numbers. The current mode, either “Caps”
or “Num”, is displayed at the bottom right of the screen on
the Status Line.

Press this key for these special characters:
space _ NUL LF CR

Press this key for these math symbols
-+ /T=<>% A

Press this key for these miscellaneous symbols

@#0$\&~()[1{}

Press this key for these punctuation symbols
I

25
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Help Function Keys

You can use the help function keys for additional navigation
when in Online Help.

Hesrrme
Returns you to the Home page.

(0

Rack
Takes you back to the previous page.

If you have used the <Back> key for navigating then this
key takes you forward to where you have come from.
Otherwise, pressing this key has no effect.

Prev

Page Scrolls up through the displayed page.

0

Mext
Pags Scrolls down through the displayed page.

@
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Status and Alarm LEDs

The Status LED indicators provide information about the status
of the instrument’s receiver. The Signal, Frame and Pattern
indicators are green if the signal is good, and red during an
alarm condition. Error indicator is off or red if error detected.

e

Frame O
Pattem O
Emors O

—
soner/sbpH QO

psn O
o O
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(@)

Multiple
Instrumelets O

8

History O

SIGNAL Green: Valid signal (level; data transitions) detected at input. Red: No data
transitions detected at input or low optical/electrical power. Operates on the
foreground instrument.

FRAME Green: Correct framing detected at all levels of the received signal (on the
line signal plus all levels down to the selected test channel). Red: Frame alignment
lost at one or more levels of the received signal. Operates on the foreground
instrument.

PATTERN Green: Correct detection of expected test pattern. Red: Expected test
pattern not received. Operates on the foreground instrument.

ERRORS Red: An error has been detected in the received signal. The indicator
remains red for 100 ms, then returns to off. Operates on the foreground instrument.

SONET/SDH: Indicates that at least one SONET or SDH alarm is present. Operates
on the foreground instrument.

DSn: Indicates that at least one ANSI DS1, DS2 or DS3 alarm is present. Operates
on the foreground instrument.

PDH: Indicates that at least one ETSI E1, E2, E3 or E4 alarm is present. Operates on
the foreground instrument.

Multiple Instruments: Indicates that an error or alarm has been detected by a
background instrument.

History: Press <Show More> to see details of current and historical
errors/alarms. Current errors/alarms are shown red, historical ones are shown
yellow. If an alarm has occurred during the current test period, the History LED will
be on. Operates on the foreground instrument.

Press <Reset> to reset the Alarm History data. The History LED will go off. If an
alarm condition is present during the reset, then the LEDs associated with that
alarm will remain on after the reset. Resetting of the history data also occurs when
you start a new test period. Operates on the foreground instrument.

27

ﬁ%

e

ﬁ%

rs



el @

@é son_Cobra.book Page 28 Wednesday, September 25, 2002 11:09 AM

1

28

Getting Started

Viewing Error/Alarm Details using the <Show More> Key

When the front panel LED lights, error and alarm conditions
have been detected. The front panel <Show More> key allows
you to view detailed alarm information.

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when you press the History <Reset>
key on the front panel.

Print Control Key

Press <Print Control> to access the print control page.
Refer to “Print Control Key (Printer Setup and Capturing
Screendumps)” on page 362. Operates on the foreground
instrument.

User Guide
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For information on the instrument’s connectors, see:

“Optical Out Ports" on page 30
“Optical In Ports" on page 31
“Clock Ports" on page 32

“DCC Port" on page 33
“Electrical Test Ports" on page 34
“Ethernet Ports" on page 35

29
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Optical Qut Ports

Provides SONET optical signals OC-1, OC-3, OC-12, OC-48,
0C-192, and SDH optical signals STM-0, STM-1, STM-4, STM-16,
STM-64 at wavelength 1310 and 1550 nm, depending on
instrument model and options.

62 Mb/s - 2.5 Gb/s 1310 nm  Selectable optical connector (see
“Optical Connectors (product options)" on page 18) for a

52 Mb/s to 2.5 Gb/s optical output. Nominal wavelength is
1310 nm. Power output is -5 to +0 dBm.

52 Mb/s - 2.5 Gb/s 1550 nm Selectable optical connector (see
“Optical Connectors (product options)" on page 18) for a

52 Mb/s to 2.5 Gb/s optical output. Nominal wavelength is
1550 nm. Power output is -2 to +3 dBm.

10 Gb/s, 1550 nm Selectable optical connector (see “Optical
Connectors (product options)" on page 18) for a 10 Gb/s optical
output. Nominal wavelength is 15650 nm. Power output is -1 to
+1 dBm.

10 Gb/s, 1550 nm (SR) Selectable optical connector (see
“Optical Connectors (product options)" on page 18) for a

10 Gb/s optical output. Nominal wavelength is 1550 nm. Power
output is -5 to -1 dBm.

10 Gb/s, 1310 nm (SR) Selectable optical connector (see
“Optical Connectors (product options)" on page 18) for a

10 Gb/s optical output. Nominal wavelength is 1310 nm. Power
output is -6 to -1 dBm.

Optical Connector Order Option
FC/PC 190
SC 191
ST 192
30 User Guide
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Optical In Ports

Accepts SONET OC-1, OC-3, OC-12, OC-48 and OC-192 and SDH
STM-0, STM-1, STM-4, STM-16, STM-64 signals, depending on
the model and options fitted.

b2 - 622 Mb/s Selectable optical connector (see “Optical
Connectors (product options)" on page 18) for a 52 Mb/s to
622 Mb/s optical input (OC-1, OC-3, OC-12/STM-0, STM-1,
STM-4 signals). Wavelength 1200 to 1600 nm. Input damage
power >+3 dBm; never exceed maximum input power. The
recommended input power operating level for OC-1,
0C-3/STM-0, STM-1 signals is -33 to -10 dBm and for
0C-12/STM-4 signals -28 to -8 dBm.

2.5 Gb/s Selectable optical connector (see “Optical Connectors
(product options)" on page 18) for a 2.5 Gb/s optical input
(0OC-48/STM-16 signals). Wavelength 1200 to 1600 nm. Input
damage power >+3 dBm; never exceed maximum input power.
The recommended input power operating level for
0C-48/STM-16 signals is -28 to -8 dBm.

10 Gb/s High Rx Sensitivity Optics Selectable optical connector
(see “Optical Connectors (product options)" on page 18) for

10 Gb/s (OC-192/STM-64) optical input signals. Wavelength
1200 to 1600 nm. Input damage power >+1 dBm; never exceed
maximum input power. The recommended input power
operating level for OC-192/STM-64 signals is -20 to -9 dBm.

10 Gb/s (SR) Optics Selectable optical connector (see “Optical
Connectors (product options)" on page 18) for 10 Gb/s
(0C-192/STM-64) optical input signals. Wavelength 1200 to
1600 nm. Input damage power >+3 dBm; never exceed maximum
input power. The recommended input power operating level for
0C-192/STM-64 (1310 nm) signals is -11 to -1 dBm. The
recommended input power operating level for OC-192/STM-64
(1550 nm) signals is -14 to -1 dBm.
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Clock Ports

2 Mb/s, 2 MHz Clock In  BNC 75 ohm (nominal) unbalanced
connector for a 2 Mb/s and 2 MHz MTS external clock source
input.

2Mb/s, 2 MHz Clock In  3-pin Siemens connector for a 2 Mb/s
and 2 MHz MTS external clock source input.

DS1 Clock In Bantam 100 ohm (nominal) connector for a DS1
BITS external reference clock input.

2 MHz Clock Out BNC 75 ohm (nominal) unbalanced connector
for a 2 MHz MTS clock reference output. Generated relative to
the selected transmit reference clock.

DS1 Clock Out Bantam 100 ohm (nominal) connector for a DS1
BITS clock reference output. Generated relative to the selected
transmit reference clock.

TX Eye Clock 52 - 25 Mb/s SMA connector providing a TX Eye
Clock signal (at 1/4 of the line rate) which can be used to trigger
an oscilloscope when examining data signals.

TX Eye Clock 10 Gb/s SMA connector providing a TX Eye Clock

signal (at 1/16 of the line rate) which can be used to trigger an
oscilloscope when examining data signals.

32 User Guide
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Getting Started 1

Connector 9-pin miniature D-type.

Use this port to insert and drop either the D1-D3 DCC channel
or the D4-D12 DCC channel. The first bit of data inserted will be
put into the MSB of the DCC channel. The MSB of the dropped
data bytes will be output first. The transmit (drop) and receive
(insert) capabilities are independent, that is the transmit and
receive clock rates can be set to different rates. The instrument
acts as a DCE (Data Communications Equipment), supplying
the clock signal for both drop and insert operation.

Rates D1-D3 DCC: 192 kb/s, D4-D12 DCC: 576 kb/s

Signal Type Unipolar differential signal as defined in ANSI
EIA-422-B and EIA-423-B.

Input Termination 100 ohms differential.

Input Sensitivity 500 mV over a +/-15 V common mode range
and 200 mV over a +/-7 V range.

Pin Number RS-449/422 Circuit

1 Rx Data Output (+)
Rx Clock Output (+)
Signal ground

Tx Clock Output (+)
Tx Data Input (+)
Rx Data Output (-)
Rx Clock Output (-)

0 N ool W DN

Tx Clock Output (-)

9 Tx Data Input (+)

33

e

>

rs



A

@é son_Cobra.book Page 34 Wednesday, September 25, 2002 11:09 AM

1

34

Getting Started

Electrical Test Ports

SONET/SDH Out BNC 75 ohm unbalanced connector for an
STS-1/STM-0 (B3ZS) or STS-3/STM-1 (CMI) electrical output.

SONET/ SDHIn BNC 75 ohm unbalanced connector for an
STS-1/STM-0 (B3ZS) or STS-3/STM-1 (CMI) electrical input.
Input Mode - Terminate or Monitor. Monitor mode conforms to
G.772-1993. Monitor Gain - 20 dB.

2 Mb/s Qut 3-pin Siemens 120 ohm balanced connector for an
E1 Transmit or E1 Drop signal output. Either this port or the
2-140 Mb/s, DS3 unbalanced Out port can be active for the E1
Transmit function.

2Mb/sIn 3-pin Siemens 120 ohm balanced connector for an
E1 Receive or E1 Insert signal input. Either this port or the
2-140 Mb/s DS3 unbalanced In port can be active for the E1
Receive function.

DS10ut Bantam 100 ohm balanced connector for a DS1
Transmit or DS1 Drop signal output.

DS1In Bantam 100 ohm balanced connector for a DS1 Receive
or DS1 Insert signal input.

2-140 Mb/s DS3 Out BNC 75 ohm unbalanced connector for E1,
E2, E3, E4, DS3 transmit or E3, E4, DS3 Drop signals. Either
this port or the 2 Mb/s balanced Out port can be active for the
E1 Transmit function.

2-140 Mb/s DS3In BNC 75 ohm unbalanced connector for E1,

E2, E3, E4, DS3 receive or E3, E4, DS3 Insert signals. Either this
part or the 2 Mb/s balanced In port can be active for E1.

User Guide
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Ethernet Ports

10M/100M Ethernet Ports Eight RJ-45 connectors are provided,
each of which can support 10 Mb/s or 100 Mb/s data rates.

1G Ethernet Ports Two Gigabit Interface Convertors (GBICs)
are provided as follows:

Instrument Option Ethernet Type GBIC
Number Agilent Part Number

325 1000BASE-SX (850 nm) ~ HFBR-5601
326 1000BASE-LX (1310 nm)  HFBR-5611

Tx Eye Clock SMA connector providing a TX Eye Clock signal
that can be used to trigger an oscilloscope when examining data
signals.

User Guide 35
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Connectors on Instrument Front/Left Side Panel

@ /‘\
Arotective

Earth
Floppy

@ Disk
Drive

GPIB U

GPIB Allows test set to be remotely controlled via the GPIB
control bus.

External Protective Earth Connect an external earth connection
to the instrument at this point.

Floppy Disk Drive Accepts 1.44 Mb IBM formatted disks.

36 User Guide
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Connectors on Instrument Front/Right Side Panel

User Guide
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LAN 10M/100M 10/100 Base-T LAN interface port. Supports
remote control of the test set and the downloading of firmware
upgrades.

10 Base-T LAN Connection Radiated Emissions To ensure
compliance with EN 55011 (1991) a category 5, STP patch lead,
RJ45 cable should be used to connect to the LAN port.

Mouse PS/2 port for connecting a mouse. To prevent possible
damage, the mouse should only be connected and disconnected
when the instrument is powered off.

USB Two Universal Serial Bus ports for connecting to a
Printer.

Keyboard PS/2 port for connecting an external keyboard. Can
be hot-plugged for use at any time. Ensure that keyboard port is
used - if connected to mouse PS/2 port in error the instrument

will require to be restarted.

RS232 Remote Control port providing following
configurations:

37
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¢ Controller Type: Computer and Terminal.
¢ Protocol: None and Xon/Xoff.

e Speed: 110, 300, 600, 1200, 2400, 4800, 9600, 19200, 38400
baud.

¢ Parity: Odd, Even, 1s, Os.

e Stop Bits: 1, 2

* Data Length: 7 bits.

VGA Connector for displaying contents of instrument screen

on an external display. Ensure that the external display is
connected before powering up the instrument.

User Guide
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Using the Graphical User Interface (GUI)

User Guide

The graphical user interface (GUI) with windows, menus and
dialog boxes provides easy access to all the instrument setup,
monitoring and results pages together with constant display of
context sensitive help and a summary diagram showing
instrument status. The interface includes an Online Help
system which gives detailed information on using the
instrument.

For more information, see:

¢ “Display Windows" on page 39

¢ “Menus" on page 43

¢ “Basic User Interface Operations" on page 45

You can use a mouse and keyboard, instead of the arrow

navigation keys, <Select> key and keypad on the front panel, to
access the graphical user interface. For more information, see:

e “Using a Mouse and Keyboard with the Instrument" on
page 57

Display Windows

There are two types of windows that you can display on the
instrument. The Instrument Window is used to display the user
interface for setting up and using the instrument. The

Online Help window is used to display user help information.

39
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Instrument Window
Window Title Bar >
Field Highlight > Physical |SONET | POHIDSN | Pattern | Ffysical | SONET | FDHDSh  Pattern |
Signal Rate 0C-162 hd
~Line
Interface Optical -
Active Window > ‘Wavelength 1550nm - Brt
(indicated by < Inactive Window
Magenta border) Total LastSecond {indicated by
~Clock G
ray border
Source Internal | ||f | ©ount * U Y )
Format D51 Data > Ratio 3 @iy 0. IO

Summary Window >

Status Information > |Status:

Ry Optical Power .. Measurement Elapsed Time  00d 00h 00m 01s

g N

TxFunetions

[ ErorsiAlams
I Frequenoy Dffset
I~ Fointer Offset
I Hon-default OH

- - -

¥ Coupling

|Laser 0n; Press Select to switch Laser OniDff. Always switch off hefore connecting/disconnecting fibers

| < Context-Sensitive

| Laser-om |

Help Message

Main Windows

Two main windows display the pages for setting up, monitoring
and viewing results.

Only one of these windows is active at a time. The active
window is indicated by a colored (magenta) border. You can
change the active window by pressing the <Window> button
next to the arrow navigation keys.

Move around within a window by using the arrow navigation
keys. The current position on the window is shown by a red
highlight box around the control field.

The title of the current displayed page is given at the top of the
window in the title bar. The title includes the menu headings
that you selected to access the page. For example, Overhead
Setup - Trace Messages is the Trace Messages page selected
from Overhead Setup on the menu.

User Guide
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Summary Diagram

The current setup of the Transmitter and Receiver, along with
Test Function Indicators and the Elapsed Time for the current
measurement period are displayed in the diagram at the bottom
of the screen. An example of the summary diagram is shown

below.
Ti¢ Fuin stinhs R Optical Powar .. Meazurernent Elapzed Tirme  0Dd 006 00m s
[T Ermomialams
[¥ Hon-detault OH
-z, | .
RxPowar ., dBm
Context-Sensitive Help

A single line of Context-Sensitive Help appears at the bottom of
the display. This gives you helpful information relating to the
area of the screen that is highlighted by the red box.

Status Line

The Status line displays the instrument and keyboard status.

User Guide 4
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NOTE

Online Help Window

You can access this at any time by pressing <Help>. To close the
help just press <Help> again.

Home

Getting Started
Instrument Setup and Use
Instrument Details
Telecoms Concepts
User's Own Help Files
Glossary

Index

Using online help...

To selact a link...

* & & 5 S &

more information

7% Agilent Technologies

The <Help> button toggles the display between the online help and the
instrument windows - when you go back into online help it will be in the
same page as when you left it. If you want to return to the Home Page of
the online help, press the <Home> key on the instrument keypad.

User Guide
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Menus

Instrument Menu

All instrument pages are accessed through the main menu.

To use the main menu

Getting Started

1

1 Press <Menu>. The focus will be on the first menu item and
the submenu will also be displayed.

2 Use the up/down arrow navigation buttons to move the focus

through the main menu and the left/right arrow navigation

buttons to move in and out of the submenus. As you move the

focus down the menu, the submenu for each item will be

displayed automatically.

3 To select a menu item press <Select>.

SONET/SDH Instrument Menu

Multiple Instruments

Results
Measurement Record
Test Functions
Overhead Monitor
Oyerhead Setup
Systemn

L]

Transmitter Settings
Receiver Settings
Thru Mode
Coupling
Stared Settings

43
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Online Help Menu

This feature allows you to quickly navigate through the Online
Help system and provides quick access to the index and your
own help files.

To use the Online Help Menu

1 Press <Menu> while in the Online Help. A list of the main
sections in the Online Help will appear.

2 Use the arrow navigation keys to select a menu item, then
press <Select>.

Getting Started
Instrument Use
Instrument Details
Telecoms Concepts
Index

Your Chwn Help
Fid

Back

Exit Online Help

User Guide
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Basic User Interface Operations

For information on how to control the instrument, see:

“Drop-Down List Box" on page 45
“Numeric Entry Box" on page 46
“Folder/Tab Selector" on page 47
“Text Entry Box" on page 47
“Modal Window" on page 48
“Action Buttons" on page 48
“More Button" on page 49
“Mapping Diagram" on page 49
“Checkboxes" on page 50

Drop-Down List Box

Drop-down lists have been used where there are multiple
choices required.

[ 2 To use a drop-down list box

1
2

Move to the drop-down box and press <Select>.

Use the arrow navigation keys to highlight your choice, then

press <Select>.

To close the drop-down list without making a selection press

<Cancel>.

Internal v|

Floppny I
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Numeric Entry Box

You can edit values using the keypad, Live Edit or Edit Field. Or
you can choose from the preset or most recently-used values
listed in the drop down menu.

To use the numeric entry box

¢ Use the keypad to enter the value into the numeric entry box.
If you make a mistake, press <Cancel>, otherwise press
<Select> to save your entry. Alternatively, press <Select> to
display a drop-down list of min/max settings, Edit Field,
Live Edit and a list of the most recently used values for that
field.

Edit Field allows you to select individual digits and edit
them using the keypad. This is useful when you want to edit
one digit of an eight-digit number. Press <Select> to enter the
value. Each time you enter a new value the focus moves to
the right.

Live Edit allows you to increment or decrement a value
during a measurement, using the arrow navigation keys. Use
the left/right arrow keys to highlight the digit to be changed
and use the up/down arrow keys to increase or decrease the
value. Note that you cannot enter new values via the keypad
while in Live Edit mode.

| ppr

90.0 Max
Edit Field
Live Edit
-90.0

50.0
0.0

User Guide
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Folder/Tab Selector

Some windows have multiple pages within a window that are
separated into different folders/tabs.

To select a folder/tab

* Use the arrow navigation keys to move to the required folder.

System - File Manager

| Logging | UserHelp | Screen Dump |
Drrive Internal =
Files Default_Factory_Settings PER v|
Operation  Refresh file list v|
Action |
Close |
Text Entry Box

To use the text entry box

¢ For quick text entry, see the “Keypad" on page 24. For
example to edit text the J1 message (shown below), press
<Select> to display a list of preset values, Edit Field and a
list of recently used text.

Edit Field allows you to select individual letters in a string of
text and edit them using the keypad. Press <Select> when
you have finished. Each time you input a letter the focus
moves to the right.

-Path Trace

16 Byte '|
ST (1)

MUl Msg
TestM=sg

47
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Modal Window

A modal window is a secondary window (dialog box) used when
an action is required on certain settings. For example, when
setting up Measurement Timing, the Measurement Timing

modal window will be displayed. You must select Close to close
the window.

You can use the <Cancel> button to close the window without
making any changes to the settings.

Results - Measurement Timing
Run [ Stap User Program

— Start
On dateftime =
Yoy-mM-DD [2001-08-12
HH:Mhd 12:45
— Stop
After duration: 24 hrs 2

Close |

Action Buttons

Buttons are used to process an action. For example, in Pointer
Adjustment, to action a pointer burst you would move to the
Transmit Pointer Burst button and press <Select>.

[ Transrnit Pointer Burst |

User Guide
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More Button

A More button, indicated by three dots, is used to indicate that
there are more selections available.

To use the More button

¢ Move to the button and press <Select>. For example, in the
mapping setup area of the Transmitter Settings pages, select
the More button to open the mapping diagram.

o

Mapping Diagram

Use the mapping diagram to select a signal mapping structure.

To use the mapping diagram

¢ Use the arrow navigation keys to select the required
mapping. Press <Select> when you have finished, or
<Cancel> to close the mapping diagram without changing the
settings. An example of a mapping diagram is shown below.

Rocket Diagram

5T5-192¢ SPE
sTS-430 5PE
£TS120 SPE
5T530 SPE

OC-1/8T8-1

|

Use cursor keys 10 configure. Press Selact o set configuration and exil. Press Cancel 1o el

49

ﬁ%

e

rs



é son_Cobra.book Page 50 Wednesday, September 25, 2002 11:09 AM

+

1  Getting Started

Checkboxes

These are used to set a control either OFF or ON. For example,
to enable Thru mode, move to the checkbox and press <Select>.

Tx /Bx - Thru Mode

50 User Guide
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Using Multiple Instruments

Products Supported

This product supports multiple instruments, namely:

SONET/SDH Upto 10 Gb/s line rates
T-carrier (DS1/DS3)
PDH (2/8/34/140 Mb/s)
Ethernet 2-port 1 Gb/s
8-port 10/100 Mb/s

Feature Summary

¢ These instruments continue to transmit and receive, and
make measurements irrespective of which is the foreground
instrument.

¢ The main menu changes to contain the selections for just the
foreground instrument.

* The <Run/Stop> key controls measurements on foreground
and background instruments simultaneously.

¢ The <Smart Test>, <Single Error>, <Show More>, <Reset>
and <Print Control> keys operate on the foreground
instrument.

¢ The front panel Signal, Frame, Pattern, Errors,
SONET/SDH, DSn, PDH and History LEDs operate only on
the foreground instrument.

¢ The Multiple Instruments LED indicates errors or alarms in
all background instruments. If on, check the Multiple
Instruments > Status page to locate the problem.

* Trouble Scan/Results Summary operates only on the
foreground instrument.

¢ A Multiple Instruments Status page is available. It is a full
product SONET/SDH Trouble Scan and Ethernet Results
Summary.

User Guide 51
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Foreground Instrument Selection

> To select the foreground instrument

¢ Press <Menu>, choose Multiple Instruments > Select then
press <Select>. Choose SONET/DSn (SDH/PDH) or
Ethernet then press <Select>.

The name of the selected foreground instrument is shown at
the top of the main menu.

A combined SONET/SDH Trouble Scan and Ethernet Results
Summary report is available. Press <Menu>, choose Multiple
Instruments > Status then press <Select>.

A summary of the main features of Multiple Instruments is
also available. Press <Menu>, choose Multiple Instruments >
Quick Help then press <Select>.

52 User Guide
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You can use the instrument’s Online Help to guide you while

using the instrument. For information on how to use the Online
Help, see:

¢ “Context-Sensitive Help" on page 54
¢ “Accessing the Index" on page 54

¢ “Using Online Help - Which Keys Do I Press?" on page 55
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Context-Sensitive Help

A single line of text appears at the bottom of the display, above
the Status line. This gives you helpful information relating to
the area of the screen that is highlighted by the red box.

Tx - Transmitter Settings Results - Errors
Phygical | SONET | PDHIDSN | Pattern | Fhysical | SOMET | PDHDSN  Patiem |
Signal Rate 0c-192 >
-~ Line
Interface Cptical hd
Wawelength 1 5500k - Blt
I LaserCn
Total LastSecond
~Clock
4 0
Source Internal hd Count
Format DS1 Data - Ratio o DALEE-1D 0 DTS00
TraFumaliens Rit Optical Power ...  dBm Measurement Elapsed Time  00d 00h 00m 01s

T ErossAlarms
I~ Frequenoy Ofiset

Tx|i-—’-’
[ Pointer Offsat
™ Honedefault oH
o
[+ Coupling
[Laser On: Press Selact lo switch Laser OniOff. Always swilch off before connectingfdisconnecting fibers | < Context-Sensitive
‘stams: [ Laser-on | Help Message

Accessing the Index

To find information quickly on a particular topic press <Menu>
and select Index, when in Help mode.
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Using Online Help - Which Keys Do | Press?

Use the Arrow Navigation keys to move between
hypertext links on a page.

Once a hypertext link is highlighted, press the <Select>
key to jump to the chosen topic.

Home  Press the <Help> key to enter or exit the Online Help.

@ Press the <Home> key to go to the Home page.

Back Fyiel Use these keys to move backwards and forwards between
Prey Next Use these keys to scroll up and scroll down through the
Press <Menu> to display a list of the main Online Help
O sections. Use the Arrow Navigation keys to select a

heading, then press <Select>.

What is Included in the Online Help?

The Online Help is divided into sections to help you quickly find
the information you want.

Getting Started - Contains an instrument tour, safety
information and measurement tutorials.

Instrument Setup and Use - Explains how to set up the
instrument, recall stored settings, make measurements and
view, save and print results. There is an Instrument Setup and
Use section for each network that the instrument can test (for
example, SDH, SONET).

Instrument Details - Contains supplementary product
information. It includes:

55
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System Features - available options, manufacturing data,
setting time and date, using the keyboard lock, printing
results, file management and creating/storing your own help
files.

Technical Support - maintenance, instrument reboot
information.

Specifications
Frequently Asked Questions

Telecoms Concepts - A reference section including a glossary,
reference tables (for example, payloads, signal rates, overhead
bytes), a summary of the ITU Standards, information on
applications.

Index - Contains a list of all features and procedures.
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Using a Mouse and Keyboard with the Instrument

CAUTION If you connect the keyboard to the Mouse Port (PS/2), the keyboard

will not function. Re-connect the keyboard and mouse to the correct
ports, then restart the instrument.

To prevent possible damage, the mouse should only be connected and
disconnected when the instrument is powered off.

J|ERIE

)

® [ Keyboard o Power ]
2 On/Off

0 " =

@

| . U —/)

Mouse Port (PS/2) You can use an external mouse (to point
and click) instead of the arrows and <Select> key to select
instrument settings on the display.

Keyboard Port (PS/2) You can use an external keyboard

instead of the front panel keypad to enter data. The keyboard
can be connected to the instrument at any time.
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Safety Information

58

This instrument has been designed and tested in accordance
with publication EN61010-1(1993) / IEC 61010-1(1990)
+A1(1992) +A2(1995) / CSA C22.2 No. 1010.1(1993) Safety
Requirements for Electrical Equipment for Measurement,
Control and Laboratory Use, and has been supplied in a safe
condition.

The Installation and Verification Manual (supplied with the
instrument) contains safety information and warnings. These
must be followed by the user to ensure safe operation and to
maintain the instrument in a safe condition.

The Installation and Verification Manual is supplied with the
instrument and included on the Product CD-ROM.

Also, please note the following safety information:

¢ “Optical Connector Safety Information" on page 59

¢ “Avoiding Problems When Making Measurements" on page 61
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Optical Connector Safety Information

Always switch off the laser before connecting or disconnecting
the optical cables.

NEVER examine or stare into the open end of a broken, severed
or disconnected optical cable when it is connected to one of the
instrument’s Optical Out connectors.

CAUTION

When connecting/disconnecting optical cables between the
instrument and device-under-test, observe the correct
connection sequences given below.

Connecting: Connect the optical cable to the input of the
device-under-test before connecting to any of the instrument’s
Optical Out connectors. When connecting to the Optical In
ports ensure the power level never exceeds the maximum stated
limit for that port. Also ensure that the power level of a signal
applied to an instrument receive port is within the
recommended operating level for that port. Recommended
input operating power levels for each input port are printed on
the connector panel adjacent to the port.

Disconnecting: Disconnect the optical cable from the Optical
Out connector before disconnecting from the device-under-test.
Close the fiber optic connector dust caps over the laser port.
Arrange for service-trained personnel, who are aware of the
hazards involved, to repair optical cables.

When connecting or disconnecting, ensure you are grounded or, make
contact with the metal surface of the mainframe with your free hand to
bring you, the module, and the mainframe to the same static potential.

For additional ESD information, see the Installation and Verification
manual.
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For further information, see:
¢ “Cleaning Optical Connectors" on page 365

* “Avoiding Optical Receiver Overload" on page 60

Avoiding Optical Receiver Overload

When connecting an optical transmitter to an optical receiver,
check that you do not overload the receiver.

Status Message Warnings Check the Status message on the
instrument display. This will warn you of overload conditions.

Maximum/Recommended Optical Power Levels Maximum
output/input power levels for the Tx Optical Out and Rx Optical
In ports are printed on the connector panel, as is the
recommended Rx Optical In port input power operating range.
When performing tests, it is recommended that you use a signal
that has an average power comparable to the middle of the
receiver’s operating range.
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Avoiding Problems When Making Measurements

Bit errors can occur due to network defects (such as faulty
network elements, damaged optical fiber or dust/dirt particles
in the fiber connections) or problems with the test
environment/setup. Follow the steps below to avoid problems
when making measurements.

| 2 To avoid introducing errors when performing tests:

1

User Guide

ﬁ%

Ensure that optical fibers connecting the instrument to the
network are not damaged - check that fibers have not been
crimped.

Avoid acute bends in the fiber. Ensure that fibers only have
gentle arcs.

If the instrument is left unattended for a long term test,
ensure that the equipment is not in a position where people
will disturb the connecting fibers.

Ensure that all fiber connections are clean and dirt-free. Use
a fiberscope to measure the cleanliness of a (unpowered)
fiber. A poorly cleaned fiber results in a drop in power.
Alternatively, use a power meter (e.g. the instrument’s
internal power meter) to measure the power at the end of a
fiber, the other end of which is connected to the network.

Before connection is made, always clean the connector
ferrule tip with acetone or alcohol using a cotton swab. Dry
the connector with compressed air. Failure to maintain
cleanliness of connectors is liable to cause excessive
insertion loss.

Ensure that the correct time and date is set on the
instrument.
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Using Smart Test Features

62

You can use Smart Test to access the SignalWizard feature
(when the foreground instrument is set to SONET/SDH) or to
the RFC Conformance Tests (when set to Ethernet). It also
provides shortcuts to results, measurements and stored
settings. Smart Test also allows you to reset the instrument to
its default settings. For specific measurement setup
information, refer to Instrument Setup and Use sections.

> To access Smart Test features

¢ Press <Smart Test>, choose the appropriate feature from the
drop-down menu using the arrows and <Select> key.

For more information on Smart Test features, see:
e “Using SignalWizard" on page 64
¢ “RFC 2544 Conformance Tests" on page 304

* “Shortcuts to Results, Measurements and Stored Settings" on
page 63

¢ “Resetting Instrument to Default Settings" on page 63
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Shortcuts to Results, Measurements and Stored Settings

You can use Smart Test to access results, measurements and
stored settings.

To access shortcuts

1 Press <Smart Test>, choose Shortcuts. Select an item from
the list and press <Select>.

2 Select an item from the list of shortcuts.

Resetting Instrument to Default Settings

You can use the Smart Test to reset the instrument to its default
values.

To reset instrument to default settings

1 Press <Smart Test>, choose Reset Instrument then press
<Select>.

2 Select OK in the “Warning” window to reset the instrument
settings.
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Using SignalWizard

64

SignalWizard checks the test ports for valid signals. A signal is
valid if its power level and frequency are with in the specified
limits of the port it is connected to. The line rate and interface
level for optical signals is determined along with the
termination, signal level and line coding for electrical signals.

SignalWizard then scans all STS/AU channels (up to 192) and
selected 'expanded' VT/TU channels simultaneously for error
and alarm information. For VT/TU channels that are not
'expanded' in the display, error and alarm information is
obtained sequentially (within milliseconds).

SignalWizard can also scan PDH/DSn sub-channels, and shows
which channels are unequipped and the type of service being
carried by equipped channels.

For information on connecting to a network when testing with
SignalWizard, see:

¢ “In-Service Testing" on page 71

e “Out-of-Service Testing" on page 72

To monitor a signal with SignalWizard

1 Press <Smart Test>, choose SignalWizard then press
<Select>. A progress indicator is displayed. If more than one
valid signal is detected, the port selection window is
displayed. Select the port you want to examine, then select
Continue. If only one valid signal is detected or if the
instrument is in Thru mode, the Channel Overview window
will automatically appear on the display. For more
information, see “Understanding the SignalWizard Overview
Window" on page 66.

If SignalWizard detects a DSn/PDH signal, then PDH/DSn
Channel Scan will automatically be launched. A window will
appear showing the status and structure of all channels.

If no valid signal is detected, you can re-scan the ports or
return to the main instrument.
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Signal Viewer Overhead Viewer Selected Channel Viewer

BONET Qc-ta- :
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Ontical Power Elapgad Time

24 008Em Agileri TesiSal Od00h08m1 05
| stats: LasarON
Channel Viewer J1 Trace Message Alarms .~ Errors

2 Press <Menu> to further investigate channels, errors or path

trace messages using Next Error, Previous Error, Expand or
Collapse. If any STS/AU contains VT/TU tributaries, you can
view a tributary in more detail. Press <Menu>, choose
Expand then press <Select>. You can also manually start the
PDH/DSn Channel Scan from the menu.

For more information on path trace messages, see
“Monitoring Path Trace Messages" on page 69.

To close SignalWizard, do one of the following:

Press <Smart Test>, choose Stop Wizard then press
<Select>.

Press <Menu>, choose Exit then press <Select>. Before
closing SignalWizard, you can automatically configure the
transmitter and/or receiver settings to match the signal being
applied to the instrument (not available in Thru mode). This
feature is useful if you intend doing further testing, it saves
you from having to manually configure the instrument
settings.
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Understanding the SignalWizard Overview Window

Signal Viewes Overhead Viewer Selected Channel Viewsr

BOMET oc-48: !

QT ST
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Optical Povwer Elapsad Tima
24 H0d8m Agilert TastSat e m0n D108
Siatias: Lasger-0M
Channel Viewer J1 Trace Message Alarms .~ Errors

Signal Viewer

Displays the detected signal. If a JO trace message is detected
this is also displayed (both 16- and 64-byte message formats are
supported).

Overhead Viewer

Displays results information associated with the overhead layer
of the signal, including;:
¢ Synchronization status message (decoded S1 byte)

¢ CV-S (RS-BIP), CV-L (MS-BIP) and REI-L (MS-REI) error
status

66 User Guide
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e AIS-L (MS-AIS) and RDI-L (MS-RDI) alarm status

(LOS and LOF alarms are displayed on the instrument’s front
panel LEDs.)

Selected Channel Viewer

Displays result information associated with the selected
channel, including:

¢ Type of payload (traffic) being carried in the channel
(decoded C2 byte)

e CV-P (HP-BIP) and REI-P (HP-REI) error status

¢ AIS-P (AU-AIS), LOP-P (AU-LOP) and RDI-P (HP-RDI) alarm
status

¢ Indicator for detected pointer adjustments

J1 Trace Message

Displays the decode path trace message associated with the
selected channel. Both 16- and 64-byte messages formats are
supported.

Channel Viewer

The Overview window shows a summary (using color coding) of
the results for all channels. Each channel detected in the signal
is provided with a dedicated box that summarizes the channel
status. A channel carrying VT/TU channels is highlighted by its
size designator being underlined. Broadband mappings are not
underlined.

The size designator identifier is displayed within each box.
While any non-standard concatenated channels will be detected
and displayed, no errors or alarms are reported for that
channel. Unequipped channels are on a grey background.
Pointer activity within a channel is indicated by the channel
background flashing blue.
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Color Coding

Color Coding Result

Green No Errors/Alarms during test or since
I:I last history reset

Red - Errors/Alarms detected

Yellow History (errors/alarms detected in the

past)

Red/white A AIS (STS-1, STS-3¢/STM-0, STM-1)

Blue - Pointer Move

Grey Unequipped

White/black dot Other Standard

Black - lllegal Pointer Combination

Errors

An Error flag is raised when one or more errors occur in any
one sampling period.

Alarms

An Alarm flag is raised when one or more alarms occur in any
one sampling period.

* Loss of Pointer LOP

e Path AIS (AIS-P)

¢ Remote Path Alarm (RDI-P)

¢ Pointer Adjustment LOP (LOP flashes blue on each
adjustment)

User Guide
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Monitoring Path Trace Messages

When running SignalWizard any routing errors in the network
will be shown in the Overview window.

During the installation and commissioning of new services, or
troubleshooting, the ability to generate and monitor path trace
messages is essential. This allows you to confirm correct routing
paths through network equipment with software controlled
routing capability. You can also use path trace messages for
checking routing performance of network elements during
protection switching to confirm the correct signals have been
protected in fault conditions.

You can view all the J1 path trace messages for the received
signal at the same time. Alternatively, you can view all the J2
path trace messages associated with VI/TU channels in a
selected STS/AU.

To view path trace messages

* Use the arrow keys to select the STS/AU channel of interest.
View the J1 path trace message at the bottom of the display.

To list/search all J1 Path trace messages in the receive signal

¢ Press <Menu>, choose Trace Messages then press <Select>.
Select List Current Levels, a trace message window will be
displayed.

or

¢ Press <Menu>, choose Trace Messages then press <Select>.
Select Search Current Level. Enter the trace message you
are searching for in the dialog box, then select OK.
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Trace Messages

| Channel | Signal Label | Trace Message |
ST5-3c #1,1 Mon-specific Agilent TestSet
STS-3c#21 Uneqguipped
STS-3c#3.1 Uneqguipped
STS-3c#4.1 Uneqguipped
STS-3c#5,1 Uneqguipped
STS-3c#6,1 Uneqguipped
STS-3c#7 .1 Uneqguipped
STS-3c#8,1 Uneqguipped
STS-3c#9,1 Uneqguipped
STS-3c#10,1 Uneqguipped
Selected channel:
Agilent TestSet Jump To |
Mext Page Close |

> To view J2 Path trace message in a VT /TU channel
1 Use the arrow keys to highlight the channel for further
analysis.

2 Press <Menu>, choose Expand then press <Select>. This
expands the VT/TU substructure.

3 Press <Menu>, choose Collapse then press <Select>. This
closes the VT/TU substructure.

STS/AU channels that contain VT/TU channels are shown underlined on
NOTE X
the display.
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You can use SignalWizard for in-service testing, to
simultaneously monitor all channels in the received signal. This
feature is useful when commissioning new transmission
systems or performing routine maintenance checks.

A typical in-service network test connection is shown below.

Multi-channel SONET/SDH signals

l

l

—'l HF8PEED
Customer i SONET!SCH

sernvices L TuR:
+“— ELEMENT

e

SONET!3OH|
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muy
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Out-of-Service Testing

You can use the instrument’s transmitter in conjunction with
SignalWizard all channel test feature to test each path carried
within a tributary or line signal. You can apply the test signal to
the tributary or line side of the network element.

Applying a test signal to the line side of the network element
may reduce the number of ports that need to be checked.
SignalWizard will identify the type of network paths present in
the received signal (including the mix of channel types), and the
traffic carrying status of each channel (showing which are

equipped).

Typical tributary and line network test connections are shown.

Next-generation platform

A&

Line interfaces
Tributaries STM-64/0C-192
3TM-16/0C-38

to STM-1/0C-3

&

Tributary-Side Testing Setup

Next-generation platform

TN,

STM-64/0C-192

Tributaries E
STM-16/0C-48 | Line interfaces
to STM-1/0C-3 H

Line-Side Testing Setup
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SONET Measurement Tutorial

User Guide

The following procedure shows you how to use the instrument
controls and arrow navigation keys to set up and perform a
measurement. In this procedure the instrument’s transmitter
output is connected directly to the receiver input. Under normal
operating conditions the transmitter output would be
connected to a system under test and the output from the
system connected to the instrument’s receiver input.

Steps 1-7 show you how to configure the instrument to transmit
and receive an OC-12 optical signal with an STS-3c SPE payload
containing a 223.1 PRBS test pattern.

In Steps 8-10 you will set the measurement test timing to be
started and stopped manually, make the measurement and view
the results.

Finally, in Steps 11-13 you will insert errors and alarms into the
transmitted signal to confirm that the instrument receiver
measures and displays those conditions.
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Step 1: Connect Optical Ports

When connecting to optical interfaces please refer to:
* “Avoiding Optical Receiver Overload" on page 60

¢ “Avoiding Problems When Making Measurements" on
page 61.

> To connect optical ports

1 Check the Test Set Optical Out ports and ensure that all
Laser On LEDs are Off. There should also be a Laser-OFF
message on the instrument Status line (bottom of display).

2 Before making any connections to the receiver Optical In
ports always check the input power level on a Power Meter.

3 Connect the 52 Mb/s - 2.5 Gb/s Optical Out port (1310 or
1550 nm depending on options fitted to your instrument) to
the receiver 52-622 Mb/s Optical In port through a 15 dB
attenuator.

74 User Guide
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Step 2: Set Up Transmitter

p  To set up the transmitter

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.

2 Select Signal Rate and press <Select> to reveal a drop down
menu of the available signal rates. Use the arrow navigation
keys to highlight OC-12, then press <Select> to set the signal
rate. Use the arrow navigation keys to set up the other
settings, including the Line (includes Wavelength and Laser
On/Off selection, set Laser to On), and Clock Source. For
safety, only turn laser on after the fiber has been connected
to the transmitter. Check the Status line for any warnings of
optical power overload.

Signal Rate Qc-12 v|
—Line

Interface Optical M|
Wavelenath 1310nm 2
~Clock

Source Internal hd
Frirfriat v|
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Step 3: Set Up the SONET Mapping

> To set the SONET mapping

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the SONET tab.

2 Move the cursor to the Mapping field and press <Select>.
Use the arrow navigation keys to select the required mapping
from the mapping diagram then press <Select>.

\ll §T812e | STS12¢3PE BLULE FILLED

BULE EILLED

bS53
8754 &8T5 BPE IMbis

BULK FILLED

Tidbdz AEYHC

- Growp T2 W12 SPE Zhdbis FLOAT
D51 ASTNG

TS VT1S5 SPE D51 FLOAT
Use cursor keys fo configure. Press Select bo set configuration and exil Press Cancel to exit
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Step 4: Set the Payload Pattern

> To set the transmitter payload pattern

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab.

2 Set up Payload Pattern as shown.

Pattern

PRBS M|
2423-1 M|
MNon-lnverted =

Step 5: Couple Tx and Rx Settings

This setting ensures the receiver has the same setting as the
transmitter.

> To couple the transmitter to the receiver

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.

Tx fRx - Coupling

Copy Txto Rx I Copy Rxto Tx |
Coupling Off
 Switih Coupling of |

Close |

2 If Coupling is On proceed directly to Step 8: Set
Measurement Gating. If it is Off, proceed to the next step.
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3 Select Copy Tx to Rx (this selection copies Transmitter
settings to the Receiver) and press <Select>. Move the cursor
to Close then press <Select> to exit the coupling window.

Step 6: Check Receiver Input Power

| 2 To check receiver input power

1 Check the Status line at the bottom of the display for any
warning messages and check Receiver Input Power as
follows.

2 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Optical Power tab.

Wavelength 1310nm v|

622 hhrs

-19.1 dBm

3 Check the receiver input power.
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Step 7: Check Setup

The Transmitter and Receiver settings should now be identical.

[ 2 To check the transmitter and receiver settings

* You can check this by viewing the summary diagram at the
bottom of the display. An example of this diagram is shown

below.

Ta Funetisns R Optical Power - Measurement Elapsed Time  0Dd 00h 00m Dis
[T EmomiAlaims

r F'.wviml o " --m—'

¥ Hondetault OH

¥ TR Coupling

e Prowesr . dbm [-_-_m_

Step 8: Set Measurement Gating

> To set measurement gating

1 Press <Menu>, choose Results > Measurement Timing then
press <Select>.

Results - Measurement Timing
Run ! Stop hdanually -

— Start

Manually v|
— Stop
After duration: | 1 min hd

Close |
2 Set the measurement Run/Stop to Manually to ensure that
testing is controlled via the green <Run/Stop> button on the
instrument front panel.
3 Use the arrow navigation keys to choose Close, then press
<Select>.
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Step 9: Start Measurement

> To start the measurement
1 Press the front panel <Run/Stop> button to start the
measurement.

2 The measurement will continue until you end the
measurement (gating) period by pressing <Run/Stop>. Leave
the instrument running the measurement.

Step 10: View Results

p  To view the results
1 Press <Menu>, choose Results > Error Summary then press
<Select>. Select the SONET tab.

2 Select the Error Type you require. Check that there are no
errors displayed.

3 To confirm that the instrument is measuring correctly, add
errors and alarms to the output signal.

80 User Guide
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Step 11: Add an Error and an Alarm to Tx Output

> To add a single error and an RDI-P Alarm

1 Press <Menu>, choose Test Functions > Errors and Alarms
then press <Select>.

2 Use the arrow navigation keys to set up errors and alarms.

Test Functions - Errors and Alarms

—Add Errars

Type Path 0iH v | cvp M|

Rate Mane v|

- Add Alarms

Type Path 0/H _ ~| ROI-P M|
V¥ Enahle Alarm

Step 12: Add a Single Error

p  To add a single error

¢ Press the front panel <Single Error> button a number of
times. Check that with each button press the CV-P error
count increments on the Error Summary results page. Try
selecting other Error Types and Error Rates and observe the
change to the results displayed.

Step 13: View Alarm Results

p  To view the alarm results

1 Press <Menu>, choose Results > Alarm Seconds then press
<Select>. Select the SONET tab.

User Guide 81
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2 Set the Alarm Type to Path.

Alarm Type  Path v|

AlS-C

LOP-P i LOP-Y
LOP-C o000 P1P0 Loss
UMEQ-P i LIMEG-Y
ROI-P i RO
RDI-P-P 0 ROI-Y-P
RDI-P-5 1] ROI-Y-5
RDI-P-C 1] R4
RFI-4

3 Check that the RDI-P alarm seconds count is incrementing,
and that the front panel SONET/SDH LED alarm indicator is
on.

(The RDI-P alarm was enabled in Step 11: Add an Error and
an Alarm to Tx Output).

4 Press the blue front panel <Show More> key to see details of
current and historical errors/alarms. Current errors/alarms
are shown red, historical ones are shown yellow.

Physical SONET || PDH/DSN |
@ @ Signal N
p ear End
g; SR TOH TS Path VT-Path
@@ LOF @@ AS-P @ P He
@ @ SEF @ @ NB-C @@
@@ AS-L @ @ LOP-P @@ Lo
@ & KIK2 Change @ & LOP-C *P
G |
@ :m;:rtern @ @ Pointer Action @@F
B @ UNEG-P s
@& Emors @ b
FarEnd
TOH STS-Path T-Fath
@ @ RDKL @ RDI-P *@
@ @ RDIP-P @@ HI
@ % RDIP-5 @@
@ @ RDIP-C @
a .o RE
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b Press the front panel <Run/Stop> button to stop the
measurement.

End of tutorial.
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Ethernet Measurement Tutorials

84

These tutorials show you how to use the instrument to set up
and perform Ethernet measurements.

Before you start, you will need to decide how to configure the
system under test. For advice on this and for background
information on Ethernet and Ethernet measurements, see
“Ethernet in Telecommunications Transmission Networks" on
page 393.
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End To End Testing Tutorial

Getting Started 1

In End To End mode, test frames are sent from one instrument
through the network under test to another instrument. The
frames should arrive error-free.

Step 1: The End To End Testing Setup

1 Connect patchcords to one or more ports on the instruments
from the line cards at both ends of the link.

2 Provision the paths through the network between the ports

on the two line cards.

3 Designate one instrument as Near End and the other as Far

End.

Set 1

Mear End

MAC Address
00-30-D3-03-DD-2A

00-30-D3-03-DD-2C
00-30-D3-03-DD-2E
00-30-D3-03-DD-30
00-30-D3-03-DD-32
00-30-D3-03-DD-34
00-30-D3-03-DD-36
00-30-D3-03-DD-38
00-30-D3-03-DD-3A

00-30-D3-03-DD-3C

8
9
10

A

A

A

A

v

=
"

\ s

-
-

8
9
10

(DUT)

SONET
(or SDH)

pipe

End-to-End Setup (ten ports shown)

Step 2: Near End Instrument Setup

10

Device Under Test

Set 2

Far End

-

'

Y

\ i

A\

A\

F 1

F 1

- - - R B T R

-
(=]

A

MAC Address
00-30-D3-03-DD-2B

00-30-D3-03-DD-2D

00-30-D3-03-DD-2F

00-30-D3-03-DD-31

00-30-D3-03-DD-33

00-30-D3-03-DD-35

00-30-D3-03-DD-37

00-30-D3-03-DD-39

00-30-D3-03-DD-3B

00-30-D3-03-DD-3D

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 In the Test Mode field, select End To End Test.
3 In the Setup Mode field, select Pre-set.
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4 In the Designate This Instrument As field, select Set 1.

b Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

6 Select Transmit Duration ... then select Burst as the
Duration Type.

7 Set a Burst Duration, either a time or number of frames, to
suit your application. For example, 1000000 frames.

8 Select Close to return to the Ethernet: Manual Tests page.

Step 3: Far End Instrument Setup

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

In the Test Mode field, select End To End Test.

In the Setup field, select Pre-set.

In the Designate This Instrument As field, select Set 2.

Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

a1l AW N

6 For the Receiver, set the Result Type to display Port Frame
Rate/Count results.

Step 4: Run the End To End Test

1 On the Far End instrument press <Run/Stop>.
2 Then, on the Near End instrument press <Run/Stop>.

3 On the Near End instrument, when the burst has finished
transmitting, the Transmitter Status will change from Tx
Burst Frames to Tx Idle Frames.

4 When this happens, check that the Far End instrument
Receiver results are as follows:

The Port Frame Count should be 1000000 frames on the
relevant ports.

The Port Errored Frame Count should be 0.
The Port Broadcast/Multi-cast Frame Count should be 0.
The Out of Sequence Event Count should be 0.

86 User Guide
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1 Port Loopback Testing Tutorial

NOTE

User Guide

ﬁ%

In 1 Port Loopback mode, the instrument is connected at one
end of a link. At the far end of the link, the transmitter on the
relevant port is looped to the receiver.

Test frames sent from the instrument into the network travel
around the Tx-Rx loop and are sent back to the instrument. The
frames should arrive error-free.

This type of loopback will only work on simple Layer 1 systems. See
“Ethernet in Telecommunications Transmission Networks" on page 393
for more details.

An alternative is to use “Loopthru Testing Tutorial" on page 92 at the far
end.

Step 1: The 1 Port Loopback Testing Setup

1 Apply transmitter/receiver loopback(s) at the Far End and
connect patchcords to the instrument at the Near End.

Set1
Near End Device Under Test
MAC Address (ouT)

00-30-D3-03-DD-2A 1 =] 1 1 B
00-30-D3-03-DD-2C 2 =] 2 2 B
00-30-D3-03.DD-2E 3 [ 3 3 R
00-30-D3-03-DD-30 4 == 4 4 R
00-30-D3-03-D0-32 5 =] 5 5 R
00-30-D3-03-DD-34 ¢ =] ¢ [
00-30-D3-03-DD-36 7 =] 7 ;?g;;} TR
00-30-D3-03-DD-38 & fg=2=] & pipe s B2
00-30-D3-03-DD-34 9 g 9 s 2
00-30-D3-03-DD-3C 10 =2 10 10 2

1 Port Loopback Setup
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Step 2: Near End Instrument Setup

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

In the Test Mode field, select Loopback Test.

In the Setup Mode field, select Pre-set.

In the Loopback Mode field, select 1 Port Loopback.

Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

(23 B — T LR X )

6 Select Transmit Duration ... then select Burst as the
Duration Type.

7 Set a Burst Duration, either a time or number of frames, to
suit your application. For example, 1000000 frames.

8 Select Close to return to the Ethernet: Manual Tests page.

9 For the Receiver, set the Result Type to display Port Data
Rate results.

Step 3: Run the 1 Port Loopback Test

1 Press <Run/Stop>.

2 While the burst is transmitting, check that the Port Data
Rate on the Receiver matches the expected bandwidth
provisioned in your system.

3 When the burst has finished transmitting, the Transmitter
Status will change from Tx Burst Frames to Tx Idle Frames.

4 When this happens, press <Run/Stop> again and check that
the Receiver results are as follows:

The Port Errored Frame Count should be 0 frames on the
relevant ports.

The Dropped Frame Count should be 0.

The Average Latency is within the limits expected for your
system.

88 User Guide
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2 Ports Loopback Testing Tutorial

NOTE

User Guide

-
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In 2 Ports Loopback mode, ports are connected together in
pairs at the far end of a link. The test instrument is then
connected to similar pair(s) of port(s) at the near end.

Test frames are sent from the first of the pair of ports on the
test instrument through the network and are sent back from the
first port of a pair at the far end into the second port of the pair
by the loopback. The test frames then travel back through the
network to the second port of the pair on the test instrument.
The frames should arrive error-free.

This type of loopback can only be used on networks working at Layer 1.

For networks working at Layer 2 (networks that include Ethernet
switching), the 2 ports loopback method can be used by correct use of
VLAN tags. See “VLAN Tagging Test Method Tutorial" on page 94 for
details. An alternative is to use “Loopthru Testing Tutorial" on page 92 at
the far end.

See “Ethernet in Telecommunications Transmission Networks" on
page 393 for more details.

Step 1: The 2 Ports Loopback Testing Setup

1 Connect loopback(s) between the relevant pair(s) at the Far
End and connect patchcords to the instrument at the Near
End.

2 Provision paths between pair(s) of ports on the network
elements at the ends of a link.

.
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Set 1

Near End Device Under Test

MAC Address (oum)
00-30-D3-03-DD-24 1 =

-y
-

00-30-D3-03-DD-2C 2 =

00-30-D3-03-DD-2E 3 [a—

00-30-D3-03-DD-30 4

1
A

o Bk W N
=

00-30-D3-03-DD-32 5 =

00-30-D3-03-DD-34 &

SOMET

00-30D3-03.DD-36 7 == orsory | 7
00-30.03.03-DD-38 8 =] pipe 8
00-30-D3-03-DD-3A 9 = 9 9

U U UUU

00-30-D3-03-DD-3C  10f==2=] 10 10

2 Ports Loopback Setup

Step 2: Near End Instrument Setup

1

S 1 A W N

Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

In the Test Mode field, select Loopback Test.

In the Setup Mode field, select Pre-set.

In the Loopback Mode field, select 2 Ports Loopback.
In the Designate This Instrument As field, select Set 1.

Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

Select Transmit Duration ... then select Burst as the
Duration Type.

Set a Burst Duration, either a time or number of frames, to
suit your application. For example, 1000000 frames.

Select Close to return to the Ethernet: Manual Tests page.

10 For the Receiver, set the Result Type to display Port Data

Rate results.
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Step 3: Run the 2 Ports Loopback Test

1 Press <Run/Stop>.

2 While the burst is transmitting, check that the Port Data
Rate on the Receiver matches the expected bandwidth
provisioned in your system.

3 When the burst has finished transmitting, the Transmitter
Status will change from Tx Burst Frames to Tx Idle Frames.

4 When this happens, press <Run/Stop> again and check that
the Receiver results are as follows:

The Port Errored Frame Count should be 0 frames on the
relevant ports.

The Dropped Frame Count should be 0.

The Average Latency is within the limits expected for your
system.

User Guide 91
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Loopthru Testing Tutorial

Loopthru is a means of testing Ethernet services on a loopback,
even if the network under test contains a Layer 2 (Ethernet)
switch.

Loopthru can therefore be used to test single or multiple
Ethernet services on any type of network. Also, the service(s)
are tested exactly as an end user will see them, with no special
network provisioning required.

Step 1: The Loopthru Testing Setup
1 Connect patchcords to one or more ports on the instruments
from the line cards at both ends of the link.

2 Provision the paths through the network between the ports
on the two line cards.

Set1 Set 2
Near End Device Under Test Far End
MAC Address (ouT) MAC Address
00-30-D3-03-DD-2A 1 =2 1 1 =="121 00-30.D3.03.0D-28
00-30-D3-03-DD-2C 2 f=2] 2 2 =132 00-30-D3-03-DD-2D
00-30-D3-03-DD-2E 3 fg=2] 3 3 =223 00-30-D3-03-DD-2F
00-30-D3-03-DD-30 4 =4 4 4 =124 00-30-D303-DD-31
00-30-D3-03-DD-32 5 [ 5 5 »12 5 00-30-D3-03-DD-33
00-30-D3-03-DD-34 6 =2 ¢ 6 =126 00-30-D3-03-DD-35
- SONET -

003003030036 7 =2 7 | orspw | 7 =7 00-30-D3-03-0D-37
00-30-D3-03-DD-38 8 =] B PiPe | g k158 00-30-03-03-DD-38
00-30-D3-03-DD-34 9 == ¢ ¢ =29 00-30-D3-03-DD-3B

00-30-D3-03-DD-3C 40

f
Yy

10 10 = 10 00-30-D3-03-DD-3D

Loopthru Setup

Step 2: Near End Instrument Setup

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

User Guide
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In the Test Mode field, select Loopback Test.
In the Setup Mode field, select Pre-set.
In the Loopback Mode field, select 1 Port Loopback.

Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

Select Transmit Duration ... then select Burst as the
Duration Type.

Set a Burst Duration, either a time or number of frames, to
suit your application. For example, 1000000 frames.

Select Close to return to the Ethernet: Manual Tests page.

For the Receiver, set the Result Type to display Port Data
Rate results.

Step 3: Far End Instrument Setup

1

2

Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

In the Test Mode field, select Loopthru.

Step 4: Run the Loopthru Test

1
2

Press <Run/Stop>.

While the burst is transmitting, check that the Port Data
Rate on the Receiver matches the expected bandwidth
provisioned in your system.

When the burst has finished transmitting, the Transmitter
Status will change from Tx Burst Frames to Tx Idle Frames.

When this happens, press <Run/Stop> again and check that
the Receiver results are as follows:

The Port Errored Frame Count should be O frames on the
relevant ports.

The Dropped Frame Count should be 0.

The Average Latency is within the limits expected for your
system.

93
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VLAN Tagging Test Method Tutorial

NOTE

VLAN Tagging is a technique used on networks containing
Layer 2 (Ethernet) switches so that testing can be carried out
on a loopback, instead of end to end.

The method forces networks to return test frames to the source
instrument for testing to be carried out. This method should
work on any network where the network elements can use
VLAN tagging.

For more information on network types, see “Ethernet in
Telecommunications Transmission Networks" on page 393.

For networks where this method cannot be used, see “End To End Testing
Tutorial" on page 85 or “Loopthru Testing Tutorial" on page 92

The VLAN Method

The network is provisioned so that pairs of ports on network
elements at opposite ends of a link have a valid path between
them. For the purposes of this tutorial, only a single pair are
considered.

1 The network element at the Near End is programmed such
that Port 1 belongs to VLAN 1 and Port 2 belongs to VLAN 2.
Similar programming occurs at the Far End.

2 Test frames are sent in to Port 1 where they will be tagged as
belonging to VLAN 1. The switch in the network element, not
recognizing the Destination MAC Address as belonging to
VLAN 1, will send the frames to the Far End.

3 The switch at the Far End, also not recognizing the frames as
being in VLAN 1, will broadcast the frames to all ports in
VLAN 1 - in this case, only Port 1. As the frames are sent out
of Port 1, the VLAN tag will be stripped off.

4 You have looped Port 1 to Port 2, so the frames will now be
received on Port 2 where they will be re-tagged as VLAN 2.

b The switch, once again, will not recognize the Destination
MAC Address as belonging to VLAN 2 and will therefore send
the frames back to the Near End.

User Guide
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6 The Near End switch will receive the frames and will now
recognize the Destination MAC Address as being Port 2 -

which does belong to VLAN 2.

7 The switch will send the frames to Port 2 where they will be
received by the test instrument.

Testing can therefore be carried out from the Near End using

Getting Started

1

the method described in “2 Ports Loopback Testing Tutorial" on

page 89.

Set 1

Near End

Port1(VLAN1) 1
Port2(VLAN2) 2
3
4

5

A

\J

VLAN Tagging

{ouT)

SONET
(or SDH)

pipe

Device Under Test

9

Far End

Port 1 (VLAN 1)
Loopback cable
Port 2 (VLAN 2)

95

e

rs



o
?

g%g son_Cobra.book Page 96 Wednesday, September 25, 2002 11:09 AM

1  Getting Started

96

User Guide

ﬁ%

e



@é son_Cobra.book Page 97 Wednesday, September 25, 2002 11:09 AM

A

. °
(] [ ]

°
° °

0% 2
ce0@® @9 - [pstrument Setup and Use - SONET

000, |
P PY °® etting up the SONET Transmitter 98
. ® . Setting up the SONET Receiver 135
. Setting Up Thru Mode Operation 160
Storing and Recalling Instrument Settings 162
Measurements and Results 163

This chapter tells you how to set the instrument interfaces, to
match the network being tested, and how to make
measurements.

Agilent Technologies 97
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Setting up the SONET Transmitter

Physical

¢ “Optical Connector Safety Information" on page 59

¢ “Selecting SONET or SDH Operation" on page 100

e “Setting Up the SONET Transmit Interface" on page 101

¢ “Selecting the SONET Transmit Clock Source" on page 105

Overhead

¢ “Generating Trace Messages" on page 108

* “Generating Synchronization Status Messages" on page 109
* “Generating Path Signal Labels" on page 110

¢ “Generating Automatic Protection Switching (APS)
Messages" on page 111

o “Editing SONET Overhead Bytes" on page 113

* “Inserting Messages into the Data Communications Channel
(DCC)" on page 115

Payload

e “Generating STS-1 SPE Payloads" on page 121

¢ “Generating Concatenated Payloads" on page 123

¢ “Transmitting SONET Tributary Payloads" on page 127

e “Transmitting a DSn Payload into a SONET Signal" on
page 129

¢ “Inserting an External DSn Payload into a SONET Signal" on
page 130

¢ “Transmitting PDH Payloads in a SONET Signal" on page 131

* “Inserting an External PDH Payload into a SONET Signal" on
page 132

98 User Guide
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Errors, Alarms, Frequency Offset and Pointer Movement
¢ “Adding SONET Errors and Alarms" on page 133

¢ “Adding Frequency Offset to the SONET Signal" on page 106
¢ “Adjusting SPE or VT Pointer Values" on page 116
¢ “Switching Off All Test Function Features" on page 134

User Guide
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Selecting SONET or SDH Operation

You can use this instrument to check the operation of individual
SONET or SDH network elements, or you can check the
performance of the spans that make up a network.

| 2 To select SONET or SDH operation

1 Press <Menu>, choose System > Preferences then press
<Select>.

2 Select the SONET or SDH network standard (as required).

100 User Guide
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Setting Up the SONET Transmit Interface

You can set up the interfaces to transmit optical or electrical
SONET signals.

For more information, see:

“Setting up the Optical SONET Transmit Interface" on
page 102

“Setting up the Electrical SONET Transmit Interface" on
page 103

“Coupling the Receiver to the Transmitter Settings" on
page 104

“Storing and Recalling Instrument Settings" on page 162

101
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Setting up the Optical SONET Transmit Interface

You apply the OC-192 optical signals to network equipment via
the 10 Gb/s (1550 nm) Optical Out port, and OC-1, OC-3, OC-12
and OC-48 via the 52 Mb/s - 2.5 Gb/s (1310 nm or 1550 nm)
Optical Out port.

Make sure the transmit interface settings match the network
equipment.

The transmitter and receiver can operate independently, or they can be
NOTE . : . . .

coupled. For more information, see “Coupling the Receiver to the

Transmitter Settings" on page 104.

Also, on power up the transmitter will re-establish the laser settings
(enabled or disabled) that existed prior to the last power down. If you want
the laser to always be disabled on power up, select the laser control
setting, see “System Preferences" on page 342.

m Always switch off the laser before connecting or disconnecting optical
cables. Read the laser warning information given in “Optical Connector
Safety Information" on page 59 before switching ON the laser. Laser
status is always shown at the bottom right of screen.

| 2 To set up the optical SONET Transmit interface
1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.
2 Select an optical Signal Rate.
3 Select a Wavelength (if dual wavelength option is fitted).

4 Select the Laser On checkbox (the Laser-ON message
appears in the Status: line at the bottom of the screen).

102 User Guide
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Setting up the Electrical SONET Transmit Interface

You apply SONET electrical STS-1 and STS-3 signals to network
equipment via the 52/155 Mb/s Out port.

Make sure the transmit interface settings match the network
equipment being test.

NOTE The transmitter and receiver can operate independently, or they can be coupled.

For more information, see “Coupling the Receiver to the Transmitter Settings" on
page 104.

| 2 To set up the electrical SONET Transmit interface

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.

2 Select an electrical Signal Rate.

User Guide 103
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Coupling the Receiver to the Transmitter Settings

You can set up the instrument so that the receiver will
automatically configure to the transmitter’s settings.

| 2 To couple the receiver to the transmitter settings

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.
2 Select Copy Tx to Rx.

3 Select Close.

> To switch off coupling

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.
2 Select Switch Coupling Off.

3 Select Close.

104 User Guide
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Selecting the SONET Transmit Clock Source

You can reference the transmitter’s timing to an internal,
external or recovered clock source.

Mode Clock Source
Internal Clock generated within the instrument.
External 1.5 Mb/s (ternary) BITS clock applied to the 100 ohm balanced

Clock In port (Bantam connection).

Recovered Clock recovered from the SONET signal applied to the receiver.

| 2 To select the transmit clock source

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.
Select a Clock Source.

Select a Clock Format if you are using an external clock
source.

105
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Adding Frequency Offset to the SONET Signal

You can apply frequency offset of up to +/-90 ppm (for 10 Gb/s
operation) or +/-100 ppm (for 2.5 Gb/s operation) to a signal,
regardless of the selected clock source. Offset can be applied
while measurements are taking place.

[ 2 To add frequency offset to a signal

1 Press <Menu>, choose Test Functions > Frequency Offset
then press <Select>.

2 Select Line Offset, then enter the required offset by editing
the frequency offset value.

3 Select the Enable Offset checkbox, then press <Select> to
switch on the offset.
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Generating SONET Overhead Signals

Tributary
signals :

You can use the procedures on the following pages to transmit
section, line or path signals (they include trace messages,
synchronization status messages, signal labels and APS
messages). You can also edit and transmit overhead bytes and
send messages in the Data Communications Channel (DCC).

SONET digital
cross-connect
VT system VT
assembly disassembly
SONET SONET
regenerator regenerator
SONET terminal SONET terminal  : Tributar:
multiplexer —> —> — —>  multiplexer : signalsy
i ' ' i
! ¢ > e g
1 - L) Ll il Ll
! i Section span i Section span E Section span |
! 1 1 1 !
1 | 1
A : ! \ ; ]
, Line span Line span |
1

Path

For more information, see:

* “Section Overhead (SOH)" on page 378
¢ “Line Overhead (LOH)" on page 379

¢ “SONET Concepts" on page 374
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Generating Trace Messages

You can check for continuity between the transmitting and
receiving ends of a section, STS path or VT path by transmitting
a message in the JO, J1 or J2 byte.

The message format can be 16-byte CRC-7 or 64-byte non-CRC.

> To generate a J0, J1 or J2 trace message
1 Press <Menu>, choose Overhead Setup > Trace Messages
then press <Select>. Select the required tab.
2 Select the JO, J1 or J2 byte format as required.
3 Select the trace message field, then press <Select>.

4 Select a trace message from the drop down menu or select
Edit Field then enter a new trace message using the keypad.

If you selected a 16 byte formatted message, you can only edit
15 bytes, the 16th byte is used for frame alignment and CRC
bits.

If you selected a 64 byte formatted message, you must
terminate the message with CR and LF for the 63rd and 64th

bytes. The CR and LF characters are selected by cycling the
“1” key.
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Generating Synchronization Status Messages

You can transmit synchronization status message in bits 5 to 8
of the S1 byte.

[ 2 To generate a S1 synchronization status message
1 Press <Menu>, choose Overhead Setup > Labels then press
<Select>.

2 Select Synchronization Status S1, then select a message as
required. When you select a message, its binary value is
automatically displayed.

For more information, see:

¢ “Synchronization Status Messages (S1 bits 5 to 8)" on
page 385
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Generating Path Signal Labels

You can assign a STS path signal label to the C2 byte to reflect
the current SPE payload mapping. Or, you can assign the VT
path overhead signal label to bits 5 to 7 of the V5 byte to reflect

the current tributary payload mapping. Messages comply with
ITU-T G.783.

| 2 To generate an STS or VT path signal label

1 Press <Menu>, choose Overhead Setup > Labels then press
<Select>.

2 Select STS (C2) or VT (V5), then select a label from the drop
down menu. When you select a label, its binary value is
automatically displayed.

For more information, see:
e “C2 Byte Mapping" on page 387
e “V5 (bits 5 to 7) Signal Label" on page 410
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Generating Automatic Protection Switching (APS) Messages

You can check a network equipment’s ability to switch to a
standby line (to maintain service when a failure is detected).
Switching is controlled by messages provided by the K1 and K2
bytes.

APS occurs when there is signal failure, signal degradation, or
in response to commands from a local terminal or remote
network manager.

You can transmit linear or ring APS messages, the instrument
will display the code and a description of the message being
transmitted.

The following procedure assumes that you have already set up
SONET signal rate.
For more information, see:

e “Linear APS Messages (Telecordia GR-253-CORE Issue 3)" on
page 381

¢ “Ring APS Messages (Telecordia GR-1230)" on page 383.

To generate a ring APS message

1 Press <Menu>, choose Overhead Setup > APS Messages
then press <Select>.

2 Set the Topology to Ring (GR-1230).

3 Select New Message K1 Bits 1->4, then select the APS
condition.

4 Select New Message K1 Bits 5->8, then select the destination
node.

5 Select New Message K2 Bits 1->4, then select the source
node.

6 Select New Message K2 Bits 5, then select the path.

7 Select New Message K2 Bits 6->8, then select the appropriate
status information.

8 Select Transmit New Message.
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> To generate a linear APS message
1 Press <Menu>, choose Overhead Setup > APS Messages
then press <Select>.
2 Set the Topology to Linear (GR-253).

3 Select New Message K1 Bits 1->4, then select the APS
condition.

4 Select New Message K1 Bits 5->8, then select the working
channel.

b Select New Message K2 Bits 1->4, then select the bridged
channel.

6 Select New Message K2 Bits 5, then select the APS
architecture.

7 Select New Message K2 Bits 6->8, then select the appropriate
status information.

8 Select Transmit New Message.
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Editing SONET Overhead Bytes

NOTE

NOTE

You can assign values to overhead bytes. You access the bytes
by selecting the appropriate STS channel number. For OC-12,
0C-48 or 0OC-192, you access the appropriate STS-3# and
STS-1#.

You cannot use Overhead Setup to edit the H1 to H3 pointer bytes, the B1,
B2 or B3 BIP bytes (as these are calculated values), or the J0 or J1 section
and path trace message bytes.

The instrument’s Test Function features interact with overhead
byte values set using the Overhead Setup feature.

¢ If the Test Function Error Add (REI-L and REI-P), Alarm
Add (all alarms) or Section/Line DCC Insert feature is active,
any byte values generate from these features will override
the values previously assigned using Overhead Setup.

¢ If the Test Function Error Add (Entire Frame and Al, A2
Frame) feature is active, it will act on the framing byte values
previously assigned using Overhead Setup.

The following procedure assumes that you have already set up
SONET signal rate.

To edit SONET overhead bytes

1 Press <Menu>, choose Overhead Setup > Byte Setup then
press <Select>.

2 Select the required STS Channel Number.

3 Edit the overhead bytes. For more information, see “Editing
Bytes" on page 114.

Note that the Test Path (POH) bytes shown correspond to the channel you
have selected on the Receiver Settings page and are not necessarily the
path bytes associated with the transport overhead bytes currently on
display.
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Editing Bytes

You can use the following procedures to edit overhead bytes.

> To edit a byte using the keypad

1 Use the arrow keys to select the overhead byte for editing.

2 Use the keypad to key in the new value in hexidecimal (0 to 9
and A to F).

3 Press <Select> (current byte value is replaced by new value).
Or press <Cancel> if you want to continue using the current
byte value.

> To edit a byte using Edit Field from the popup menu

1 Use the arrow keys to select the overhead byte for editing.

2 Press <Select>, then use the arrow keys to select Edit Field
from the popup menu.

3 Press <Select>, then use the keypad to key in the new value
in hexidecimal (0 to 9 and A to F).

4 Use the arrow keys to select the next digit (if it requires
editing).

b Press <Select> (current byte value is replaced by new value).
Or press <Cancel> if you want to continue using the current
byte value.

> To restore the default value of an individual overhead byte

1 Use the arrow keys to select the overhead byte for editing.

2 Press <Select>, then press <Select> again to select the
default value from the popup menu.

> To restore the default value of all overhead byte

1 Press <Menu>, choose Overhead Setup > Restore Defaults
then press <Select>.

2 Select Yes, then press <Select> to restore the default values
to all overhead bytes.
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Inserting Messages into the Data Communications Channel (DCC)
You can insert network management messages into the section

DCC (D1 to D3) or the line DCC (D4 to D12) of a SONET signal.

[ 2 To insert a message into the DCC of a SONET signal

1 Press <Menu>, choose Test Functions > DCC Drop/Insert
then press <Select>.

2 Connect a Protocol Analyzer to the instrument DCC port.
3 Select Transmitter DCC Insert, then select the Section DCC.
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Adjusting SPE or VT Pointer Values

You can check network equipment’s ability to handle
adjustments to SPE or VT pointer values. Pointers compensate

for frequency and phase differences between VTs and STS-ns in
the SONET frames.

Adjustments to pointer values can occur at random, can be
periodic or can occur in bursts. Pointer values can also be
individually adjusted. Pointer adjustments are byte wide, and
can cause significant amounts of jitter on payload signals.

For more information, see:

¢ “Selecting a Burst of SPE or VT Pointers" on page 117
¢ “Selecting a New SPE or VT Pointer" on page 118

* “Selecting SPE or VT Pointer Offset" on page 119
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Selecting a Burst of SPE or VT Pointers

You can have an incrementing, decrementing or alternating
burst of pointer values.

The burst size is 1 to 10 for STS and STS-Nc pointers and 1 to 5
for VT-1.5 and VT-2 pointers.

An alternating burst results in a movement in the same
direction for the burst size specified (that is, if burst size 7 is
selected then all 7 movements are in the same direction). The
generated burst is in the opposite direction to the previous
burst. The interval between movements within a burst is 500 us
for STS-N pointers and 2 ms for VT pointers.

Use Burst Size to select the size of the burst. If, for example, you
choose 5 the pointer value will be stepped 5 times in unit steps.
That is, O (start value), 1, 2, 3, 4, 5 (final value).

The following procedure assumes that you have already set up
SONET signal rate and payload.

To transmit a burst of SPE or VT pointer values

1 Press <Menu>, choose Test Functions > Pointer Adjustment
then press <Select>.

Set Pointer to SPE or VT and then select Burst.
Select the required Burst Type.

Select the Burst Size using the edit offset feature.

(23 B — T 7L R X )

Select the Transmit Pointer Burst.
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Selecting a New SPE or VT Pointer

You can select any pointer value in the valid range for the
selected pointer. The new pointer value is transmitted with or
without a New Data Flag. The current pointer value is displayed
for information purposes.

Pointer Type Range
STS 0to 782
VT-1.5 0to 103
VT-2 0to0 139

p  To select a new SPE or VT pointer
1 Press <Menu>, choose Test Functions > Pointer Adjustment
then press <Select>.
Set Pointer to SPE or VT and then select New Value.
Select the New Pointer Value, using the edit offset feature.

Select the New Data Flag checkbox if required.

Sl BN

Select Transmit New Pointer to transmit the new pointer
value (the payload jumps to the new position).
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Selecting SPE or VT Pointer Offset

You can frequency offset the Transmitter output Signal Rate or
the STS rate, relative to each other to produce pointer
movements. If you offset the VT pointer, an 87:3 sequence of
pointer movements is generated.

NOTE Pointer Offset is not available if you are currently adding frequency offset
to the SONET signal or the payload.

Pointer Type Line Rate STS Payload (VC) Rate
STS Constant Offset

STS Offset Constant

VT Constant Constant

\) Offset Tracks Line Rate

p  To add SPE or VT pointer offset
1 Press <Menu>, choose Test Functions > Pointer Adjustment
then press <Select>.
Set Pointer to SPE or VT, then select Pointer Offset.

Select the Offset value (in the range +/— 100 ppm), using the
edit offset feature.

4 Select Offset Applied to, then select Line or Payload.
Select the Enable Offset checkbox.
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Generating STS-1 SPE and Concatenated Payloads

You can transmit 34 Mb/s, DS3 and bulk-filled payloads in a

STS-1 SPE, you can bulk-fill concatenated STSs.

————
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For more information, see:
¢ “Generating STS-1 SPE Payloads" on page 121

* “Generating Concatenated Payloads" on page 123
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Generating STS-1 SPE Payloads

A framed or unframed DS3 (44 Mb/s) or 34 Mb/s signal can be
asynchronously mapped into a full STS-1 SPE payload, or you
can bulk fill the STS-1 SPE. If you are using a bulk-filled
payload, you can choose to overwrite all bytes including or
excluding the fixed stuffing bytes. (Press <Menu>, choose
System > Preferences then press <Select>.)

Signal Framing Payload Structure

DS3 C-bit, M13  DS1,2 Mb/s, 56 kb/s, 64 Kb/s, N x 56/64 kb/s
34 Mb/s ITU-TG.751 8 Mb/s, 2 Mb/s or 64 kb/s

If you are transmitting a framed signal it can be structured or
unstructured. With structured (or channelized) DS3 and E3
signals, you will need to select test patterns for the foreground
(test) channel and background (non-test) channels in the
payload. The test patterns can be inverted or non-inverted.

If you are transmitting an OC-3/STS-3 signal (or greater), you
will also need to select a pattern for the background STS-1s.

For more information, see:
e “PRBS Polarity" on page 126

This procedure assumes that you have set up the SDH signal
rate and pattern.

To insert DS3 or 34 Mb/s in a STS-1 SPE in a SONET signal

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the SONET tab.

2 Select the DS3 or 34 Mb/s payload, using the drop down box
and/or the mapping diagram.
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NOTE

3 Select the Channel that is to carry the DS3 or 34 Mb/s
payload by selecting the appropriate STS.

Mapping { 8TS-1 Jdhibrs )|:|
Channel
STS-3  §T&1
T
WT-Grp WT

Insert [ 34Mbis HOB3 -|

Background Settings ]

4 If you are transmitting an STS-3 signal (or greater), select
Background Settings then select a pattern for the
background STSs.

b Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab. Select a framed or
unframed DS3 or 34 Mb/s payload.

For 34 Mb/s framed or unframed signals, see “Setting up the
PDH Transmitter" on page 182.

For a DS3 framed or unframed signals, see “Setting up the
DSn Transmitter" on page 230.

You can view a summary of the setup at the bottom of the
screen.
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Generating Concatenated Payloads

A concatenated payload can be transmitted in a SONET signal.
This type of payload reduces test times by testing the entire
bandwidth in one go. If you are using a bulk-filled payload, you
can choose to overwrite all bytes including or excluding the
fixed stuffing bytes. (Press <Menu>, choose System >
Preferences then press <Select>.)

This procedure assumes you have selected the OC-48 signal rate
and a test pattern.

SONET Signal
0c-3 0C-12 0C-48 0C-192

STS-3c SPE STS-3c SPE STS-3c¢ SPE STS-3c SPE
STS-12¢ SPE STS-12¢ SPE  STS-12¢ SPE

STS-48c SPE  STS-48c SPE
STS-192¢ SPE

For more information, see:
e “PRBS Polarity" on page 126.

¢ “Reduced Test Time with Concatenated Payloads" on
page 125

To insert a concatenated payload into an OC-48

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the SONET tab.

2 Select a concatenated payload (STS-3¢, STS-12¢ or STS-48c¢),
using the drop down box and/or the mapping diagram.
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NOTE

3 Select the Channel that is to carry the concatenated payload
by selecting the appropriate STS.

Mapping {5TS-3c  BulkFilled J[.]
Channel

STS3  5Ts-1

[1]

WT-Grp WT
Insert - Ds3 B375 v|
Background Settings ]

You can view a summary of the setup at the bottom of the

screen.
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Reduced Test Time with Concatenated Payloads

Bulk filled and concatenated (contiguously structured)
payloads carry entire broadband services with no structured
mapping or channelization. These types of payload reduce test
times (see table below) by testing the entire bandwidth in one

go.

Concatenation is the linking together of various data structures, for
example two channels joined together to form a single channel. In SONET,
a number (M) of SPEs can be linked together to produce a concatenated
container, M times the size of the SPE. An example of this is the
concatenation of forty-eight STS-1 SPEs to carry an STS-48¢ 2.5 Gb/s
signal.

The concatenated SPE contains one Path Overhead and a single
container that carries the payload. The payload is multiplexed,
switched and transported through the network as a single
entity.

Test Time (based on 100 errors)

Test limit STS-48¢ SPE payload STS-3c SPE payload
10E-14 48 days >2 years
10E-13 4.8 days 77 days
10E-12 11.6 hours 1.7 days
10E-11 1.2 hours 18.5 hours
10E-10 7 minutes 1.9 hours
125
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PRBS Polarity

The definition of PRBS polarity may differ between ITU-T
Recommendation O0.150 and common practice in the USA. This
is illustrated by the table below.

Pattern ITU-T USA

PRBS9 Non-inverted Non-inverted
PRBS11 Non-inverted Non-inverted
PRBS15 Inverted Non-inverted
QRSS Non-inverted Non-inverted
PRBS23 Inverted Non-inverted
PRBS31 Inverted Inverted

Note that a non-inverted (2En)-1 PRBS will produce a longest
run of n-1 zeros in the PRBS sequence and inverted sequence
produces a longest run of n zeros in the PRBS sequence.

You can select PRBS polarity to be inverted or non-inverted. For
all signal types except SONET, either ITU or non-ITU is
displayed beside your selection to indicate if it conforms to
ITU-T 0.150.
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Transmitting SONET Tributary Payloads

You can transmit 28 VT1.5s, 21 VI2s or 7 VT6s in a STS-1 SPE.

The VTs are structured into 7 virtual tributary groups (VT
Groups) within a STS-1 SPE. Each VT-group can contain 4
VT1.5s, 3 VT-2s or 1 VT-6. The VTs can carry internally
generated or externally sourced PDH or DSn signals. A framed
or unframed DS1 (1.5 Mb/s) signal can be mapped into a VT1.5,
an E1 (2 Mb/s) signal can be mapped into a VT2 payload
(mapping can be asynchronous or floating byte), or you can
bulk fill a VT6. If you are transmitting a framed signal it can be
structured or unstructured. With structured (or channelized)
DS1 and 2 Mb/s signals, you will need to select test patterns for
the foreground (test) channel and background (non-test)
channels in the payload. The test patterns can be inverted or
non-inverted. If you are transmitting an OC-3/STS-3 signal (or
greater) with STS-1 mapping, you will need to select a pattern
for the background STS-1s. This procedure assumes that you
have set up an STS-48 signal rate and test pattern.

For more information, see:
¢ “PRBS Polarity" on page 152

To insert a 2 Mb/s or DS1 payload in a STS-48

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the SONET tab.

2 Select the VT2 or VT1.5 SPE payload, using the drop down
box and/or the mapping diagram.

3 Select the Channel that is to carry the 2 Mb/s or DS1 payload
by selecting the appropriate STSs and VT.

4 If you are transmitting an STS-3 signal (or greater), select
Background Settings then select a pattern for the
background VTs.

b Select the PDH/DSn tab, then select a framed or unframed
2 Mb/s or DS1 payload.
For 2 Mb/s framed or unframed signals, see “Setting up the
PDH Transmitter" on page 182.
For a DS1 framed or unframed signals, see “Setting up the
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DSn Transmitter" on page 230.

NOTE You can view a summary of the setup at the bottom of the

screen.
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Transmitting a DSn Payload into a SONET Signal

You can asynchronously map a DS1 or DS3 payload into the
tributary of a SONET signal.

For more information, see:

¢ “Transmitting SONET Tributary Payloads" on page 127

DSn Payload Inserted into SONET Tributary
DS1 VT1.5
DS3 STS-1 SPE
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Inserting an External DSn Payload into a SONET Signal

You can asynchronously map an external DS1 or DS3 payload
into the tributary of a SONET signal. This procedure assumes
that you have setup the OC-48 signal and a test pattern.

External Applied to Port Inserted into SONET Tributary
Payload

DS1 DS1In (Siemens) VT1.5

DS3 2-140 M/s DS3 In (BNC) STS-1 SPE

| 2 To insert an external DS1 payload in a OC-48 signal
1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the SONET tab.

2 Select the VT1.5 SPE DS1 payload, using the drop down box
and/or the mapping diagram.

3 Select the Channel that is to carry the DS1 payload by
selecting the appropriate STSs and VTs.

4 Select the Insert DS1 checkbox. The external signal applied
to the instrument via the DS1 In ports will be inserted into
the SONET signal.

b Select the required line code as BS8ZS or AMI.

6 If you are transmitting an OC-12 signal (or greater), select
Background Settings then select a pattern for the
background SPEs.

NOTE You can view a summary of the setup at the bottom of the

screen.
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Transmitting PDH Payloads in a SONET Signal

You can asynchronously map a 2 Mb/s PDH payload into the
tributary of a SONET signal.

PDH Payload Framing Payload Structure Inserted into
SONET Tributary
2 Mb/s PCM30, 64 kb/s or N x 64 Kb/s VT2
PCM30CRC,
PCM31 or
PCM31CRC

For more information, see:

¢ “Transmitting SONET Tributary Payloads" on page 127
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Inserting an External PDH Payload into a SONET Signal

You can asynchronously map an external 2 Mb/s payload into
the tributary of a SONET signal. This procedure assumes that
you have setup the OC-48 signal and a test pattern.

External Payload Applied to Port Inserted into SONET
Tributary
2Mb/s 2-140 M/s DS3 In (BNC) VT2
unbalanced

2 Mb/s balanced  2Mb/s In (3-pin Siemens)

> To insert an external 2 Mb/s payload in a OC-48 signal

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the SONET tab.

2 Select the VT2 SPE 2 Mb/s payload, using the drop down box
and/or the mapping diagram.

3 Select the Channel that is to carry the 2 Mb/s payload by
selecting the appropriate STSs and VTs.

4 Select the Insert E1 checkbox. The external signal applied to
the instrument via the 2Mb/s port will be inserted into the
SONET signal.

5 If you are transmitting an STS-16 signal (or greater), select
Background Settings then select a pattern for the
background SPEs.

NOTE You can view a summary of the setup at the bottom of the

screen.
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Adding SONET Errors and Alarms

NOTE

NOTE

You can add errors and alarms to a SONET signal during
testing. Refer to the Specifications, available on the CD-ROM,
for a full list of errors and alarms. Errors can be added singly, at
preset rates (1E-3, 1E-4 1E-5, 1E-6, 1E-7, 1E-8 and 1E-9) or at a
user programmable rate. With the exception of Entire Frame,
A1A2 Frame and BIT, errors can be added at all rates. You can
also generate CV-L errors by setting the APS threshold.

To add enhanced RDI alarm (RDI-P-Payload, RDI-P-Server, and RDI-P-Connection)
you must first enable the enhanced RDI feature:

1. Press <Menu>, choose System > Preferences then press <Select>.

2. Select the Enhanced RDI checkbox.

The following procedure assumes that you have already set up
SONET signal rate and payload.

To add errors and/or alarms.

1 Press <Menu>, choose Test Functions > Errors and Alarms
then press <Select>.
2 Select the Add Errors Type and Rate required.

3 Select the Add Alarm Type, then select the Alarm ON
checkbox.

You can add errors and alarms at the same time.
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Switching Off All Test Function Features

You can switch off all Test Functions features. This is useful if
you want to start configuring the instrument from a known
state.

| 2 To switch off all Test Function features

1 Press <Menu>, choose Test Functions > Switch Off then
press <Select>.
2 Select Switch Off All Active Test Functions.

3 Select Close.
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Setting up the SONET Receiver

User Guide

Physical

“Optical Connector Safety Information" on page 59
“Selecting SONET or SDH Operation" on page 100
“Setting Up the SONET Receive Interface" on page 136

Overhead

“Monitoring Trace Messages" on page 141
“Monitoring Synchronization Status Messages" on page 141
“Monitoring Path Signal Labels" on page 142

“Monitoring Automatic Protection Switching (APS)
Messages" on page 143

“Monitoring SONET Overhead Bytes" on page 144

“Dropping Messages from the Data Communications Channel
(DCC)" on page 145

Payload

“Monitoring STS-1 SPE Payloads" on page 147

“Monitoring Concatenated Payloads" on page 149
“Monitoring SONET Tributary Payloads" on page 153
“Monitoring a DSn Payload in a SONET Signal" on page 155
“Dropping a DSn Payload from a SONET Signal" on page 156
“Monitoring PDH Payloads in a SONET Signal" on page 157

“Dropping a 2 Mb/s Payload from a SONET Signal" on
page 158

“Dropping a Voice Channel to the Internal Speaker" on
page 159

Resetting Instrument

“Switching Off All Test Function Features" on page 134
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Setting Up the SONET Receive Interface

You can set up the interfaces to receive optical or electrical
SONET signals.

For more information, see:

“Setting up the Optical SONET Receive Interface" on
page 137

e “Setting up the Electrical SONET Receive Interface" on
page 138

¢ “Coupling the Transmitter to the Receiver Settings" on
page 139

¢ “Storing and Recalling Instrument Settings" on page 162
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NOTE

CAUTION

Instrument Setup and Use - SONET 2

Setting up the Optical SONET Receive Interface

You can apply OC-192 optical signals from network equipment
to the 10 Gb/s (1550 nm) Optical In port, and OC-1, OC-3, OC-12
and OC-48 to the 52 Mb/s - 2.5 Gb/s (1310 nm or 1550 nm)
Optical In port.

Make sure the receive interface settings match the network
equipment being tested.

The transmitter and receiver can operate independently, or they can be
coupled. For more information, see “Coupling the Transmitter to the
Receiver Settings" on page 139.

Network elements can produce transient power levels > 10 dBm at
switch on. These power levels will damage the instrument’s optical
receiver. To prevent damage, fit a suitable attenuator to the
instruments receiver port to ensure the received power level does not
exceed the maximum specified for the port.

Always switch off the laser before connecting or disconnecting optical
cables. Read the laser warning information given in “Optical Connector
Safety Information" on page 59 before switching ON the laser. Laser
status is always shown at the bottom right of screen.

To set up the optical SONET Receive interface

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Physical tab.

2 Select an optical Signal Rate.
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Setting up the Electrical SONET Receive Interface

You apply SONET electrical STS-1 and STS-3 signals from
network equipment to the 52/155 Mb/s In port.

Make sure the receive interface settings match the network
equipment being tested.

The transmitter and receiver can operate independently, or they can be
NOTE ) . . . :
coupled. For more information, see “Coupling the Transmitter to the

Receiver Settings" on page 139.

| 2 To set up the electrical SONET Transmit interface

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Physical tab.

2 Select an electrical Signal Rate.

3 Set the Line Interface to Electrical.

4 Set the Operating Level to Terminated or Monitor. If
Monitor is selected the input gain is boosted by 20 dB.

b Select the Equalization On checkbox if required.

138 User Guide
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Coupling the Transmitter to the Receiver Settings

You can set up the instrument so that the transmitter will
automatically configure to the receiver’s settings.

| 2 To couple the transmitter to receiver the settings

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.
2 Select Copy Rx to Tx.

3 Select Close.

> To switch off coupling

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.

2 Select Switch Coupling Off.
3 Select Close.
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Monitoring SONET Overhead Signals

You can use the procedures on the following pages to monitor
section, line or path signals (they include trace messages,
synchronization status messages, signal labels and APS
messages). You can also monitor overhead bytes and drop
messages from the Data Communications Channel (DCC).

SONET digital
cross-connect
VT system VT
assembly disassembly
SONET SONET
regenerator regenerator
Tributary: = SONET terminal SONET terminal | Tributar
signalsyi multiplexer —> — > — > — > multiplexer : Slig:a|sy
_) 1 1 _)
! ; : ! 5
X E ~ Section span - iéection spa; E " Section span 'i
! 1 1 1 !
1 | 1
1 N N
vV Linespan / \ Line span [
= N
. Path o
For more information, see:
* “Section Overhead (SOH)" on page 378
¢ “Line Overhead (LOH)" on page 379
¢ “SONET Concepts" on page 374
140 User Guide
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Monitoring Trace Messages

You can check for continuity between the transmitting and
receiving ends of a section, STS or VT path by monitoring a
message in the JO, J1 or J2 byte.

The message format can be 16-byte CRC-7 or 64-byte non-CRC.

[ 2 To monitor a JO, J1 or J2 trace message

¢ Press <Menu>, choose Overhead Monitor > Trace Messages
then press <Select>. Select the required tab.

Monitoring Synchronization Status Messages

You can monitor the synchronization status message in bits 5 to
8 of the S1 byte.

[ 2 To monitor the S1 synchronization status message

¢ Press <Menu>, choose Overhead Monitor > Labels then
press <Select>.

For more information on this part of the overhead, see:

¢ “Synchronization Status Messages (S1 bits 5 to 8)" on
page 402
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Monitoring Path Signal Labels

You can monitor the STS path signal label in the C2 byte (it
reflects the current SPE payload mapping). Or, you can monitor
the VT path signal label in bits 5 to 7 of the V5 byte (the label
reflects the current tributary payload mapping).

[ 2 To monitor an STS (C2) or VT (V5) path signal label

¢ Press <Menu>, choose Overhead Monitor > Labels then
press <Select>.

For more information, see:
e “C2 Byte Mapping" on page 387
e “V5 (bits 5 to 7) Signal Label" on page 390

142 User Guide
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Monitoring Automatic Protection Switching (APS) Messages

You can check network equipment’s ability to switch to a
standby line (to maintain service when a failure is detected).
Switching is controlled by Automatic Protection Switching
(APS) messages provided by the K1 and K2 bytes.

APS occurs when there is signal failure, signal degradation, or
in response to commands from a local terminal or remote
network manager.

You can transmit linear or ring APS messages, the instrument
will display the code and a description of the message being
transmitted.

The following procedure assumes that you have already set up
an SONET signal rate.

To view an APS messages

1 Press <Menu>, choose Overhead Monitor > APS Messages
then press <Select>.

2 Set the Topology to Linear (GR-253) or Ring (GR.1230).

For more information on APS messages, see:

¢ “Linear APS Messages (Telecordia GR-253-CORE Issue 3)" on
page 381

¢ “Ring APS Messages (Telecordia GR-1230)" on page 383.
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Monitoring SONET Overhead Bytes

NOTE

You monitor all overhead bytes including the H1 to H3 pointer
bytes, the B1, B2 or B3 BIP bytes (calculated values), and the JO
and J1 section and path trace message bytes.

You access TOH bytes by selecting the appropriate STS channel
number. For OC-12;, OC-48 or OC-192, you access the
appropriate STS-3# and STS-1#.

The following procedure assumes that you have already set up
SONET signal rate.

To monitor SONET overhead bytes

1 Press <Menu>, choose Overhead Monitor > Byte Monitor
then press <Select>.

2 Select the required STS-3# and STS-1# channel numbers.

Note that the Test Path (POH) bytes shown correspond to the channel you
have selected on the Receiver Settings page and are not necessarily the
path bytes associated with the transport overhead bytes currently on
display.

User Guide

ﬁ%

.



@é son_Cobra.book Page 145 Wednesday, September 25,2002 11:09 AM @é

>

el @

Instrument Setup and Use - SONET 2

Dropping Messages from the Data Communications Channel (DCC)

You can drop network management messages from the section
DCC (D1 to D3) or the line DCC (D4 to D12) of a SONET signal
via the DCC connector.

[ 2 To drop a message from the DCC of a SONET signal

1 Press <Menu>, choose Test Functions > DCC Drop/Insert
then press <Select>.

2 Connect a Protocol Analyzer to the instrument’s DCC port.
3 Select the required DCC, and Drop.

User Guide 145
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Monitoring STS-1 SPE and Concatenated Payloads

You can monitor 34 Mb/s, DS3 and bulk-filled payloads in an
STS-1, or bulk fill concatenated STSs.

Bk Filked

Culk filled

BEulk filled

Eulk fillad

Gulk filled
C4 asyne

D53 anyne
Ed asymic
Bulk filled

Bulk Filked

. xd
Pointer processing E1 async
. . VT2 E1 flnahng
VT2 SPE |
—

byte syno
Mluelbipeing Bulk filled
Alinni xd
- inming )
I WT1,5 [ VIS gy AR
—s—— Mapping . SPE :

For more information, see:
¢ “Monitoring STS-1 SPE Payloads" on page 147

¢ “Monitoring Concatenated Payloads" on page 149

146 User Guide

.
4~ ~¢/8




el @

-

@é son_Cobra.book Page 147 Wednesday, September 25,2002 11:09 AM

ﬁ%

User Guide

Instrument Setup and Use - SONET 2

Monitoring STS-1 SPE Payloads

A framed or unframed DS3 (44 Mb/s) or E3 (34 Mb/s) payload
can be monitored in a full STS-1 SPE, or you can monitor a bulk
filled STS-1 SPE.

Signal  Framing Payload Structure

DS3  C-bit, M13  DS1,2 Mb/s, 56 kb/s, 64 Kb/s, N x 56/64 kb/s
E3  ITUTG.751 8 Mb/s,2 Mb/s or 64 kb/s

If you are receiving a framed signal it can be structured or
unstructured. With structured (or channelized) DS3 and E3
signals, you will need to select test patterns for the foreground
(test) channel and background (non-test) channels in the
payload. The test patterns can be inverted or non-inverted.

For more information, see:
e “PRBS Polarity" on page 152

This procedure assumes that you have set up the SDH receiver
signal rate and test pattern.

To monitor a DS3 or 34 Mb/s payload in an SDH signal

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the SONET tab.

2 Select a DS3 or 34 Mb/s payload, using the drop down box
and/or the mapping diagram.

3 Select the Channel that is to carry the DS3 or 34 Mb/s
payload by selecting the appropriate STS.
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4 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab. Select a framed or
unframed DS3 or 34 Mb/s payload.

For 34 Mb/s framed or unframed signals, see “Setting up the
PDH Receiver" on page 198.

For a DS3 framed or unframed signals, see “Setting up the
DSn Receiver" on page 250.

NOTE You can view a summary of the setup at the bottom of the
screern.

148 User Guide
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Monitoring Concatenated Payloads

A concatenated payload can be monitored in a SONET signal.
This type of payload reduces test times by testing the entire
bandwidth in one go.

SONET Signal
0c-3 0C-12 0C-48 0C-192

STS-3c SPE STS-3c SPE STS-3c¢ SPE STS-3c SPE
STS-12¢ SPE STS-12¢ SPE  STS-12c SPE

STS-48c SPE  STS-48c SPE
STS-192¢ SPE

A framed or unframed 140 Mb/s (E4) payload can be carried in
a STS-3c SPE, or it can be bulk filled. The STS-12¢, STS-48c and
STS-192c¢ SPEs are bulk filled only.

If you are monitoring a STS-3c SPE, the framed 140 Mb/s signal
can be structured or unstructured. With structured signals, you
will need to select test patterns for the foreground (test)
channel and background (non-test) channels in the payload. If
you are monitoring an OC-3/STS-3 signal (or greater), you will
also need to select a pattern for the foreground STS-1. The test
patterns can be inverted or non-inverted.

For more information, see:
e “PRBS Polarity" on page 152.

¢ “Reduced Test Time with Concatenated Payloads" on
page 151

To monitor a concatenated payload

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the SONET tab.

2 Select a concatenated payload, using the drop down box
and/or the mapping diagram.

149
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3 Select the Channel that is to carry the concatenated payload
by selecting the appropriate STS.

NOTE You can view a summary of the setup at the bottom of the
screen.
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Reduced Test Time with Concatenated Payloads

Bulk filled and concatenated (contiguously structured)
payloads carry entire broadband services with no structured
mapping or channelization. These types of payload reduce test
times by testing the entire bandwidth in one go.

Concatenation is the linking together of various data structures, for
example two channels joined together to form a single channel. In SONET,
a number (M) of SPEs can be linked together to produce a concatenated
container, M times the size of the SPE. An example of this is the
concatenation of forty-eight STS-1 SPEs to carry an STS-48¢ 2.5 Gb/s
signal.

The concatenated SPE contains one Path Overhead and a single
container that carries the payload. The payload is multiplexed,
switched and transported through the network as a single
entity.

Test Time (based on 100 errors)

Test limit STS-48¢ SPE payload STS-3c SPE payload
10E-14 48 days >2 years
10E-13 4.8 days 77 days
10E-12 11.6 hours 1.7 days
10E-11 1.2 hours 18.5 hours
10E-10 7 minutes 1.9 hours
151
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PRBS Polarity

The definition of PRBS polarity may differ between ITU-T
Recommendation O0.150 and common practice in the USA. This
is illustrated by the table below.

Pattern ITU-T USA

PRBS9 Non-inverted Non-inverted
PRBS11 Non-inverted Non-inverted
PRBS15 Inverted Non-inverted
QRSS Non-inverted Non-inverted
PRBS23 Inverted Non-inverted
PRBS31 Inverted Inverted

Note that a non-inverted (2En)-1 PRBS will produce a longest
run of n-1 zeros in the PRBS sequence and inverted sequence
produces a longest run of n zeros in the PRBS sequence.

You can select PRBS polarity to be inverted or non-inverted. For
all signal types except SONET, either ITU or non-ITU is
displayed beside your selection to indicate if it conforms to
ITU-T 0.150.
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Monitoring SONET Tributary Payloads

NOTE

You can monitor 28 VT1.5s, 21 VI2s or 7 VT6s in a STS-1 SPE.

The VTs are structured into 7 virtual tributary groups
(VT Groups) within a STS-1 SPE. Each VT-group can contain 4
VT1.5s, 3 VT-2s or 1 VT-6.

A framed or unframed DS1 (1.5 Mb/s) signal mapped into a
VT1.5 or a 2 Mb/s signal mapped into a VT2 payload can be
monitored (mapping can be asynchronous or floating byte), or
you can monitor a bulk filled VT6.

The framing information for a 2 Mb/s signal that is mapped into a VT2
(floating byte) can be embedded into timeslot 0, or into the H4 byte of the
SONET signal.

If you are monitoring a framed signal it can be structured or
unstructured. With structured (or channelized) DS1 and 2 Mb/s
signals, you will need to select test patterns for the foreground
(test) channel and background (non-test) channels in the
payload. The test patterns can be inverted or non-inverted.

This procedure assumes that you have set up the SDH receiver
signal rate and test pattern.

For more information, see:

¢ “PRBS Polarity" on page 152.

To monitor a 2 Mb/s or DS1 payload in a SONET signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the SONET tab.

2 Select the VT2 or VT1.5 SPE payload, using the drop down
box and/or the mapping diagram.

3 Select the Channel that is to carry the 2 Mb/s or DS1 payload
by selecting the appropriate STSs and VT.

4 Select Timeslot 0 if the framing information of the received
signal is embedded in timeslot O (only applicable for 2 Mb/s
signals mapped into a VT2 (floating byte)).
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b Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab. Select a framed or
unframed 2 Mb/s or DS1 payload.

For 2 Mb/s framed or unframed signals, see “Setting up the
PDH Receiver" on page 198.

For a DS1 framed or unframed signals, see “Setting up the
DSn Receiver" on page 250.

NOTE You can view a summary of the setup at the bottom of the
screern.
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Instrument Setup and Use - SONET 2
You can monitor an asynchronously mapped DS1 or DS3
payload in a SONET signal.
DSn Payload Monitored in a SONET Tributary
DS1 VT1.5
DS3 STS-1 SPE
For more information, see:
¢ “Monitoring SONET Tributary Payloads" on page 153
155
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Dropping a DSn Payload from a SONET Signal

NOTE

156

You can drop an asynchronously mapped DS1 or DS3 payload
from the tributary of a SONET signal.

You obtain balanced signals at the DS1 Out port (Siemens
connector), and an unbalanced signal at the 2-140 Mb/s DS3 Out
port (BNC connector). The procedure below assumes that you
have set up the receiver with a SONET signal rate and test
pattern.

Payload Drop Port Dropped from a SONET
Tributary
DS1 DS1 Out (Siemens) VT1.5
DS3 2-140 Mb/s DS3 Out STS-1 SPE
(BNC)

To drop a DS1 payload from a SONET signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the SONET tab.

2 Select the VT1.5 SPE DS1 payload, using the drop down box
and/or the mapping diagram.

3 Select the Channel that is to carry the DS1 payload by
selecting the appropriate STSs and VT.

4 Select the Drop DS1 checkbox. The signal is available at the
DS1 Out ports.

You can view a summary of the setup at the bottom of the
screern.
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Monitoring PDH Payloads in a SONET Signal

You can monitor a 2 Mb/s PDH payload into the tributary of a

SONET signal.
PDH Payload Framing Payload Structure Monitored in a
SONET Tributary
2 Mb/s PCM30, 64 kb/s or N x 64 Kb/s VT2
PCM30CRC,
PCM31 or
PCM31CRC

For more information, see:

¢ “Monitoring SONET Tributary Payloads" on page 153
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Dropping a 2 Mb/s Payload from a SONET Signal

NOTE

158

You can drop an asynchronously mapped 2 Mb/s PDH payload
from the tributary of a SONET signal.

You obtain balanced signals at the 2 Mb/s (Bantam connector),
and an unbalanced signal to at the 2-140 Mb/s DS3 Out port
(BNC connector). The procedure below assumes that you have
set up the receiver with a SONET signal rate and test pattern.

Payload Drop Port Dropped from a SONET
Tributary
2Mb/s 2 Mb/s Qut (Bantam) or VT2
2-140 Mb/s DS3 Out
(BNC)

To drop a 2Mb/s payload from a SONET signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the SONET tab.

2 Select the VT2 SPE 2 Mb/s payload, using the drop down box
and/or the mapping diagram.

3 Select the Channel that is to carry the 2 Mb/s payload by
selecting the appropriate STSs and VT.

4 Select the Drop 2 Mb/s checkbox. The signal is available at
the 2 Mb/s Out ports.

You can view a summary of the setup at the bottom of the
screern.
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Dropping a Voice Channel to the Internal Speaker

You can drop a 56 kb/s or 64 kb/s voice channel from a PDH or
DSn signal carried in the payload of a SONET signal to the
instrument’s internal speaker.

This procedure assumes you have selected an SONET line rate.
Also you must set up the SONET receiver by selecting a payload
mapping and choosing a channel to carry the DS3 or 34 Mb/s

payload, by selecting the appropriate STSs, VT groups and VTs.

[ 2 To drop a voice channel to the internal speaker

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to Framed, M13 or C-Bit and Structured. Set
the Test Channel Rate to 2 Mb/s (64 kb/s), DS1 (64kb/s) or
DS-1 (56kb/s) as required.

3 Enter values in the Test Channel DS2, DS1, 34 Mb, 8 Mb,
2Mb and 64 kb boxes to select the required channel (the
selected test channel rate determines which boxes will be
active).

4 When you click on the 56 kb/s or 64 kb/s box, select the
Single Timeslot checkbox, then select the appropriate
timeslot carrying the voice channel.

b Select the Listen checkbox, then select the appropriate
volume level. Select Close.
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Setting Up Thru Mode Operation

160

Thru mode is used to monitor signals in networks with no
protected monitor points. The instrument is inserted into the
communications path and the received signal is routed through
to the transmit port. Two types of thru mode are available on
the instrument.

¢ “Transparent Thru Mode" on page 160
¢ “Overhead Overwrite Thru Mode" on page 161

Transparent Thru Mode

NOTE

In transparent thru mode, the signal on the receive port is
routed, unchanged, to the transmit port. The instrument
operates as normal, monitoring errors and alarms in the
received signal.

The instrument’s timing is derived from a clock recovered from
the received data.

Settings cannot be changed once you have selected Transparent THRU
mode. This stops you from selecting settings which would affect the data
path.

You must select the signal rate you want before selecting THRU mode.

To set up transparent thru mode operation
1 Press <Menu>, choose Tx/Rx > Thru Mode then press
<Select>.

2 Select the Enable Thru Mode checkbox (a tick appears in the
box).

3 Select Close.
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Overhead Overwrite Thru Mode

NOTE

Overhead Overwrite Thru Mode is applicable only for SONET and SDH line
signals.

You must select the signal rate you want before selecting THRU mode.

In overhead overwrite thru mode, the signal on the receive port
is routed to the transmit port. You can overwrite the trace
messages JO and J1, the labels S1 and C2 and the APS message
bytes K1/K2 before you retransmit the received signal. You can
also perform DCC drop and insert. In addition you can add
errors and alarms to the high order path level. The B1, B2 and
B3 BIP values are recalculated before retransmission. Errors
can be added to the frame (Entire Frame and A1A2 errors)
before you retransmit the received signal.

The instrument operates as normal, monitoring errors and
alarms in the received signal.

The instrument’s timing is derived from a clock recovered from
the received data.

To set up overhead overwrite thru mode

1 Press <Menu>, choose Tx/Rx > Thru Mode then press
<Select>.

Select the Enable Thru Mode checkbox.

Select the Overhead Overwrite checkbox.

Select Close.

Use the Overhead Setup menu to change the overhead bytes
from the As Received setting.

[ B — R 7~ B L)
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Storing and Recalling Instrument Settings

You can store four sets of instrument settings (i.e. those shown
in the summary diagram at the bottom of the display). These,
along with the factory default settings, can be recalled. This
procedure assumes that you have already set up the instrument.

> To store instrument settings

1 Press <Menu>, choose Tx/Rx > Stored Settings then press
<Select>.
Select one of the User (1 to 4) radio buttons.

3 Press the right arrow key, then enter a suitable title using
front panel keypad.

4 Select Save to store the settings.
b Select Close.

Tx ! Rx - Stored Settings
& Default

¢ User| |measurementl

|
(/User2 [measurementz |
¢ User3 [setupd |
¢ Userd [setupd |

Recall | Save Close I

p  To recall stored settings

1 Press <Menu>, choose Tx/Rx > Stored Settings then press
<Select>.

Select one of the User (1 to 4) radio buttons.

3 Select Recall. A warning dialog box will appear. Select OK
and the instrument will reconfigure using the recalled
settings.

4 Select Close.
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Measurements and Results

User Guide

Physical

“Measuring Optical Power" on page 164
“Measuring STS-1 or STS-3 Signal Level" on page 165
“Measuring Frequency" on page 166

“Viewing and Capturing the Pulse Mask of a SONET Signal
(STS-1)" on page 167

Errors and Alarms

“Viewing SONET Alarms" on page 169
“Viewing SONET Errors (Total or Last Second)" on page 170
“Viewing SONET Summary of Errors" on page 171

“Viewing Errors/Alarms using the <Show More> Key" on
page 172

“Viewing Errors and Alarms Using Trouble Scan" on page 173

Pointers, Service Disruption and Round Trip Delay

“Monitoring SPE and VT Pointer Values" on page 175

“Measuring Service Disruption Time in a SONET Network" on
page 176

“Measuring Round Trip Delay in a SONET Network" on
page 178

Analysis, Network Testing and Shortcuts to Results

“Viewing the ITU Analysis of SONET Errors and Alarms" on
page 179

“Measurement Logging" on page 331

“Shortcuts to Results, Measurements and Stored Settings" on
page 63

“Viewing Results Graphically" on page 335
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Measuring Optical Power

NOTE

You can continuously measure the optical power of the optical
signal connected to the selected (active) Optical In port, to a
resolution of 0.1 dBm.

This procedure assumes that you have connected the optical
input signal to the Optical In port and set up the SONET
receiver.

Rate Range Accuracy
10G -3t0-25 dBm +/-15dB
10G (SR) -1to0-14 dBm +/-2dB

2.5G 0to-28 dBm +/-2dB
622M and below  0to -30 dBm +/-1dB

To measure optical power

1 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Optical Power tab.

2 If your instrument has the dual wavelength featured fitted,
set Wavelength to 1310 nm or 1550 nm.

The green portion of the colored bar shows the power range for accurate BER
measurement. The blue portion indicates power levels beyond the receiver’s
operating range for accurate BER measurement. If the power level is too high and
reaches damage level the colored bar turns red.
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Measuring STS-1 or STS-3 Signal Level

You can measure the level of a STS-1 or STS-3 electrical signal at
the instrument’s SONET. In port. This procedure assumes that
you have connected the electrical signal to the appropriate
input port and set up the SONET receiver.

[ 2 To measure level of an STS-1 or STS-3 electrical signal

* Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Electrical tab.
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Measuring Frequency

The frequency of a valid receive signal is continuously
measured and available for display (independent of any test
period). During signal loss, the measurement is disabled and the
results invalidated.

The measured frequency and the amount of offset from the
expected standard rate can be used to give an indication of the
probability of errors.

This procedure assumes that the test signal has been connected
to the appropriate optical or electrical input port and that the
receiver signal rate has been set.

To measure frequency

¢ Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Frequency tab.
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Viewing and Capturing the Pulse Mask of a SONET Signal (STS-1)

With the instrument connected to the appropriate
cross-connect level (STSX-1), you can check that the pulse shape
of a STS-1 electrical signal meets the ANSI T1.102 standard. You
can also view the level and pulse width of both the positive and
negative pulses. Level ratio and width ratio are also displayed.

This procedure assumes that you have set up the SONET
receiver.

NOTE Excessive jitter on the input signal may adversely affect the pulse shape.

oagR

H-
B-
B-

| 2 To view and capture the pulse mask of a STS-1 signal

1 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Pulse Mask tab.

2 Set the mask to ANSI T1.102.

3 Select Capture. The +ve and -ve LEDs are grey while data is
being captured.

User Guide 167
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4 Select the appropriate +ve or -ve radio button to view the
positive or negative pulse shape and measurements.

If the +ve and -ve LEDs are green, the pulse shape will also be
green and within specification.

If an LED is red, the part of the pulse that violates the mask
envelope will be red and out of specification.
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Viewing SONET Alarms

NOTE

You can monitor alarms in an SONET signal during testing. See
the Specifications on the CD-ROM, for a full list of alarms.

The instrument displays alarms as Alarm Seconds results (the
total number of seconds in the test period during which the
alarm was active).

To view enhanced RDI alarms (RDI-P-Payload, RDI-P-Server, and
RDI-P-Connection), first enable the enhanced RDI feature:

1. Press <Menu>, choose System > Preferences then press <Select>.
2. Select Enhanced RDI.

Refer to the instrument specifications document on the
instrument CD-ROM, for a full list of alarms.

To view alarms seconds results

1 Press <Menu>, choose Results > Alarm Seconds then press
<Select>. Select the SONET tab.

2 Select the Alarm Type.
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Viewing SONET Errors

You can view errors using either of the procedures listed below:
¢ “Viewing SONET Errors (Total or Last Second)" on page 170
¢ “Viewing SONET Summary of Errors" on page 171

¢ “Viewing Errors/Alarms using the <Show More> Key" on
page 172

Viewing SONET Errors (Total or Last Second)

You can monitor errors in an SONET signal during testing.

Refer to the Specifications, on the CD-ROM for full details of
errors results. You can view errors on the instrument as Total
or Last Second results.

Total Results The display shows the running total of errors as
they occur throughout the measurement gating period. The total
result stops when measurement gating stops.

Last Second The errors results display is updated every
second. A last second result is the number of errors occurring in
the last second.

NOTE To view enhanced RDI alarms (RDI-P-Payload, RDI-P-Server, and
_ RDI-P-Connection), first enable the enhanced RDI feature:
1. Press <Menu>, choose System > Preferences then press <Select>.
2. Select Enhanced RDI.

p  To view SONET errors

1 Press <Menu>, choose Results > Errors then press <Select>.
Select the SONET tab.

2 Select the Error Type.
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Viewing SONET Summary of Errors

The Error Summary window provides a running total of the
number of errors occurring during the current measurement
period.

Refer to the Specifications, provided on the CD-ROM supplied
with your instrument, for full details of available errors.

p  To view the error summary

1 Press <Menu>, choose Results > Error Summary then press
<Select>. Select the SONET tab.

2 Select the Error Type.
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Viewing Errors/Alarms using the <Show More> Key

When the front panel LED lights, error and alarm conditions
have been detected. The front panel <Show More> key allows
you to view detailed alarm information.

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when History <Reset> on the front
panel is pressed.

[ 2 To view the error/alarm conditions

¢ Press <Show More>. Select the SONET tab.
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Viewing Errors and Alarms Using Trouble Scan

You can use Trouble Scan to continuously monitor errors and
alarms in a SONET signal (gives an initial indication of the
problems existing when you first test a channel). Initial errors
and/or alarms may indicate problems with connections to the
instrument or problems with the network.

Trouble Scan displays up to 4 error counts (in priority order).

Priority Error

1 CV-S

2 CV-L

3 Cv-P

4 Cv-v

5 CV-V (V5)

6 Frame Errors (A1A2)

7 Payload: near-end errors except Bit

8 REI-L

9 REI-P

10 IEC-P

" REI-V

12 RFI-V

13 Bit for bulk filled payloads

14 Payload: far-end errors and Bit
User Guide 173
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p  To start Trouble Scan

1 Press <Menu>, choose Results > Trouble Scan then press
<Select>. The errors and an alarm message will be displayed.

2 If no alarms are detected and all error counts are zero then
“No Trouble” is displayed. If “Alarms Active” or
“Alarms Were Active” is displayed, then press the front panel
<Show More> key for details on which alarms have occurred.

Front Panel LEDs and <Show More> key
The front panel <Show More> key allows you to view detailed
alarm information.

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when History <Reset> on the front
panel is pressed.

NOTE Clock Loss and Power Loss alarms are not monitored in Trouble Scan.
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Monitoring SPE and VT Pointer Values

You can monitor the pointer values in the SONET signal. The
pointer results that can be displayed are shown below:

Pointer Value: The received pointer value is displayed as a
decimal number.

NDF Seconds: The number of seconds containing one or more
active New Data Flag (NDF) events.

Missing NDF: The number of seconds containing one or more
new pointer value moves with no accompanying active NDF.

Implied Offset: The calculated average offset that would cause
the pointer adjustments measured during the test period.

Positive Adjustments (Count): The number of pointer
increments in the test period.

Positive Adjustments (Seconds) The number of seconds in the
test period which contain one or more pointer increments.

Negative Adjustments (Count): The number of pointer
decrements in the test period.

Negative Adjustments (Seconds): The number of seconds in
the test period which contain one or more pointer decrements.

To monitor pointer values

1 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Pointers tab.

2 Set Pointer Type to SPE or VT, as required.

You can also graphically view the relative offset between pointer
values. The Graph feature also shows the timing relationship of
pointer movements during the measurement.

For more information, see:

¢ “Viewing Results Graphically" on page 335
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Measuring Service Disruption Time in a SONET Network

NOTE

You can measure the time it takes (service disruption time) for
the automatic protection switch (APS) circuit to detect and
activate the standby equipment when a fault occurs. This
protection switch action allows the network to continue earning
revenue even when equipment goes faulty.

For more information, see “Test Configuration for Measuring
Service Disruption Time" on page 443.

You can deliberately invoke a protection switch in a network
carrying a PRBS by generating a burst of PRBS errors.

To view disruption time

1 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Service Disruption tab.

Press <Run/Stop>.
3 Verify error-free reception of the PRBS test pattern.

4 Invoke a protection switch on a working section of the
transmission system that is transporting the PRBS. The
instrument will display the service disruption results.

You can deliberately invoke a protection switch in a network carrying a
PRBS by generating a burst of PRBS errors. You can simulate a node
failure by removing the power from the transmission element, or you can
simulate fiber break by disconnecting a fiber. For background information,
see “Service Disruption"” on page 442.
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Service Disruption Test Results

The instrument provides three separate results:

* Longest: The duration of the longest error burst detected
during the test

¢ Shortest: The duration of the shortest error burst detected
during the test

¢ Last: The duration of the most recent error burst detected
during the test

When you press the <Run/Stop> key at the beginning of a
protection-switching time test, all result fields are reset to O ms.

When the protection switch is triggered, the duration of the
resulting error burst is measured and displayed.

For the system under test to pass, a single error burst of
duration less than 50 ms should be detected. Detection of a
single error burst is indicated by an identical value being
displayed in the three result fields.

Three separate results are provided because some transmission
systems exhibited a characteristic similar to switch-bounce
during a protection-switching event. This results in multiple
distinct error bursts being present on the received test pattern.
By providing three separate results, the instrument’s service
disruption measurement clearly identifies the presence of this
unwanted operating characteristic.

Other additional measurement features include:

¢ Relative timestamping of the beginning and end of each
service disruption event.

e History: A record of the first ten service disruption
measurements.

While an Alarm Indication Signal is not strictly speaking a pure
protection-switching measurement, it is closely tied to these
types of measurements by being activated as a result of any
physical layer failure, such as a fibre break.
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Measuring Round Trip Delay in a SONET Network

You can measure round trip delay using an electrical or optical
SONET signal. Round trip delay is the time taken for traffic to
pass through a network.

When you run a round trip delay measurement, the
instrument’s transmitter and receiver operate together. First,
the instrument transmits a burst of bit errors, it then measures
the time it takes for the errors to be detected by the receiver.
The time difference between transmitting and receiving errors
is the round trip delay.

This procedure assumes that you have set up a loopback
connection in the network you are testing. Also, make sure that
the bit rate, line code, input operating level and termination
settings match the network element being tested and that the
Transmit and Receive SONET signal structures match. Set up
the instrument to transmit a SONET signal with a PRBS pattern
and ensure there are no Signal, Frame or Pattern errors.

To measure the round trip delay of a SONET network
1 Press <Menu>, choose Test Functions > Switch Off then
press <Select>.

2 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Round Trip Delay tab.

3 Select Measure.
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Viewing the ITU Analysis of SONET Errors and Alarms

NOTE

You can view the ITU analysis of section, line or STS path errors
and alarms.

First make sure the bit rate, line code, input operating level and
termination settings match the network element being tested.
Also check that the receive SONET framing structure and
payload are set correctly.

For more information, see:

¢ “Introducing ITU Performance Analysis" on page 428

To view the ITU analysis of results

1 Press <Menu>, choose Results > Performance Analysis then
press <Select>.

2 Set the G- or M-series Analysis Type as required.

All supported types of analysis are available during a measurement. The
measurement will not be affected if you switch between the different
results provided.
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This chapter tells you how to set the instrument interfaces to
match the network being tested and how to make
measurements.
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Setting up the PDH Transmitter

Physical

e “Setting Up the PDH Transmit Interface" on page 183

¢ “Selecting the PDH Transmit Clock Source" on page 185

¢ “Adding Frequency Offset to the PDH Signal" on page 186

Framed or Unframed Signal

e “Transmitting a Framed PDH Signal (Unstructured
Payload)" on page 188

¢ “Transmitting a Framed PDH Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 189

e “Transmitting an Unframed PDH Signal" on page 193

Payload

¢ “Inserting an External 2 Mb/s Payload into a PDH Signal" on
page 194

Error and Alarms

¢ “Adding Errors to a PDH Signal" on page 195

¢ “Adding Alarms to a PDH Signal" on page 196

¢ “Switching Off All Test Function Features" on page 197
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Setting Up the PDH Transmit Interface

You can transmit a balanced 2 Mb/s signal or an unbalanced
2 Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s signal via the 2 Mb/s Out
and the 2-140 Mb/s DS3 Out ports.

Make sure the instrument’s bit rate, line code, output level and
termination settings match the network element being tested.

Signal Bit Rate Line  Output Termination
Code Level

E1 2Mb/s  HDB3 3V 75 ohm unbalanced (BNC)
120 ohm balanced (3-pin Siemens)

E2 8Mb/s HDB3 237V 75ohm unbalanced (BNC)
E3 34 Mb/s  HDB3 1V 75 ohm unbalanced (BNC)

E4 140 CMI 1V 75 ohm unbalanced (BNC)
Mb/s

NOTE The transmitter and receiver can operate independently, or they can be

coupled. For more information, see “Coupling the Receiver to the
Transmitter" on page 184.

p  To set up the PDH transmit interface

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.
2 Select Signal Rate, then select the required bit rate.

3 Set the Line Termination to 75 ohm (Unbal) or 120 ohm
(Bal) (2 Mb/s line signals only).
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Coupling the Receiver to the Transmitter

You can set up the instrument so that the receiver will
automatically configure to the transmitter’s settings.

| 2 To couple the receiver to the transmitter settings
1 Press <Menu>, then select Tx/Rx > Coupling using the arrow
and <Select> keys.
2 Select Copy Tx to Rx.
3 Select Close.

> To switch off coupling

1 Press <Menu>, then select Tx/Rx > Coupling using the arrow
and <Select> keys.
2 Select Switch Coupling Off.

3 Select Close.
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Selecting the PDH Transmit Clock Source

You can reference the transmitter’s timing to an internal,
external or recovered clock source.

Mode Clock Source

Internal Clock generated within the instrument.

External 2 Mb/s (ternary) or 2 MHz (binary) Master Timing Signal (MTS)
applied to the 75 Q unbalanced Clock In port (BNC).
or
2 Mb/s (ternary) MTS applied to the 120 Q balanced clock In port
(Siemens).

Recovered  Clock recovered from the 2 Mb/s signal applied to the receiver.

[ 2 To select the transmit clock source

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.

2 Select the Clock Source. The Clock Format is 2 Mb/s Data
or 2 Mb/s Clock if you select an external clock source.
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Adding Frequency Offset to the PDH Signal

You can apply frequency offset of up to +/-100 ppm (resolution
0.1 ppm and accuracy 0.02 ppm) to a signal, regardless of the
selected clock source. Offset can be applied while
measurements are taking place.

[ 2 To add frequency offset to a signal

1 Press <Menu>, choose Test Functions > Frequency Offset
then press <Select>.

2 Select Line Offset, then enter the required offset by editing
the frequency offset value.

3 Select the Enable Offset checkbox, then press <Select> to
switch on the offset.
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Transmitting a Framed PDH Signal

You can transmit a framed 2 Mb/s, 8Mb/s, 34 Mb/s or 140 Mb/s
PDH signal via the 2 Mb/s or 2-140 Mb/s DS3 Out ports. Also, a
framed signal can be inserted into the payload of a SONET/SDH
signal. The framed PDH signal can be structured or

unstructured and can carry inverted or non-inverted (normal)
PRBS patterns.

For more information, see:

¢ “Transmitting a Framed PDH Signal (Unstructured
Payload)" on page 188

e “Transmitting a Framed PDH Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 189

e “PRBS Polarity" on page 192
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Transmitting a Framed PDH Signal (Unstructured Payload)

You can transmit a framed PDH signal with an unstructured
payload via the 2 Mb/s or 2-140 Mb/s DS3 Out ports. Also, you
can insert an unstructured PDH signal into the payload of a
SONET or SDH signal. The test pattern transmitted in the PDH
signal fills the entire payload and can be inverted or
non-inverted (normal).

This procedure assumes you have set up a PDH signal rate.

Signal Framing

2Mb/s  PCM30, PCM30CRC, PCM31 or PCM31CRC
8 Mb/s  Framed (ITU-T G.751)

34 Mb/s  Framed (ITU-T G.751)

140 Mb/s  Framed (ITU-T G.751)

To transmit an unstructured payload
1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.

2 Set Framing to the required setting, then select
Unstructured.

3 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab.

4 Select the required pattern (inverted or normal).
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Transmitting a Framed PDH Signal (Structured Payload, Signaling
Bits and Spare Bits)

When you transmit a framed PDH signal with a structured
(channelized) payload, you will need to select the test patterns
for the foreground (test) channel and background (non-test)
channels in the payload. The test patterns can be inverted or
non-inverted (normal).

Signal Framing Payload Structure

2Mb/s  PCM30, PCM30CRC, 2 Mb/s (64 kb/s)
PCM31 or PCM31CRC

8 Mb/s  Framed (ITU-T G.751) 2 Mb/s or 64 kb/s
34 Mb/s  Framed (ITU-T G.751) 8 Mb/s, 2 Mb/s or 64 kb/s
140 Mb/s  Framed (ITU-T G.751) 34 Mb/s, 8 Mb/s, 2 Mb/s or 64 kb/s

You can also select the signaling bits of 2 Mb/s signal with
PCM30 or PCM30CRC framing.

Signal Framing Signaling bits
2 Mb/s PCM30 or A B C D individually set to 1 or 0.
PCM30CRC

The signaling bits of all timeslots are set
to the 4-bit user-defined value.

The Si and Sa spare bits can also be transmitted if a framed
PDH signal is selected (see the final step of this procedure).
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PDH Signal Spare Bits

2Mb/s Si bits (international bits) - Located in Timeslot 0 Bit 1of both
the FAS and NFAS frames. Si bits can be modified when in
non-CRC-4 frames.

E bits - Are the Si bits of frames 13 and 15 of a CRC-4 frame,
and can be independently modified. When transmitted as 0,
they inform the far end that block errors have occurred.

Sa bits (national bits) - located in bits 4 to 8 of NFAS timeslot
can be independently modified.

Sa bit Sequences - Defines sync status, it is an 8-bit
sequence transmitted in selected NFAS Sa bits of a CRC-4
frame. The sequence appears in odd numbered CRC-4
frames (starting from frame 1).

CAS Multiframe - Located in MFAS timeslot bits 5, 7 and 8
can be modified.

8 Mb/s FAS bit 12 can be modified.
34 Mb/s FAS bit 12 can be modified.
140 Mb/s FAS bits 14 and 16 can be modified.

This procedure assumes you have set up a PDH signal rate.

To transmit a PDH signal with a structured payload

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.

2 Set the Framing and select Structured.

3 Set the Test Channel Rate. Enter values in the Test Channel
boxes to select the required channel (the selected test
channel rate determines which boxes will be active). When
you select the 64 kb/s box, a timeslot selection window will
be displayed. Select the Single Timeslot checkbox and a
timeslot (or de-select the Single Timeslot checkbox for
N x 64 kb/s foreground channels), then select Close.

User Guide
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When transmitting 2 Mb/s channelized payloads, you can
transmit either a single 64 kb/s foreground channel or

N x 64kb/s foreground channels (contiguously or
non-contiguously). Use the N x 64kb/s channels when testing
wideband services such as high speed data and LAN links
(112 or 336 kb/s).

Timeslot Editor

2Mbis

¥ Single Timeslot
Timeslot

Bandwidth 64 khisg

Close |

Tlmeslot Editor

2Mbis

I~ Single Timeslot

Timeslot

Timeslot 16 ignared
Bandwidth 704 khis

Close |

4 Select the Test Channel Framing (line rates over 8 Mb/s).

Select Background Settings and select a background
pattern.

Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab.

7 Choose a test pattern.

8 Press <Menu>, choose Overhead Setup > Signaling Bits then

press <Select>. This lets you access the signaling bits.

Press <Menu>, choose Overhead Setup > Spare Bits then
press <Select>. This lets you access the spare bits.
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PRBS Polarity

The definition of PRBS polarity may differ between ITU-T
Recommendation O0.150 and common practice in the USA. This
is illustrated by the table below.

Pattern ITU-T USA

PRBS9 Non-inverted Non-inverted
PRBS11 Non-inverted Non-inverted
PRBS15 Inverted Non-inverted
QRSS Non-inverted Non-inverted
PRBS23 Inverted Non-inverted
PRBS31 Inverted Inverted

Note that a non-inverted (2En)-1 PRBS will produce a longest
run of n-1 zeros in the PRBS sequence and inverted sequence
produces a longest run of n zeros in the PRBS sequence.

You can select PRBS polarity to be inverted or non-inverted
(normal). For all signal types except SONET, either ITU or
non-ITU is displayed beside your selection to indicate if it
conforms to ITU-T 0.150.
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Transmitting an Unframed PDH Signal

You can transmit test patterns in an unframed 2 Mb/s, 8 Mb/s,
34 Mb/s or 140 Mb/s PDH signal via the 2 Mb/s or 2-140 Mb/s
DS3 Out port. Also, an unframed PDH signal can be inserted
into the payload of a SONET/SDH signal. The test patterns can
be inverted or non-inverted (normal).

This procedure assumes you have set up a PDH signal rate.

p  To transmit an unframed PDH signal

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.

2 Set Framing to Unframed.

3 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab.

4 Select the required pattern (inverted or normal).

User Guide 193
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Inserting an External 2 Mb/s Payload into a PDH Signal

You can insert an external 2 Mb/s payload into a framed 8 Mb/s,
34 Mb/s or 140 Mb/s PDH signal via the 2 Mb/s In port.

This procedure assumes you have set up a PDH signal rate.

> To insert an external 2 Mb/s payload into a PDH signal
1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.
2 Set Framing to Framed and Structured.
3 Set the Test Channel Rate to 2 Mb/s.

4 Enter values in the Test Channel 34 Mb, 8 Mb and 2 Mb
boxes to select the required channel (the selected line rate
determines which boxes will be active).

b Select the Insert checkbox.
6 Connect the external 2 Mb/s signal to the In port.
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Adding Errors to a PDH Signal

You can add bit errors to the PDH signal either singly or at a
selectable rate.

Refer to the Specifications provided on the CD-ROM for full
details of the errors.

p  To add bit errors to a PDH signal
1 Press <Menu>, choose Test Functions > Errors and Alarms
then press <Select>.

2 Select the appropriate Add Errors Type, then select the
required error.

3 Set the Add Errors Rate as required. If you select a User
rate, then enter the required value. The errors will be added
to the signal during the measurement period. Also, you can
use the <Single Error> key to add single errors.
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Adding Alarms to a PDH Signal

You can transmit alarms in a PDH signal.

Refer to the Specifications provided on the CD-ROM for full
details of the alarms.

p  To add alarms to a PDH signal
1 Press <Menu>, choose Test Functions > Errors and Alarms
then press <Select>.

2 Select the appropriate Add Alarm Type, then select the
required alarm.

3 Select the Enable Alarm checkbox. The alarm will then be
transmitted during the measurement period.

196 User Guide
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Switching Off All Test Function Features

You can switch off all Test Functions features. This is useful if
you want to start configuring the instrument from a known
state.

| 2 To switch off all Test Function features

1 Press <Menu>, choose Test Functions > Switch Off then
press <Select>.

2 Select Switch Off All Active Test Functions.
3 Select Close.
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Setting up the PDH Receiver

Physical
e “Setting Up the PDH Receive Interface" on page 199

Framed or Unframed Signal

e “Monitoring a Framed PDH Signal (Unstructured
Payload)" on page 202

* “Monitoring a Framed PDH Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 203

¢ “Monitoring an Unframed PDH Signal" on page 207

Payload
* “Dropping a 2 Mb/s Payload from a PDH Signal" on page 209

¢ “Dropping a Voice Channel from a PDH Signal to the Internal
Speaker" on page 208

Signaling and Spare Bits, Switching Off All Test Functions

¢ “Monitoring Signaling Bits in Structured 2 Mb/s Signal" on
page 211

¢ “Monitoring Spare Bits of a 2 Mb/s signal in a DS3 Signal" on
page 263

e “Switching Off All Test Function Features" on page 197

198 User Guide
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Setting Up the PDH Receive Interface

NOTE

You can receive a balanced 2 Mb/s signal or an unbalanced 2
Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s signal via the 2 Mb/s In or
2-140 Mb/s DS3 In ports.

Make sure the bit rate, line code, input operating level and
termination settings match the network element being tested.

Signal BitRate Line Input
Code o .
Termination Operating Level
E1 2Mb/s  HDB3 75Qunbalanced  Terminate (2.37 V)
(BNC) Monitor (2.37 Vyy but with
additional gains of 20, 26 or
30 dB)
120 Q balanced Terminate (3.0 V)
(3-pin Siemens) Monitor (3.0 Vi but with
additional gains of 20, 26 or
30 dB)
E2 8Mb/s  HDB3 75Qunbalanced Terminate (2.37 V)
(BNC) Monitor (2.37 Vi but with
additional gains of 20, 26 or
30 dB)
E3 34 Mb/s HDB3 75Qunbalanced  Terminate (1.0 Vj with

E4 140 Mb/s  CMI

(BNC)

75 Q unbalanced
(BNC)

equalization automatic or off)
Monitor (1.0 Vi but with
additional gains of 20 or 26
dB)

Terminate (1.0 Vi with
automatic equalization)
Monitor (1.0 Vi but with
additional gains of 20 dB)

The receiver and transmitter can operate independently, or they can be
coupled. For more information, see “Coupling the Transmitter to the

Receiver" on page 200.

The receiver derives its timing from the input signal.

ﬁ%
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[ 2 To set up the PDH Receive interface

1

Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Physical tab.

2 Set the Signal Rate to 2 Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s.

Set Line Termination to 75 ohm (Unbal) or 120 ohm (Bal) (2
Mb/s line rate only).

Set the Operating Level to Terminate or Monitor. If you
select Monitor, you can set the Gain to 20 dB or 26 dB.

Select the Equalization On checkbox if required.

Coupling the Transmitter to the Receiver

You can set up the instrument so that the transmitter will
automatically configure to the receiver’s settings.

> To couple the receiver to the transmitter settings

1

Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.

2 Select Copy Rx to Tx.
3 Select Close.

> To switch off coupling

1

Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.

2 Select Switch Coupling Off.
3 Select Close.
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Monitoring a Framed PDH Signal

You can monitor a framed 2 Mb/s, 34 Mb/s or 140 Mb/s PDH
signal or drop the framed PDH signal from the payload of a
SONET or SDH signal. The framed PDH signal can be structured
or unstructured. The PRBS patterns carried in these signals can
be inverted or non-inverted (normal).

You should connect the 2 Mb/s or 2-140 Mb/s DS3 In port to the
network element being tested.

For more information, see:

¢ “Monitoring a Framed PDH Signal (Unstructured
Payload)" on page 202

¢ “Monitoring a Framed PDH Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 203

e “PRBS Polarity" on page 206
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Monitoring a Framed PDH Signal (Unstructured Payload)

You can monitor a framed 2 Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s
PDH signal with an unstructured payload. The transmitted test
pattern fills the entire payload and can be inverted or
non-inverted (normal).

This procedure assume you have set up a PDH signal rate.

p  To view a PDH signal with an unstructured payload

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to the required setting, then select
Unstructured.

3 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Pattern tab.

4 Select the required pattern (inverted or normal).

202 User Guide
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Monitoring a Framed PDH Signal (Structured Payload, Signaling
Bits and Spare Bits)

When you monitor a framed PDH signal with a structured (or
channelized) payload, you will need to select test patterns for
the foreground (test) channel and the background (non-test)
channels in the payload. The test patterns can be inverted or
non-inverted (normal).

Signal Framing Payload Structure

2 Mb/s PCM30, PCM30CRC, 2 Mb/s (64 Kb/s)
PCM31 or PCM31CRC

8 Mb/s ITU-T G.742 2Mb/s or 64 kb/s
34 Mb/s ITU-T G.751 8 Mb/s, 2 Mb/s or 64 kb/s
140 Mb/s  ITU-T G.751 34 Mb/s, 8 Mb/s, 2 Mb/s or 64 kb/s

You can also monitor the signaling bits of a 2 Mb/s with PCM30
or PCM30CRC framing.

Signal Framing Signaling bits
2 Mb/s PCM30 or A B C D individually set to 1 or 0.
PCM30CRC

The signaling bits of all timeslots are set
to the 4-bit user-defined value.

The Si and Sa spare bits can also be monitored if a framed PDH
signal is selected (see the final step of this procedure).
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PDH Signal Spare Bits

2Mb/s Si bits (international bits) - Located in Timeslot 0 Bit 1of both
the FAS and NFAS frames.

E bits - Are the Si bits of frames 13 and 15 of a CRC-4 frame,
and can be independently modified. When transmitted as 0,
they inform the far end that block errors have occurred.

Sa bits (national bits) - located in bits 4 to 8 of NFAS
timeslot.

Sa bit Sequences - Defines sync status, it is an 8-bit
sequence in the selected NFAS Sa bits of a CRC-4 frame.
The sequence appears in odd numbered CRC-4 frames
(starting from frame 1).

CAS Multiframe - Located in MFAS timeslot bits 5, 7 and 8.
8 Mb/s FAS bit 12.
34 Mb/s FAS bit 12.
140 Mb/s FAS bits 14, 15 and 16.

This procedure assumes you have set up a PDH signal rate.

To view a PDH signal with a structured payload

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set the Framing and select Structured.

3 Set the Test Channel Rate. Enter values in the Test Channel
boxes to select the required channel (the selected test
channel rate determines which boxes will be active). When
you select the 64 kb/s box, a timeslot selection window will
be displayed. Select the Single Timeslot checkbox and a
timeslot (or de-select the Single Timeslot checkbox for
N x 64 kb/s foreground channels), then select Close.
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When monitoring 2 Mb/s channelized payloads, you can
monitor a single 64 kb/s foreground channel or N x 64kb/s
foreground channels (contiguously or non-contiguously). Use
the N x 64 kb/s channels when testing wideband services
such as high speed data and LAN links (112 or 336 kb/s).

Timeslot Editor

2hbis

¥ Single Timeslot
Timeslot
Bandwidth 64 khisg

Close |

Tlmeslot Editor

2Mbis

I~ Single Timeslot

Timeslot 16 ignared
Bandwidth 704 khis

Close |

Select Test Channel Framing (line rates 8 Mb/s and above).

b Press <Menu>, choose Tx/Rx > Receiver Settings then press

<Select>. Select the Pattern tab. Choose a test pattern.

Press <Menu>, choose Overhead Monitor > Signaling Bits
then press <Select>. View the signaling bits.

Press <Menu>, choose Overhead Monitor > Spare Bits then
press <Select>. View the Sa bits.
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PRBS Polarity

The definition of PRBS polarity may differ between ITU-T
Recommendation O0.150 and common practice in the USA. This
is illustrated by the table below.

Pattern ITU-T USA

PRBS9 Non-inverted Non-inverted
PRBS11 Non-inverted Non-inverted
PRBS15 Inverted Non-inverted
QRSS Non-inverted Non-inverted
PRBS23 Inverted Non-inverted
PRBS31 Inverted Inverted

Note that a non-inverted (2En)-1 PRBS will produce a longest
run of n-1 zeros in the PRBS sequence and inverted sequence
produces a longest run of n zeros in the PRBS sequence.

You can select PRBS polarity to be inverted or non-inverted
(normal). For all signal types except SONET, either ITU or
non-ITU is displayed beside your selection to indicate if it
conforms to ITU-T 0.150.
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Monitoring an Unframed PDH Signal

You can monitor test patterns in an unframed 2 Mb/s, 8 Mb/s,
34 Mb/s or 140 Mb/s PDH signal applied to the 2 Mb/s In or
2-140 Mb/s DS3 In ports, or drop the unframed signal from the
payload of a SONET or SDH signal. The test patterns can be
inverted or non-inverted.

This procedure assumes you have set up a PDH signal rate.

p  To receive an unframed PDH signal

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to Unframed.

3 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Pattern tab.

4 Select the required pattern (inverted or normal).
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Dropping a Voice Channel from a PDH Signal to the Internal Speaker

You can drop a 64 kb/s voice channel from a 2 Mb/s, 8 Mb/s, 34
Mb/s or 140 Mb/s framed PDH signal to the instrument’s
internal speaker.

This procedure assumes you have set up a PDH signal rate.

[ 2 To drop a voice channel to the internal speaker

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to Framed and Structured. Set the Test
Channel Rate to 2 Mb/s (64 kb/s).

3 Enter values in the Test Channel 34 Mb, 8 Mb, 2Mb and
64 kb boxes to select the required channel (the selected test
channel rate determines which boxes will be active).

4 When you click on the 56 kb/s or 64 kb/s box, select the
Single Timeslot check box, then select the appropriate
timeslot carrying the voice channel.

b Select the Listen checkbox, select the appropriate volume
level. Select Close.
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Dropping a 2 Mb/s Payload from a PDH Signal

You can drop a 2 Mb/s payload from a framed 8 Mb/s, 34 Mb/s
or 140 Mb/s signal via the 2 Mb/s Out port.

The PDH signal carrying the 2 Mb/s payload (to be dropped)
must be connected to the 2-140 Mb/s DS3 In port.

This procedure assumes you have set up a PDH signal rate.

> To drop an 2 Mb/s payload from a PDH signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.
2 Set Framing the to Framed and Structured.
3 Set the Test Channel Rate to 2 Mb/s.

4 Enter values in the Test Channel 34 Mb, 8 Mb and 2 Mb
boxes to select the required channel (the selected line rate
determines which boxes will be active).

b Select the Drop 2 Mb/s checkbox.
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Monitoring Si and Sa Spare Bits of a2 Mb/s signal in a PDH Signal

You can view the Si and Sa spare bits of a structured 2 Mb/s
signal carried in a PDH signal.

PDH Signal Spare Bits

2Mb/s Si bits (international bits) - Located in Timeslot 0 Bit 1of both
the FAS and NFAS frames.

E bits - Are the Si bits of frames 13 and 15 of a CRC-4 frame,
and can be independently modified. When transmitted as 0,
they inform the far end that block errors have occurred.

Sa bits (national bits) - located in bits 4 to 8 of NFAS
timeslot.

Sa bit Sequences - Defines sync status, it is an 8-bit
sequence in the selected NFAS Sa bits of a CRC-4 frame.
The sequence appears in odd numbered CRC-4 frames
(starting from frame 1).

CAS Multiframe - Located in MFAS timeslot bits 5, 7 and 8.
8 Mb/s FAS bit 12.
34 Mb/s FAS bit 12.
140 Mb/s FAS bits 14, 15 and 16.

p  To view Si and Sa spare bits

¢ Press <Menu>, choose Overhead Monitor > Spare Bits then
press <Select>. View the Si bits

¢ Press <Menu>, choose Overhead Monitor > Sa Bits then
press <Select>. View the Sa bits.

210 User Guide

rs



@é son_Cobra.book Page 211 Wednesday, September 25,2002 11:09 AM

el @

Instrument Setup and Use - PDH 3

Monitoring Signaling Bits in Structured 2 Mb/s Signal

You can monitor signaling bits in a 2 Mb/s (with PCM30 or
PCM30CRC framing) signal.

Signal Framing Signaling bits
2 Mb/s PCM30 or A B C D individually set to 1 or 0.
PCM30CRC

The signaling bits of all timeslots are set
to the 4-bit user-defined value.

[ 2 To view signaling bits of a 2 Mb/s signal

¢ Press <Menu>, choose Overhead Monitor > Signaling Bits
then press <Select>.
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Setting Up Thru Mode Operation

212

NOTE

Use transparent thru mode to non-intrusively monitor signals
in networks with no protected monitor points.

The instrument is inserted into the communications path and
the received data is routed unaltered to the Transmit Out port
for retransmission.

The instrument operates as normal, monitoring errors and
alarms in the received signal.

The instrument’s timing is derived from a clock recovered from
the received data.

Settings cannot be changed once you have selected THRU mode. This
stops you from selecting settings which would affect the data path.

You must select the signal rate you want before selecting THRU mode.

To set up transparent thru mode operation

1 Press <Menu>, then select the Tx/Rx > Thru Mode window
using the arrows and <Select> key.

2 Select the Enable Thru Mode checkbox (a tick appears in the
box).

3 Select Close.
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Storing and Recalling Instrument Settings

User Guide

You can store four sets of instrument settings (i.e. those shown
in the summary diagram at the bottom of the display). These,
along with the factory default settings, can be recalled. This
procedure assumes that you have already set up the instrument.

To store instrument settings

1

Press <Menu>, choose Tx/Rx > Stored Settings then press
<Select>.

Select one of the User (1 to 4) radio buttons.

3 Press the right arrow key, then enter a suitable title using

front panel keypad.

Select Save to store the settings.

b Select Close.

Tx ! Rx - Stored Settings
& Default

¢ User| |measurementl

|
(/User2 [measurementz |
¢ User3 [setupd |
¢ Userd [setupd |

Recall | Save Close I

To recall stored settings

1

Press <Menu>, choose Tx/Rx > Stored Settings then press
<Select>.

Select one of the User (1 to 4) radio buttons.

Select Recall. A warning dialog box will appear. Select OK
and the instrument will reconfigure using the recalled
settings.

Select Close.

213
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Measurements and Results

Physical

“Measuring PDH Signal Level" on page 215
“Measuring the Frequency of a PDH Signal" on page 216
“Viewing the Pulse Mask of a PDH Signal" on page 217

Errors and Alarms

“Viewing PDH Errors (Total and Last Second)" on page 220
“Viewing the PDH Summary of Errors" on page 221

“Viewing Errors/Alarms using the <Show More> Key" on
page 222

“Viewing Alarms in a PDH Signal" on page 223

“Viewing Errors and Alarms Using Trouble Scan" on page 224

Service Disruption

“Measuring Service Disruption Time in a PDH Network" on
page 225

Analysis

214

“Viewing the ITU Analysis of PDH Errors and Alarms" on
page 228

“Measurement Logging" on page 331

“Viewing Results Graphically" on page 335
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Measuring PDH Signal Level

You can measure the level of a balanced 2 Mb/s signal or
unbalanced 2 Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s signal at the
instrument’s 2 Mb/s In or 2-140 Mb/s DS3 In port.

This procedure assumes you have set up the PDH receiver and
connected the electrical PDH signal to the appropriate input
port.

p  To measure the level of a PDH signal

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Signal Rate to the appropriate PDH rate, then select the
interface settings as required.

3 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Electrical tab.
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Measuring the Frequency of a PDH Signal

You can measure the frequency of a balanced 2 Mb/s signal or
an unbalanced 2 Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s signal at the
instrument’s 2 Mb/s In or 2-140 Mb/s DS3 In port.

You can also measure frequency offset in the incoming signal.
The amount of offset gives an indication of the probability of
errors in the incoming signal.

This procedure assumes that the bit rate, line code, input
operating level and termination settings match the network
element being tested. Also make sure that the test signal is
connected to the appropriate optical or electrical input port.

> To measure the frequency of a PDH signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Physical tab.

2 Select Signal Rate, then select the required signal and
interface settings.

3 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Frequency tab.
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Viewing the Pulse Mask of a PDH Signal

With the instrument connected to the appropriate
cross-connect level, you can check that the pulse shape of an
unbalanced 2 Mb/s, 8 Mb/s or 34 Mb/s signal meets the G.703,
GR-449 and ANSI T1.102 standards. You can view the level and
pulse width of both the positive and negative pulses. Level ratio
and width ratio are also displayed.

This procedure assumes you have set up the PDH receiver.

NOTE Excessive jitter on the input signal may adversely affect the pulse shape.

oap

HF
B

p  To view the pulse mask of a PDH signal

1 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Pulse Mask tab.

2 Set the mask to G703, GR-449 or ANSI T1.102.

3 Select Capture. The +ve and -ve LEDs are grey while data is
being captured.

User Guide 217
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4 Select the appropriate +ve or -ve radio button to view the
positive or negative pulse shape and measurements.

If the +ve and -ve LEDs are green, the pulse shape will also be
green and within specification. If an LED is red, the part of
the pulse that violates the mask envelope will be red and out

of specification.

b After data has been captured, you can apply different masks.

Results - Signal Quality

Dptical Fywr | Freguency  Pulse Mask | Electrical
U l l l T J4mbrs

1.2
1.0 Capture
03 1 aro3 ~|
0.6
0.4
0.2 (i +ve G
0.0 Cve o
-0.2
-0.4 ] ] ] ] |

-4 -02 00 02 04
Level: L.og 4 Width: 14.08 ns
Level Ratin:  1.01 Width Ratio:  0.293
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Viewing PDH Errors

You can view errors using any of the procedures listed below:
* “Viewing PDH Errors (Total and Last Second)" on page 220
¢ “Viewing the PDH Summary of Errors" on page 221

¢ “Viewing Errors/Alarms using the <Show More> Key" on
page 222
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Viewing PDH Errors (Total and Last Second)

You can view PDH errors during a test or at the end of the test.

You can view errors on the display as Total or Last Second
results.

Total Results The display shows the running total of errors as
they occur throughout the measurement gating period. The total
result stops when measurement gating stops.

Last Second The errors results display is updated every
second. A last second result is the number of errors occurring in
the last second.

Refer to the Specifications provided on the CD-ROM for full
details of errors results.

To view PDH errors

1 Press <Menu>, choose Results > Errors then press <Select>.
Select the PDH/DSn tab.

2 Select the Error Type results to be displayed.

User Guide

.



el @

@é son_Cobra.book Page 221 Wednesday, September 25, 2002 11:09 AM

ﬁ%

User Guide

Instrument Setup and Use - PDH 3

Viewing the PDH Summary of Errors

The Error Summary window provides a running total of the
number of errors occurring during the current measurement
period.

To view the PDH error summary

1 Press <Menu>, choose Results > Error Summary then press
<Select>. Select the PDH/DSn tab.

2 You can then view errors in more detail. Press <Menu>, then
select the Results > Errors window to view the Error Ratio
or errors occurring in the last second.
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Viewing Errors/Alarms using the <Show More> Key

When the front panel LED lights, error and alarm conditions
have been detected. The front panel <Show More> key allows
you to view detailed alarm information.

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when History <Reset> on the front
panel is pressed.

[ 2 To view the error/alarm conditions

¢ Press <Show More>. Select the PDH/DSn tab.
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Viewing Alarms in a PDH Signal

You can monitor the time an PDH alarms is active for (Alarm
Second) on the Results screen.

Refer to the Specifications provided on the CD-ROM for full
details of the alarms.
p  To view alarms in a PDH signal

¢ Press <Menu>, choose Results > Alarm Seconds then press
<Select>. Select the PDH/DSn tab.

User Guide

)
- 4~ 4

rs



@é son_Cobra.book Page 224 Wednesday, September 25, 2002 11:09 AM

A

3 Instrument Setup and Use - PDH

Viewing Errors and Alarms Using Trouble Scan

You use Trouble Scan to continuously monitor errors and
alarms in a framed PDH signal, or the framed PDH signal in the
payload of a SONET or SDH signal.

Trouble Scan is useful for testing new networks as it can
simultaneously detect up to four error types in the following
priority order: Code, CRC4, Frame, E-bit and Bit.

[ 2 To monitor errors and alarms using Trouble Scan

1 Press <Menu>, choose Results > Trouble Scan then press
<Select>. The errors and the alarms that have been detected
will be displayed.

2 If Alarms Active is displayed, then press the front panel
<Show More> key to determine which alarms have occurred.

Front Panel LEDs and <Show More> key

The front panel <Show More> key allows you to view detailed
alarm information

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when History <Reset> on the front
panel is pressed.

¢ If no alarms are detected and all error counts are zero then
“No Trouble” is displayed on the Results > Trouble Scan

page.

NOTE Clock Loss and Power Loss alarms are not monitored in Trouble Scan.
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Measuring Service Disruption Time in a PDH Network

NOTE

User Guide
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You can measure the time it takes (service disruption time) for
the automatic protection switch (APS) circuit to detect and
activate the standby equipment when a fault occurs. This
protection switch action allows the network to continue earning
revenue even when equipment goes faulty.

For more information, see “Test Configuration for Measuring
Service Disruption Time" on page 443.

You can deliberately invoke a protection switch in a network
carrying a PRBS by generating a burst of PRBS errors.

To view disruption time

1 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Service Disruption tab.

Press <Run/Stop>.
3 Verify error-free reception of the PRBS test pattern.

4 Invoke a protection switch on a working section of the
transmission system that is transporting the PRBS. The
instrument will display the service disruption results.

You can deliberately invoke a protection switch in a network carrying a
PRBS by generating a burst of PRBS errors. You can simulate a node
failure by removing the power from the transmission element, or you can
simulate fiber break by disconnecting a fiber. For more information, see
“Service Disruption” on page 442.
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Service Disruption Test Results

The instrument provides three separate results:

* Longest: The duration of the longest error burst detected
during the test

¢ Shortest: The duration of the shortest error burst detected
during the test

¢ Last: The duration of the most recent error burst detected
during the test

When you press the <Run/Stop> key at the beginning of a
protection-switching time test, all result fields are reset to O ms.

When the protection switch is triggered, the duration of the
resulting error burst is measured and displayed.

For the system under test to pass, a single error burst of
duration less than 50 ms should be detected. Detection of a
single error burst is indicated by an identical value being
displayed in the three result fields.

Three separate results are provided because some transmission
systems exhibited a characteristic similar to switch-bounce
during a protection-switching event. This results in multiple
distinct error bursts being present on the received test pattern.
By providing three separate results, the instrument’s service
disruption measurement clearly identifies the presence of this
unwanted operating characteristic.

Other additional measurement features include:

¢ Relative timestamping of the beginning and end of each
service disruption event.

e History: A record of the first ten service disruption
measurements.

While an Alarm Indication Signal is not strictly speaking a pure
protection-switching measurement, it is closely tied to these
types of measurements by being activated as a result of any
physical layer failure, such as a fiber break.
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Measuring Round Trip Delay in a PDH Network

You can measure round trip delay using a balanced 2 Mb/s
signal or unbalanced 2 Mb/s, 8 Mb/s, 34 Mb/s or 140 Mb/s
signal. Round trip delay is the time taken for traffic to pass
through a network.

When you run a round trip delay measurement, the
instrument’s transmitter and receiver operate together. First,
the instrument transmits a burst of bit errors, it then measures
the time it takes for the errors to be detected by the receiver.
The time difference between transmitting and receiving errors
is the round trip delay.

This procedure assumes that you have set up a loopback
connection in the network you are testing. Also, make sure that
the bit rate, line code, input operating level and termination
settings match the network element being tested and that the
Transmit and Receive PDH signal structures match. Set up the
instrument to transmit a PDH signal with a PRBS pattern and
ensure there are no Signal, Frame or Pattern errors.

For more information, see:

¢ “Setting Up the PDH Transmit Interface" on page 183

* “Coupling the Receiver to the Transmitter" on page 184

e “Transmitting a Framed PDH Signal" on page 187

To measure the round trip delay of a PDH network

1 Press <Menu>, choose Test Functions > Switch Off then
press <Select>.

2 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Round Trip Delay tab.

3 Select Measure.
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Viewing the ITU Analysis of PDH Errors and Alarms

NOTE

You can view the ITU analysis of a framed PDH signal, or framed
PDH signal in the payload of a SONET or SDH signal. Make sure
the bit rate, line code, input operating level and termination
settings match the network element being tested. Also ensure
that the Receive PDH signal framing structure is set correctly.

To view the ITU analysis of result
1 Press <Menu>, choose Results > Performance Analysis then
press <Select>.

2 Set the G- or M-series Analysis Type as required.

All supported types of analysis are available during a measurement. For
more information, see “Introducing ITU Performance Analysis" on

page 428. The measurement will not be affected if you switch between the
different results provided.

User Guide

.



@é son_Cobra.book Page 229 Wednesday, September 25,2002 11:09 AM

A

. °
(] [ ]

°
° °
0% 4
ce0@® @9 [pstrument Setup and Use - DSn

20, - |
P PY °® etting up the DSn Transmitter 230
. ® . Setting up the DSn Receiver 250
. Setting Up Thru Mode Operation 266
Storing and Recalling Instrument Settings 267
Measurements and Results 268

This chapter tells you how to set the instrument interfaces to
match the network being tested and how to make
measurements.
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Setting up the DSn Transmitter

Physical

e “Setting Up the DSn Transmit Interface" on page 231

¢ “Selecting the DSn Transmit Clock Source" on page 233

¢ “Adding Frequency Offset to the DSn Signal" on page 234

Framed or Unframed Signal

¢ “Transmitting a Framed DSn Signal (Unstructured
Payload)" on page 236

¢ “Transmitting a Framed DSn Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 237

e “Transmitting an Unframed DSn Signal" on page 241

Payload

¢ “Inserting an External 2 Mb/s or DS1 Payload into a DS3
Signal" on page 242

Errors, Alarms, FEAC Messages and Loop Codes

¢ “Adding Errors to a DSn Signal" on page 243

¢ “Adding Alarms to a DSn Signal" on page 244

e “Transmitting FEAC Messages in a DS3 Signal" on page 245
¢ “Transmitting DS1 Loop Codes" on page 246

e “Switching Off All Test Function Features" on page 249
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Setting Up the DSn Transmit Interface

You can transmit a balanced DS1 signal or an unbalanced DS3
signal via the DS1 Out and 2-140 Mb/s DS3 Out ports.

Make sure the instrument’s bit rate, line code, output level and
termination settings match the network element being tested.

Signal Bit Rate Line Output Level Termination
Code
DS1 1.5 Mb/s AMI DSX-1 100 Q balanced (Bantam)

B8ZS DS1-LO

DS3 45 Mb/s B3ZS DS3-HI 75 Q unbalanced (BNC)
DSX-3
DS3-900

NOTE The transmitter and receiver can operate independently, or they can be

coupled. For more information, see “Coupling the Receiver to the
Transmitter" on page 232.

[ 2 To set up a DS1 or DS3 transmit interface

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Physical tab.

2 Set the Signal Rate to DS1 or DS3.

3 Select the Line Code (DS1 line signal only).

4 Select the Line Output Level.
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Coupling the Receiver to the Transmitter

You can set up the instrument so that the receiver will
automatically configure to the transmitter’s settings.

| 2 To couple the receiver to the transmitter settings

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.
2 Select Copy Tx to Rx.

3 Select Close.

> To switch off coupling

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.
2 Select Switch Coupling Off.

3 Select Close.
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Selecting the DSn Transmit Clock Source

>

You can reference the timing to an internal, external or
recovered clock source.

Mode Clock Source
Internal Clock generated within the instrument.
External DS1 Data clock applied to the DS1 Clock In port.

Recovered Clock recovered from the Dsn signal applied to the receiver.

To select the transmit clock source

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then

press <Select>. Select the Physical tab.

2 Select the Clock Source. The Clock Format is automatically

set to DS1 Data if you select an external clock source.
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Adding Frequency Offset to the DSn Signal

You can apply frequency offset of up to +/-100 ppm (resolution
0.1 ppm and accuracy 0.02 ppm) to a signal regardless of the
selected clock source. Offset can be applied while
measurements are taking place.

[ 2 To add frequency offset to a signal

1 Press <Menu>, choose Test Functions > Frequency Offset
then press <Select>.

2 Select Line Offset, then enter the required offset by editing
the frequency offset value.

3 Select the Enable Offset checkbox, then press <Select> to
switch on the offset.
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Transmitting a Framed DSn Signal

You can transmit a framed DS1 or DS3 signal via the DS1 or
2-140 Mb/s DS3 Out ports. Also, a framed signal can be inserted
into the payload of a SONET/SDH signal. The framed DS1 or
DS3 signal can be structured or unstructured and can carry
inverted or non-inverted (normal) PRBS patterns.

For more information, see:

¢ “Transmitting a Framed DSn Signal (Unstructured
Payload)" on page 236

¢ “Transmitting a Framed DSn Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 237

e “PRBS Polarity" on page 240
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Transmitting a Framed DSn Signal (Unstructured Payload)

You can transmit a framed DSn signal with an unstructured
payload via the DS1 or 2-140 Mb/s DS3 Out ports. Also, you can
insert an unstructured DSn signal into the payload of a SONET
or SDH signal. The test pattern transmitted in the DSn signal
fills the entire payload.

Signal Framing

DS1 ESF, D4, SLC-96 or Unframed
DS3  C-bit, M13, Unframed

The test patterns can be inverted or non-inverted (normal).

This procedure assume you have set up a DSn signal rate.

> To transmit an unstructured DSn signal

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.

2 Set Framing to the required setting, then select
Unstructured.

3 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab. Then select the
required pattern (inverted or normal).
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Transmitting a Framed DSn Signal (Structured Payload, Signaling

Bits and Spare Bits)

When you transmit a DSn signal with a structured (or
channelized) payload, you will need to select the test patterns
for the foreground (test) channel and background (non-test)
channels in the payload.The test patterns can be inverted or
non-inverted.

Signal Framing Payload Structure

DS1 ESF, D4, SLC-96 or DS1(56 kb/s), DS1 (64 kb/s)
Unframed

DS3  C-bit, M13, Unframed ~ DS1, DS1(56 kb/s), DS1 (64 kb/s), 2 Mb/s,
2 Mb/s (64 kb/s)

You can also select the signaling bits of a DS1 (56 kb/s) or
2 Mb/s with PCM30 or PCM30CRC framing.

Signal Framing Signaling bits
DS1 ESF A B C D individually setto 1 or 0.
D4 A B individually set to 1 or 0.
SLC-96 A B individually set to 1, 0 or alternating.
No framing bit A B C D individually setto 1 or 0.

The same signaling bit pattern is carried
in all foreground timeslots.

2 Mb/s PCM30, PCM31, A B C D individually setto 1 or 0.
PCM30CRC,
PCM31CRC The signaling bits of all timeslots are set
to the 4-bit user-defined value.

The Si and Sa spare bits can also be transmitted if a 2 Mb/s
signal is selected (see the final step of this procedure).
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PDH Signal Spare Bits

2Mb/s Si bits (international bits) - Located in Timeslot 0 Bit 1of both
the FAS and NFAS frames. Si bits can be modified when in
non-CRC-4 frames.

E bits - Are the Si bits of frames 13 and 15 of a CRC-4 frame,
and can be independently modified. When transmitted as 0,
they inform the far end that block errors have occurred.

Sa bits (national bits) - located in bits 4 to 8 of NFAS timeslot
can be independently modified.

Sa bit Sequences - Defines sync status, it is an 8-bit
sequence transmitted in selected NFAS Sa bits of a CRC-4
frame. The sequence appears in odd numbered CRC-4
frames (starting from frame 1).

CAS Multiframe - Located in MFAS timeslot bits 5, 7 and 8
can be modified.

This procedure assumes you have set up a DSn signal rate.

To transmit a DSn signal with a structured payload

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.

Set the Framing and select Structured.

Set the Test Channel Rate. Enter values in the Test Channel
boxes to select the required channel (the selected test
channel rate determines which boxes will be active). When
you select the 56 kb/s or 64 kb/s box, a timeslot selection
window will be displayed. Select the Single Timeslot
checkbox and a timeslot (or de-select the Single Timeslot
checkbox for N x 56/64 kb/s foreground channels), then
select Close.

When transmitting DS1 channelized payloads, you can
transmit either a single 56/64 kb/s foreground channel or
N x 56/54 kb/s foreground channels. Use the N x 56/64 kb/s
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channels when testing wideband services such as high speed
data and LAN links (112 or 336 kb/s). The N x 64 kb/s
foreground channels can be contiguous or non-contiguous.

Timeslot Editor

D&-1

¥ Single Timeslot

Timeslot

Bandwidth 64 khisg

Close |

Tlmeslot Editor

D&-1

I~ Single Timeslot

Timeslot 1000000000000l 1ll1l000000

Bandwidth 384 khbis

Close |

4 Select the Test Channel Timing reference.
Select the Test Channel Framing (DS3 line rate only).

Select Background Settings, then select a background
pattern.

7 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab.

8 Choose a test pattern.

9 Press <Menu>, choose Overhead Setup > Signaling Bits then
press <Select>. This lets you access the signaling bits feature.

10 Press <Menu>, choose Overhead Setup > Spare Bits then
press <Select>. This lets you access the spare bits feature.
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PRBS Polarity

The definition of PRBS polarity may differ between ITU-T
Recommendation O0.150 and common practice in the USA. This
is illustrated by the following table.

Pattern ITU-T USA

PRBS9 Non-inverted Non-inverted
PRBS11 Non-inverted Non-inverted
PRBS15 Inverted Non-inverted
QRSS Non-inverted Non-inverted
PRBS23 Inverted Non-inverted
PRBS31 Inverted Inverted

Note that a non-inverted (2En)-1 PRBS will produce a longest
run of n-1 zeros in the PRBS sequence and inverted sequence
produces a longest run of n zeros in the PRBS sequence.

You can select PRBS polarity to be inverted or non-inverted
(normal). For all signal types except SONET, either ITU or
non-ITU is displayed beside your selection to indicate if it
conforms to ITU-T 0.150.
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Transmitting an Unframed DSn Signal

You can transmit test patterns in an unframed DS1 or DS3
signal via the instrument’s DS1 or 2-140 Mb/s DS3 Out ports.
Also, an unframed signal can be inserted into the payload of a
SONET/SDH signal. The test patterns can be inverted or
non-inverted (normal).

This procedure assumes you have set up a DSn signal rate.

p  To transmit an unframed DSn signal

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.
2 Set Framing to Unframed.

3 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the Pattern tab.

4 Select the required pattern (inverted or normal).

User Guide 241

- 4~ 4

-

rs




@é son_Cobra.book Page 242 Wednesday, September 25,2002 11:09 AM

A

4  Instrument Setup and Use - DSn

Inserting an External 2 Mb/s or DS1 Payload into a DS3 Signal

You can insert an external 2 Mb/s or DS1 signal into a DS3
signal via the 2 Mb/s In ports (balanced).

This procedure assumes you have set up the DS3 signal rate.

p  To insert an external 2 Mb/s or DS1 signal into a DS3
1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.
2 Set Framing to M13 or C-Bit and Structured.
3 Set the Test Channel Rate to 2 Mb/s or DSI.

4 Select the Test Channel to be used by the external signal by
selecting the appropriate DS2, DS1 or 2 Mb channel settings.

b Select the Insert checkbox.

6 Select Background Settings, then select the required
background pattern.

7 Connect the external 2 Mb/s or DS1 signal to the appropriate
In port.
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Adding Errors to a DSn Signal

You can add errors to the DSn signal either singly or at a
selectable rate.

Refer to the Specifications provided on the CD-ROM for a full
list of errors.

Mode Errors Transmitted

Single One error transmitted when you press the <Single Error> key.

Rate M.PE-ON errors are transmitted, where N=4t0 9, and M.P=1.0to
9.9in 0.1 steps.

To add errors to a DSn signal

1 Press <Menu>, choose Test Functions > Errors and Alarms
then press <Select>.

2 Select the appropriate Add Errors Type, then select the
required error.

3 Set the Add Errors Rate as required. If you select a User
rate, then enter the required value. The errors will be added
to the signal during the measurement period. Also, you can
use the <Single Error> key to add single errors.
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Adding Alarms to a DSn Signal

You can transmit alarms in a DSn signal.

Refer to the Specifications provided on the CD-ROM for a full
list of the alarms.

p  To add alarms to a DSn signal
1 Press <Menu>, choose Test Functions > Errors and Alarms
then press <Select>.

2 Select the appropriate Add Alarm Type, then select the
required alarm.

3 Select the Enable Alarm checkbox. The alarm will then be
transmitted during the measurement period.
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Transmitting FEAC Messages in a DS3 Signal

You use the FEAC channel (the 3rd C-bit of a framed DS3 signal)
to transmit loopback, alarm or status information from far-end
to near-end network elements.

This procedure assumes you have set up the DS3 signal rate.

FEAC Message

Loopback Codes You can transmit N loopcodes and M messages in a
single burst, where N and M are selectable in the range 1
to 15.

Alarm/Status You can transmit ANSI T1.107-1995 messages or any
Messages user specified code (11111111 0XXXXXX0) continuously,
or in a single burst.

[ 2 To transmit a FEAC message in a DS3 signal
1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.
Set Framing to C-Bit.

3 Press <Menu>, choose Overhead Setup > DS3 FEAC then
press <Select>.

4 Set FEAC Code Type to Loopback or Alarm/Status.

Select the Message for transmitting in All Channels or in a
Single Channel. If you select Single Channel, you will need
to select a channel value between 1 and 28.

Select the Repeat (Times) for Loopback and Message.

Select Transmit Code.
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Transmitting DS1 Loop Codes

>

You use in-band or out-of-band loop codes to locate faults. They
are used to remotely control loop circuits in network
equipment.

Typically, the far-end equipment activates the loop circuit when
it detects the loop code. The DS1 signal is then routed back to
the near-end equipment where you can verify signal integrity.
For more information on loop codes, see:

¢ “Transmitting In-band DS1 Loop Codes" on page 246

¢ “Transmitting Out-of Band DS1 Loop Codes" on page 247

Transmitting In-band DS1 Loop Codes

When you select an in-band loop code, the entire payload of the
DS1 signal is overwritten with the loop code, and transmitted
for 8 seconds.

If you are transmitting a framed DS1 signal, the framing bit
overwrites the DS1 loop code (as per T1.403-1999.CORE). This
overwriting action can be prevented by setting the instrument
for 1566 MTS compatibility (the loop code is gapped).

This procedure assumes you have set up theDS1 signal rate.

Loop Activate Deactivate

Line 00001 001
Payload 1100 1110
Network 11000 11100

User XXXXXXXX XXXXXXXX

To transmit an in-band DS1 loop code

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.

2 Set Framing as required.
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3 Press <Menu>, choose Overhead Setup > DS1 Loopcodes
then press <Select>.

4 Set Inband Loop Code to F-bit gaps or F-bit overwriten,
then select the appropriate code.

5 Select Transmit Code.

Transmitting Out-of Band DS1 Loop Codes

When you select an out-of-band loop code, it can be transmitted
continuously or in a burst of N-messages, where N is the
number of frames in the range 1 to 15.

These loop codes are located in the data link of an ESF framed
DS1 signal.

When the data link is not transmitting loop code, it transmits
idle code (01111110). The switching of idle to loop code occurs
at the end of the idle message, and not part way through it.

This procedure assumes you have set up the DS1 signal rate.

Loop Activate Deactivate
Line 11111111 01110000 11111111 00011100
Payload 11111111 00101111 11111111 01001100
Network 11111111 01001000 n/a
Universal n/a 11111111 00100100
User 11111111 0XXXXXX0

To transmit an out-of-band DS1 loop code

1 Press <Menu>, choose Tx/Rx > Transmitter Settings then
press <Select>. Select the PDH/DSn tab.
Set Framing to ESF.

3 Press <Menu>, choose Overhead Setup > DS1 Loopcodes
then press <Select>.

4 Select the Outband Loop Code as required.
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b Set Burst Length to Burst or Continuous. If you select Burst
you will also need to select the burst length.

6 Select Transmit Code.
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Switching Off All Test Function Features

You can switch off all Test Functions features. This is useful if
you want to start configuring the instrument from a known
state.

| 2 To switch off all Test Function features

1 Press <Menu>, choose Test Functions > Switch Off then
press <Select>.

2 Select Switch Off All Active Test Functions.
3 Select Close.
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Setting up the DSn Receiver

Physical
e “Setting Up the DSn Receive Interface" on page 251

Framed or Unframed Signal

¢ “Monitoring a Framed DSn Signal (Unstructured
Payload)" on page 254

¢ “Monitoring a Framed DSn Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 255

¢ “Monitoring an Unframed DSn Signal" on page 259

Payload
* “Dropping a DS1 Payload from a DS3 Signal" on page 260

¢ “Dropping a Voice Channel from a DSn Signal to the Internal
Speaker" on page 261

FEAC Messages, Signaling and Spare bits, DS1 loop codes and
Switching Off All Test Functions

e “Monitoring FEAC Messages in a DS3 Signal" on page 262

¢ “Monitoring Signaling Bits in Structured DS1 or 2 Mb/s
Signal" on page 264

* “Monitoring Spare Bits of a 2 Mb/s signal in a DS3 Signal" on
page 263

e “Monitoring DS1 Loop Codes" on page 265
¢ “Switching Off All Test Function Features" on page 249
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Setting Up the DSn Receive Interface

You can receive a balanced DS1 signal or an unbalanced DS3
signal via the DS1 In port or 2-140 Mb/s DS3 In ports.

Make sure the instrument’s bit rate, line code, input operating
level and termination settings match the network element being

tested.
Signal BitRate Line Input
Code . .
Termination Operating Level
DS1T  15Mb/s AMI 100 ohm Terminate (3.0 V)
B8ZS balanced
(Bantam Monitor (3.0 Vi but with
connection) additional gains of 20, 26 or 30
dB)

DS3  45Mb/s B3ZS 750hm Terminate (0.9 V with
unbalanced (BNC equalization automatic or off)
connection)

Monitor (0.9 V but with
additional gains of 20 or 26 dB)
The receiver and transmitter can operate independently, or they can be
NOTE . : . . :
coupled. For more information, see “Coupling the Transmitter to the

Receiver" on page 252.

The receiver derives its timing from the input signal.

| 2 To set up the DS1 or DS3 Receive interface

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Physical tab.

Set the Signal Rate to DS1 or DS3.
Select the Line Code (DS1 signals only).

4 Set the Operating Level to Terminate or Monitor. If you
select Monitor, you can set the Gain to 20 dB or 26 dB.

b Select the Equalization On checkbox if required.
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Coupling the Transmitter to the Receiver

You can set up the instrument so that the transmitter will
automatically configure to the receiver’s settings.

| 2 To couple the transmitter to the receiver settings

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.
2 Select Copy Rx to Tx.

3 Select Close.

> To switch off coupling

1 Press <Menu>, choose Tx/Rx > Coupling then press
<Select>.

2 Select Switch Coupling Off.
3 Select Close.
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Monitoring a Framed DSn Signal

You can monitor a framed DS1 or DS3 signal or drop the framed
DSn signal from the payload of a SONET or SDH signal. The
framed DS1 or DS3 signal can be structured or unstructured.
The PRBS patterns carried in these signals can be inverted or
non-inverted (normal).

You should connect the DS1 or 2-140 Mb/s DS3 In port to the
network being tested.

For more information, see:

¢ “Monitoring a Framed DSn Signal (Unstructured
Payload)" on page 254

¢ “Monitoring a Framed DSn Signal (Structured Payload,
Signaling Bits and Spare Bits)" on page 255

e “PRBS Polarity" on page 257
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Monitoring a Framed DSn Signal (Unstructured Payload)

You can monitor a framed DS1 or DS3 signal with an
unstructured payload. The transmitted test pattern fills the
entire payload and can be inverted or non-inverted (normal).

This procedure assumes you have set up a DSn signal rate.

p  To view a DSn signal with an unstructured payload
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to the required setting, then select
Unstructured.

3 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Pattern tab. Then select the required
pattern (inverted or normal).

254 User Guide

4~ 4

.




@é son_Cobra.book Page 255 Wednesday, September 25,2002 11:09 AM @é

>

A

Instrument Setup and Use -DSn 4

Monitoring a Framed DSn Signal (Structured Payload, Signaling
Bits and Spare Bits)

When you monitor a DSn signal with a structured (channelized)
payload, you will need to select the test patterns for the
foreground (test) channel and background (non-test) channels
in the payload. The test pattern can be inverted or non-inverted
(normal).

Signal Framing Payload Structure

DS1 ESF, D4, SLC-96 or DS1(56 kb/s), DS1 (64 kb/s)
Unframed

DS3  C-bit, M13, Unframed ~ DS1, DS1(56 kb/s), DS1 (64 kb/s), 2 Mb/s,
2 Mb/s (64 kb/s)

You can also monitor the signaling bits of a DS1 (56 kb/s) or
2 Mb/s with PCM30 or PCM30CRC framing.

Signal Framing Signaling bits
DS1 ESF A B C D individually set to 1 or 0.
SF (D4) A B individually set to 1 or 0.
SLC-96 A B individually set to 1, 0 or alternating.

No framing bit A B C D individually setto 1 or 0.

The same signaling bit pattern is carried
in all foreground timeslots.

2 Mb/s PCM30 or A B C D individually set to 1 or 0.
PCM30CRC
The signaling bits of all timeslots are set
to the 4-bit user-defined value.

Si and Sa spare bits can also be viewed if a 2 Mb/s signal is
selected (see the final step of this procedure).

This procedure assumes you have set up a DSn signal rate.
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PDH Signal Spare Bits

2Mb/s Si bits (international bits) - Located in Timeslot 0 Bit 1of both
the FAS and NFAS frames.

E bits - Are the Si bits of frames 13 and 15 of a CRC-4 frame,
and can be independently modified. When transmitted as 0,
they inform the far end that block errors have occurred.

Sa bits (national bits) - located in bits 4 to 8 of NFAS
timeslot.

Sa bit Sequences - Defines sync status, it is an 8-bit
sequence in the selected NFAS Sa bits of a CRC-4 frame.
The sequence appears in odd numbered CRC-4 frames
(starting from frame 1).

CAS Multiframe - Located in MFAS timeslot bits 5, 7 and 8.

| 2 To view a DSn signal with a structured payload

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

Set the Framing and select Structured.

Set the Test Channel Rate. Enter values in the Test Channel
DS2, DS1/2Mb/s and 56/64 kb/s boxes to select the required
channel (the selected test channel rate determines which
boxes will be active). When you click on the 56 kb/s or 64
kb/s box, a timeslot selection window will be displayed.
Select the Single Timeslot checkbox and a timeslot (or
de-select the Single Timeslot checkbox for N x 56/64 kb/s
foreground channels, then select Close.

When monitoring DS1 channelized payloads, you can
monitor a single 56/64 kb/s foreground channel or N x 56/64
kb/s foreground channels. Use the N x 56/64 kb/s channels
when testing wideband services such as high speed data and
LAN links (112 or 336 kb/s). The N x 64 kb/s foreground
channels can be contiguous or non-contiguous
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Timeslot

Bandwidth

¥ Single Timeslot

64 khisg

Close |

Timeslot Editor

-~ D51

Timeslot

Bandwidth

I~ Single Timeslot

1000000000000l 1ll1l000000

384 khis

Close |

4 Select Test Channel Framing (DS3 line rate only).

14

b Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Pattern tab.

6 Press <Menu>, choose Overhead Monitor > Signaling Bits
then press <Select>. View the signaling bits.

7 Press <Menu>, choose Overhead Monitor > Spare Bits then
press <Select>. View the spare bits.

Or: Press <Menu>, choose Overhead Monitor > Sa Bits then
press <Select>. View the Sa bits.

PRBS Polarity

The definition of PRBS polarity may differ between ITU-T

Recommendation O0.150 and common practice in the USA. This
is illustrated by the following table.
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Pattern ITU-T USA

PRBS9 Non-inverted Non-inverted
PRBS11 Non-inverted Non-inverted
PRBS15 Inverted Non-inverted
QRSS Non-inverted Non-inverted
PRBS23 Inverted Non-inverted
PRBS31 Inverted Inverted

Note that a non-inverted (2En)-1 PRBS will produce a longest
run of n-1 zeros in the PRBS sequence and inverted sequence
produces a longest run of n zeros in the PRBS sequence.

You can select PRBS polarity to be inverted or non-inverted
(normal). For all signal types except SONET, either ITU or
non-ITU is displayed beside your selection to indicate if it
conforms to ITU-T 0.150.
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Monitoring an Unframed DSn Signal

You can monitor test patterns in an unframed DS1 or DS3 signal
applied to the DS1 In or 2-140 Mb/s DS3 In ports, or dropped
from the payload of a SONET or SDH signal. The test patterns
can be inverted or non-inverted.

This procedure assumes you have set up a DSn signal rate.

p  To view an unframed DSn signal

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to Unframed.

3 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Pattern tab.

4 Then select the required pattern (inverted or normal).
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Dropping a DS1 Payload from a DS3 Signal

You can drop a DS1 payload from a framed DS3 signal via the
DS1 Out port.

The DS3 signal (carrying the DS1 payload to be dropped) must
be connected to the 2-140 Mb/s DS3 In port.

This procedure assumes you have set up a DS3 signal rate.

> To drop a DS1 payload from a DS3 signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing, then select the required DS3 frame setting,
then select Structured.

3 Set the Test Channel Rate to DS1.

4 Enter values in the Test Channel DS2 and DS1 boxes to
select the required channel.

b Select the Drop DS-1 checkbox.
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Dropping a Voice Channel from a DSn Signal to the Internal Speaker

You can drop a 56 kb/s or 64 kb/s voice channel from a framed
DSn signal to the instrument’s internal speaker.

This procedure assumes you have set up a DSn signal rate.

[ 2 To drop a voice channel to the internal speaker

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Framing to M13 or C-Bit and Structured. Set the Test
Channel Rate to 2 Mb/s (64 kb/s), DS1 (64kb/s) or DS-1
(56kb/s) as required.

3 Enter values in the Test Channel DS2, DS1 and 64 kb boxes
to select the required channel (the selected test channel rate
determines which boxes will be active).

4 When you click on the 56 kb/s or 64 kb/s box, select the
Single Timeslot checkbox, then select the appropriate
timeslot carrying the voice channel.

b Select the Listen checkbox (a tick appears in the box), select
the appropriate volume level. Select Close.
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Monitoring FEAC Messages in a DS3 Signal

You can monitor the current and previous loopback, alarm or
status information contained in the FEAC channel (the 3rd
C-bit of a framed DS3 signal).

This procedure assumes you have set up a DS3 signal rate.

FEAC Message

Loopback Codes You can transmit N loopcodes and M messages in a
single burst, where N and M are selectable in the range 1
to 15.

Alarm/Status You can transmit ANSI T1.107-1995 messages or any
Messages user specified code (0XXXXXX0 11111111) continuously,
or in a single burst.

[ 2 To view a FEAC message in a DS3 signal
1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.
Set Framing to C-Bit.

3 Press <Menu>, choose Overhead Monitor > DS3 FEAC then
press <Select>. View the current and last non-idle FEAC
messages.
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Monitoring Spare Bits of a 2 Mb/s signal in a DS3 Signal

You can view the Si and Sa spare bits of a structured 2 Mb/s
signal carried in a DS3 signal.

PDH Signal Spare Bits

2Mb/s Si bits (international bits) - Located in Timeslot 0 Bit 1of both
the FAS and NFAS frames.

E bits - Are the Si bits of frames 13 and 15 of a CRC-4 frame,
and can be independently modified. When transmitted as 0,
they inform the far end that block errors have occurred.

Sa bits (national bits) - located in bits 4 to 8 of NFAS
timeslot.

Sa bit Sequences - Defines sync status, it is an 8-bit
sequence in the selected NFAS Sa bits of a CRC-4 frame.
The sequence appears in odd numbered CRC-4 frames
(starting from frame 1).

CAS Multiframe - Located in MFAS timeslot bits 5, 7 and 8.

p  To view Si spare bits

¢ Press <Menu>, choose Overhead Monitor > Spare Bits then
press <Select>.

p  To view Sa spare bits

¢ Press <Menu>, choose Overhead Monitor > Sa Bits then
press <Select>.
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Monitoring Signaling Bits in Structured DS1 or 2 Mb/s Signal

You can monitor signaling bits in a DS1 (56 kb/s) or 2 Mb/s
(with PCM30 or PCM30CRC framing) signal.

Signal Framing Signaling bits
DS1 ESF A B C D individually set to 1 or 0.
SF (D4) A B individually set to 1 or 0.
SLC-96 A Bindividually set to 1, 0 or alternating.

No framing bit A B C D individually setto 1 or 0.

The same signaling bit pattern is carried
in all foreground timeslots.

2 Mb/s PCM30 or A B C D individually set to 1 or 0.
PCM30CRC
The signaling bits of all timeslots are set
to the 4-bit user-defined value.

[ 2 To view signaling bits of a DS1 or 2 Mb/s in a DS3 signal

¢ Press <Menu>, choose Overhead Monitor > Signaling Bits
then press <Select>.
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Monitoring DS1 Loop Codes

You use in-band or out-of-band loop codes to locate faults. They
are used to remotely control loop circuits in network
equipment.

Typically, the far-end equipment activates the loop circuit when
it detects the loop code. The DS1 signal is then routed back to
the near-end equipment where you can verify signal integrity.

The in-band loopcodes are shown below.

Loop Activate Deactivate

Line 00001 001
Payload 1100 1110
Network 11000 11100

User XXXXXXXX XXXXXXXX

The out-of-band loopcodes are shown below.

Loop Activate Deactivate
Line 11111111 01110000 11111111 00011100
Payload 11111111 00101111 11111111 01001100
Network 11111111 01001000 n/a
Universal n/a 11111111 00100100
User 11111111 OXXXXXX0

| 2 To view in-band and out-of-band DS1 loop codes

¢ Press <Menu>, choose Overhead Monitor > DS1 Loopcodes
then press <Select>.
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Setting Up Thru Mode Operation

266

NOTE

Use transparent thru mode to non-intrusively monitor signals
in networks with no protected monitor points.

The instrument is inserted into the communications path and
the received data is routed unaltered to the Transmit Out port
for retransmission.

The instrument operates as normal, monitoring errors and
alarms in the received signal.

The instrument’s timing is derived from a clock recovered from
the received data.

Settings cannot be changed once you have selected THRU mode. This
stops you from selecting settings which would affect the data path.

You must select the signal rate you want before selecting THRU mode.

To set up transparent thru mode operation

1 Press <Menu>, then select the Tx/Rx > Thru Mode window
using the arrows and <Select> key.

2 Select the Enable Thru Mode checkbox (a tick appears in the
box).

3 Select Close.

User Guide

ﬁ%

rs



el @

-

@é son_Cobra.book Page 267 Wednesday, September 25, 2002 11:09 AM

ﬁ%

Instrument Setup and Use -DSn 4

Storing and Recalling Instrument Settings

User Guide

You can store four sets of instrument settings (i.e. those shown
in the summary diagram at the bottom of the display). These,
along with the factory default settings, can be recalled. This
procedure assumes that you have already set up the instrument.

To store instrument settings

1

Press <Menu>, choose Tx/Rx > Stored Settings then press
<Select>.

Select one of the User (1 to 4) radio buttons.

3 Press the right arrow key, then enter a suitable title using

front panel keypad.

Select Save to store the settings.

b Select Close.

Tx ! Rx - Stored Settings
& Default

¢ User| |measurementl

|
(/User2 [measurementz |
¢ User3 [setupd |
¢ Userd [setupd |

Recall | Save Close I

To recall stored settings

1

Press <Menu>, choose Tx/Rx > Stored Settings then press
<Select>.

Select one of the User (1 to 4) radio buttons.

Select Recall. A warning dialog box will appear. Select OK
and the instrument will reconfigure using the recalled
settings.

Select Close.
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Measurements and Results

Physical

“Measuring DSn Signal Level" on page 269
“Measuring the Frequency of a DSn Signal" on page 270
“Viewing the Pulse Mask of a DSn Signal" on page 271

Errors and Alarms

“Viewing DSn Errors (Total or Last Second)" on page 274
“Viewing the DSn Summary of Errors" on page 275

“Viewing Errors/Alarms using the <Show More> Key" on
page 276

“Viewing Alarms in a DSn Signal" on page 277

“Viewing Errors and Alarms Using Trouble Scan" on page 278

Service Disruption

“Measuring Service Disruption Time in a DSn Network" on
page 279

Analysis

268

“Viewing the ITU Analysis of DSn Errors and Alarms" on
page 283

“Measurement Logging" on page 331

“Viewing Results Graphically" on page 335
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Measuring DSn Signal Level

You can measure the +ve peak, -ve peak, and peak-to-peak
voltage of the balanced DS1 signal or unbalanced DS3 signal at
the instrument’s DS1 In or 2-140 Mb/s DS3 In port.

Results are also displayed in dBdsx as defined in ANSI T1.102 (the
+ve peak, -ve peak, and peak-to-peak signal level relative to the
nominal level).

This procedure assumes you have set up the DSn receiver and
connected the electrical DSn signal to the appropriate input
port.

> To measure the level of a DSn signal

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the PDH/DSn tab.

2 Set Signal Rate to the appropriate DSn signal rate, then
select the interface settings as required.

3 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Electrical tab.
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Measuring the Frequency of a DSn Signal

You can measure the frequency of a balanced DS1 signal or an
unbalanced DS3 signal at the instrument’s DS1 In or 2-140 Mb/s
DS3 In port.

You can also measure frequency offset in the incoming signal.
The amount of offset gives an indication of the probability of
errors in the incoming DSn signal.

This procedure assumes that the bit rate, line code, input
operating level and termination settings match the network
element being tested. Also make sure that the test signal is
connected to the appropriate optical or electrical input port.

> To measure the frequency of a DSn signal

1 Press <Menu>, choose Tx/Rx > Receiver Settings then press
<Select>. Select the Physical tab.

2 Select Signal Rate, then select the required signal and
interface settings.

3 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Frequency tab.
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Viewing the Pulse Mask of a DSn Signal

With the instrument connected to the appropriate
cross-connect level (DSX-1 or DSX-3), you can check that the
pulse shape of a balanced DS1 signal or an unbalanced DS3
signal meets the G.703, GR-449 and ANSI T1.102 standards. You
also view the level and pulse width of both the positive and
negative pulses. Level ratio and width ratio are also displayed.

This procedure assumes you have set up the DSn receiver.

NOTE Excessive jitter on the input signal may adversely affect the pulse shape.

L —L_ - L
m 30 am =0

> To view the pulse mask of a DSn signal

1 Press <Menu>, choose Results > Signal Quality then press
<Select>. Select the Pulse Mask tab.

2 Set the mask to G703, GR-449 or ANSI T1.102.

3 Select Capture. The +ve and -ve LEDs are grey while data is
being captured.
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4 Select the appropriate +ve or -ve radio button to view the
positive or negative pulse shape and measurements.

If the +ve and -ve LEDs are green, the pulse shape will also be
green and within specification. If an LED is red, the part of
the pulse that violates the mask envelope will be red and out
of specification.

b After data has been captured, you can apply different masks.

Results - Signal Quality

Optical Pwr | Freguency Pulge Magk | Electrical
1.2 T T T T [n]=ke
1.0
Capture

0.a
i 15703 ~|
0.4
0.2 4 E e @
00 4 e @
-0.2 ] ] ] ]

-0.5 0.0 0.4 1.0
Level: 0.59 W Wiiidth: 12.37 ns
Level Ratio.  1.0Z Width Ratio;  1.01
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Viewing DSn Errors

You can view errors using any of the procedures listed below:
¢ “Viewing DSn Errors (Total or Last Second)" on page 274
¢ “Viewing the DSn Summary of Errors" on page 275

¢ “Viewing Errors/Alarms using the <Show More> Key" on
page 276
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Viewing DSn Errors (Total or Last Second)

You can monitor errors in a DSn signal during testing.

You can view errors on the display as Total or Last Second
results.

Total Results The display shows the running total of errors as
they occur throughout the measurement gating period. The total
result stops when measurement gating stops.

Last Second The errors results display is updated every
second. A last second result is the number of errors occurring in
the last second.

Refer to the Specifications provided on the CD-ROM for full
details of errors results.

To view errors in a DSn signal

1 Press <Menu>, choose Results > Errors then press <Select>.
Select the PDH/DSn tab.

2 Select the Error Type results to be displayed.

User Guide
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Viewing the DSn Summary of Errors

The Error Summary window provides a running total of the
number of errors occurring during the current measurement
period.

To view the DSn error summary

1 Press <Menu>, choose Results > Error Summary then press
<Select>. Select the PDH/DSn tab.

2 You can then view errors in more detail. Press <Menu>, then
select the Results > Errors window to view the Error Ratio
or errors occurring in the last second.
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Viewing Errors/Alarms using the <Show More> Key

When the front panel LED lights, error and alarm conditions
have been detected. The front panel <Show More> key allows
you to view detailed alarm information.

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when History <Reset> on the front
panel is pressed.

[ 2 To view the error/alarm conditions

¢ Press <Show More>. Select the PDH/DSn tab.
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Viewing Alarms in a DSn Signal

You can monitor the time a DSn alarms is active for (Alarm
Second) on the Results screen (except for Clock Loss and FEAC
Codes). Refer to the Specifications provided on the CD-ROM for
full details of the alarms.

p  To view alarms in a DSn signal

¢ Press <Menu>, choose Results > Alarm Seconds then press
<Select>. Select the PDH/DSn tab.

User Guide 277
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Viewing Errors and Alarms Using Trouble Scan

You use Trouble Scan to continuously monitor errors and
alarms in a framed DSn signal, or the framed DSn signal in the
payload of a SONET or SDH signal.

Trouble Scan is useful for testing new networks as it can
simultaneously detect up to four error types in the following
priority order; Code, CRC6, Frame, CP-Parity, P-Parity, FEBE,
and Bit (useful for testing new networks).

[ 2 To monitor errors and alarms using Trouble Scan

1 Press <Menu>, choose Results > Trouble Scan then press
<Select>. The errors and the alarms that have been detected
will be displayed.

2 If Alarms Active is displayed, then press the front panel
<Show More> key to determine which alarms have occurred.

Front Panel LEDs and <Show More> key

The front panel <Show More> key allows you to view detailed
alarm information

¢ Current alarms are shown red, while previous (historical
alarms) are shown yellow.

¢ The History LED indicates that an alarm has occurred since
the History alarms were last reset. It is reset either when a
test period is started or when History <Reset> on the front
panel is pressed.

¢ If no alarms are detected and all error counts are zero then
“No Trouble” is displayed on the Results > Trouble Scan

page.

NOTE Clock Loss and Power Loss alarms are not monitored in Trouble Scan.
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Measuring Service Disruption Time in a DSn Network

NOTE

User Guide

ﬁ%

You can measure the time it takes (service disruption time) for
the automatic protection switch (APS) circuit to detect and
activate the standby equipment when a fault occurs. This
protection switch action allows the network to continue earning
revenue even when equipment goes faulty.

For more information, see “Test Configuration for Measuring
Service Disruption Time" on page 443.

You can deliberately invoke a protection switch in a network
carrying a PRBS by generating a burst of PRBS errors.

To view disruption time

1 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Service Disruption tab.

Press <Run/Stop>.
3 Verify error-free reception of the PRBS test pattern.

4 Invoke a protection switch on a working section of the
transmission system that is transporting the PRBS. The
instrument will display the service disruption results.

You can deliberately invoke a protection switch in a network carrying a
PRBS by generating a burst of PRBS errors. You can simulate a node
failure by removing the power from the transmission element, or you can
simulate fiber break by disconnecting a fiber. For more information, see
“Service Disruption” on page 442.
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Service Disruption Test Results

The instrument provides three separate results:

* Longest: The duration of the longest error burst detected
during the test

¢ Shortest: The duration of the shortest error burst detected
during the test

¢ Last: The duration of the most recent error burst detected
during the test

When you press the <Run/Stop> key at the beginning of a
protection-switching time test, all result fields are reset to O ms.

When the protection switch is triggered, the duration of the
resulting error burst is measured and displayed.

For the system under test to pass, a single error burst of
duration less than 50 milliseconds should be detected.
Detection of a single error burst is indicated by an identical
value being displayed in the three result fields.

Three separate results are provided because some transmission
systems exhibited a characteristic similar to switch-bounce
during a protection-switching event. This results in multiple
distinct error bursts being present on the received test pattern.
By providing three separate results, the instrument’s service
disruption measurement clearly identifies the presence of this
unwanted operating characteristic.

Other additional measurement features include:

¢ Relative timestamping of the beginning and end of each
service disruption event.

e History: A record of the first ten service disruption
measurements.

While an Alarm Indication Signal is not strictly speaking a pure
protection-switching measurement, it is closely tied to these
types of measurements by being activated as a result of any
physical layer failure, such as a fibre break.
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Alarm Indication Signal (AIS)

The instrument can provide details of AIS duration
measurements, AIS timestamping and an AIS history. When
used in conjunction with the instrument’s service disruption
measurements, it becomes possible to show a relationship
between alarms within a device and automatic protection
switches in a network. This provides the ability to quickly and
accurately debug network elements. For example, using the
timestamping and AIS duration measurements, it is easy to see
if a device fails due to AIS not being raised quickly enough, or if
it fails due to AIS not being removed quickly enough once the
switch has taken place.
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Measuring Round Trip Delay in a DSn Network

You can measure round trip delay using a balanced DS1 signal
or an unbalanced DS3 signal. Round trip delay is the time taken
for traffic to pass through a network.

When you run a round trip delay measurement, the
instrument’s transmitter and receiver operate together. First,
the instrument transmits a burst of bit errors, it then measures
the time it takes for the errors to be detected by the receiver.
The time difference between transmitting and receiving errors
is the round trip delay.

This procedure assumes that you have set up a loopback
connection in the network you are testing. Also, make sure that
the bit rate, line code, input operating level and termination
settings match the network element being tested and that the
Transmit and Receive DSn signal structures match. Set up the
instrument to transmit a DSn signal with a PRBS pattern and
ensure there are no Signal, Frame or Pattern errors

For more information, see:

e “Setting Up the DSn Transmit Interface" on page 231

¢ “Coupling the Receiver to the Transmitter" on page 232

e “Transmitting a Framed DSn Signal" on page 235

| 2 To measure the round trip delay of a DSn network

1 Press <Menu>, choose Test Functions > Switch Off then
press <Select>.

2 Press <Menu>, choose Results > Network Measurements
then press <Select>. Select the Round Trip Delay tab.

3 Select Measure.
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Viewing the ITU Analysis of DSn Errors and Alarms

NOTE

You can view the ITU analysis of a framed DSn signal, or framed
DSn signal in the payload of a SONET or SDH signal.

Make sure the bit rate, line code, input operating level and
termination settings match the network element being tested.
Also ensure that the Receive DSn signal framing structure is set
correctly.

To view the ITU analysis of result
1 Press <Menu>, choose Results > Performance Analysis then
press <Select>.

2 Set the G- or M-series Analysis Type as required.

All supported types of analysis are available during a measurement. For
more information, see “Introducing ITU Performance Analysis" on

page 428. The measurement will not be affected if you switch between the
different results provided.
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Manual Tests - Functions and Results 311
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This chapter tells you how to access and use the Ethernet
capabilities of the instrument and view the results.
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Setting up the Transceiver

Test Mode Selection

Three test modes are available for rapidly configuring the
instrument for specific test scenarios:

¢ End-to-End Test
* Loopback Test
¢ Loopthru

For End-to-End and Loopback, there are two setup modes:

¢ Pre-set mode pre-configures the stream information
including source and destination addresses automatically for
either loopback or end-to-end testing.

¢ Expert mode allows you to override the pre-configured
settings, if required.

¢ See “Setup Mode Selection" on page 291 for details.

¢ In Loopthru, the setup mode is automatically set to Expert.

For each of the test modes, the Ethernet frame type can be
selected.

* See “Ethernet Frame Type Selection" on page 296 for details.

Finally, you can re-negotiate the status of each link individually.

* See “Negotiation Status" on page 296 for details.

286 User Guide
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End-to-End Test

End-to-end testing requires two instruments, one at the near or
local end, the other at the far or remote end.

Note that RFC 2544 Conformance Testing is not available when
testing in end-to-end mode.

> To select end-to-end mode
1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Test Mode field and choose End To End Test from
the drop-down list.

3 Choose which Setup Mode you require.
If you choose Pre-set, then all settings are chosen for you
automatically.
If you choose Expert, see “Settings Available" on page 292.

4 In the Designate This Instrument As field, set the near end
instrument to Set 1 and the far end instrument to Set 2, or
the other way round as appropriate.

Set 1 Set 2
Near End Device Under Test Far End
MAC Address (DU MAC Address
00-30-D3-03-DD-2A 1 =24 1 1 =1 00-30-D3-03-DD-2B
00-30-D3-03-DD-2C 2 =2 2 2 =12 00-30-D3-03-DD-2D
00-30-D3-03-DD-2E 3 =2 3 3 =43 00-30-D3-03-DD-2F
00-30-D3-03-DD-30 4 =21 4 4 14 00-30-D3-03-DD-31
00-30-D3-03-DD-32 5 |3 5 5 [==]5 00-30-D3-03-DD-33
00-30-D3-03-DD-34 6 =2 6 6 f=—"]6 00-30-D3-03-DD-35
00-30-D3-03-DD-36 7 =] 7 ;’?gg:} 7 ===|7 00-30-D3-03.0D-37
00-30-D3-03-DD-38 8 =] 8 piee | 5 k=18 00-30-03-03-0D-39
00-30-D3-03-DD-3A & fog=2=] 9 9 =19 00-30-D3-03-DD-3B
00-30-D3-03-DD-3C 10 fg—#=] 10 10 =410 00-30-D3-03-DD-3D
End-to-End Testing
287
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Loopback Test

There are two ways of performing loopback testing with this
instrument:

¢ 1portloopback at the far end. This involves looping back the
data sent on one port back to the same port at the near end.

Depending on the type of device under test, this may require
the use of a second instrument at the far end to perform the
loopback using the loopthru mode.

¢ 2 ports loopback at the far end. This involves looping back
the data sent on one port to another port at the near end.

Note that RFC 2544 Conformance Testing is available only in
loopback mode.

To select loopback mode

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Test Mode field and choose Loopback Test from
the drop-down list.

3 Choose which Setup Mode you require.

If you choose Pre-set, then in the Loopback Mode field,
select 1 Port Loopback or 2 Ports Loopback as appropriate.

For 2 Ports Loopback, in the Designate This Instrument As
field, choose MAC Address Set 1 or Set 2, as appropriate.

If you choose Expert, see “Settings Available" on page 292.
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Device Under Test

(DUT)

00-30-D3-03-DD-2A 1 ¢
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1 Port Loopback Testing
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2 Port Loopback Testing
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Loopthru

This mode uses two testers, one at each end of the Ethernet
circuit. However, the far end tester does not actively test the
circuit. It simply acts as a “loopthru”. It receives the test frames
and strips the source and destination MAC addresses. It then
re-inserts the original source address as the new destination
address and the original destination address as the new source
address before re-transmitting the frames.

Using this method it is possible for all tests to be carried out,
including latency, on a single circuit, without provisioning an
extra path through the network.

To select loopthru mode
1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Test Mode field and choose Loopthru from the
drop-down list.

Set1 Set 2
Near End Device Under Test Far End
MAC Address (buT) MAC Address

00-30-D3-03-DD-2A 1 =24 1 1 f="4> 1 00-30-D3-03-DD-2B
00-30-D3-03-DD-2C 2 > 2 2 =122 00-30-D3-03-DD-2D
00-30-D3-03.DD-2E 3 [ 3 3 =123 00-30-D3-03-DD-2F
00-30-D3-03-DD-30 4 == 4 4 =124 00-30-D3-03-DD-31
00-30-D3-03-DD-32 5 =2 5 5 =125 00-30-D3-03-DD-33
00-30-D3-03-DD-34  § [ & 6 —*1>¢ 00-30-D3-03-DD-35
00-30-D3-03-DD-36 7 =] 7 ;’?;‘g;} 7 =7 00-30-D3-03-DD-37
00-30.03-03-DD-38 8 fg=2=] 8 Pire | 5 t=458 00-30.03-03.0D-39
00-30-D3-03-DD-3A 9 =2 ¢ 9 F==1>9 00-30-D3-03-DD-3B
00-30-D3-03-DD-3C 10 =] 10 10 [="4=10 00-30-D3-03-DD-3D

1 Port Loopback Testing, with Loopthru
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Setup Mode Selection

For the End To End and Loopback Tests there are two setup
modes available:

¢ Pre-set Mode pre-configures the stream information
including source and destination addresses automatically.

¢ Expert Mode allows you to override the pre-configured
settings, if required.

Pre-set Mode

All stream information including source and destination
addresses is set automatically, except for negotiation status and
laser control. The exact settings chosen by the instrument
depend on whether loopback or end-to-end testing is chosen.

Negotiation Status lets you re-negotiate each link individually.
Laser On/Off applies only to 1 Gb/s Ethernet.

To select pre-set mode
1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Setup Mode field and choose Pre-set from the
drop-down list.

To see what the settings are in pre-set mode, refer to “Settings
Available" on page 292.

Expert Mode

All the default settings selected automatically in Pre-set Mode
can be overridden in Expert Mode.

To select expert mode

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Setup Mode field and choose Expert from the
drop-down list.

For information on what settings are available to choose from,

see “Settings Available" on page 292.
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Settings Available

1 Gb/s Settings - Pre-set Mode

Auto Neg Data Rate / Duplex Mode Flow Control *

On 1 Gb/s / Full Auto

* See “Flow Control" on page 293

1 Gb/s Settings - Expert Mode

Auto Neg Data Rate / Duplex Mode Flow Control *
On 1 Gb/s / Full Auto

off

TX + RX
off 1 Gb/s / Full Off

TX + RX

* See “Flow Control" on page 293

10/100 Mb/s Settings - Pre-set Mode

Auto Neg Data Rate / Duplex Mode / Flow Control *

On Auto

* See “Flow Control" on page 293

292 User Guide

.




@é son_Cobra.book Page 293 Wednesday, September 25, 2002 11:09 AM

el @

Instrument Setup and Use - Ethernet 5

10/100 Mb/s Settings - Expert Mode

Auto Neg Data Rate Duplex Mode Flow Control *
On Auto Auto Auto
100 Mb/s Full off
10 Mb/s TX + RX
Half Auto
off 100 Mb/s Full off
10 Mb/s TX + RX
Half off

* See “Flow Control" on page 293

Laser

The laser can be turned on or off. This applies only to 1 Gb/s
Ethernet.

m Always deactivate the laser before connecting or disconnecting
optical cables.

Flow Control

If two stations are capable of flow control, the way Ethernet
initiates it is through PAUSE frames. PAUSE frames are special
control frames that are sent to a reserved multicast address and
contain a request to stop transmitting frames for a certain
period of time (usually configured in the send device). The
receiving station should obey this request and start transmitting
when that time has elapsed.

Flow Control choices:

o Off

* Auto - flow control auto-negotiated

e TX + RX - can transmit and receive PAUSE frames

User Guide 293
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Source and Destination Addresses

The instrument is not a standard Ethernet device. It can
transmit and receive frames with any source and destination
address.

However, there are nominal MAC (Media Access Control)
addresses for each port that are used by default as the source
address of all frames transmitted from that port. The default
addresses are used when the instrument is in Pre-set mode.

These addresses may be overridden in Expert mode.

Setting MAC Address Sets

There are two sets of Default MAC Addresses, see page 295,
which can be selected as Set 1 or Set 2.

| 2 To change a source or destination address
1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Setup Mode field and choose Expert from the
drop-down list.

3 Select the Source or Destination Address that you wish to
change. Press <Select> again to edit the field.

4 Use the keypad to enter the new address in hexadecimal.
Press <Select> to save the new address or <Cancel> to revert
to the original address.

294 User Guide
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Default MAC Addresses
Set 1 Set 2
Port MAC Address MAC Address

1(10/100 Mb/s)
2 (10/100 Mb/s)
3 (10/100 Mb/s)
4(10/100 Mb/s)
5 (10/100 Mb/s)
6 (10/100 Mb/s)
7 (10/100 Mb/s)
8 (10/100 Mb/s)
9 (1Gb/s)

10 (1 Gb/s)

00-30-D3-03-DD-2A
00-30-D3-03-DD-2C
00-30-D3-03-DD-2E
00-30-D3-03-DD-30
00-30-D3-03-DD-32
00-30-D3-03-DD-34
00-30-D3-03-DD-36
00-30-D3-03-DD-38
00-30-D3-03-DD-3A
00-30-D3-03-DD-3C

00-30-D3-03-DD-2B
00-30-D3-03-DD-2D
00-30-D3-03-DD-2F
00-30-D3-03-DD-31

00-30-D3-03-DD-33
00-30-D3-03-DD-35
00-30-D3-03-DD-37
00-30-D3-03-DD-39
00-30-D3-03-DD-3B
00-30-D3-03-DD-3D

These addresses may be overridden in Expert mode.

Frame Size

This field can be changed only in Expert mode.

The Frame Size can be set in 1 byte steps from:
¢ 58 bytes up to 16384 bytes for 10/100 Mb/s Ethernet
* 58 bytes up to 65536 bytes for 1 Gb/s Ethernet.

VLAN

This field can be changed only in Expert mode.

When enabled, you can set the Priority Level between 0O
(highest) and 7 (lowest) and the VID (VLAN ID) between 0 and
4095, in decimal.
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Ethernet Frame Type Selection

The Ethernet frame type can be selected from hexadecimal
values between 0000 (the default value) and FFFF.

See “Frame Type Selection" on page 296 for more details.

[ 2 To select Ethernet frame type
1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the Setup Mode field and choose Expert from the
drop-down list.

3 Select the Ethernet Frame Type field and enter the
hexadecimal value required, then press <Select>.

Frame Type Selection

The type/length field in an Ethernet frame can describe either
the type of protocol unit that is held in the frame data field or it
can be how many bytes of Logical Link Control (LLC)
information are in the frame data field. The difference is in the
value of the field:

¢ If the value is more than 1536 decimal (or 0600 in
hexadecimal), then it describes the protocol type.

e If the value is 1518 decimal (or O5EE in hexadecimal) or less,
then it is the number of LLC bytes in the data field.
Negotiation Status

This lets you re-negotiate each link individually. It applies only
to those links whose Auto Neg status is set to On.

For more details, see “Auto-negotiation" on page 297.
> To display negotiation status

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.
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2 Select the Negotiation Status More button (indicated by
three dots).

Select Re-Negotiate to re-negotiate the links, as appropriate.

Select the Registers More buttons to view the
auto-negotiation registers, as appropriate.

Auto-negotiation

Auto-negotiation is a means of automatically connecting two
Ethernet stations for the best possible performance without
intervention from a user. This can include link speed and flow
control for 10/100 Mb/s. For 1 Gb/s it applies to flow control
only since the speed is preset to 1 Gb/s.

Auto-negotiation is done by sending out signals called Fast Link
Pulses that contain a mixture of clock information and data to
identify the Ethernet technology and flow control support. The
stations work out between themselves the best way they can
connect.

In 1000BASE-X the stations exchange special code groups of
control data to perform the auto-negotiation but they look
identical from a signal level, timing point of view to normal
data.

If the stations cannot connect, then manual configuration is
required.

In the auto-negotiation registers:

¢ Advertisement Register shows the value of the
auto-negotiation register the port has advertised during
auto-negotiation.

* LP Ability Register shows the value the port received from
it's Link Partner (LP) during auto-negotiation.

 MDIX Status Bit is set if a crossed connection is used, clear
if not. A crossed connection is one where the Tx lines from
one end are connected to the Rx line at the other end and
vice versa. These cables are primarily used to connect two
pieces of DTE (Data Terminal Equipment) together, for
example two laptop Ethernet ports together to allow file
transfer.
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Physical Interfaces

Gigabit Ethernet Ports

Connector Type Two slots for GBIC Modules

Data Rate 1000 Mb/s
This is 8B/10B encoded as per ANSI X3.230-1994 (FC-PH),
clause 11 (referenced in IEEE802.3(2000) 36.2.4) to give a
Line Transmission rate of 1250 Mb/s

Port Settings Full duplex

(with Auto Negotiate

ON) Flow Control ON, Flow Control OFF
or
Auto Negotiate Flow Control

Port Settings Full duplex

(with Auto Negotiate

OFF) On/0ff

Tx Power GBIC dependent

Rx Sensitivity GBIC dependent

The gigabit interfaces use GBIC (GigaBit Interface Converter)
plug-in modules and parameters such as connector type or
optical signal specifications are therefore dependent on the
GBIC that is fitted.

“Standard” GBICs are 1000BASE-SX (850 nm, multi mode) and
1000BASE-LX (1300 nm, multi mode or single mode). Agilent
recommend the following GBICs:

Interface Type

GBIC Agilent Part Number

1000 BASE-SX
1000 BASE-LX

850 nm, multi-mode

1300 nm, multi-mode

J5491A (1 pair)
J5492A (1 pair)

or single-mode
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There are many other GBICs available, including
“non-standard” formats such as 1000BASE-ZX (1550 nm, single
mode) or GBICs with non-standard connector types. Any of
these GBICs can be used provided they operate at the 1.25 Gb/s
line rate and meet the GBIC specification (SFF Standard,
Document Number SFF-8053 Rev 5.5).

The Ethernet module GBIC interfaces comply with the GBIC
standard and full details of the electrical connections can be
found in that standard.

Information about any GBIC that is inserted into ports 9 or 10 is
displayed automatically on the Ethernet Transceiver - Port
Setup page.

To view GBIC information

1 Press <Menu>, choose Tx/Rx > Transceiver Settings then
press <Select>.

2 Select the 1 Gb/s folder.

3 Information about any GBIC inserted into ports 9 or 10 is
displayed at the bottom of the page. The information
displayed is:

Ethernet Type
MOD_DEF
Data Rate
Vendor

Part Number
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10/100 Mb/s Ethernet Ports

Connector Type

Port Settings
(With Auto Negotiate
ON)

Port Settings
(With Auto Negotiate
OFF)

10 Mb/s Operation

100 Mb/s Operation

Eight RJ45 connectors

Data Rate 10 Mb/100 Mb (Restricted Negotiation) /
Auto Negotiate

Duplex Mode  Full/Half (Restricted Negotiation) / Auto
Negotiate

Flow Control On/0ff/(Restricted Negotiation) / Auto
Negotiate

Data Rate 10 Mb/s or 100 Mb/s, Fixed Setting

Duplex Mode  Full or Half, Fixed Setting

Flow Control On/0ff

Complies with IEEE802.3 (2000) 10BASE-T for operation
over two pairs of CAT5 UTP cabling.

Note: To guarantee RFI performance shielded twisted pair
must be used.

Maximum Cable 100 metres

Length

Modes of Full Duplex, Half Duplex

Operation

Data Rate 10 Mb/s, Manchester encoded to give a

binary signal at 10 Mbaud in accordance
with IEEE802.3 (2000)

Complies with ANSI X3.1995(TP-PMD) referenced in
IEEE802.3 (2000) 100BASE-TX for operation over two pairs
of CAT5 UTP cabling.

Note: To guarantee RFI performance shielded twisted pair
must be used

Maximum Cable 100 metres

Length

Modes of Full Duplex, Half Duplex

Operation

Data Rate 100 Mb/s, 4B/5B encoded to give tertiary

signal at a symbol rate of 125 Mbaud in
accordance with [EEE802.3 (2000)
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The instrument will display the following status information for

5

Ethernet Port Status

the test ports.

All Ports Auto
Negotiation
Status
Paused

10/100Mb Ports No Signal

Gigabit Ethernet No Signal
Ports
Tx Fault
Data Invalid
GBIC
information

This will display the outcome of the
auto-negotiation process

Displayed if Flow control is enabled
and PAUSE frames are being received

This is defined as loss of fast link
pulse

This is defined as a Loss of Signal
indication from the GBIC module

Displayed if the GBIC module detects
a fault

Indicates a fault with the received
data

Displays the type of GBIC installed,
for example 1000BASE-SX

[ 2 To display port status

1 Press <Show More>. This displays the status of all 10 ports.

2 Press <Menu>, choose Tx/Rx > Transceiver Settings then

press <Select>.

Select 1 Gb/s to view the GBIC information.

Select Negotiation Status to view the auto negotiation

status.

User Guide

- 4~

301

e

rs



A

@é son_Cobra.book Page 302 Wednesday, September 25, 2002 11:09 AM

5

302

Instrument Setup and Use - Ethernet

Ethernet Tx Eye Clock

The transmit eye clock is operational only for 100 Mb/s and

1000 Mb/s.
Connector Type SMA
Frequency 100 Mb/s - 25 MHz
1000 Mb/s - 125 MHz
Impedance Drives 50 ohm inputs
Signal Level Nominal ECL level, AC coupled

p  To select the Ethernet Tx Eye Clock
1 Press <Menu>, choose Tx/Rx > Tx Eye Clock then press
<Select>.

2 In the Eye Clock field, select Off, 100 Mb/s or 1 Gb/s, as
appropriate.

3 Then select Close.
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RFC 2544 Conformance Tests

304

This test suite produces results that allow comparisons between
network equipment. The tests give specific results for
throughput, latency and frame loss rate.

The test options allow for full RFC compliance to be selected, or
a reduced time 'quick test' option to be chosen. This
dramatically reduces the test execution time and has little
impact on the acquired results.

The tests are run in loopback mode only. For details on the
setup, see “Loopback Test" on page 288.

Path Select lets you choose 1-port or 2-port loopback testing
and the individual ports over which the tests will be performed.

The Test Point Options page lets you choose the number of test
points, which tests you wish to perform, and the test point
parameters.
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Test Point Options

This page lets you choose the number of test points, which tests
you wish to perform, and the test point parameters.

The tests are designed to be run automatically as a sequence,
but you can select a sub-set to run as a preliminary check.
However, the latency test cannot be run without first running
the throughput test. The tests can also be selected to run in one
or both directions. This allows for testing traffic load under
both conditions.

> To select test point options
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.
Select Test Point Options ... to reveal the pop-up page.
Set the Test Point Options as appropriate.
4 Select Close to close the pop-up page.

Test Point Choices

Run All Tests selects all tests.

¢ Throughput, Latency and Frame Loss are the individual
tests.

In Test Point Parameters, choose the Duration Setting from
Default, Quick or User. When User is chosen, enter individual
values using the keypad as follows:

¢ Preliminary Throughput: from 5 to 9 seconds
¢ Final Throughput: from 10 to 60 seconds

¢ Latency: from 10 to 180 seconds

* Frame Loss: from 10 to 60 seconds

¢ Number of Latency Trials: from 1 to 30
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Path Select

This lets you choose 1-port or 2-port loopback testing and the
individual ports over which the tests will be performed.

Select the Use Pre-set Settings checkbox to override the user
settings made on the Transceiver Setting page.

| 2 To select the test paths
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.
2 Choose Path Select ... then, from the Loopback Type field,
select:

One Port for 1-port loopback testing. For details, see “1 Port
Loopback Testing" on page 289 and “1 Port Loopback Testing,
with Loopthru" on page 290.

Two Port for 2-port loopback testing. For details, see “2 Port
Loopback Testing" on page 289.

3 Select the ports you wish to connect.
4 Select Close to return to the Ethernet RFC 2544 page.

306 User Guide
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RFC 2544 Throughput Test

The throughput test runs to determine at what rate the device
under test can sustain transmission without erroring frames, or
dropping frames.

A search is implemented through a selection of frames sizes,
namely 64, 128, 256, 512, 1024, 1280 and 1518. At each frame
size the maximum throughput at which error free transfer takes
place is found. This is done by running a series of tests where a
count of transmitted frames is compared to a count of received
frames looking for any dropped frames. When a rate where no
dropped frames is found, the maximum throughput is also
found.

The results are presented in a table and graphically.

To set up an RFC 2544 throughput test
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.

2 Set up the paths to be tested as detailed in “Path Select" on
page 306.

3 Set the “Test Point Options" on page 305 as appropriate.

4 To run only the Throughput Test, deselect Run All Tests and
select Throughput.

b Select Close to close the pop-up page.

6 Select Start in the Test Control field and then press
<Select> to start the test.

7 The progress of the test is displayed in the RFC Test Status
field.
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RFC 2544 Latency Test

The latency test is run at the maximum throughput rate found
in the throughput test, to determine the latency through the
device under test.

For this instrument, this has been extended to include the
network transmission delays and far end device under test
latency too. This gives a more accurate picture of round trip
delay. A series of tests are run at the specified frame sizes. The
latency figure is averaged over a number of runs; this number is
configurable.

The results are presented in a table and graphically.

> To set up an RFC 2544 latency test
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.

2 Set up the paths to be tested as detailed in “Path Select" on
page 306.

Set the “Test Point Options" on page 305 as appropriate.

4 To run only the Latency Test, deselect the Run All Tests field
and select Latency.

b Select Close to close the pop-up page.

Select Start in the Test Control field and then press
<Select> to start the test.

7 The progress of the test is displayed in the RFC Test Status
field.
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RFC 2544 Frame Loss Rate Test

Finally run the frame loss rate test.

This starts at 100% loading for each of the specified frame sizes
and drops by 10% until 10% load is reached. That is, it runs a
series of tests at 100%, 90%, 80%, 70%, 60%, 50%, 40%, 30%, 20%
and 10% load. These tests are run at each of the specified frame
sizes.

The results are presented in a table and graphically.

[ 2 To set up an RFC 2544 frame loss rate test
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.

2 Set up the paths to be tested as detailed in “Path Select" on
page 306.

3 Set the “Test Point Options" on page 305 as appropriate.

4 To run only the Frame Loss Rate Test, deselect the Run All
Tests field and select Frame Loss.

b Select Close to close the pop-up page.

6 Select Start in the Test Control field and then press
<Select> to start the test.

7 The progress of the test is displayed in the RFC Test Status
field.
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Viewing and Printing Results

You can log the RFC 2544 results to a file or printer (connect the
printer to the instrument's USB port).

> To view the results of an RFC 2544 frame loss test
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.

2 Select the Port x to Porty field in the View Results For Path
area and press <Select>. Choose which results you wish to
view and press <Select>.

| 4 To print the results of an RFC 2544 frame loss test
1 Press <Menu>, choose Test Functions & Results > RFC2544
Tests & Results then press <Select>.

2 Select Print Results.... Select a Destination (File or Printer).
If you choose File, enter a filename and press <Select>.

3 Select Generate Report.
4 Select Close to return to the RFC 2544 page.
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Manual Tests - Functions and Results

Before carrying out any of the procedures in this section, it is
assumed you have followed the steps detailed in “Setting up the
Transceiver" on page 286.

With this set of pages, you can set the transmit duration, the
type of errors to add and the requested port data rates for the
transmitter and receiver. In addition, you can view the results
for the measurements you have set up.

Transmit Duration

The transmission period for test frames can be either
Continuous or Burst.

For Continuous, the period is started and stopped by selecting

Start then Stop.

For Burst, the duration can be programmed in:

¢ Frames: from 1 to 1,000,000,000

¢ Time: from 1 second to 99 days, 23 hr, 59 min, 59 sec

¢ For both Frames and Time, the period is started by selecting
Start

When frames are selected, an equivalent time is displayed for
the currently selected frames size and bandwidth. For example,
for 64 byte frames at 10 Mb/s, a 1,000,000,000 frames burst will
take 18.7 hours.

| 4 To set transmit duration
1 Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

2 Select Transmit Duration and then, from the Duration Type
field in the pop-up page, Continuous or Burst.

3 If Burst is chosen, then select Frames or Time and enter the
values you require.

4 Select Close to save the values you have entered and return
to the Ethernet Manual Tests page.
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Error Add

This feature controls the generation of errors. It allows you to
select the type of error to be added and the port(s) onto which
the error condition is injected.

The types of errors that can be added are:

* Non-testset Frame

¢ Drop Frame

¢ Error Frame

¢ QOut of Sequence Event

How to add errors
1 Press <Menu>, choose Test Functions & Results > Error
Add then press <Select>.

2 Select from the Add Frame Errors field in the pop-up page
the type of error to add.

3 Select the port(s) onto which you wish to inject the error
condition.

4 Select Close to save the values you have entered.

b Errors are added by pressing the <Single Error> button.

Non-testset Frame

This inserts a frame that does not have a valid test set data area.
The frame is counted in the port transmit frame count. The
action does not affect the port data rate which is constant but
does affect the stream data rate (although the effect should be
small). This should produce a non-testset frame count on the
receiver. The second transmission of the frame will be without
corruption.

Drop Frame

This mimics the dropping of a frame by a network. Note that the
transmitter frame count will increment.
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Error Frame

This errors the Frame Check Sequence (FCS) in the next
transmitted frame.

An errored frame is measured at the receiver as either a
dropped frame (Ethernet devices such as switches will drop
errored frames) or as an errored frame (where no Ethernet
switch is in the path).

Out of Sequence Event

This adds an out-of-sequence event to the specified stream and
should be registered in the Out of Sequence Event Count by the
receiver.

Data Throughput (Port Data Rate)

You can change the data transmission rate for each port
individually. You can also change the receive rate, assuming
that flow control is supported by the device under test (DUT).

This allows you to set the transmission rate higher than the rate
the receiver can handle. When this happens the receiver will
issue PAUSE commands to the DUT and potentially frames will
be lost. If the DUT is not capable of full-bandwidth transmission
then frames will also be lost. Alternatively the DUT will issue
PAUSE commands to the test set transmitter to reduce the
transmission rate. PAUSE indication on the test set lets you see
this happening in real time.

The port date rate ties in to the negotiated line rate and sets an
upper limit for itself. The test set will also be aware of the frame
size and if changed will re-calculate the frames required per
second to achieve the set bandwidth.

For more information, see “Theoretical Frame Rate" on
page 426.
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| 2 To change the data throughput
1 Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

2 From the Result Type field, select Port Data Rate or Port
Data Rate (Frame Size).

3 Highlight the Requested Port Data Rate of the port you wish
to change the data throughput on and press <Select>.

4 Using Edit Field or Live Edit, set the data rate to the value
you require and press <Select>.

b Repeat until all the Port Data Rates are set.

Viewing Results

A variety of measurement results are provided for both the
transmitter and receiver. In addition, LEDs are provided to
indicate error conditions.

Transmitter and Receiver Results

Results are displayed port by port. All the 10/100 Mb/s port
results are displayed on one folder and all the 1 GbE port
results on another.

NOTE When you select a folder (10/100 Mb/s or 1 GbE) on the transmitter, the

same folder is automatically displayed on the receiver.

| 2 How to view transmitter and receiver results

1 Press <Menu>, choose Test Functions & Results > Manual
Tests & Results then press <Select>.

2 In the Result Type field, select the Results Format you wish
to view.

3 Select the 10/100 Mb/s or 1 GbE folder.
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Results Format

Error Count Format: Displayed as an integer for counts up to
999,999,999; then changes to X.XXX E+nn, where nn is between
9 and 15.

Transmitter Results

Result Type Results Displayed

Port Data Rate Port Data Rate (Mb/s):
* Requested
* Actual
* Minimum
* Maximum

Port Data Rate (Frame Size) Frame Size (Bytes)
Port Data Rate (Mb/s):
* Requested
* Actual

Port Frame Rate/Count Port Frame Rate: the port frame count transmitted
in the last second
Port Frame Count: the total number of frames
transmitted, including learning frames but
excluding PAUSE frames

Stream Data Rate Stream Data Rate (Mb/s):
* Actual
* Minimum
* Maximum

Stream Frame Rate/Count  Stream Frame Rate: the number of frames in a
stream transmitted in the last second
Stream Frame Count: the total number of frames in
a stream transmitted, excluding learning frames
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Receiver Results

Result Type

Results Displayed

Port Data Rate

Port Frame Rate/Count

Port Errored Frame Count

Port Non-testset Frame
Count

Port Jumbo/Runt Frame
Count

Port Broad/Multi-Cast
Frame Count

Stream Data Rate

Stream Frame Rate/Count

Port Data Rate (Mb/s):
* Requested

* Actual

* Minimum

* Maximum

Port Frame Rate: the port frame count received in
the last second

Port Frame Count: the total number of frames
received, including any learning frames and
errored frames but excluding PAUSE frames

The total number of frames for which the received
Frame Check Sequence (FCS) does not match the
FCS calculated by the test set. The count relates to
all frames on the port

The total number of frames that have not been
transmitted from an Agilent test set.

Port Jumbo Frame Count: the total number of
frames that exceed 1518 bytes in length (1522
bytes with VLAN)

Port Runt Frame Count: the total number of frames
that are less than 64 bytes in length

Port Broadcast Frame Count: the total number of
frames that have been broadcast, that is, the
destination MAC address is all ones

Port Multicast Frame Count: the total number of
frames that have the multicast bit set in the
destination MAC address field

Stream Data Rate (Mb/s):
* Actual

* Minimum

* Maximum

Stream Frame Rate: the number of frames ina
stream transmitted in the last second

Stream Frame Count: the total number of frames in
a stream transmitted, excluding learning frames
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Receiver Results (Continued)

Result Type

Results Displayed

Stream Errored Frame
Count

Dropped Frame Count

Out of Sequence Event
Count

Latency

The total number of frames for which the received
Frame Check Sequence (FCS) does not match the
FCS calculated by the test set. The count relates to
frames in an identifiable test set stream where the
test set data area must be intact

This measurement is available only in loopback
mode

Frames in Transit Count: transmitter frame count
minus receiver frame count. This is updated every
second and finally on stop gating

Dropped Frame Count: transmitter frame count
minus receiver frame count. This is only updated
at the end of the receiver measurement period

This counter increments if the received current
sequence number is less than or equal to the last
sequence number

Gaps in a positively incrementing sequence are
not counted

This is a measure of the frame transmission time
from port to port and is available only in loopback
mode

The latency measurement excludes any delays
due to half duplex and flow control (PAUSE)
effects

Latency results are:

* Maximum

* Minimum

» Average

These are measured since the start of gating in
milliseconds up to 1,999.99 with an accuracy of
10 us
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Stream Summary

The stream summary shows which instrument port the stream
was received on. It allows rapid matching of source port and
destination port through stream ID interpretation.

Also displayed are:

e Stream contents

* Source address

¢ Destination address

e Frame size

¢ Frame type

e Priority

¢ VLAN tag information

¢ Stream status, updated every second:

¢ Active = One or more frames received in last 10 seconds
for this stream

¢ Quiet = No frames received in last 10 seconds for this
stream

To view the stream summary

¢ Press <Menu>, choose Test Functions & Results > Stream
Summary then press <Select>.

LED Port Status Indicators

LEDs are used in a variety of ways to indicate activity on a port,
that errors have been received or even that everything is
satisfactory with a connection. The LEDs are situated on the
front panel, on the top panel beside the Ethernet ports and on
the GUI on a page displayed by pressing the <Show More>
button. Front Panel LEDs

On the front panel only two LEDs relate to Ethernet capability:
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This indicates Ethernet errors only when Ethernet is selected as
the Foreground instrument.

LED Color

Error(s) Detected

Red

Off

Any of the following counters have incremented in the
last deci-second:

» Port Errored Frames

+ Stream Errored Frames

+ Out of Sequence Order Frames

* Non Test Set Frames

* Runt Frames

None of the above counters has incremented in the
last deci-second

Multiple Instruments LED

This indicates Ethernet errors only when Ethernet is selected as
the Background instrument.

LED Color

Error(s) Detected

Red

Off

Any of the following counters have incremented in the
last deci-second:

» Port Errored Frames

+ Stream Errored Frames

* Qut of Sequence Order Frames

* Non Test Set Frames

* Runt Frames

None of the above counters has incremented in the
last deci-second. This LED will only be Off if all
background instruments have no active errors or
alarms in the last deci-second.
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Top Panel LEDs

There are two LEDs beside each of the Ethernet ports on the top
panel of the instrument.

LED Color Condition Indicated

10/100 Mb/s Ports 1 GbE Ports
Green (flashing) Activity Activity
Amber (solid) Link up Laser on

<Show More> LEDs

The port status for all 10 Ethernet ports is displayed on the
Show More page.

> To display the Show More page

1 Press <Show More>.

2 For details of the meaning of these LEDs see <Show More>

LEDs.
3 Close the Show More page by pressing <Cancel> or <Show
More>.
320 User Guide
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The <Show More> LEDs
LED Fault Detected
10/100 Mb/s Ports 1 GbE Ports
LOS This alarm is set if the linkis  This alarm is set if the Loss

PAUSED

GBIC Tx Fault

Data Invalid

down in the last
deci-second.

of Signal line is set from the
GBIC transceiver.

On if port is PAUSED any time in last deci-second.
Off if never PAUSED in last deci-second.

Setif the GBIC tx fault line is
set.

This alarm is set if the
instrument cannot
synchronize to the incoming
stream. For example, if an
incompatible signal has
been inserted into the GBIC

Red LED: indicates current fault.
Yellow LED: indicates historical fault.

None of these status indicators will light a physical LED on the front panel.
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Frame Capture

It is possible to capture up to 8 frames of the following data.
Each captured frame is timestamped on capture. The following
fields are captured:

¢ Source Address

* Destination Address

¢ Frame Length/Type

e VLAN Frame

¢ VLAN Priority Level and ID
¢ Up to 20 Bytes Client Data
e FCS Status

¢ Instrument Frame indicator

See “Frame Capture Criteria" on page 322 for details on when
frames are captured.

[ 2 To set up frame capture and show results

1 Press <Menu>, choose Frame Capture then press <Select>.

2 Select the Frames to Capture and the ports you wish to
capture on.

For guidance on the settings, see “Frame Capture Settings
Choices" on page 323

3 Select Start Capture and press <Select>.

Frame Capture Criteria

The following table summarizes when frames are captured. The
mechanism is to store only those frames which match the
trigger condition.

The trigger is applied to all ports. Captured data is then filtered

by port.
The captured data will report the port on which the frame was
captured.
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Frame Capture Criterion

Triggers Trigger format
Source Address XX-XX-XX-XX-XX-XX
Destination Address XX-XX-XX-XX-XX-XX
Length/Type XX-XX

VLAN frames Boolean select
VID XXXX

Priority Value=0to 7
FCS Errored
Non-testset frames Boolean
Immediate Action Field

Frame Capture Settings Choices

First choose whether you want to capture on All Frames or on
Filtered Frames.

If you choose Filtered Frames, then choose which type of frame
you wish to capture from and which ports you wish to inspect:

¢ Non-Instrument Frames
¢ Errored Frames

¢ Specific Frames

Non-Instrument Frames

Select this to capture any frames that have not been sent by
your Transmission Test Set. The expected result is 0 as the
instrument operates in either Loopback or End To End modes.
That is, it is either talking to itself or to another instrument of
its own kind.

Errored Frames

Select this to capture only errored frames.
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Specific Frames

This selection gives most control.

When Destination MAC is selected, you can choose from:

* Specific - you then choose the specific MAC address of the
device the frame is being sent to.

¢ Broadcast - this is used send to all devices in the Ethernet
domain. The broadcast address is all 1s
(or FF-FF-FF-FF-FF-FF in hexadecimal notation).

¢ Any Multicast - a multicast address is used to send to
multiple addresses that have already been defined as being
within a group.

When Source MAC is checked, you then choose your MAC
Address.

When VLAN is checked, you then choose your Priority Level
and VID:

¢ Select Priority Level to choose the priority from O up to 7.
¢ Select VID to choose a VLAN ID of between 0 and 4095.

Select Frame Length/Type and enter a value between 0000 and
FFFF.
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Viewing Ethernet Errors Using Results Summary

You can use Results Summary to continuously monitor errors in
Ethernet networks. Initial errors and/or alarms may indicate
problems with connections to the instrument or problems with
the network.

Results Summary operates on only the foreground instrument.
Errors or alarms detected by the background instrument are
indicated by the Multiple Instruments LED being turned on.

For more information about the detected alarms, press the
<Show More> key.

p  To start Results Summary

1 Press <Menu>, choose Test Functions & Results > Results
Summary then press <Select>. A results window will be
displayed.

2 More information on any errors detected is available. Press
<Show More>. Refer to “The <Show More> LEDs" on
page 321 for details of the meaning of these LEDs.
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Transmitter and Receiver Start/Stop

The transmitter and receiver within the Ethernet instrument
can be started and stopped in several ways:

¢ The transmitter and receiver can be started and stopped
simultaneously by pressing the <Run/Stop> key. This is the
default setting. For this mode, couple the transceiver to the
<Run/Stop> key. In this mode, the SONET/SDH instrument
is started and stopped simultaneously with the ethernet
instrument.

¢ The transmitter can be started and stopped using the
Start/Stop field on the Ethernet: Manual Tests page, while
the receiver is started and stopped independently of the
transmitter by pressing the <Run/Stop> key. For this mode,
deselect coupling the transceiver to the <Run/Stop> key. Use
this mode to count dropped frames.

¢ The start and stop time can be programmed. See “Setting the
Measurement Timing" on page 332 for details.

| 2 To set the Tx/Rx coupling

1 Press <Menu>, choose Tx/Rx > Transceiver Coupling then
press <Select>.

2 Select Couple Transceiver to Run/Stop gating key to start
and stop the transmitter and receiver using the <Run/Stop>
key.

Deselect Couple Transceiver to Run/Stop gating key to
start and stop the transmitter and receiver independently.

Transmitter Start/Stop

This is controlled using the <Run/Stop> key and the Start/Stop
controls in the measurement timing capability. The transmitter
will start only once the receiver measurements have started.
The transmitter will stop at the same time as the receiver
measurements stop.
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The measurement timing allows for the transmitter to start
immediately the <Run/Stop> key is pressed, or using a
programmed start/stop time.

The transmitter has two states:

¢ Stopped (or Idle): In this state, a “Learning Stream" on
page 327 is transmitted at a nominal low line rate.

The transmitter stream frame count does not increment in
this state.

¢ Started: In this state, defined frames at a defined rate are
transmitted for a defined duration. No learning frames are
transmitted.

The transmitter stream frame count increments.

The Start/Stop action applies to all Ethernet ports
simultaneously. The transmission can be prematurely stopped
by selecting Stop.

Receiver Measurement Run/Stop

When Run is selected, the receiver zeros all counters, clears the
list of identified streams and starts accumulating results. The
receiver continues to measure and accumulate results until
Stop is selected.

The Run/Stop action applies to all Ethernet ports
simultaneously. Measurements can be prematurely stopped by
selecting Stop.

Learning Stream

A learning stream is transmitted in advance of tests to teach the
device under test the MAC address of the test instrument
connected to it. The stream is identical to the port stream in
content but is transmitted with a stream ID = 0. It contains the
instrument test fields.
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This chapter gives information on additional features provided
by the instrument, plus information on technical support.
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Logging, Instrument Control and File Management Tools

Measurement Control and Results Management

¢ “Measurement Logging" on page 331

e “Setting the Measurement Timing" on page 332
¢ “Setting Time and Date" on page 334

¢ “Viewing Results Graphically" on page 335

Instrument Control and Settings

¢ “System Options" on page 341

¢ “System Preferences" on page 342
¢ “Manufacturing Data" on page 344
¢ “Keyboard Lock" on page 344

e “Self Test" on page 345

* “Remote Control" on page 349

User's Own Help Files, File Management and Printing
¢ “Creating Your Own Help Files" on page 353

¢ “Accessing Your Own Help Files" on page 356

¢ “File Management" on page 357

¢ “Print Control Key (Printer Setup and Capturing
Screendumps)" on page 362
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Measurement Logging

NOTE

You can generate a report at the end of the measurement period
or create an interval report at any time during the
measurement. Before logging results, set the measurement
period, see “Setting the Measurement Timing" on page 332.

You can log the measurement results to a file or printer
(connect the printer to the instrument’s USB port).
The measurement results you can log include:

¢ Interval Report - generated every “Logging Interval”. This
report can contain Cumulative Totals (the running total for
the measurement period) and Interval Totals (the totals for
the Interval).

¢ End of Measurement Report - generated at the end of the
measurement period. This includes report Totals (the total
for the measurement period).

To set up measurement logging
1 Press <Menu>, choose System > Measurement Logging then
press <Select>.

2 Select Enable logging. Select a Destination (File or Printer).
If you choose File, enter a filename and press <Select>.

3 Select the checkboxes for Interval Report (the minimum
Logging interval is 10 minutes), End of Measurement
Report, Logged Events and Logged Reports as required.

4 Press <Run/Stop> to start a new measurement. The
instrument will now log the results requested.

b Select Snapshot Interval Report for an interval report.
Use an underscore “_", not spaces, in filenames. Files are given the suffix

' A1.LOG'. If you log to an existing filename the suffix letter will
increment. Up to ten logging files can be stored on the instrument.

Logged results are stored in ASCII text format. You can copy
these files to a floppy disk and import them to a PC. See:

* “Copying an Internal File to a Floppy Disk" on page 358
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Setting the Measurement Timing

You can control the start/stop time of a test period, as follows:

Manual Start and Stop - Press the <Run/Stop> key to start.
The test runs until you press the <Run/Stop> key again.

Manual Start and Timed Stop - Press the <Run/Stop> key to
start. The test runs for a fixed period (1 min, 5 min, 15 min,
1 hr, 24 hrs or 72 hrs) or for a user-defined period.

Timed Start and Stop - Use the Start On date/time feature
to set the exact date/time when a test is to start. The test
runs for a fixed period (1 min, 5 min, 15 min, 1 hr, 24 hrs or
72 hrs) or for a user-defined period.

Manual Start and Stop

| 2 To set manual control of the measurement period

1

Press <Menu>, choose Results > Measurement Timing then
press <Select>.

In the Run/Stop field, choose Manually. This allows you to
use the <Run/Stop> button to manually start and stop a
measurement gating period.

Manual Start and Timed Stop

You can use this setting to capture results for a single
measurement period.

> To set up a manual start/timed stop measurement period

1

Press <Menu>, choose Results > Measurement Timing then
press <Select>.

To start manually - In the Run/Stop field choose User
Program. Select the Start field and choose Manually.

To stop after a fixed or user defined period - Select the Stop
After duration field and choose either one of the fixed
periods (1min, 5 min, 15 min, 1 hr, 24 hrs or 72 hrs) or User,
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for a user-defined duration. If User is chosen, use the
keyboard to set an end of measurement time.

Start On Date/Time and Timed Stop

You can define an exact date/time when you wish to start a
measurement and whether the measurement stops after a fixed
or user-defined period.

To set up a timed measurement period

1

Press <Menu>, choose Results > Measurement Timing then
press <Select>.

To choose a start time - In the Run/Stop field and select User
Program. Now select the Start field and choose On
date/time. Use the Keyboard to enter the start time then
press <Select>.

To stop after a fixed or user defined period - Select the Stop
After duration field and choose either one of the fixed
periods (1min, 5 min, 15 min, 1 hr, 24 hrs or 72 hrs) or User,
for a user-defined duration. If User is chosen, use the
keyboard to set an end of measurement time.
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Setting Time and Date

You should set the time and date correctly to enable
timestamping of logged results.

p  To set time and date

1 Press <Menu>, choose System > Time and Date then press
<Select>.

2 Set up the required date and time using the keypad.

3 Select Close and press <Select> to exit.
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Viewing Results Graphically

The Measurement Record System (MRS) time stamps all
captured errors, alarms and pointer movements. You can view
graphs that track pointer movements and graphs of error
distributions or alarm seconds durations, with respect to time.
The graphical data can also be stored and used for future
reference. Viewing and management of measurement record
data is controlled using the Measurement Record Graph
Manager.

Viewing Graphs

Use the graph manager window to view graphs of all error,
alarm and pointer information during a measurement period.
This window is split into three sections:

* Total Memory Usage - displays how much of the internal
storage has been used. If this becomes full, delete some of the
previously stored graphs using the Stored Sessions section.

* Latest Session - details the active graph and percentage of
available memory currently being used.

¢ Stored Sessions - allows the recall of previously stored
graphs. The session name and memory usage are displayed.
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> To view graphs

1 Press <Menu>, choose Measurement Record > Graph
Manager then press <Select>.

Maasuremant Raecard - Graph Manager
rTotal Memory Usage
rLatest Session

Mermory Usage: 1l g Stare | iew Graphs |
~Stored Session

MRS Session HName Memory Usage % Rename |

Chicago 23 March 02 1%

Chicaga 26 March 02 1% Delate

Naperville 20 March 02 1%

Wi Info
Wiew Graphs
|status: Laser-ON |

2 Select View Graphs from either the Latest Session or Stored
Sessions section as appropriate. The Graph Viewer window
will be displayed. This window is split into two sections.

¢ Summary Graphs (top section)

¢ Detail Graphs (bottom section)

The summary section shows a summary of alarm and error
seconds. A solid red bar depicts the time of occurrence of
detected alarms and errors.

The detail graphs section can be configured to show either
one or two graphs.
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Cursor ——— Window 2
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Use the <Menu> key to access the selection and navigation
features.

From Select, select the item you want to view, then press
<Select>. A menu appears showing Physical, Section, Path,
TCM, PDH, DSn and Pattern (errors and alarms are grouped
into each of these layers). Any item in the menu with active
error/alarm information within the visible time range is
shown in red. Graphs of pointer positions are found at Path >
SPE/VT or AU/TU Pointer Value. A green cursor allows you
to interrogate results for a particular time period. Use the
arrow navigation keys to pan through the results. Error
counts or pointer values are shown on the graph against the
selected time period.

Select View Range to rescale the time axis. The time taken to
view will depend on the amount of data stored. The message
“Retrieving data...” is displayed on the status line during data
processing.

Select Show to pan Page Left or Page Right or to select a
Single/Double Graph.
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NOTE

The <Menu> key also allows you access to the session manager
to store/recall graphs or to close the graph window and return
to the user interface. For more information, see

“Storing Graphs" on page 338.

If power fails during a measurement period, this is recorded in the graph
viewer window, under Power loss seconds in the Physical Alarms
section. When power is restored to the instrument, re-select the graph
viewer to see results being captured again.

Storing Graphs

Use the Graph Manager window to store results of all error,
alarm and pointer information during a measurement period.
This window is split into three sections:

* Total Memory Usage - displays how much of the internal
storage has been used. If this becomes full, delete some of the
previously stored graphs using the Stored Sessions section.

* Latest Session - details the active graph and percentage of
available memory currently being used.

¢ Stored Sessions - allows the recall of previously stored
graphs. The session name and memory usage are displayed.
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> To store graphs

1 Press <Menu>, choose Measurement Record > Graph
Manager then press <Select>.

Measurement Record - Graph Manager

Total Mermary Usage
rLatest Session
Mernory Usage 1| % Store | view Graphs |
~Stored Session
MRS Session Name Memory Usage % Rename |
Chicago 23 March 02 1%
Chicago 26 March 02 1% Delete I
Naperlle 29 March 02 1%
View Info |
Wiew Graphs
[status: | Laser-on |

2 Select Store to save a current graph. If Store is unavailable,
the test is still running. Wait until the end of the test period
before storing results. When storing a graph, include the date
in the filename.

NOTE Store results from the last graph session before starting a new test.

If the graph storage space is full, use the session manager to delete
previously stored sessions. Text results will still be stored.
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To recall graphs

1 Press <Menu>, choose Measurement Record > Graph
Manager then press <Select>.

2 Use the arrow keys to move to the Stored Sessions section,
then press <Select>.

3 Move to the session you wish to view, then press <Select> (it
will be highlighted in blue).

4 Move to View Graphs to see the captured information.

If you wish to rename a graph, select the appropriate result
and press Modify.

6 Select View Info to view details about the configuration of
the instrument during a graph capture.

71 If required (for example if the 10 available store locations are
used), use Delete to free up space.

8 To exit the session manager, press <Menu> then select the
appropriate screen to view.

Dynamic Axis Scaling and Scrolling

The graph is continually updated during a measurement and
the X-axis (time) automatically scrolls. When the plotted points
reach the X-axis limit the graph will scroll and continue plotting
from the X-axis mid point.

The X-axis range must be manually selected to suit the data
being viewed. The ranges are 1 minute (default), 1 hour, 12
hours, 2 days, 3 days, 4 days and so on in 1 day increments up to
a maximum of 7 days.

The Y-axis is dynamically scaled for pointer movements. The
Y-axis for error and alarm measurement histograms is a fixed
logarithmic scale. Histograms are capped at 10000
errors/alarms (actual values can be viewed by using the cursor
to select the event of interest). A single error/alarm can also be
viewed on the same graph.
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The System Options window lets you view the following;:

Instrument Options: Options installed.
Software Version: Firmware revision and build date/time.

Option Control: Use this page to enable/disable options and
enter serial numbers and code words when upgrading your
instrument.

p  To view system options

Press <Menu>, choose System > Options then press
<Select>. Select the Instrument tab.
Or,

Press <Menu>, choose System > Options then press
<Select>. Select the Software tab.
Or,

Press <Menu>, choose System > Options then press
<Select>. Select the Option Control tab.
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System Preferences

> To access the System Preferences

1 Press <Menu>, choose System > Preferences then press
<Select>.

System - Preferences
MNetwork Standard SOMET -

Errors and Alarms
¥ MS-REI!REI-L result monitor

W MS-AIS | AIS-L alarm monitor

¥ G.826 collect ES, SES, BBE while path unavail
¥ Enhanced RDI

MS-REIf REI-L: MO, M1 byte usage b0 & 1 v|
at STM-64 f OC192

W STS-1 bulkfilled stuff column ovenawtrite
Audio Controls 1

Access Control

Save As Defaultl

2 Select the preferences you require.

3 Select the Save as Default button. A dialog box is displayed.
This prompts you to confirm any changes you have made to
the settings.

Use the system preferences window to select the following
settings:
¢ Network Standard - Select from SDH or SONET operation.

¢ MS-REI/REI-L byte usage - Select from M1 only or MO & M1.
The G.707 (October 2000) ITU specification introduced the
use of two bytes (MO, M1) for MS-REI/REI-L error monitoring
in STM-64/0C-192 line signals. To support interfaces of
equipment designed prior to this new recommendation the
instrument supports both single (M1) and two (MO, M1) byte
MS-REL If the measurement results are not as expected,
check that the MS-REI field selection is correct for the
network-under-test. Try repeating the test with a different
MS-REI selection.
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MS-REI/REI-L Results Monitor - Enable (default)/disable
collection of MS-REI/REI-L results.

MS-AIS/AIS-L Alarm Monitor - Enable (default)/disable
collection of MS-AIS/AIS-L alarms.

G.826 Collect ES, SES, BBE While Path Unavailable. Use this
to enable/disable the collection of results for Errored
Seconds (ES), Severely Errored Seconds (SES) and
Background Block Error (BBE) while the path is unavailable.
These counts are not included in the calculation of ESR,
SESR and BBER. For more information, see: “Introducing
ITU Performance Analysis" on page 428.

Enhanced RDI - Enable/disable (default) the Enhanced
Remote Defect (RDI) alarm function (as specified in
Telecordia GR-253 CORE Issue 3 and ITU-T G.707).

Signal Wizard: SONET B1/B2/B3/BIP Labelling - Allows the
CVS, CVL and CVP bits to be labelled as B1, B2 and B3 on the
Signal Wizard screen.

STS-1 bulk-filled stuff column overwrite - You can overwrite
all bytes including or excluding the fixed stuffing bytes.

Laser Off on power up - Ensures the laser is always disabled
on power up. If this checkbox is not selected, the instrument
on power up will re-establish the laser setting (enabled or
disabled) that existed prior to the last power down.

STS-1 numbering: 1-to-N Scheme - Allows the default
numbering system to be replaced with the G.707 STS-1
numbering, 1-to-N scheme.
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Manufacturing Data

The manufacturing data window lists the modules/assemblies
fitted to your instrument. The information may be useful to an
engineer if your instrument requires repair or calibration.

[ 2 To open the manufacturing data window

* Press <Menu>, choose System > Manufacturing Data then
press <Select>.

The information given in the window indicates the following,
reading from left to right.

¢ J1413-60502 0200 SL119 000107 - Module or PCA drawing
number

e J1413-60502 0200 SL119 000107 - Material List Revision
Code

e J1413-60502 0200 SL119 000107 - Vendor Code

e J1413-60502 0200 SL119 000107 - Year/Week of assembly
(YWW)

e J1413-60502 0200 SL119 000107 - Board serial number

e J1413-60502 0200 SL119 000107 - Total board unique
identification number

Keyboard Lock

This feature calls up the Keyboard Lock window to deter others
from using the instrument.

NOTE The keyboard is not actually locked. The message displayed advises other

users not to change the current settings. All keys are still operable.

p  To lock the keyboard

¢ Press <Menu>, choose System > Keyboard Lock then press
<Select>.
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Self Test

The self test consists of a confidence test to verify that the
instrument is operating correctly. This includes a range of tests
for the main measurement interfaces. You can run an ‘all
interface’ confidence test (which takes approximately 5
minutes) or individual interface tests. If a failure occurs then a
descriptive text message and error code is returned. For further
information on the self test and error codes, refer to the
Installation and Verification manual (on the CD-ROM).

p  To run the confidence test

1 Press <Menu>, choose System > Self Test then press
<Select>.

2 Ensure all loopbacks are in place. Select the appropriate
1310/1550 nm 2.5 G - 52 M optical loopback cabling
configuration.

3 Select Run Selected test radio button, then select
Confidence Test.

4 Select Start. The elapsed test time and remaining test time is
displayed. If any sub-test fails a error message and error code
will be returned. Up to six errors are recorded.

NOTE Perform the Confidence Test twice if single wavelength optics are fitted to
the 2.5 Gb/s-52 Mb/s Optical Out port, to verify all Optical In ports. For the
first test connect the 2.5 Gb/s-52 Mb/s Optical Out port to the 2.5 Gb/s
Optical In port. For the second test connect the 2.5 Gbh/s-52 Mb/s Optical
Out port to the 662-52 Mb/s Optical In port. Select the cable configuration
from the test menu as appropriate.

CAUTION Observe safety precautions, care and connection cleanliness to avoid

damage or degradation of the optical connections. Ensure the
recommended optical attenuation is present in all optical loopback
connections to avoid self test failure or damage to the optical
receivers.
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Confidence Test Failure

If the confidence test fails:
¢ Make sure all the correct loopback connections are in place.

* With optical interface failures, clean all optical connections
with a recognized cleaning kit before repeating the
confidence test. For more information on cleaning optical
connectors, see the Installation and Verification Manual (on
the CD-ROM).

¢ If the problem persists then contact your local Agilent
Service Office or representative.
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Self Test Loopback Connections

The confidence test verifies all the optical and electrical test
ports on the unit therefore loopback connections are required
on the instrument.

DCC Loopback  goNET/SDH and E1 Balanced
connector only  pg3/2-140Mbls Electrical Loopback

required for Loopback
DCC NQ

|__DS1 Balanced

Electrical Loopback

SN

15 dB Optical
'| Attenuators* to

ADD/DROP

(or All Tests)
\

Optical r

ensure level is

Loopback Patch _— within Receiver

Cords shown for Dual
Wavelength option

User Guide

Input Range

* Optical attenuators not required when connecting the
Tx and Rx ports of short reach (SR) optical modules

Optical Loopback Connections (All Instruments)
Use optical cables (Part Number 1005-0337) and 15 dB
attenuators* (Part Number 1005-0433):

¢ 10 Gb/s 1550 nm Optical Out via 15dB Attenuator to 10 Gb/s
Optical In.

e 52 Mb/s-2.5 Gb/s Optical Out via 15 dB Attenuator to
2.5 Gb/s Optical In.

e 52 Mb/s-2.5 Gb/s Optical Out via 15 dB Attenuator to
52 Mb/s-622 Mb/s Optical In.
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Electrical Connections 155 Mb/s to 8 Mb/s)

Use BNC cables (Part Number 15525A):
e 52/155 Mb/s Out (BNC) to 52/155 Mb/s In (BNC)
e 2-140 Mb/s DS3 Out (BNC) to 2-140 Mb/s DS3 In (BNC)

Balanced Electrical Connections 2M/DS1 (Enhanced Testing Product
Required)

Use 3-pin Siemens cable (Part Number 15512A) and Bantam
Cable (Part Number 15670A):
e 2M Out (3-pin Siemens) to 2M In

e DS1 Out to DS1In

User Guide
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Remote Control

> To access the remote control window

* Press <Menu>, choose System > Remote Control then press
<Select>.

The following options are available for remote control of the
instrument through your PC/terminal:

¢ RS232 connection
¢ LAN connection

¢ GPIB connection

User Guide
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RS232 Operation

To remotely control the instrument via an RS232 connection.

1

Connect your PC/terminal via a suitable RS232 cable to the
instrument RS232 port.

Press <Menu>, choose System > Remote Control then press
<Select>.

Set Connection mode to RS232.

4 Select the Command prompt checkbox if you are going to

remotely control the instrument. Do not select Command
prompt if a computer program is going to control the
instrument.

Select the Baud rate, Data bits, Stop bits, Parity and
Handshaking.

Select Close.

User Guide
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LAN Operation

You can remotely control an instrument via a LAN connection.

> To remotely control the instrument via a LAN connection.

1
2

7
8

User Guide

ﬁ%

Connect your PC/terminal and instrument to your LAN.

Press <Menu>, choose System > Remote Control then press
<Select>.

Set Connection mode to LAN.

Select the Command prompt checkbox if you are going to
remotely control the instrument. Do not select Command
prompt if a computer program is going to control the
instrument.

Select Network Settings.

Enter the IP address, Subnet mask and Default gateway
values. These values are typically assigned by your
Information Technology (IT) department. Then select Close.

Metwork Settings

010 211
255.255.255.000 {nnn.nnn.nnn.anm
010.225.000.001 {nnn.nnn.nnn.anm

Close |

IP address

{nnn.nnn.nnn.anm
Subnet mask

Default gateway

Ensure the Port number is to 5001.

Run Telnet on your PC. Enter the IP address assigned to the
instrument and the Port number (5001).

351

e

rs



@é son_Cobra.book Page 352 Wednesday, September 25, 2002 11:09 AM

A

6 Instrument Details

GPIB Operation

> To remotely control the instrument via a GPIB connection.
1 Connect your PC/terminal via a suitable GPIB card and cable
to the instrument GPIB port.

2 Press <Menu>, choose System > Remote Control then press
<Select>.

3 Set Connection mode to GPIB.
4 Enter the required GPIB address.
b Select Close.

352 User Guide
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User's Own Help Files

You can add your own help files to the instrument and refer to
them when carrying out your routine procedures, solving
problems or following detailed test procedures. To produce your
own help system, create HTML files using a standard
word-processor. To access these files on the instrument, you
need to create an index file containing hypertext links to each
of the files. You must call the index file ‘ownhelp.html’.

For more information on creating and accessing your own help
files, see:

¢ “Your Own Help Files - Hierarchy" on page 353

¢ “Creating Your Own Help Files" on page 353

¢ “Accessing Your Own Help Files" on page 356

Your Own Help Files - Hierarchy

Network Test > Test 1
Test1 ==~
Test2
-~
~ L
TeSt I o - Filemame:
Iy Test1.html
~ L5
Fil *'
Hename:
ownhelp.html TESt 2
Index file {ownhelp.html) with
links to individual test files.

Filename:
Test2.html

Creating Your Own Help Files
To create your own help files

1 Use a standard word processor or HTML editor to create the
file. If you keep your document short, it will load quickly and

353
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be easy to navigate through. Save the document(s) with the
extension ‘.html’. For more information on how to structure
your HTML pages, see “Guidelines for Creating HTML

Files" on page 355.

2 Create an index file with hypertext links to each of your files.
Save this file as ‘ownhelp.html’.

3 Before loading your own help files onto the instrument,
check them in a Web browser.

4 Copy all of your files, including your ‘ownhelp.html’ index
file and any image files, onto a floppy disk.

b Copy the files from the floppy disk to the instrument (see:
“Importing Files from a Floppy Disk" on page 359).

6 To access your files via the instrument’s Online Help system,
see: “Accessing Your Own Help Files" on page 356.

Use a meaningful name for your files, and save them with the
NOTE o .
extension”.html’.
Images should be in JPG or GIF format. When you add files to the
instrument, any files with the same name will be overwritten by your new

files.

CAUTION You must load your index f.lle (‘ownhelp.html’) onto the instrument
to be able to access your files.

354 User Guide
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CAUTION

Guidelines for Creating HTML Files

Use only a sans serif font (such as Arial) of size 12, 14 or 16
point, Normal or Bold - DO NOT use italic as this font is not
supported on the instrument and can cause problems with
the presentation of your document.

Any images you include should be either GIF or JPEG format.

Design a page size and layout that is appropriate for the size
of the instrument display. For example, write several short
documents, rather than one long one, and make sure any
inserted tables will fit the screen width (maximum 560 pixels
or 15cm wide).

Have all the documents and images in one folder/directory.
The instrument does not currently support file tree
structures.

The total size of the files should not be more than 1.44Mb.
You cannot download files that are larger than the capacity of
a floppy disk.

Format your document to fit the instrument’s screen-width.
If you insert tables that are larger than the screen, they will not
display properly.

The instrument supports HTML Standard 3.2. Documents produced
using later HTML standards are not guaranteed to operate or display
on the instrument.

User Guide

ﬁ%

355

rs



@é son_Cobra.book Page 356 Wednesday, September 25,2002 11:09 AM

A

6 Instrument Details

Accessing Your Own Help Files

p  To access your own help files

1 Press <Help> to access the Online Help system.
2 Press <Menu>, select Your Own Help and press <Select>.

3 Select the link to the file you require, using the arrow
navigation and <Select> keys.

4 If a file is longer than one screen-size, use the <Next Page>
and <Prev Page> keys (on the instrument keypad) to scroll
up or down.

b Press the <Back> key to return to the ‘ownhelp.html’ index,
or the <Home> key to return to the Online Help Home page.

356 User Guide
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File Management

While using the instrument, you will generate a number of
different types of files:

Stored Settings Files - There is one Factory Default Stored
Setting and four User Defined Stored Settings. You can recall
these settings, saving you time when setting up measurements.

Measurement Logging Files - During a measurement you can
log the measurement results to an internal file or to an external
printer. For more information, see:

¢ “Measurement Logging" on page 331
User Help Files - You can create your own help files to add to

the instrument and then access them through the Online Help
system. For more information on accessing your own files, see:

e “Accessing Your Own Help Files" on page 356

Screendump Files - You can capture screen images using the
Print Control key on the Front Panel. These can be stored as
files or printed directly. For more information, see:

¢ “Saving and Printing Screendumps" on page 363.

For information on how to manage your stored files, see:

¢ “Copying an Internal File to a Floppy Disk" on page 358
¢ “Importing Files from a Floppy Disk" on page 359

¢ “Deleting Files from a Floppy Disk" on page 360

¢ “Deleting Files from the Instrument" on page 361

User Guide 357
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Copying an Internal File to a Floppy Disk

You can copy different file types (settings, logging, user’s own
help or screen dumps) from the instrument to a floppy disk,
ready for transfer to another instrument or to a PC.

First you should view the latest list of files stored on the
instrument, by completing the Refresh List function. Then you
can choose which file to copy to the floppy disk. If a file
approaches the capacity of a floppy disk, it will be split
automatically.

p  To refresh the list of files
1 Press <Menu>, choose System > File Manager then press
<Select>.
Select the required file type.
Set Drive to Internal.
Set Operation to Refresh file list.

Select Action, then press <Select> to refresh the list of files.

(23 B — T VLR ()

> To copy a file to a floppy disk

1 Select the Files field, then choose a file from the list.
2 Set Operation to Copy file to floppy.

3 Select Action, then press <Select>.

358 User Guide
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Importing Files from a Floppy Disk

You can copy different file types (your own help files or
settings) to the instrument from a floppy disk.

First you should view the latest list of files stored on the floppy
disk, by completing the Refresh List function. Then you can
choose which file to copy to the instrument.

p  To refresh the list of files

1

S 1 AW

Insert the Floppy disk, containing the files to be imported, to
the instrument’s Floppy disk drive.

Press <Menu>, choose System > File Manager then press
<Select>.

Select the required file type.
Set Drive to Floppy.
Set Operation to Refresh file list.

Select Action, then press <Select> to refresh the list of files.

> To import files from a floppy disk

User Guide

Select the Files field, then choose the file to be imported.

Select the Operation field, then choose the destination to
import the file to.

Select Action, then press <Select>.
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Deleting Files from a Floppy Disk

You can use the instrument to delete different file types
(settings, logging, user’s own help or screen dumps) from a
floppy disk.

First you should view the latest list of files stored on the floppy
disk, by completing the Refresh List function. Then you can
choose which file to delete.

p  To refresh the list of files

1 Insert the Floppy disk in the instrument Floppy disk drive.

2 Press <Menu>, choose System > File Manager then press
<Select>.

3 Select the required file type, depending on which file type
you wish to delete.

4 Set Drive to Floppy.
b Set Operation to Refresh file list.

6 Select Action, then press <Select> to refresh the list of files.

> To delete files from a floppy disk

1 Select the Files field and choose the file to be deleted.
2 Set Operation to Delete file.

3 Select Action, then press <Select>.

360 User Guide
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Deleting Files from the Instrument

You can delete different file types (logging, user’s own help or
screen dumps) from the instrument.

First you should view the latest list of files stored on the
instrument, by completing the Refresh List function. Then you
can choose which file to delete.

p  To refresh the list of files

1 Press <Menu>, choose System > File Manager then press
<Select>.

2 Select the required file type, depending on which file type
you wish to delete.

3 Set Drive to Internal.
4 Set Operation to Refresh file list.

b Select Action, then press <Select> to refresh the list of files.

p  To delete files

1 Select the Files field and choose the file to be deleted.
2 Set Operation to Delete file.

3 Select Action, then press <Select>.

User Guide 361
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Print Control Key (Printer Setup and Capturing Screendumps)

You can connect a printer to the instrument via the USB port.

Use the print control to check your printer connection, or use it
to print or save the current screen graphics (screendump).

> To open the print control window

¢ Press <Print Control> on the instrument’s front panel. The
print control window is split into two areas:
The Screendump area allows you to control the printing or
saving of the current screen graphics. Saved graphics are
stored internally on the instrument. You can then transfer
these files to a floppy disk.
The Printer Setup area shows details of the connected
printer and the printer driver being used.

For more information, see:
e “Saving and Printing Screendumps" on page 363

¢ “Recommended Printers" on page 363

User Guide
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Saving and Printing Screendumps

NOTE

You can capture screen graphics and save or print them.

To print the screendumps, connect a printer to the instrument
via the USB port.

Up to ten screendump (.bmp) files can be saved on the instru-
ment. You can then transfer these saved files to a floppy disk.

If you already have ten screendumps stored, you will need to delete some
files before you can store new files. If you need to retain a copy of the
existing files, then copy them to a floppy disk before you delete them from
the instrument. See: “Deleting Files from the Instrument" on page 361.

To capture a screendump

1 Press <Print Control> on the instrument’s front panel.

2 Select the Screendump - Destination field and choose
Printer or File. If you choose File, use the keypad to enter a
filename and press <Select>.

3 Select the Close Dialog and Dump Screen Image box and
press <Select>. The screen image is either stored or printed,
depending on whether you selected Printer or File.

To copy saved files from the instrument to a floppy disk, see:

* “Copying an Internal File to a Floppy Disk" on page 358

Recommended Printers

NOTE

¢ HP DeskJet 970Cxi

¢ HP DeskJet 930C/cm
¢ HP DeskJet 959C

e HP DeskJet 950C

¢ HP DeskJet 895Cxi

e HP DeskJet 840C

If you are not using a recommended printer, the printer output will be text
only.

363
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Technical Support

For technical support information, see:

¢ “Operators Maintenance" on page 365

¢ “Instrument Reboot (Cold Start)" on page 367
¢ “CD-ROM Resources" on page 368

¢ “Frequently Asked Questions" on page 368

For further technical support, contact your nearest Agilent
Sales Office.

364 User Guide
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Operators Maintenance

No operator serviceable parts inside. Refer servicing to qualified
personnel. To prevent electrical shock, do not remove covers.

CAUTION

Maintenance appropriate for the operator is:
¢ (Cabinet cleaning - clean the cabinet using a dry cloth only.
¢ Cleaning Optical Connectors

¢ Ensure ventilating fan cover is clean.

Cleaning Optical Connectors

You should clean the optical connectors at regular intervals
using the following materials:

Description Agilent Part Number

Compressed Air Can or Blow Brush

Isopropyl Alcohol 8500-5344
Lens Cleaning Paper 9300-0761
Swabs 5080-5400

Do not insert any tool or object into the optical IN or OUT ports of the
instrument as damage to or contamination of the optical fiber may
result.

To clean the optical connectors

1 Disconnect the instrument from the Power Line or switch off
the laser transmitter before commencing this cleaning
procedure.

2 Remove the adapters from the optical IN and OUT ports by
flipping back the lever on the optical adapter.

365
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Using the blow brush with the brush removed blow through
the ferrule of the standard flexible connector and the
adapter.

If the optical fiber of the fixed connector requires further
cleaning this entails disassembly of the module. This should
be carried out only by suitably trained service personnel.

Apply some isopropyl alcohol to a piece of the cleaning paper
and clean the barrel of the adapter. Using a new piece of
cleaning paper, clean the face of the adapter. Repeat this
operation, using a new piece of cleaning paper each time.

Use a blow brush or compressed air to remove any particles
of cleaning paper which may be present.

Replace the adapters in the optical connector. Secure in
place by clicking the retaining lever back into position.

User Guide
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Instrument Reboot (Cold Start)

An instrument “cold start” routine is provided to reset the
instrument in the event of an unplanned hardware or firmware
event. A cold start reboots the instrument and restarts the
instrument using a default configuration file. Performing a cold
start erases existing configuration information.

To perform a cold start

1 Switch the instrument off and wait a few seconds.

2 Switch the instrument on and as the instrument boots up,
look carefully at the display.

3 Wait for the “Initialising instrument” . . . . . text to be
displayed. After a few seconds start to repeatedly press the
<Menu> key until the Agilent splash screen appears with an
options menu in the top left corner of the display.

The following options are available:
1 Reload configuration.

3 Cold start.

b Normal start.

6 Upgrade software.

4 Press 3 on the numeric keypad to select cold start. The unit
will then continue with the boot up process.

b When the boot-up procedure is complete, the instrument
displays a dialog box with the message: “Instrument reset to
default settings.”
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CD-ROM Resources

The instrument CD ROM is a useful resource for all users. It
contains training materials and support information, including;:

¢ User documentation

¢ Full technical specifications

* Remote control manual

¢ Product/application notes

¢ Multimedia presentations including an instrument tour
¢ Links to the product website

¢ Telecommunications glossary

¢ Frequently asked questions

Frequently Asked Questions

1. Is there a reference list to quickly remind me how to set up the
instrument?

Use the Quick Reference Guide to remind you of the main key
presses required to set up and control the instrument. This
booklet was provided with the product CD-ROM.

2. Can | change the optical connectors to a different type?

Yes, your instrument will have been fitted with FC/PC, SC or ST
connectors. If you wish to change the connector type, you need
to order the appropriate accessory. See the product Option
Guide, in the Getting Started > Product Description section of
the Online Help, for details.

For details on changing the connectors, please consult the
Installation and Verification manual (available on the product
CD-ROM). While performing the operation, care must be taken
to avoid damaging the connectors or instrument optics and to
ensure cleanliness of parts at all times.

368 User Guide
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3. How often should | check the calibration of the instrument?

The calibration interval is every two years. However, adjustment
is expected to be less frequent as it is only required if any of the
performance tests (as detailed in the Installation and
Verification manual, available on the product CD-ROM) fail.
Please contact your local Agilent Service Center for details of
calibration services.

4. How do | control the instrument remotely?

The instrument can be remotely controlled via a LAN
connection, RS-232 modem or GPIB connection. The instrument
is controlled by sending SCPI commands or by using the Virtual
Instrument software (from Agilent's website) and Sun Java
Virtual Machine (from Sun's website). There is no cost
associated with this software. The software will run on any
platform with the appropriate Java VM installed; however
Agilent only warrants use under Windows 95, 98, NT and XP
and 2000 based PC systems.

5. How do | upgrade instrument firmware?

You can download firmware upgrades to a PC/laptop and
transfer them to the instrument via a LAN or RS-232
connection. For more information, contact your nearest Agilent
Office or contact Customer Support through the product web
site (see the product CD-ROM for more details).

6. Can | use a mouse and keyboard with the instrument?

Yes, the mouse and keyboard PS/2 connectors are enabled. PS/2
connections must always be made before the instrument is
powered-on.

7. How do | print my results?

Connect a suitable printer to the USB port. This enables you to
print results and screendumps.

For information on how to log to a printer, see the Online Help:

369
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1 Press the <Help> key on the instrument to open the Online
Help.

2 Press the <Home> key to open the Online Help Home Page.

3 Use the arrow navigation and <Select> keys to select the
options: Instrument Details > System Features >
Measurement Logging.

8. What printers are compatible with the instrument?

The instrument supports printing via the USB interface with
PCL 3.0 compatible printers. PCL 3.0 covers Hewlett-Packard
DeskJets & LaserJets. Because of the wide variety of printers on
the market and due to the differences in implementing the PCL
3.0 standard, Agilent cannot guarantee that all PCL compatible
printers will operate issue-free. The following (non-exhaustive)
list of printers have been tested and verified to work error-free:
HP DeskJets 840c, 895cxi, 930c/cm, 950c, 959¢, 970Cxi.

9. Where can | find information on instrument installation,
verification and self testing?

Refer to the Installation and Verification Manual (available on
the product CD-ROM).

Also, details of the instrument Self Test (Confidence Test are
contained in the Online Help. To access this information:

1 Press the <Help> key on the instrument to open the Online
Help.

2 Press the <Home> key to open the Home Page.

3 Use the arrow navigation and <Select> keys to select the
options Instrument Details > System Features > Self Test.

10. How do | transfer my own help files to the instrument

Save your help file in HTML format. Transfer your files to a
floppy disk, then load them onto the instrument.

The Online Help contains full instructions for installing and
managing your own help files. To access this information:

User Guide
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1 Press the <Help> key on the instrument to open the online
help.

2 Press the <Home> key to open the Home page.

Select the option Users Own Help Files from the Online Help

Home Page.

NOTE Remember, if a help page is longer than one screen, use the <Next Page>
and <Prev Page> navigation keys on the instrument keypad to view the
whole page.
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This chapter provides useful reference material, including a
summary of the ITU standards, explanations of telecoms terms
and lists of overhead bytes, signal rates and errors/alarm.
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7  Telecoms Concepts

SONET Concepts

For SONET reference information, see:

e “SONET STS-1 Frame Structure" on page 375
¢ “SONET Payload Structure" on page 376

¢ “SONET Overhead Bytes" on page 377

374 User Guide
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SONET STS-1 Frame Structure
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1

The relationship between the various elements that make up a
SONET STS-1 signal is shown in the following diagram.
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SONET Payload Structure

The payloads that can be carried in a SONET signal are outlined
below.

* You can asynchronously map a framed/unframed DS3 (44
Mb/s) or E3 (34 Mb/s) signal into a full STS-1 SPE, or you can
bulk fill the STS-1 SPE.

¢ You can transmit 28 VT1.5s, 21 VT2s or 7 VT6s in a STS-1
SPE. The VTs are structured into 7 virtual tributary groups
(VT Groups) within a STS-1 SPE. Each VT-group can contain
4 VT1.5s, 3 VT-2s or 1 VT-6.

¢ You can transmit concatenated payloads in SONET signals.
These types of payload reduce test times by testing the entire
bandwidth in one go.
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SONET Overhead Bytes

Four overheads are used to transport SONET signals across the
spans of a network.

SONET digital
criass-ponnact
wT system T
assembly disassembly

SOMET SOMET
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Tributary: ~ SOMET teerminal SOMET tarmiral ! ?m;_-. I
! : BETTHORN o, —_— —_— —_— ) : Litary
signals ! mutiglexar : mutipleanr i signals

P o

-

i E Section span Saction 5|:|a.|:|i 1SE¢1ion span | !
| Nt !
v Y Linespan ! | Line span o
- >
- Path £
For more information, see:
¢ “Section Overhead (SOH)" on page 378
¢ “Line Overhead (LOH)" on page 379
e “STS Path Overhead (STS POH)" on page 386
e “VT Path Overhead (VT POH for VT-1.5, VT-2 or VT-6)" on
page 389
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Section Overhead (SOH)

The Section overhead (SOH) supports the transmission of
SONET signals across the section span of a network.

Byte Label Description

Al, A2 Framing Provides a frame alignment pattern (A1=F6 Hex,
A2=28 Hex), The frame alignment word of an STS-n
frame is n A1 bytes followed by n A2 bytes.

Jo Section Supports continuity testing between the
Trace transmitting and receiving device on each section
span.
20 Reserved for future international standardization.
B1 Section Provides section error monitoring. The section BIP-8
Code provides end-to-end error performance monitoring

Violation ~ across an individual section. The BIP-8 is calculated
(CV-S) over all bits of the previous STS-n frame after
scrambling. The computed value is placed in the B1
byte of the current STS-n before scrambling.

E1 Orderwire  Provides local orderwire channel for voice
communication between regenerators, hubs and
remote terminal locations.

F1 User Provides a 64 kb/s proprietary data communications
Channel channel for the user. It is terminated at each section
terminating equipment.

D1toD3 DataComm. Provides a 192 kb/s message-based data
Channel communications channel (DCC) for administration,
monitor, alarm and maintenance functions between
section terminating equipment.
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Line Overhead (LOH)

The LOH carries SONET signals over the line span of a network.

Byte Label Description

B2 Line Code Provides line error monitoring. The BIP-8 is
Violation calculated over all bits of the line overhead and
(CV-L)  envelope capacity of the previous STS-n frame
before scrambling and is placed in the B2 byte of the
current STS-n frame before scrambling.

K1, K2 APS Line automatic protection switching (APS) is
Channel controlled by the K1K2 bytes. Two APS message

types are used:
Linear APS messages
Ring APS messages
For more information, see “Linear APS Messages
(Telecordia GR-253-CORE Issue 3)" on page 381 and
“Ring APS Messages (Telecordia GR-1230)" on
page 383.

D4 to D12 Data Provides a 576 kb/s data communications channel
Comm.  (DCC) between line terminating equipment. Used for
Channel network administration/maintenance information.

S1 Sync S1 bits 5 to 8 show which levels of synchronization
Status  are being used at the transmit end of a line span. For
more information, see “Synchronization Status
Messages (S1 bits 5 to 8)" on page 385.

21,72 Allocated for future growth.

MO0 REI-L STS-1 line remote error indication (defined only for
STS-1) conveys the B2 errors detected by the
downstream line terminating equipment.

M1 REI-L STS-n line remote error indication (defined for n>3)
conveys the B2 errors detected by the downstream
line terminating equipment.

E2 Orderwire Provides express orderwire channel for voice
communication between line terminating equipment.
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Byte

Label

Description

H1 to H3

The payload pointer contained in the H1 and H2
bytes of the line overhead designates the location of
the byte where the STS SPE begins. The last ten bits
(bits 7 to 16) of H1H2 carry the pointer value (0 to
782). The H1 and H2 bytes are also used to indicate a
concatenated payload by transmitting the pointer
word “1001XX1111111111" in the second to Nth
STS-1inan STS-Nc.The H3 bytes is allocated for SPE
frequency justification purposes and can carry “live”
information from a STS SPE when a negative pointer
adjustment occurs.
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Linear APS Messages (Telecordia GR-253-CORE Issue 3)

Protection Switching Protocol

K1

Bits 1to 4

1nn
1110
1101
1100
1011
1010
1001
1000
011
0110
0101
0100
0011
0010
0001
0000

Condition

Locked out of protection
Forced switch

Signal fail high priority
Signal fail low priority
Signal degrade high priority
Signal degrade low priority
Unused

Manual switch

Unused

Wait-to-restore

Unused

Exercise

Unused

Reverse request

Do not revert

No request

Bits5to8 Selects channel used by APS messages

381
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382

Protection Switching Protocol

K2
Bits 1to 4
Bith

Bits 6 to 8
100
101
110
m

Condition
Selects bridged channel used

Determines APS architecture

Provisional mode is unidirectional
Provisional mode is bidirectional
RDI-L

AIS-L

All other combinations of bits 6 to 8 not used.
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Ring APS Messages (Telecordia GR-1230)

Protection Switching Protocol

K1 Condition

Bits 1to 4

"M Locked out of protection (span) or signal fail (protection)

1110 Forced switch (span)

1101 Forced switch (ring)

1100 Signal fail (span)

1011 Signal fail (ring)

1010 Signal degrade (protection)

1001 Signal degrade (span)

1000 Signal degrade (ring)

0111 Manual switch (span)

0110 Manual switch (ring)

0101 Wait-to-restore

0100 Exercise (span)

0011 Exercise (ring)

0010 Reverse request (span)

0001 Reverse request (ring)

0000 No request

Bits 5to 8 Destination node ID
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Protection Switching Protocol

K2
Bits 1to 4
Bitb

Bits 6to 8
000
001
010
011
100
101
110
m

Condition
Source node ID

Path code: 0 = short path request, 1 = long path request

Idle

Bridged

Bridged and switched

Extra traffic (ET) on protection channels
Note used

Not used

RDI-L

AIS-L
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Synchronization Status Messages (S1 bits 5 to 8)

$1 (Bits5to8)  Quality level SONET synchronization quality level
description
0001 1 Stratum 1 traceable
0000 2 Synchronized-traceable
011 3 Stratum 2 traceable
1010 4 Stratum 3 traceable
1100 5 SONET minimum clock traceable
n/a 6 Stratum 4 traceable
1M1 7 Do not use for synchronization
0111 User-assignable Reserved for network synchronization use
User Guide 385
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STS Path Overhead (STS POH)

The STS Path overhead (STS POH) support the transmission of
SONET signals across the path of a network.

Byte

Label

Description

J1

B3

C2

G1

F2

H4

73,74
N1

Path Trace

Path Code
Violation
(CV-P)

Signal Label

Path Status

User
Channel

Position
Indicator

The first byte in the STS SPE. Its location is indicated by
the pointer (H1H2). Provides an STS path trail trace
identifier (64-byte free format string or 16 frame
including CRC7). Supports end-to-end monitoring of an
STS path.

Provides STS path error monitoring. The BIP-8 is
calculated over all bits of the previous STS SPE. The
computed value is placed in the B3 byte before
scrambling.

STS path signal label indicates the content of the STS
SPE, including the status of the mapped payloads. For
more information, see “C2 Byte Mapping" on page 387.

STS path status contains status and performance
monitoring information from the receiving path
terminating equipment to the originating equipment.
Allows status and performance of the complete duplex
path to be monitored at either end.For more information,
see “G1 (Bits 5 to 7) Coding and Interpretation” on

page 388. Bits 1 to 4 of this byte indicate the count of
interleaved-bit block errors, based on the B3 count, to
the upstream path terminating equipment.

STS path user channel. Allocated for network operator
communication between STS path terminating
equipment.

This byte provides multiframe phase indication for VT
structured payloads.

Allocated for future use.

Allocated for tandem connection maintenance and the
path data channels. Bits 1 to 4 are used to provide
tandem connection incoming error count (IEC). Bits 5 to
8 ar used to provide the path data channel. For more
information, refer to ANSI T1.105.05.
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C2 Byte Mapping
Bits1to4 Bitsbto8 Hex Code Description
0000 0000 00 Unequipped
0000 0001 01 Equipped - non-specific
0000 0010 02 VT-structured STS-1 SPE
0000 0011 03 Locked VT mode
0000 0100 04 Asynchronous mapping for DS3
0001 0010 12 Asynchronous mapping for DS4NA
0001 0011 13 ATM mapping
0001 0100 14 Mapping DQDB
0001 0101 15 Asynchronous mapping for FDDI
387
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G1 (Bits 5 to 7) Coding and Interpretation

Bits b to 7 Description Triggers
000 No remote defect No defect
001 No remote defect No defect
010 Remote payload defect LCD-P, PLM-P
011 No remote defect No defect
100 Remote defect (RDI-P, ERDI-P) AIS-P, LOP-P
101 Remote server defect (ERDI-P-S) AIS-P, LOP-P
110 Remote connectivity defect (ERDI-P-C) TIM-P, UNEQ-P
m Remote defect (ERDI-P-P) AIS-P, LOP-P
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VT Path Overhead (VT POH for VT-1.5, VT-2 or VT-6)

The VT Path Overhead (VT POH) support the transmission of
SONET signals across the tributary path of a network.

Byte Label Description

V5 CV-v, This byte contains error analysis, signal label and path
Signal  status information.
Labeland Bits 1 and 2 contain lower order path error analysis (BIP-2).
Path Bits b, 6 and 7 contain signal label. For more information,
Status  see “V5 (bits b to 7) Signal Label" on page 390.
Bit 3 contains the Remote Error Indication (REI-V).
Bit 4 contains the Remote Failure Indication (RFI-V).
Bit 8 contains the Remote Defect Indication (RDI-V).

Number of data bytes separating fields: VT-1.5 = 25, VT-2 =34 and VT-6 = 106

J2 VT Path  Supports the end-to-end monitoring of a path.
Trace
Identifier

Number of data bytes separating fields: VT-1.5 = 25, VT-2 =34 and VT-6 = 106
Z6 Reserved for future use.
Number of data bytes separating fields: VT-1.5 = 25, VT-2 =34 and VT-6 = 106

Z7 Bits b to 7 of Z7 provide enhanced RDI-V. Bits 5 to 7 of Z7
together with bit 8 of Vb provide codes to indicate both the
old version and enhanced version of RDI-V. For more
information, see “Z7 (bits 5 to 7) Coding and
Interpretation” on page 391.

Number of data bytes separating fields: VT-1.5 = 25, VT-2 =34 and VT-6 = 106
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V5 (bits 5 to 7) Signal Label

Bits 5to 7

Description

000
001
010
01
100
101
110
m

Unequipped
Equipped - non-specific

Asynchronous mapping

Bit synchronous mapping (no longer valid for DS1)

Byte synchronous mapping
Unassigned
Unassigned

Unassigned
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Z7 (bits 5 to 7) Coding and Interpretation
V5 bit 8 Interpretation Triggers
Z7 bits Z7 hit 6 Z7 hit7
0 0 0 No remote defect No defect
0 0 1 No remote defect No defect
0 1 0 Remote payload PLM-V
defect
0 1 1 No remote defect No defect
1 0 0 Remote defect AIS-V, LOP-V
1 0 1 Remote server defect  AlS-V, LOP-V
1 1 0 Remote connectivity  UNEQ-V
defect
1 1 1 Remote defect AIS-V, LOP-V
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Ethernet Concepts

For Ethernet reference information, see:
¢ Ethernet in Telecommunications Transmission Networks

¢ Theoretical Frame Rate
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Ethernet in Telecommunications Transmission Networks

User Guide

This paper provides useful background information that will
help you when using your instrument.

Introduction 394
Testing Ethernet Services 408
An Example 423

Summary 425
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Introduction

394

The object of this paper is to discuss the use and testing of
Ethernet services in telecommunications transmission
networks, with the emphasis on the installation through to
maintenance phases of network deployment and use. These
phases are generally taken to be:

¢ Installation

¢ Commissioning

¢ Acceptance testing

¢ Service turn-up/hand-over

¢ Network maintenance/troubleshooting

This paper introduces Ethernet in its various forms and
discusses its increasing use as a transport protocol in
telecommunications networks. It then discusses what testing
should be done, and how that testing can be carried out, in

order to ensure quality of service for the end user of an
Ethernet service.

This paper is intended for telecommunications engineers and
technicians involved in the deployment and use of Ethernet
services. It will be of particular interest to those who are
familiar with SONET/SDH services and who now find
themselves deploying the “new” Ethernet services.

It is assumed the reader has a good working knowledge of
SONET/SDH transmission systems.

For more details, see:

¢ The Need to Use Ethernet in Transmission 395
e Introduction to Ethernet 396

¢ Introduction to the OSI Seven Layer Model 401

¢ Transmission Methods 403
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The Need to Use Ethernet in Transmission

The need to transmit data on telecommunications networks is
not new. In fact the very first telecommunications systems
could only transmit “data”, in the form of Morse code. The
networks that have since been built around the world however
were designed to carry only one type of traffic - voice. The
telephony network is the biggest machine in the world, with
many millions of interconnections. Until recently this network
served its purpose well and it is only with the huge increase in
the need for data transport, driven mostly by the Internet, that
there has been any real need for change.

Until recently data traffic was carried on the
telecommunication network by making it “look” like voice
traffic, either by using a modem or, for higher bandwidth
connections, packaging the data in such a way that it would fit
into the standard 56/64 kb/s channel structure of the telecoms
network. However as the amount of data traffic in the network
continues to grow, other means have to be found of carrying the
new traffic that are more bandwidth efficient, less complex and
less costly.

There are several options for dealing with this increase in data
traffic and the various approaches all have advantages and
disadvantages. For example, one option is to build an entirely
new data-only network. The biggest disadvantage of this
approach, and most of the other options, is the large amount of
capital investment required. For this reason most network
operators are integrating data services into their existing
networks and they are doing this by utilizing the “next
generation” of SONET/SDH network elements.

These new network elements carry all of the traditional
T-carrier/PDH and SONET/SDH services but also allow the
transport of data services in their native format, Ethernet. This
reduces the complexity of the network for both the customer
and the operator leading to a lower overall cost and more
efficient use of bandwidth.

It is the use of these “next generation” elements that this paper
addresses.
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Introduction to Ethernet

Ethernet is an asynchronous, frame-based protocol originally
intended to provide a means of communication between more
than two data devices, using shared media. Ethernet, fully
defined by the IEEE 802.3(2000) standard, has changed and
evolved over time, increasing in speed and allowing the use of
full-duplex transmission, rather than shared media.

The current version of the standard allows for many variations
of speed and media type and these are described by the
following notation:

<data rate in Mb/s> <medium type> <Maximum segment
length(x100 m)>

For example, the standard contains a specification for a

10 Mb/s, baseband system with a maximum segment length of
500m. The notation for this would be 10BASE5. A media type
identifier often replaces the segment length, for example the T
identifier is used for systems running on unshielded twisted
pair cabling.

All of the variations of Ethernet share the same basic frame
structure, access/control method (MAC - Media Access Control)
and, for systems using shared media, the same collision
detection scheme (CSMA/CD - Carrier Sense Multiple Access /
Collision Detect). The most common Ethernet physical
interfaces in current use are:

* 10BASE-T - 10 Mb/s, baseband system, using category 3,4 or
5 twisted pair cabling

¢ 100BASE-TX - 100 Mb/s, baseband system, using category 5
twisted pair cabling

* 1000BASE-SX - 1000 Mb/s, baseband system, using 850 nm,
multi-mode optical fibre

¢ 1000BASE-LX - 1000 Mb/s, baseband system, using 1300 nm,
single-mode or multi-mode fibre

Discussions in this paper refer to these physical interfaces,
unless otherwise stated.
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Ethernet Frame Structure

The structure of an Ethernet frame is:

s £, = &
= zg‘gghh o~
= - = 7 = 5
@5--" =S “ =
" 2% A3 5 OB
7 1 6 & 4 2 4

The function of the various parts is as follows:
Preamble/Start of Frame Delimiter, 8 Bytes

Alternate ones and zeros for the preamble, 10101011 for the
SFD. This allows for receiver synchronization and marks the
start of frame.

Destination Address, 6 Bytes

The MAC destination address of the frame, usually written in
hex, is used to route frames between devices. Some MAC
addresses are reserved, or have special functions. For example
FF.FF:FF:FF:FF.FF is a broadcast address which would go to all
stations.

Sources Address, 6 Bytes

The MAC address of the sending station, usually written in hex.
The source address is usually built into a piece of equipment at
manufacture. The first three bytes would identify the
manufacturer and the second three bytes would be unique to
the equipment. However there are some devices, test equipment
for example, in which the address is changeable.
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VLAN Tag, 4 Bytes (optional)

The VLAN tag is optional. If present it provides a means of
separating data into “virtual” LANSs, irrespective of MAC
address. It also provides a “priority tag” which can be used to
implement quality of service functions.

Length/Type, 2 Bytes

This field is used to give either the length of the frame or the
type of data being carried in the data field. If the length/type
value is less than 0600 hex then the value represents the length
of the frame. If the value is greater that 1536 then it represents
the type of protocol in the data field, for example 0800 hex
would mean the frame was carrying IP. XXXX hex would mean
the frame was carrying AppleTalk.

Data, 46 to 1500 Bytes

The client data to be transported. This would normally include
some higher layer protocol, such as IP or AppleTalk.

Frame Check Sequence, 4 Bytes

The check sequence is calculated over the whole frame by the
transmitting device. The receiving device will re-calculate the
checksum and ensure it matches the one inserted by the
transmitter. Most types of Ethernet equipment will drop a frame
with an incorrect or missing FCS.

The minimum legal frame size, including the FCS but excluding
the preamble, is 64 bytes. Frames below the minimum size are
known as “runts” and would be discarded by most Ethernet
equipment.

The maximum standard frame size is 1522 bytes if VLAN
tagging is being used and 1518 bytes if VLAN is not being used.
It is possible to use frames larger than the maximum size. Such
frames are called “Jumbo Frames” and are supported by some
manufacturer's equipment in various sizes up to 64 Kbytes.
Jumbo frames are identical in form to standard frames but with
a bigger data field. This produces a better ratio of “overhead”
bytes to data bytes and hence more efficient transmission.
Jumbos are non-standard and manufacturer specific and
therefore inter operability cannot be guaranteed.
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The frames are transmitted from left to right, least significant
bit first. The frames are separated by an “inter-packet gap”. The
minimum length of the inter-packet gap is 12 bytes. The
inter-packet gap exists because in a half duplex system time is
needed for the medium to go quiet before the next frame starts
transmission. The inter-packet gap is not really needed for full
duplex operation but is still used for consistency.

Auto Negotiation and Flow Control

Most Ethernet devices support auto-negotiation. When two
devices are first connected together they will send information
to each other to “advertise” their capabilities. The devices will
then configure themselves to the highest common setting. The
capabilities negotiated are speed, full or half duplex operation
and the use of flow control. For gigabit Ethernet nearly all
systems are 1000 Mb/s and full duplex, leaving only flow control
to be negotiated. If one end of a link does not support
auto-negotiation the link will have to be manually configured.

Flow control is only used in full-duplex mode and is achieved by
sending PAUSE requests to the station at the other end of an
Ethernet link when a receiver is being overloaded with data.
Flow control can be either non-symmetrical, when only one
station can issue pause requests or symmetrical, where both
stations can issue PAUSE requests. The PAUSE request contains
a field that tells the far end station how long to stop
transmitting for in order to give the receiver an opportunity to
catch up. If flow control is not being used data will be lost under
overload conditions.

Transmission Schemes

Various line-coding schemes are used to transmit Ethernet
frames at the physical layer.

For 100 BASE-X (TX or FX) a 4b/5b encoding scheme is used,
giving a physical line rate of 125 Mb/s. Other coding schemes
are used to suit various media types.
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For gigabit Ethernet the most common transmission scheme is
the 8b/10b encoding scheme used for 1000BASE-X (CX, SX,
LX), giving a line rate of 1250 Mb/s. As well as coding data for
transmission the 8B/10B scheme has special code groups,
including a “line idle” and a “start of frame”. This means that at
the physical layer a gigabit Ethernet transmitter is always “on”
and the receiver is always synchronized, even during the
inter-packet gap. This, combined with full duplex operation,
makes both the inter-packet gap and the preamble redundant
for gigabit Ethernet. However both are still used to provide
consistency of operation to the upper layers.
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Introduction to the 0SI Seven Layer Model

The OSI seven layer model presents a means of describing the
functions of the various sections, or layers, of a data
communication system. Ethernet covers the bottom two layers
of this model, Layer 1, the physical medium (UTP, Co-ax, Fibre)
over which the data is transferred and Layer 2 (Data Link
Layer), the control mechanism for transmitting data onto the
medium and receiving data from the medium.

05l reference model IEEE 802.3 reference model

Application \ Upper protocol layers |
Presentation - MAC-client
Sessi o
ssion . MAC
Transpart o # memmmmssspessssee——.
i . T Reconcilliation ‘
Hetwork o Lo — Media-independent
Data Link e L
FCS
Physical !
. PIA :
S, Auto-megotiation” Madia-dependent
T sublayer
M Medium-dependent interface N [ R

Wil Media-independent interface
PCS: Physical coding sublayer
PMA: Physical medium attachiment
* Bath the Ml and Auto-negotiation are optional

. H
N
. Medium 't

Relationship between the 0S| Seven Layer Model and Ethernet

Layer 3 is the network layer and this function is most commonly
carried out by IP, but could also be AppleTalk, IPX or other such
protocols.

The purpose of Ethernet is to ensure data is transferred over a
link in a communications network, while the Layer 3 protocol
has the job of ensuring the data is transferred over the whole
network, from the original source to the ultimate destination.
This may use any number of separate Ethernet links. The
simplified network diagram below illustrates this.
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Layer3 Route =

Ether et Segment

I
L

Etheriet Segment

The higher layer protocols, Layers 4 and above, have the task of
ensuring the integrity of transmitted data and presenting the
data to the user or application. The function of these higher
layer protocols is of little interest in a transmission
environment. A detailed description of the function of all seven
layers of the model, and the advantages and disadvantages of
the various protocols used in each layer, can be found in any
good text on data networking.
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Transmission Methods

Current telecommunications networks are, of course, built
using SONET/SDH and DWDM technologies. Transmitting an
asynchronous, “self-routing”, frame-based protocol such as
Ethernet on a synchronous, fixed-routing, fixed-bandwidth
SONET/SDH network creates numerous potential problems. In
order to address these problems Network Equipment
Manufacturers have created numerous different methods of
getting the Ethernet frames onto the transmission network and
each of the methods has advantages and disadvantages. It is
essential to know how the Ethernet frames are being
transported when using or testing an Ethernet service as it
affects the way the service is used or tested. The different
methods of transmission can be loosely categorized as follows:

Layer 1 - Ethernet-on-Light Solutions

In these systems the Ethernet signal is simply transported, in
native format, on a DWDM wavelength. These systems are only
used with Gigabit Ethernet.

Advantages: Simplicity
Security
Disadvantages: Uses an entire wavelength

No grooming/muxing of traffic

No grooming/muxing of traffic

No value-added services can be applied

Reliability is dependent on the DWDM system protection
scheme

Since no Layer 2 switching is involved, these systems can be
expected to operate in a different manner to a “normal”
Ethernet device. For example, a Layer 1 system should
propagate errored frames rather than rejecting them.

GHE  ————» OFEO or Wavelength —— DWDM
InfOut 44— Transator - Line
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Layer 1/2- Ethernet-in-SONET/SDH (Unswitched)

In these systems the Ethernet frames are received by the
equipment, encapsulated in some way and then transported as
a SONET payload. The encapsulation can be done in a number
of ways; the most common methods are PPP over HDLC, GFP,
LAPS or a proprietary method. See “Encapsulation" on

page 406 for more details on encapsulation schemes.

These systems may incorporate some Layer 2 “intelligence”,
switching the Ethernet frames into the correct SONET channel
by using VLAN tags for example. Most of the current systems
however simply send all received frames to SONET line-side and
vice-versa.

The advantages and disadvantages of the unswitched method
are:

Advantages: Does not use an entire DWDM wavelength
Uses the SONET protection scheme

Disadvantages: Grooming/muxing/switching of traffic is not possible
Sharing of line-side bandwidth is not possible
Inefficient use of line-side bandwidth

Ethernet — ™
Input <

E
Ethemet »

Input <

»  SONETISDH

Line-Side
Ethemet —»
Input g ]
1 Mapper
Ethemnet — ™
Iput 4 | —
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Layer 2 - Ethernet-in-SONET/SDH (Switched)

In these systems a Layer 2 Ethernet (MAC) switch is built into
the network element tributary card. The SONET/SDH
channel(s) that the Ethernet traffic are to be carried over are
treated by the switch as an “extra” Ethernet port, or ports, with
the Ethernet frames being encapsulated into SONET/SDH by
using the same methods as the un-switched solution. An
Ethernet switch will learn the MAC addresses of all the devices
connected to it and then route frames to the correct port based
upon the destination MAC address.

This method therefore allows for the switching/grooming and
statistical multiplexing of the Ethernet traffic. This gives far
greater flexibility in allocating bandwidth on the line side of the
device. A single line-side channel can now be used to serve
several customers. This greatly enhances the bandwidth
efficiency when carrying a “bursty” Ethernet service that at
times may have no traffic on it. The downside to sharing of
line-side bandwidth is that when all of the customers are trying
to access the service at the same time bandwidth contention,
with a consequent loss of traffic, will occur.

Advantages: Does not use a wavelength
Uses SONET protection scheme
Allows for efficient use of line-side bandwidth
Traffic grooming and prioritisation is possible using VLAN or
priority tags (If NE supports this)

Disadvantages: Shared bandwidth may lead to contention
Shared bandwidth may have security concerns

Ethernet g

Input < 1
Ethernet —» E
Input 4 | 1 =
7] M — P SONET/SDH
D i — Line-Side
Ethemet — ™ E
Tnpmst > 1 5
=

Ethemet —»
Input g | —
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Layer 3 - IP Switch/Router

A few systems have a Layer 3 switch incorporated into a SONET
network element. These systems are an extension of the
switched Layer 2 solutions with the customer traffic being sent
to the correct port or SONET line-side channel based upon IP
address instead of MAC address. These systems have the same
advantages as the Layer 2 solutions. They also have the
additional benefit of negating the need for all the customers to
have a router in a multi-tenant building environment. On the
downside such devices can be difficult to provision and manage.

Encapsulation

There are various methods of encapsulating Ethernet frames
into a SONET/SDH bearer. Encapsulation is needed in order to
ensure that the Ethernet frames are packaged in the correct
format for transport. Encapsulation is used to mark the
beginning and end of the frames and to deal with the
interpacket gap between frames. The most common
encapsulation schemes are:

PPP over HDLC

Point-to-Point Protocol over High Level Data Link Control. This
is the encapsulation method used to carry IP datagrams in
Packet over SONET (PoS) systems. For Ethernet over
SONET/SDH systems PPP/HDLC is simply used to carry
Ethernet frames instead of IP datagrams.

LAPS (ITU-T, X86)

Link Access Protocol, SDH. This method of mapping has been
specifically designed to carry Ethernet frames over SDH or
SONET links. It is being adopted by the ITU-T as a standard,
number X86. It is very similar to HDLC in operation.

GFP

Generic Framing Protocol. As the name implies this method of
encapsulation can be used to carry most types of data service,
not just Ethernet.

User Guide

ﬁ%

rs



el @

@é son_Cobra.book Page 407 Wednesday, September 25,2002 11:09 AM

ﬁ%

User Guide

Telecoms Concepts 7

Proprietary

Many manufacturers use their own encapsulation schemes.
However most of these schemes are simply variations on one of
the methods described above.

Generally the manufacturer sets the type of encapsulation
scheme and little needs to be known about it during the
installation and maintenance phases of network deployment.
However the type of encapsulation scheme and how it is used
can have an effect on the data throughput rate and so it should
not be ignored. For example GFP can have two modes of
operation: framed or transparent. In transparent mode all the
data from an incoming signal, including the interpacket gap and
the preamble, will be transported. This means that line-side
bandwidth is being used to transport “overhead” data.
Conversely if GFP is operated in framed mode it will only
transport the actual frame and not the preamble or IPG. This
can obviously lead to bandwidth efficiencies.

Most of the equipment currently available uses a proprietary
encapsulation scheme, preventing inter operability between
vendors. However many vendors are moving towards LAPS or
GFP. This should mean that future network equipment is
inter-operable.
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Testing Ethernet Services

For more details, see:
e Service Quality 409

¢ Parameters to be Measured 410
e Test Methods 417
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Service Quality

There is a perceived difference in the quality allowed for an
Ethernet service compared to a SONET/SDH or T-Carrier/PDH
service. In general for SONET/SDH or T-carrier/PDH any errors
are considered significant and in some circumstances even a
single bit error can affect the quality of the end service.

Conversely, Ethernet has its origins in a shared medium
environment where collisions, and subsequent loss of data, are
normal. In addition the discarding of packets by routers under
“overload” conditions is a normal control mechanism. For this
reason one of the primary functions of the upper layer protocols
is to ensure the completeness and correctness of the data. Small
amounts of data loss are therefore inconsequential and the data
is simply re-transmitted, the re-transmit being initiated by the
Ethernet layer if due to collisions or the upper layer protocol if
due to frame loss. This leads to the belief that a lower quality of
service can be acceptable for an Ethernet service when
compared to a SONET/SDH service. While this is generally true
it is still very important to set limits for the amount of errors or
data loss allowed and to be able to measure these limits.

The reason that quality of service is important for Ethernet is
because as more data is lost the number of re-transmits
increases. This leads to more collisions/overloads and more
data loss, which in turn leads to more re-transmits and so on.
This situation will very quickly make a network unusable. It is
therefore necessary to keep the number of re-transmits to a
minimum. In a shared-medium environment this is done by
keeping the network utilization low and thus preventing
collisions. In a full duplex environment this is done by
minimizing the number of errored or lost frames and thus
preventing the upper layer protocol requesting re-sending of
data.

As with any other telecommunications service Ethernet
services need to be tested. Testing the service will ensure
quality of service for the end user and optimum network
utilization for the operator. The parameters to be tested and
how they are measured are discussed below.
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Parameters to be Measured

There are three fundamental measures of performance for
data/Ethernet networks. These are:

¢ Data Throughput
* Frame Loss
e Latency

¢ Other Measures

Data Throughput

Data throughput is simply the maximum amount of data,
usually measured in Mb/s, that can be transported from source
to destination. However the definition and measuring of
throughput is complicated by the need to define an acceptable
level of quality. For example, if 10% errored or lost frames were
deemed to be acceptable then the throughput would be
measured at 10% error rate. This document shall use the
generally accepted definition that throughput should be
measured with zero errors or lost frames.

In any given Ethernet system the absolute maximum
throughput will be equal to the data rate, e.g.10Mb/s 100Mb/s or
1000Mb/s. In practice these figures cannot be achieved because
of the effect of frame size. The smaller size frames have a lower
effective throughput than the larger sizes because of the
addition of the pre-amble and the inter-packet gap bytes, which
do not count as data. The maximum achievable throughput for
various frame sizes is given in the following tables.

On any system incorporating a Layer 2 switch throughput (and
Frame Loss) will be affected by the way the service is used, or
tested. This is because of over-subscription. For example, it is
common to map a number, say eight, of 10/100 Mb/s Ethernet
services into a 622 Mb/s SONET or SDH bearer. If we test, or
use, only six ports we would expect to see full bandwidth
available on all six ports. If we now re-test with all eight ports
fully loaded there will only be approximately 622/8 = 77 Mb/s
available on each port and this is what our throughput test
would reveal. In addition, if PAUSE flow control is not being
used between the network element and the customer
equipment/test set then the “extra” 23 Mb of data will be lost.
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Frame Size (bytes) Data Throughput Preamble and Frames Rate
(Mb/s) IPG (Mb/s) (Frames/s)

64 1.62 2.38 14880

128 8.65 1.35 8445

256 9.27 0.72 4528

512 9.62 0.38 2349

1024 9.81 0.19 1197

1280 9.84 0.15 961

1518 9.87 0.13 812

1522 (includes VLAN) 9.87 0.13 810

100 Mb/s System

Frame Size (bytes) Data Throughput Preamble and Frames Rate
(Mb/s) IPG (Mb/s) (Frames/s)

64 76.19 23.81 148809

128 86.49 13.51 84459

256 92.75 1.25 45289

512 96.24 3.76 23496

1024 98.08 1.92 11973

1280 98.46 1.54 9615

1518 98.69 1.30 8127

1522 (includes VLAN) 98.70 1.30 8106

1000 Mb/s System

Frame Size (bytes) Data Throughput Preamble and Frames Rate
(Mb/s) IPG (Mb/s) (Frames/s)

64 761.90 238.10 1488095

128 864.86 135.14 844594

256 927.54 72.46 452898

512 962.40 37.59 234962

1024 980.84 19.16 119731

1280 984.61 15.38 96153

1518 986.99 13.00 81274

1522 (includes VLAN) 987.02 12.97 81063
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Frame Loss

Frame loss is simply the number of frames that were
transmitted successfully from the source but were never
received at the destination. It is usually referred to as frame loss
rate and is expressed as a percentage of the total frames
transmitted. For example if 1000 frames were transmitted but
only 900 were received the frame loss rate would be:

(1000-900) / 1000 x 100% = 10%

Frames can be lost, or dropped, for a number of reasons
including errors, over-subscription and excessive delay.

Errors

Most Layer 2 devices will drop a frame with an incorrect FCS.
This means that a single bit error in transmission will result in
the entire frame being dropped. For this reason BER, the most
fundamental measure of a SONET/SDH service, has no meaning
in Ethernet since the ratio of good to errored bits cannot be
ascertained.

Oversubscription

The most common reason for frame loss is oversubscription of

the available bandwidth. For example, if two 1000Mb/s Ethernet
services are mapped into a single 622Mb/s SONET/SDH pipe (a
common scenario) then the bandwidth limit is quickly reached

as the two gigabit Ethernet services are loaded. When the limit

is reached, frames may be dropped.

Under these circumstances it might be necessary to know not
only how many frames are being dropped but which frames. For
example, some network elements claim to be able to prioritize
traffic based upon VLAN ID or priority tag. If this function is
being used then as the bandwidth limit is reached it should be
the low priority packets which get dropped. This functionality
needs to be tested.

Excessive Delay

The nature of Ethernet networks means that it is possible for
frames to be delayed for considerable periods of time. This is
important when testing as the tester is “waiting” for all of the
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transmitted frames to be received and counted. At some point
the tester has to decide that a transmitted frame will not be
received and count the frame as lost. The most common time
period used to make this decision is the RFC specification of
two seconds. Thus any frame received more then two seconds
after it is transmitted would be counted as lost.

Latency

Latency is the total time taken for a frame to travel from source
to destination. This total time is the sum of both the processing
delays in the network elements and the propagation delay along
the transmission medium.

In order to measure latency a test frame containing a time
stamp is transmitted through the network. The time stamp is
then checked when the frame is received. In order for this to
happen the test frame needs to return to the original test set by
means of a loopback (round-trip delay) or the test frame needs
to be read by a similar set at the other end of the network path.

If a single test set on loopback is to be used then the “out” and
“return” paths need to be symmetrical in order for the
measurement to be accurate. Whether this is the case depends
up on the capabilities of the network under test. If separate test
sets are used then some means of synchronizing the two sets to
a single time source will be required. The only practical means
of doing this is to synchronize the two test sets using GPS
receivers but this can be difficult to achieve in practice due to
the need for the GPS antenna to have a clear view of the
satellites. Which of the two techniques needs to be used to
measure latency will depend upon the capabilities and setup of
the device/network under test.

In a pure-data network operating at Layer 3 it will probably be
necessary to measure latency end-to-end in order to achieve an
accurate figure. There are several reasons for this. Firstly, the
processing delays in the network elements, routers, can be
considerable and will vary depending upon a number of factors
including load and the size of the routing tables. Secondly, if
more than one route is available to the router there is no
guarantee that packets will be sent by the same physical route
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“out” and “return”. Finally, if traffic management is being used
then the router will delay “ordinary” traffic, possibly including
the test frame, to allow high priority traffic such as
voice-over-IP through. These factors mean that the “out” and
“return” routes will almost certainly not have a symmetrical
delay and the end-to-end method must be used.

However, the networks being examined in this paper are not
pure-data networks but Ethernet over SONET/SDH
transmission networks. In addition, with a few exceptions,
these networks will operate at Layer 2 or below. This means the
loopback method for testing latency can usually be used.

In a transmission network operating at Layer 2 the processing
delays inside the network elements should be relatively small,
when compared to the propagation delays. For example the time
taken for a bit to propagate down one kilometre of fibre is
approximately 3.33 us (this, rather crudely, ignores the
refractive index of the fibre). For 1000 Mb/s Ethernet the bit
time is 1 ns. This gives the network element 3300 bit times to
carry out processing and switching before the processing delays
become greater than the propagation delays, even on very short
fibre runs.

Layer 2 switching is relatively simple compared to Layer 3 and
it should not be affected by factors such as loading. Therefore
the time taken to process frames should be roughly symmetrical
in both the “out” and “return” directions. In addition for an
Ethernet over SONET/SDH link the physical paths will be the
same in the “out” and “return” directions.

Since the propagation delays should be very large compared to
the processing delays, thus swamping any small variation that
does occur in the processing times, and the physical paths are
identical it is safe to assume that the “out” and “return” delays
will be symmetrical for an Ethernet over SONET/SDH system.
This means that the complications of end-to-end latency
measurements can be avoided and hence the simpler loopback
method can be used.
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Other Measures

As well as these fundamental measures there are many other
parameters that may need to be tested. These include:

¢ Counts of errored frames

¢ Counts of out of sequence frames,
* Counts of runt frames

¢ Counts of jumbo frames

¢ Counts of broadcast frames

¢ Counts of multicast frames

As with the fundamental parameters the methods used to
measure these parameters, and the results obtained, will
depend upon the capabilities and setup of the network under
test.

Errored Frames

These are Ethernet frames with an incorrect or missing FCS.
Devices operating at Layer 2 will simply reject errored frames
and testing such a device would show a dropped frame rather
than counting an errored frame. On some Layer 1 solutions
however it is possible to transmit and receive errored frames.

Out of Sequence Frames

At Layer 3 it is possible for some frames to be delayed to allow
the prioritisation of other traffic and out of sequence frames are
possible. At Layer 2 or below out of sequence frames should not
normally be encountered. However a frame that arrives after
the test set has made the decision that the frame is lost (see
“Frame Loss” section, above) will count as an out of sequence
frame, provided the test set is capable of dealing with such
events.

Runts

These are frames below the minimum frame size of 64 bytes. As
with errored frames, most devices will reject runts and a lost
frame will be counted instead. Some devices will however allow
the transmission of runts so they may need to be counted.
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Jumbo Frames

These are frames above the maximum size of 1518/1522 bytes.
They may or may not be allowed in the network depending upon
configuration. If they are not allowed by the switches then they
would be dropped and a lost frame would result when testing.

Broadcast/Multicast Frames

Broadcast and Multicast frames can use up a lot of network
bandwidth and for this reason some operators will restrict their
use. For example broadcasts could be restricted to 5% of overall
bandwidth. If this is being done then it will be required to count
broadcast frames.

The tests highlighted above are the most common but not all
possible requirements are covered. For example, it may also be
necessary to be able to test the response of the device or
network under test to different MAC addresses, or its ability to
handle VLAN tagging. The need for these “other” tests will
depend upon many factors including the functionality of the
device/network under test, the nature of the service being
tested, the expectations of the end-user and the availability of
test equipment. These factors should be borne in mind when
designing test scenarios.
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When testing any telecommunications service it is necessary to
transmit test traffic into the network and then receive the test
traffic either back on the original test set or on a similar device
at the “other end” of the service being tested. In this way the
test set can measure what effect travelling through the network
has had on the test traffic.

In a SONET/SDH network the most usual method of achieving
this is to apply a transmitter to receiver loopback at the far end
and test the service around this loop. For multi-port services,
tributaries can be “daisy-chained” to speed testing as long as
jitter build up is taken into account.

With most types of network element this test methodology will
not work for Ethernet services and other methods must be used.
Which test methods will work and which will not depends upon
the method being used to transport the Ethernet frames across
the SONET/SDH network and the set-up of the network
element(s).

Ethernet frames are routed based upon their MAC address.
Ethernet switches, such as those built into some network
elements, need to “learn” what MAC address is connected to a
port before they will send any traffic to that port. If the
transmitter is looped to the receiver the switch will never see a
frame being received to learn the MAC address and so will not
transmit any frames to the port. This also applies to a
port-to-port loopback although it is sometimes possible to
overcome this problem by correct use of VLAN tags. This means
that Ethernet tributary cards, unlike their SONET/SDH
equivalents, cannot be “daisy-chained” to reduce test time. A
multi-port test set is therefore required if test time is to be kept
to a minimum.

The methods outlined below are general examples but their use
will depend on the circumstances.
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End-to-End Method

In this method testing is carried out between two separate test
sets, one at each end of an Ethernet circuit. The destination
address of the near end tester is the corresponding port on the
far end tester and vice-versa. This method can be used
irrespective of the functionality of the network under test.
However if latency testing is to be carried out some means of
synchronizing the clocks in the test sets will be required. An
external GPS receiver is often used for this.

Set 1 Set 2
Near End Device Under Test Far End
MAC Address (oum MAC Address

00-30-D3-03-DD-2A 1 g1 1 1 =11 00-30-D3-03-DD-28
00-30-D3-03-DD-2C 2 [ 2 2 =]z 00-30-D3-03-DD-2D
00-30-D3-03-DD-2E 3 > 3 3 ®13  00-30-D3-03-DD-2F
00-30-D3-03-DD-30 4 [ 4 4 =14 00-30-D3-03-DD-31
00-30-D3-03-DD-32 5 =] 5 5 =15 00-30-D3-03-DD-33
00-30-D3-03-DD-34 ¢ ] # 6 =& 00-30-D3-03-DD-35
00-30-D303-DD-36 7 g2y 7 ;’?;’g;} 7 =47 00-30-D3-03-DD-37
00.30D303DD38 8 == 8 PiPe | g k=18 00-30.03.03-0D38
00-30-D3-03-DD-3A 9 === ¢ 8 f=—*19 00-30-03-03-0D-38
00-30-D3-03-DD-3C 10 =2 10 10 f=*410 00-30-D3-03-DD-3D

End-to-End Method (ten ports shown)

Loopback

In this method testing is carried out from a single test set. Two
possible types of loopback can be used. The use of the different
loopback methods depends upon the functionality of the device
under test. The loopback types are:

* Single Port Loopback
¢ Port-to-Port Loopback
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Single Port Loopback

In a single port loopback the tester is connected to the near end
port(s) of the device under test and a Tx-Rx loop is applied to
the far end. This method only works with network equipment
that operates at Layerl, such as some Ethernet-on-light
solutions. It will not normally work with a Layer 2 Ethernet
device, as the port at the far end will be unable to route the test
frames. This method requires the source and destination MAC
addresses to be the same and so will not be supported by all
types of test set.

Set 1
Near End Device Under Test
MAC Address (bum)

00-30-D3-03-DD-2A 1 =] 1 1 PR
00-30-D3-03-DD-2C 2 =] 2 2 R
00-30-D3-03DD2E 3 =2 3 3 R
00-30-D3-03-DD-30 4 == 4 4 R
00-30-D3-03-DD-32 5 fag] 5 5 R
00-30-D3-03-DD-34 ¢ =] ¢ s
00-30-D3-03-DD-36 7 =] 7 ;?g;;} TR
00-30D3-03-DD-38 & [g=>] 8 Pre | 5 |
00-30-D3-03-DD-3A 9 == 9 s R
00-30-D3-03-DD-3C 10 =2 10 10 2

Single Port Loopback

Port-to-Port Loopback

In a port-to-port loopback the tester is connected to two (or
more) near end ports and the loopback is applied from port to
port at the far end. This method only works on network
equipment that operates at Layer 1. It can be made to work with
some Layer 2 equipment by using VLAN tagging, as follows.

Port 1 on the “Set 1" end switch is provisioned to transmit to
port 1 on the “Set 2" end switch. Port(s) 2 are connected in the
same way. Both Ethernet switches then have port 1 set to
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belong to VLAN 1 and port 2 set to belong to VLAN 2. Port 1 is
physically looped to port 2. Test frames tagged as VLAN 2 are
then transmitted into port 1 (and vice versa). The receiving
switch will ignore the MAC address and because the frame does
not belong on VLANI1 it will route the frame out of the far end
port 1, where it will be received on port 2. Since the far end port
2 is on VLAN 2 the switch will broadcast the frame to that port
and hence the frame will arrive back at the test set. This process

is repeated on all ports to be tested.

As can be seen this method, if it can be made to work, requires a
lot of provisioning. This includes the provisioning of some paths
which may already be in use for customer traffic, in which case

this method cannot be used.

Set 1

Mear End

Device Under Test

MAC Address
00-30-D3-03-DD-2A

00-30-D3-03-DD-2C
00-30-D3-03-DD-2E
00-30-D3-03-DD-30
00-30-D3-03-DD-32
00-30-D3-03-DD-34
00-30-D3-03-DD-36
00-30-D3-03-DD-38

00-30-D3-03-DD-3A

00-30-D3-03-DD-3C

10

{DUT)

Y

i\

@w @ =~ & e+ B W N =

-
=

SONET
(or SDH)
pipe

10

\CRCRCRE TR

Port-to-Port Loopback
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Loopthru

Loopthru is a phrase coined by Agilent Technologies to describe
the functionality available on some of its Ethernet test
equipment. This functionality will not be available on all test
sets. The method works as follows:

This method uses two testers, one at each end of the Ethernet
circuit. However the far end tester does not actively test the
circuit. The far end instrument simply acts as a “loopthru”. It
will receive the test frames and strip the source and destination
MAC addresses. It then re-inserts the source address as the
destination address and vice-versa before re-transmitting the
frames.

Using this method it is possible for all tests to be carried out,
including latency, on a single circuit, without the provisioning
of extra paths through the network or the use of VLAN tags.

Set1 Set 2

Near End . Far End

ear En Device Under Test aren

MAC Address (buT) MAC Address
00-30-D3-03-DD-2A 1 fg==4 1 1 =121 00-30-D3-03-DD-2B
00-30-D3-03-DD-2C 2 [ 2 2 |—=J= 2 00-30-D3-03-DD-2D
00-30-D3-03-DD-2E 3 2] 3 3 =423 00-30-D3-03-DD-2F
00-30-D3-03-DD-30 4 [ 4 4 =124 00-30-D3-03-DD-31
00-30-D3-03-DD-32 5 =2 5 5 [=—=J=5 00-30-D3-03-DD-33
00-30-D3-03-DD-34 ¢ ] & 6 =16 00-30-D3-03-DD-35
- SONET

00-30-D3-03-00-36 7 F== 7 | (o spmy | 7 »7 00-30-D3-03-DD-37

A
| 4

00-30-D3-03-DD-38 & == B Pipe | 5 kg5 8 00.30-03-03-DD-38

00-30-D3-03-DD-34 9 =2 ¢ 8 |=—"={>9 00-3003-03.DD-38

00-30-D3-03-DD-3C 10— 10 10 #4210 00-30-D3-03-DD-3D
Loopthru
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Test Method Summary

The advantages and disadvantages of the different test methods
are summarized in the table:

Method Advantages Disadvantages
End-to-End » Can be used on a single circuit * Requires two units
» Can be used to isolate * Requires two operators
unidirectional faults » Latency measurement
is not possible
Loopback » Can be used on a single circuit = Only works on some
(Single Port)  + Only requires one instrument types of network
and one operator equipment
Loopback * Only requires one instrument ~ * Requires the
(Dual Port) and one operator provisioning of a
second circuit and/or
the use of VLAN tags
*  Only works on some
types of network
equipment
Loopthru » Can be used on a single circuit = Requires the use of two

» All measurements available

+ Only requires one operator
once set-up

» Works on all types of network
equipment

instruments
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The results below were obtained while testing an Ethernet
service on a multi-service platform. The platform in question is
of the Layer 2 variety with multiple Ethernet “input” ports, a
Layer 2 switch and a line-side “output” port. The line-side ports
are connected together across the network by the provisioning
of an SDH pipe of various sizes. The pipe size used in the results
below was a C-12 (2.176 Mb/s). The tests were run on a single
port using the end-to-end test method.

Frames Sent

1

Rate Frame Size
(Mb/s)

128 256 512 1024 1500
1.024 120000 60000 30000 15000 7500 5100
1.4 164040 82020 40980 20460 10200 6960
1.536 180000 90000 45000 22500 11220 7680
1.7 199200 99600 49800 24900 12420 8460
2 234360 117180 58560 29280 14640 9960
2.048 240000 120000 60000 30000 15000 10200
25 292920 146460 73200 36600 18300 12480
5 585900 292920 146460 73200 36600 24960
10 1171860 585900 292920 146460 73200 49980
Frames Received
Rate Frame Size
(Mb/s)

128 256 512 1024 1500
1.024 120000 60000 30000 15000 7500 5100
1.4 164040 82020 40980 20460 10200 6960
1.5636 169919 90000 45000 22500 11220 7680
1.7 169990 99600 49800 24900 12420 8460
2 170083 102092 56718 29280 14640 9960
2.048 170095 102098 56761 30000 15000 10200
25 169410 101934 56718 30092 15549 10749
5 169443 101676 56679 30074 15549 11189
10 169435 101698 56537 30050 15541 10748
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Frames Lost

Rate Frame Size
(Mb/s)

128 256 512 1024 1500
1.024 0.00% 0.00% 0.00% 0.00% 0.00% 0.00%
1.4 0.00% 0.00% 0.00% 0.00% 0.00% 0.00%
1.536 5.60% 0.00% 0.00% 0.00% 0.00% 0.00%
1.7 14.66% 0.00% 0.00% 0.00% 0.00% 0.00%
2 27.43% 12.88% 3.15% 0.00% 0.00% 0.00%
2.048 29.13% 14.92% 5.40% 0.00% 0.00% 0.00%
25 42.17% 30.40% 22.52% 17.78% 15.03% 13.87%
5 71.08% 65.29% 61.30% 58.92% 57.52% 55.17%
10 85.54% 82.64% 80.70% 79.48% 78.77% 78.50%

Round Trip Delay (ms)

Rate Frame Size
(Mb/s)

128 256 512 1024 1500
1.024 20 10 10 1" 20 20
14 40 20 21 20 40 21
1.536 60 20 20 30 21 20
1.7 51 31 21 20 30 21
2 60 80 121 30 31 21
2.048 60 80 121 40 40 21
25 60 80 130 230 401 561
5 60 80 131 220 401 571
10 61 90 131 220 401 571

These results are very interesting. At the larger frame sizes, no
frame loss is encountered until we reach the bandwidth limit of
the SDH bearer. At the smaller frame sizes, we see substantial
frame loss before we reach the bandwidth limit. This is most
likely due to the frame processing software in the network
element being unable to keep up with the large number of
frames present at small sizes.

The latency/round trip delay results are also very interesting.
These show a distinct step, particularly at larger frame sizes,
when the bandwidth limit is reached. It is not possible to
speculate on the reason for this without more information on
how the network element is operating.
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Ethernet has become a transport protocol in telecommunication
networks. The use of native Ethernet interfaces on
telecommunications transmission equipment can bring cost
savings to the end customer and revenue to the network
operator. It can also offer simplicity and ease-of-use.

In order to deploy the technology and realize these benefits, an
understanding of how the technology works and how to test it is
required. Ethernet differs from the “traditional” SONET/SDH
and DSn/PDH services and these differences have to be taken
into consideration. If this is done then the “next generation” of
data-ready network elements can help network operators meet
their customers needs and maximize revenue from their
networks.
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Theoretical Frame Rate

426

The instantaneous frame rate in Ethernet is entirely dependent
on any current frames to be transported. If there is no data to
transfer, the frame rate goes to 0.

Frames can be any size, from 64 to 1518 bytes in length
(excluding Jumbo Frames). For every frame to be transmitted
there is a fixed preamble (fixed at 8 bytes) and interpacket gap
(the equivalent of 12 bytes). Frames may also contain 4
additional VLAN bytes.

For any particular size of frames, you send a preamble, the
frame, and then the interpacket gap, and then a preamble, and
then a frame and an interpacket gap, and so on as shown:

Interpacket Preamble, Frame Interpacket Preamblel
Gap Gap
8 bytes 64 to 1518/1522 bytes 12 bytes

Theoretical frame rate is calculated from:
Frame Rate = 1 / Frame Period
where, Frame Period = Total Frame Size / Port Rate;

Total Frame Size includes preamble, frame, VLAN and
interpacket gap and is expressed in bit times.

User Guide
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Minimum and Maximum Frame Sizes

Frame Size Minimum Period per Frame Sent
Minimum - 64 bytes 8 * (8 + 64 + 12) bit times™ =672 bit times”™
Maximum - 1518 bytes 8 (8 + 1518 +12) bhit times® =12304 bit times™

(non-jumbo, non-VLAN)

Maximum - 1522 bytes 8 (8 + 1522 + 12) bit times® = 12336 bit times™
(non-jumbo, VLAN)

* Bit time is dependent on the port rate.

* For 10BASE-T, the bit time is 1/10 Mb/s =100 ns

* For 100BASE-T, the bit time is 1/100 Mb/s =10 ns
* For 1000BASE-X, the bit time is 1/1000 Mb/s =1 ns

Using this yields the following table of frame rates and frame
sizes for each port rate:

Frame Rate v Frame Size

Frame Rate (frames/second)

Frame Size Port Rate

(bytes) 10 Mb/s 100 Mb/s 1000 Mb/s
64 14880 148809 1488095
128 8445 84459 844594
256 4528 45289 452898
512 2349 23496 234962
1024 197 11973 119731
1280 961 9615 96153
1518 812 8127 81274
1522 810 8106 81063

(includes VLAN)
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Introducing ITU Performance Analysis

You can use the G- or M-series ITU recommendations to analyze
results.

* G-series focuses on telecommunications design, checking of
performance limits, expected behaviors and design
structures (whether it’s the structure of the SDH/SONET
itself or its expected behaviors and conformances).

* M-series focuses on installation and maintenance of the
network. It includes “Bringing Into Service” (BIS) procedures
and test limits or fault detection and localization procedures.

Both ITU recommendations do the following:

1 They interpret the basic error and alarm information, and
categorize them into anomalies and defects as defined by
each recommendation.

The instrument processes the anomalies and defects into a
series of Performance Event results for each in-context
digital path.

2 They interpret the Performance Event results.

You assign an Allocation value to the distance, media and
network elements of the path being tested. These values are
added together to provide a working figure known as the
Path Allocation (PA). The PA is then compared with tables in
the ITU recommendations to provide Performance Objective
(PO) figures.

You can further adjust the PO based on your own experience,
and so the PO can have a proprietary element to it. At the
end of a test period, the instrument’s Performance Event
results can be compared with your own PO figures to
produce a pass or fail result. For M.2110 and M.2120, the
instrument automatically displays the pass or fail result.

For more information, see:

e “ITU G.821 (08/96)" on page 429

+ “ITU G.826 (02/99)/G.828 (02/00)" on page 430

428 User Guide
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e “ITU M.2101 (06/00)/M.2101.1(04/97)" on page 432
e “ITU M.2100" on page 433
e “ITU M.2110" on page 434
e “ITU M.2120" on page 436

ITU G.821 (08/96)

Provides a standard for evaluating Out-Of-Service long term
(e.g. 30-day) error performance objectives of international
digital connections operating below the primary rate and
forming part of an ISDN network. This includes voice traffic as
well.

This instrument will cover structured bit rates at N x 56 or
64 kb/s, where N is between 1 and 32 or 24. The ITU
recommendation focuses on BER test results and associated
alarm conditions.

Test Method
The Path Under Test can be unidirectional or bi-directional.

For a bi-directional (go and return) path, the instrument can
transmit and receive the same test signal.

For a unidirectional path, a measurable test signal must be
generated at the far-end by suitable test equipment (two-box
testing).

In both cases, the Path Under Test is always Out-Of-Service
(0O0S) and a measurable test pattern is transmitted and
received. Prior to full testing, a simple one hour BER test is
recommended. The full test itself should be run for one month
(30-days). At the end of the time, a comparison of the results
should be made with the calculated Performance Objective for
the Path Under Test.

Performance Events

Errored Seconds (ES): A one second period in which one or
more bits are in error.

429

ﬁ%

.



A

@é son_Cobra.book Page 430 Wednesday, September 25, 2002 11:09 AM

1

430

Telecoms Concepts

Severely Errored Seconds (SES): A one second period during
available time which has a BER >1E-3.

Unavailable Seconds (UAS): Unavailable time starts at the
onset of 10 consecutive SES and ends at the onset of 10
consecutive non-SES.

Performance Parameters

Error Second Ratio (ESR): The ratio of ES to total seconds in
available time.

Severely Errored Second Ratio (SESR): The ratio of SES to
total seconds in available time.

Error Performance During Unavailable Time

ES and SES are not usually accumulated during unavailable
time. However, you will be allowed to do this in accordance with
Annex A.4/G.826(02/99) and Annex A.4/G.828(02/00). In this
case the Error Performance Parameters ESR and SESR remain
unaffected.

ITU G.826 (02/99)/G.828 (02/00)

Provide standards for long term (~30-day) error performance
objectives for constant bit rate international digital paths at or
above the primary rate.

G.826 focuses on SDH/SONET and PDH/DSn paths.

G.828 focuses on SDH/SONET paths and is the more modern of
the two and is recommended for new designs. Both ITU
recommendations focus on block based error counts based on
Error Detection Codes and associated alarm conditions.

Test Method

The Digital Path Under Test can be either unidirectional or
bi-directional.

For a bi-directional (go and return) path, the instrument can
transmit and receive the same signal.
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For the unidirectional path, the instrument only needs to
receive the incoming signal.

In both cases, the Path Under Test can either be In-Service or
Out-Of-Service (0O0S), although the OOS parameters are not
used. This is because the ITU recommendation only requires the
monitoring of In-Service parameters. Prior to full testing, a
simple one hour test is recommended. The full test itself should
be run for one month (30-days). At the end of the test period,
comparison of the results should be made with the calculated
Performance Objective for the Path Under Test.

Performance Events

Errored Blocks (EB): A block in which one or more bits are in
error.

Errored Seconds (ES): A one second period with one or more
errored blocks (anomaly), or at least one defect.

Severely Errored Seconds (SES): A one second period during
available time which contains >30% errored blocks, or at least
one defect.

Background Block Errors (BBE): An errored block (BIP or
REI) not occurring as part of a SES.

Unavailable Seconds (UAS): Unavailable time starts at the
onset of 10 consecutive SES and ends at the onset of 10
consecutive non-SES

Path Unavailable Seconds (PUAS): A bi-directional path
includes both the transmit and receive direction. This path
becomes unavailable when either the near end (receive) or far
end (transmit) results become unavailable.

Severely Errored Period (SEP) - G.828 only: A sequence of
between 3 to 9 consecutive SESs.

Performance Parameters

Error Second Ratio (ESR): The ratio of ES to total seconds in
available time.

431
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Severely Errored Second Ratio (SESR): The ratio of SES to
total seconds in available time.

Background Block Error Ratio (BBER): The ratio of BBE to
total blocks in available time. The count of blocks excludes all
blocks during SESs.

Severely Errored Period Intensity (SEPI) - G.828 only: The
ratio of SEPs to total seconds in available time.

Error Performance During Unavailable Time

ES, SES and BBE are not usually accumulated during
unavailable time. However, you will be allowed to do this in
accordance with Annex A.4/G.826(02/99) and Annex
A.4/G.828(02/00). In this case the Error Performance
Parameters ESR, SESR, BBER and SEPI remain unaffected.

ITU M.2101 (06/00)/M.2101.1(04/97)

Provide standards and limits for the “bringing into service” and
maintenance of international SDH/SONET paths and multiplex
sections.

For SDH/SONET paths designed to G.826, maintenance must be
performed using M.2101.1. For SDH/SONET paths designed to
G.828, maintenance must be performed using M.2101. Both ITU
recommendations focus on block based error counts based on
Error Detection Codes and associated alarm conditions.

Test Method

The same as M.2110 for Bringing into Service (BIS) and M.2120
for Maintenance.

Performance Events

Errored Seconds (ES): A one second period with one or more
errored blocks (anomaly), or at least one defect.

Severely Errored Seconds (SES): A one second period during
available time which contains >30% errored blocks, or at least
one defect.
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Background Block Errors (BBE) - M.2101 only: An errored
block (BIP or REI) not occurring as part of a SES.

Unavailable Seconds (UAS): Unavailable time starts at the
onset of 10 consecutive SES and ends at the onset of 10
consecutive non-SES

Path Unavailable Seconds (PUAS): A bi-directional path
includes both the transmit and receive direction. This path
becomes unavailable when either the near end (receive) or far
end (transmit) results become unavailable.

Error Performance During Unavailable Time

ES, SES and BBE are not usually accumulated during
unavailable time. However, you will be allowed to do this in
accordance with Annex A.4/G.826(02/99) and Annex
A.4/G.828(02/00).

Provides limits for the “bringing into service” and maintenance
of international PDH/DSn paths, sections and transmission
systems.

For paths designed to G.821 (sub-primary level) and G.826
(primary level and above), maintenance must be performed
using M.2100. The ITU recommendation focuses on block based
error counts based on Error Detection Codes and associated
alarm conditions.

Test Method

The same as M.2110 for Bringing into Service (BIS) and M.2120
for Maintenance.

Performance Parameters

Errored Seconds (ES): A one second period with one or more
errored blocks (anomaly), or at least one defect.

Severely Errored Seconds (SES): A one second period during
available time which contains >30% errored blocks, or at least
one defect.

433
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ITU M.2110

Unavailable Seconds (UAS): Unavailable time starts at the
onset of 10 consecutive SES and ends at the onset of 10
consecutive non-SES

Path Unavailable Seconds (PUAS): A bi-directional path
includes both the transmit and receive direction. This path
becomes unavailable when either the near end (receive) or far
end (transmit) results become unavailable.

Error Performance During Unavailable Time

ES and SES are not usually accumulated during unavailable
time. However, you will be allowed to do this in accordance with
Annex A.4/G.826(02/99).

Provides a generic method for “bringing into service” PDH/DSn
paths, sections and transmission systems and SDH/SONET
paths and multiplex systems.

e M.2110 defines threshold testing methods.

e M.2100, M.2101 or M.2101.1 defines the derivation and type
of thresholds.

Test Method

The Path Under Test can be either unidirectional or
bi-directional.

For a bi-directional (go and return) path, the instrument can
transmit and receive the same signal.

For the unidirectional path, the instrument only needs to
receive the incoming signal.

In both cases, the Path Under Test can either be In-Service or
Out-Of-Service (00S). The OOS parameters are not used as the
ITU recommendations are for In-Service parameters only.

When you select the digital Path Under Test, an instrument Test
Period must be selected which is at least as long as the BIS Test
Period in the following table. The test period is dependent on
the Usage intended. For the 24 hour test, at least a 7-day test
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period is selected. This is because if a 24 hour test exhibits
marginal performance then its is permitted to proceed
contiguously to the 7-day test.

You then calculate the Performance Objective (PO) for the Path
Under Test. This is entered into the instrument as a percentage
figure in the range 0.5% - 63%. The instrument then calculates
the thresholds S1 and S2, and also the Bring into Service
Objective (BISO) for 7-day testing. (These can also be
programmed by you in the light of your experience).

The test is then run. Threshold test results can then be read
direct from the display.

Bring Into Service (BIS) Test Periods

M.2110 will run concurrent threshold tests for the following BIS
test times. The BIS test times, usage, threshold and results are
shown in the table below. If the Error Performance Event (ES,
SES, BBE or SEP) exceeds the FAIL threshold then the
instrument will report this early, otherwise the instrument will
report either -?- or PASS as the BIS Test Period elapses.

BIS Thresholds Used in Threshold

Tests
BIS Test Time
and Usage BBE  SEp DI Result
ES SES (M.2101 (M.2101
only) only)
15 min. §1,82 §1,S2  S1,82 S1,82  PASS, ?, FAIL
Multiple tributary
testing on
existing paths
1 hour S1,82 §1,S2  §1,82 S1,S2  PASS, ?, FAIL
Tributary testing
on new paths
1 hour §1,82 §1,82  S1,82 S1,82  PASS, ?, FAIL
Tributary testing
on new paths
435
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ITU M.2120

BIS Thresholds Used in Threshold

Tests
BIS Test Time
and Usage BBE SEP BIS Result
ES SES (M.2101 (M.2101
only) only)

24 hour S1,82 §1,82  §1,82 S1,S2  PASS, ?, FAIL
Tributary testing
of the first
tributary in a path
7 day BISO BISO BISO BISO PASS, FAIL
For paths
exhibiting
marginal
performance

Provides methods for detecting and locating faults for PDH/DSn
paths, sections and transmission systems and SDH/SONET
paths and multiplex systems.

¢ M.2120 defines threshold testing methods.

e M.2100, M.2101, or M.2101.1 defines the derivation and type
of thresholds. Note, only M.2100/M.2101 are applicable for
this instrument.

Test Method

The Path Under Test can be either unidirectional or
bi-directional.

For the bi-directional (go and return) path, the instrument can
transmit and receive the same signal.

For the unidirectional path, it only needs to receive the
incoming signal.

In both cases, the Path Under Test can either be In Service or
Out-Of-Service (0O0S).
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You select the digital Path Under Test. The instrument Test
Period is set to MANUAL. There is no time limit on this test as it
is intended for long term (rack mount?) performance
monitoring.

You calculate the Performance Objective (PO) for the Path
Under Test from which you determine the thresholds T1 and T2
which can also be programmed by you in the light of your
experience.

You can connect the instrument into a Performance Monitoring
network via it’s remote access capabilities or it can operate and
gather results as a stand alone.

Threshold Reports

A threshold report (TR) is an unsolicited error performance
report with respect to either a 15-minute or a 24-hour
evaluation period. TR’s can only occur when the concerned
direction is in the available state. All TR’s are delayed within
the instrument by 10s, as stated in 5.3.5.4/M.2120. Threshold
reports are offered for each of the RX and TX directions (where
present) and they are timestamped into the MRS along with the
availability state.

Evaluation of TR1: The Performance Events provided by
M.2100 or M.2101 are counted, second by second, over
consecutive 15-minute rectangular fixed windows. A threshold
can be crossed at any second within each window at which time
a “Threshold Report” TR1-ES, TR1-SES or TR1-BBE is recorded
and timestamped into the instrument’s MRS. Thus, a maximum
of only one of each TR1-xx event can be recorded in a 15-minute
period.

The T1 evaluation period (15-minutes) assists in the detection
of degraded performance.

N.B. This instrument only operates the Transient Condition
Method (M.2120) which does not concern itself with Reset
Thresholds (RTR1).

Evaluation of TR2: The events are further counted, second by
second, over consecutive 24-hour rectangular fixed windows. A
threshold can be crossed at any second within each window at
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which time a “Threshold Report” TR2-ES, TR2-SES or TR2-BBE
is recorded and timestamped into the instrument’s MRS. Thus,
a maximum of only one of each TR2-xx event can be recorded in
a 24-hour period.

The T2 evaluation period (24-hour) assists in the detection of
degraded performance.

Note that only the Transient Condition Method (M.2120) applies
for TR2s.
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Rate (Mb/s) Optical Carrier SONET SDH
51.84 0C-1 STS-1 STM-0
155.52 0C-3 STS-3 STM-1
466.56 0C-9 STS-9 STM-3
622.08 0C-12 STS-12 STM-4
933.12 0C-18 STS-18 STM-6
1244.16 0C-24 STS-24 STM-8
1866.24 0C-36 STS-36 STM-12
2488.32 0C-48 STS-48 STM-16
2 666.06 0TU-1
4 976.64 0C-96 STS-96 STM-32
9953.28 0C-192 STS-192 STM-64
10709.23 0TU-2
39813.12 0C-768 STS-768 STM-256
43018.41 0TU-3
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Summary of Errors and Alarms

The following tables show the instrument errors and alarms,
what their acronyms mean and how each alarm is implemented
in the instrument. Note that not all errors and alarms listed may
be available on your instrument.

¢ “Alarm Definition Table" on page 440
¢ “Error Definition Table" on page 441

Alarm Definition Table

Acronym Alarm
AIS Alarm Indication Signal
BDI Backwards Defect Indication
IAE Incoming Alignment Error
INCAIS Incoming AlS
LCK Locked Indication
LOF Loss of Frame
LOM/LOMF Loss of Multiframe
LOP Loss of Pointer
LOS Loss of Signal
0Cl Open Connection Indication
0DI Outgoing Defect Indication
00F Out of Frame
ooM Out of Multiframe
PDI-P Payload Defect Indicator
RAI Remote Alarm Indication
RDI Remote Defect Indication
RFI Remote Failure Indication
SEF Severely Errored Frame

440 User Guide
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Acronym Alarm

TIM Trace Identifier Mismatch
UNEQ Unequipped

Error Definition Table

Acronym Error

BEI Backwards Error Indication
BIP Bit Interleaved Parity

IEC Incoming Error Count

OEl Outgoing Error Indication
REI Remote Error Indication

RDI-P/HP-RDI is only available when the enhanced RDI
preference is OFF. To check this, Press <Menu>, choose System
> Preferences then press <Select>. The Enhanced RDI
checkbox should be unchecked.

RDI-P-P/HP-RDI- P, RDI-P-S/HP-RDI-S; RDI-P-C/HPDI-C alarms
are only available when the enhanced RDI preference is ON. To
check this, Press <Menu>, choose System > Preferences then

press <Select>. The Enhanced RDI checkbox should be

checked.
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Service Disruption

442

Service disruption is the time it takes for a transmission system
to perform an automatic protection switch following the
detection of a transmission defect. Events occurring during
protection switching are shown:

Event P NS Error-Free
Detection M5 Raksad Switch Fiermoneed Sync Operation

> g > > L >

If a fiber break causes protection switching in a network
element, an Alarm Indication Signal may be initiated by the
network element. Once switching takes place, the AIS is
removed. After a period of synchronization on the protection
signal path, error-free operation is resumed.

ITU-T recommend that protection switching should take

50 milliseconds or less. While this is a difficult standard to
meet, a large part of the problem is in actually initiating the
protection switch. There are two methods to achieve this
effectively:

¢ Create a LOS failure, which will typically be detected in
under 100 microseconds.

¢ Generate control parity errors on the protected system.

Each method has its own advantages and is ideal for particular
test scenarios.

For more information, see:

¢ “Test Configuration for Measuring Service Disruption
Time" on page 443

¢ “Contributors to Protection Switching Time" on page 444
¢ “Protection Switching Time Test Methods" on page 446
e “Measuring Protection Switch Time" on page 447

¢ “Understanding Service Disruption Test Results" on page 453
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Test Configuration for Measuring Service Disruption Time

Transmission Element

Tributary
Loopback

Working

—

Pratection

—

Transmission Element

|:|-¢

-
-
-

| SONETISOH or
POHIDS Tributary

L]
-
-
eemad

To measure service disruption time, insert a PRBS pattern at
the tributary side of the device-under-test, looping it back on
itself on the corresponding drop-side tributary. Monitor the
received PRBS for errors as a switch occurs.

Result accuracy and reliability are based on the instrument’s
ability to measure the duration of error bursts associated with a
protection switch event.

By measuring service disruption time from the tributary-side of
the system-under-test, the measurement will be independent of
the protection switching architecture. This setup supports all
protection switching architectures. The performance of the

system-under-test cannot be affected by the instrument since
results are obtained through passive monitoring of the PRBS for

€errors.
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Contributors to Protection Switching Time

Transmission:

Nebwork Event:

Tx wia working fiberpath I Tu wia protection fben‘path

Failure on
winrking flber

Fallure detected by NE; Switch to protection
protection switch triggered : fiber/path complete

444

Instrument

Detected Error Burst:

setual protection »
i ¢ swiiching time H

S agsired profeciion N '\ Instrumant reqains alignment
;" : switchiimg tire ¥ 1o test patterm

.—| G o>

Eauly Detection Time: .
Varines with type of failum; LOS failores ?H :“_':E’:;?; :“‘ ?:IEI]“L:EJ'HIITTGILTS;F
are detected in less than 100 L8 el il -V -

= Unframed Pattern: 50y Irstiument)

When a protection switch is triggered (a fiber break can trigger
a protection switch), it results in the PRBS test pattern being
corrupted for a short period. The duration of this corruption is
controlled by the following factors:

¢ The system’s fault detection time
¢ The system’s protection-switching time

¢ The time taken by the instrument to re-align to the pointers
(SONET/SDH tributary only) and test pattern

System Fault Detection Time

For fault detection time, this is achieved by triggering the
protection switch using a failure that results in a LOS defect.
Although ITU-T G.783 (2000) defines LOS detection time as
being “in the province of regional standards”, it provides an
example based on a value of less than 100 microseconds (less
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than 0.2% of the maximum acceptable protection-switching
time). In the case of pointer and pattern acquisition, the
required times are 125 to 375 microseconds for STS/AU
pointers, and 500 to 1500 microseconds for VT/TU pointers.

System Protection Switching Time

When measuring a system’s protection-switching time, the total
systematic error associated with the instrument’s service
disruption measurement can be restricted to between

+0.3% to +4.05% of the maximum acceptable switching time.
Consequently, it can be relied on to accurately evaluate this
important system specification.
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Protection Switching Time Test Methods

Many SONET/SDH linear and ring networks have built-in fault
restoration known as Automatic Protection Switching (APS).
However, the basic principles behind the instrument’s Service
Disruption measurement, and its application in verifying a
transmission system’s protection switching time, remain valid.

Following a failure, full service is not restored until all the
Bridge and Switch operations are completed. A key goal for
Network Equipment Manufacturers (NEMs) is to keep service
disruption as short as possible, as their customers (Network
Operators) will demand that all systems deployed in the
network meet or exceed the specification published by the
governing standards body (Telcordia or ITU-T). This section
deals with the challenge of making meaningful and repeatable
measurements of Protection Switch Time.

Protection Switching Summary

Head-End Hode Tail-End Node
Failure
Brid Switch
Lg T = x L —
..... .. e T e ....._._...._._._.--------------------.. ——————— ._._.__..
Brid
I R ] SR
== -= Protection Cirowit e —
Working Circujt
The diagram shows the state of the nodes after a switch has
taken place. A typical sequence of events is listed below:
1 The Tail-End node detects the failure and signals the
Head-End to request a Protection Switch.
2 The Head-End node performs a Bridge or Bridge and Switch
operation, and sends back an acknowledgement.
446 User Guide
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3 The Tail-End node receives the acknowledgement and
performs a Bridge and Switch operation, then finishes by
sending a status message to the Head-End.

4 The Head-End node finishes by performing a Switch
operation if necessary.

Measuring Protection Switch Time

The Protection Switch Time of a transmission system should be
equal to or less than 50 milliseconds. The switching process is
dominated by the protocol processing time at each node on the
Protection Circuit. The ITU-T standards specifies Protection
Switch Time and the ‘detection times’ for various SF and SD
conditions.

Protection switching can be initiated by the following events:

1 Signal Fail (SF): usually loss of signal, loss of framing, or a
very high error ratio such as 10E-03 or greater.

2 Signal Degrade (SD): a persistent background error rate that
exceeds a provisioned threshold in the range 10E-05 to
10E-09. Note that, at the Multiplex Section level, ITU-T G.806
(October 2000 draft) specifies the ‘detection time’ for these
errors as 10E-09.

To reliably measure protection switching time, you need to
measure the service disruption time associated with a SF/SD
condition that either minimizes the ‘detection time’ (create a
LOS failure - typically detected in less than 100 ms), or
eliminates the ‘detection time’ (generate control Parity Errors
(B2 and B3) on the entity being protected). Dividing service
disruption time into its component parts is necessary due to the
wide variation in detection times for different SF/SD
conditions.

Detection Times

These range from 100 microseconds for a LOS failure to 10,000
seconds for a Signal Degrade that has a provisioned threshold of
10E-09 error rate. Also, the nature of some faults can be very
unpredictable. For example, when a fiber is damaged during

447
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construction work it may not break cleanly. Instead, the optical
signal may fade over several tens of milliseconds or vary
erratically before finally disappearing. So the ITU-T standards
require that, once SF/SD is detected, a Protection Switch event
must be completed in 50 milliseconds or less. This is a tough
requirement, but if it is met, end-users will not normally notice
a Protection Switch event even allowing for a realistic SF/SD
detection time.
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Generating LOS Failure

This diagram shows three ways to generate a LOS failure.

Head End

LOS Generation:
Thiu made
DMsconnect Fibre
—— ¥ . Programmable attenuator [P Tail End »
Mode
L [ (e >

} R H
Working Circuit a PRES :
----------- Protection Circuit Tribustary Loophack
————————— Tributaries

Generate PRES & Measure

Senvice Disruption

If you use Thru mode, the LOS condition is induced by either
switching off the instrument’s laser transmitter or using its
alarm generation controls to transmit LOS. Both of these
controls produce a predictable and instantaneous LOS
condition, and consequently enable repeatable and accurate
protection switching time measurements to be performed.

The only source of measurement error associated with this
method will be due to the LOS detection time being included in
the service disruption time result. This is the recommended
method for generating a LOS failure when measuring protection
switch times.

If you manually disconnect an optical fiber, you will generate
the LOS (but it is not an instantaneous LOS). The power level
will roll-off over the time taken to perform the disconnect.
Consequently, variation in the ‘speed’ of manual disconnection
can lead to poor result repeatability.

Exercise extreme caution when disconnecting an optical fiber —
follow your organization’s standard safety procedures.
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If you insert a programmable optical attenuator in to the
working circuit, you have a more predictable method of
inducing LOS. However, it may not fully address the issue of
‘measurement error’ due to the optical power level rolling-off
over a finite period of time. Most programmable optical
attenuators have a specified response time.
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Generating Excessive Errors (SF Trigger)

With the instrument in Thru mode, inject a high-rate of errors
into the parity-check byte(s) associated with the protection
system under test. In a Multiplex Section/Line protected
system, B2 parity errors are used, while HP-B3 and LP-B3/BIP-2
parity errors are used for High-order Path and Low-order Path
protected system respectively.

In the following example, the system-under-test is protected at
the Multiplex Section/Line level.

Instrument #1
— Generate max B2 errorrate Tail-End ——
»l (above SF threshold) Hode >
g
] 4
S ‘-
1‘ ; Working Circuit
i ' . - PRBS
I - Protection Circuit
‘ y Tributaries Tributary
Instrument #2 Loopback
Generate PRES & Measure
Service Disruption

To generate excessive errors and create a Signal Fail condition
in the system-under-test, inject B2 errors at rate that exceeds
the receiving NE’s provisioned threshold for the Excessive
Error condition.

To always exceed the provisioned error threshold, inject the
maximum error rate supported by the parity-check bytes (in
this case — continuously error all bits of all B2 bytes).

Since errors are only injected into the B2 parity bytes they will
not affect the traffic being carried. Consequently, no errors will
be added to the PRBS test pattern.

This method will produce accurate and repeatable protection
switching time results.
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Signal Fail (SF) Triggering a Protection Switch Sequence

Within 10 ms of injecting the B2 errors, the Tail-End node (the
NE receiving the B2 errors) will detect the Excessive Error
condition. This causes the NE to declare a SF and to initiate a
protection switch sequence.

In addition, the Tail-End node is required to insert an AIS alarm
in all down-stream traffic channels within 250 microseconds of
declaring SF. And since this AIS will overwrite the PRBS test
pattern that is transmitted and monitored by test set#2, it
causes the service disruption measurement to be triggered
(started).

B2 Errors applied

SF detected Switch completed

SF detection Protection Switching

-

b >

<10ms

AlS Inserted

I< Measured Service Disruption Time >

For standards compliant network elements, this method will
produce accurate and repeatable protection switching time
results. Its main advantage over the ‘LOS methods’ discussed
earlier is that it eliminates the ‘SF detection time’ error from
the measured result. The only technical drawback is that its
results slightly under-estimate a system’s protection switching
time — but only by up to 250 microseconds (assuming that the
Tail-End node inserts the downstream AIS within the 250
microseconds period specified in ITU-T G.783). Possibly the
most serious ‘drawback’ associated with this measurement
method is a commercial one - it requires two transmission test
sets (one covering the required tributary rates, the other
covering required line rates).
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Understanding Service Disruption Test Results

To interpret service disruption results you must understand the
rules associated with the analysis of error-burst duration.

The service disruption test measures the elapsed time between
the first and last error in an error-burst that consists of two or
more errors. The error-burst is taken as having ended when no
errors are detected for a period of greater than 200 to 300 ms
following the last error. Single errors that are separated by more
than 200 to 300 ms are not considered as being part of an
error-burst (no result is returned).

“Illustrating Service Disruption Results" on page 454 shows the
affect these simple rules have on measurement results when
different error distributions are present in the received test
pattern.
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Case 1: Result unaffected by
background errors

Case 2: Results affected by
background errors

Case 3: Two error bursts
measured separately

Case 4. Two error bursts
measured as one

@é son_Cobra.book Page 454 Wednesday, September 25,2002 11:09 AM

lllustrating Service Disruption Results

Measured

Switching Time
—1 |,
>
me
#—] Measured Switching Time

m J o
Langest Shortest & fma
. Burst *Last Burst

— NN =

< 200ms

q—fﬂeuumd Switching Tlrnel_-

Time

Key: | single background Error  [[JJll Error burst from Protection Switch

In Case 1 and Case 2, there are single errors due to a low
background error rate in the transmission system, plus an
error-burst associated with a protection-switching event. In
Case 1 the measured protection-switching time is not affected
by the background errors as these occur outside the 200 to

300 ms period used to define the end of the error-burst. In
contrast, the result obtained in Case 2 is affected due to a single
background error being present for less than 200 ms before the
error-burst actually starts. This leads to the reporting of an
artificially high protection switching time and emphasizes the
importance of ensuring that the system-under-test is error-free
before performing the measurement.

In Cases 3 and 4 the system-under-test generates two
error-bursts when a protection switch is made. The results will
be affected by the separation of these two error-bursts. In

Case 3 a result for each error-burst will be reported (since they
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are more than 300 ms apart), while in Case 4 only a single high
value will be reported (since they are less than 200 ms apart). In
both cases the reported results will indicate that a problem
exists in the system-under-test.
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Numerics

10BASE-2

10BASE-5

10BASE-FL

10BASE-T

100BASE-FX

100BASE-SX

100BASE-T

100BASE-TX

1000BASE-LX

1000BASE-SX

1000BASE-T

802.3ae
802.3z

10 Mb/s Ethernet on 200-meter segments of thin copper -
standard 75 ohm coax. (“Cheapernet” or “Thinlan”.)

10 Mb/s Ethernet on 500-meter segments of coaxial cable -
“fat” 75 ohm coax. (The original Ethernet.)

10 Mb/s Ethernet on 2-km multimode fiber-optic cables at
850 nm.

10 Mb/s Ethernet on 200-meter loops of unshielded twisted
pair copper - UTP Cat 3.

100 Mb/s Ethernet on 2-km multimode or 10-km single-mode
fiber-optic cables at 1310 nm.

100 Mb/s Ethernet on 2-km multimode fiber-optic cables at
850 nm.

100 Mb/s Ethernet on 200-meter loops of unshielded twisted
pair copper.

100 Mb/s Ethernet on 200-meter loops of unshielded twisted
pair copper - UTP Cat 5.

1 Gb Ethernet on 2-km multimode or 10-km single-mode
fiber-optic cables at 1310 nm.

1 Gb Ethernet on 2-km multimode fiber-optic cables at
850 nm.

1 Gb Ethernet on 30-meter loops of unshielded twisted pair
copper - UTP Cat 5.

The IEEE standard for 10 Gb Ethernet.

The IEEE standard for 1 Gb Ethernet.
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AAL
ABR
ADM
ADPCM
AlS
AlS-P
AlS-L
AlS-V
AlS-C
AMI
ANSI
APS
ASCII
AT™M
AU
AU-AIS
AU-LOP
AU-NDF

BBE
BBER
BC
BCD
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ATM Adaption Layer.

Available Bit Rate.

Add and Drop Multiplexer.

Adaptive Coded Differential Pulse Coded Modulation.
Alarm Indication Signal.

Synchronous Transport Signal Path Alarm Indication Signal.
Line Alarm Indication Signal.

Virtual Tributary Path Alarm Indication Signal.
Concatenated Signal Alarm Indication Signal.
Alternate Mark Inversion.

American National Standards Institute.

Automatic Protection Switch.

American Standard Code for Information Exchange.
Asynchronous Transfer Mode.

Administrative Unit.

Administrative Unit Alarm Indication Signal.
Administrative Unit Loss Of Pointer.

Administrative Unit New Data Flag.

Background Block Error.
Background Block Error Ratio.
Background Channel.

Binary Coded Decimal.

457

ﬁ%

rs



el @

@é son_Cobra.book Page 458 Wednesday, September 25,2002 11:09 AM

7  Telecoms Concepts

BER
BERT
BIP
BPS
BPV
B3zS
B8ZS

CAN
CAS
Catb
CATV
CBR
CCITT

CcCs
CDT
cov
CEPT
CMI
co
CoS
CRC
CSES

458

Bit Error Rate.

Bit Error Rate Test.

Bit Interleaved Parity.

Bits Per Second.

Bipolar Violation.

Bipolar with 3 Zero Substitution.

Bipolar with 8 Zero Substitution.

Campus Area Network.

Channel Associated Signaling.

Category 5 unshielded twisted pair copper.
Cable Television.

Constant Bit Rate.

Consultative Committee for International Telephony and
Telegraphy.

Common Channel Signaling.
Cell Delay Tolerance.

Cell Delay Variation.
Committee of European PTTs.
Coded Mark Inversion.
Central Office.

Class of Service.

Cyclic Redundancy Check.

Consecutive Severely Errored Seconds.
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CSMA/CD
CvV-L
CV-LFE
CV-P

CV-PFE

CV-S
Cvv
CV-VFE

D/1
DACS
dB
DCC
DCS
DDF
DDN
DSn
DTMF
DUT
DWDM
DXC

Telecoms Concepts

Carrier Sense, Multiple Access with Collision Detection.
Line Code Violation, also L-BIP.
Line Far End Code Violation, also REI-L.

Synchronous Transport Signal Path Code Violation, also
P-BIP.

Synchronous Transport Signal Path Far End Code Violation,

also REI-P.
Section Code Violation, also S-BIP.
Virtual Tributary Path Code Violation, also V-BIP.

Virtual Tributary Far End Code Violation, also REI-V.

Drop and Insert.

Digital Access and Cross-connect Switch.
Decibel.

Data Communications Channel.
Digital Cross-connect Switch.

Digital Distribution Frame.

Digital Data Network.

Digital Signal Hierarchy.

Dual Tone Multi-Frequency signaling.
Device Under Test.

Dense Wave Division Multiplexing.

Digital Cross-connect Switch.
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EB
EBCDIC
EOW
ES

ESF
ESR
ETSI

FAS
FC
FCS
FDDI
FDM
FEAC
FEBE
FEC
FERF

GBIC
GP-IB
GUI

460

Errored Block.

Extended Binary Coded Decimal Interchange Code.
Engineering Order Wire.

Errored Second.

Extended SuperFrame format.

Errored Second Ratio.

European Telecommunications Standards Institute.

Frame Alignment Signal.
Foreground Channel.

Frame Check Sequence.

Fiber Distributed Data Interface.
Frequency Division Multiplexing.
Far End Alarm Channel.

Far End Block Error.

Forward Error Correction.

Far End Receive Failure.

Gigabit Interface Converter.
General Purpose Interface Bus.

Graphical User Interface.
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HDB3
HDLC
HEC

HO

HO PTE
HP-BIP
HP-PLM
HP-RDI
HP-REI
HP-TIM
HP-UNEQ
Hz

ICMP
IEC
IHL

ISDN
ISO
ITU

IXC
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High Density Bipolar 3.

High-level Data Link Control.

Header Error Control.

High Order.

High Order Path Terminating Equipment.
High Path Bit Interleaved Parity error.
High Path Payload Label Mismatch.
High Path Remote Defect Indication.
High Path Remote Error Indication.
High Path Trace Identifier Mismatch.
High Path Unequipped.

Hertz.

Internet Control Message Protocol.

Incoming Error Count.

Internet Header Length.

Internet Protocol.

Integrated Services Digital Network.
International Organization for Standardization.

International Telecommunications Union -
Telecommunications.

Inter eXchange Carrier.
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K

K-bytes K1 and K2.

L

LAN Local Area Network.
LCD Loss of Cell Delineation.
LEC Local Exchange Carrier.
L-BIP Line Bit Interleaved Parity error, also CV-L.
LCP Link Control Protocol.
LLC Logical Link Control.

LO Low Order.

LOF Loss of Frame.

LOM/LOMEF Loss of Multiframe.

LOP Loss of Pointer.
LOP-C Loss of Concatenation.
LOP-P Synchronous Transport Signal Path Loss Of Pointer.
LOP-V Virtual Tributary Path Loss Of Pointer.
LOS Loss of Signal.
LP-BIP Low Path Bit Interleaved Parity error.
LP-PLM Low Path Payload Label Mismatch.
LP-RDI Low Path Remote Defect Indication.
LP-REI Low Path Remote Error Indication.
LP-RFI Low Path Remote Failure Indication.
LP-TIM Low Path Trace Identifier Mismatch.
LP-UNEQ Low Path Unequipped.
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LSB
LT™M

MAC
MAN
M/F LOSS
MMF
MS
MS-AIS
MS-BIP
MSOH
MSP
MS-RDI
MS-REI
MSTE
MTBF
MTJ
MUX

NDF
NE
NFAS

Telecoms Concepts

Least Significant Bit.

Line Terminal Multiplexer.

Media Access Control.

Metropolitan Area Network.

Loss of Multiframe (PDH).

Multi Mode Fiber.

Multiplexer Section.

Multiplexer Section Alarm Indication Signal.
Multiplexer Section Bit Interleaved Parity error.
Multiplexer Section OverHead.

Multiplexer Section Protection.

Multiplexer Section Remote Defect Indication.
Multiplexer Section Remote Error Indication.
Multiplexer Section Terminal Equipment.
Mean Time Between Failures.

Maximum Tolerance Input Jitter.

Multiplexer.

New Data Flag.
Network Element.

Non Frame Alignment Signal.
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0AM
oc
0Ch
0DI
obu
OEl
OH
OLTU
ONNI
00F
ooMm
0PU
0S
0SC
0SI
0T™
O0TN
0TU

P/AR
P-BIP

PBX

Operations, Administration and Management.
Optical Carrier.

Optical Channel.

Outgoing Defect Indication.

Optical channel Data Unit.

Outgoing Error Indication.

Overhead.

Optical LIne Terminal Unit.

Optical transport Network Node Interface.
Out Of Frame.

Out Of Frame.

Optical channel Payload Unit.

Operating System.

Optical Supervisory Channel.

Open Systems Interconnection.

Optical Transport Module.

Optical Transport Network.

Optical channel Transport Unit.

Peak to Average Ratio.

Synchronous Transport Signal Path Bit Interleaved Parity
error, also CV-P.

Private Branch Exchange.
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PC
PCM
PCS
PCR
PDH
PES
PHY
PLM
PLM-P
PLM-V
PMD
POH
PoP
POS
PPP
PRBS
PSN
PSTN
PTE
PUAS

QoS
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Personal Computer.

Pulse Code Modulation.

Physical Coding Sublayer.

Peak Cell Rate.

Plesiochronous Digital Hierarchy.

Percentage Errored Seconds.
Physical layer device

Payload Label Mismatch.

Synchronous Transport Signal Path Payload Label Mismatch.
Virtual Tributary Path Payload Label Mismatch.
Physical Media Dependent.

Path OverHead.

Point of Presence.

Packet Over SONET.

Point-to-Point Protocol.
Pseudo-Random Bit Sequence.

Packet Switched Network.

Public Switched Telephone Network.

Path Terminating Equipment.

Path UnAvailable Seconds.

Quality of Service.
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RAI

RAI (M/F)
RDI

RDI-L
RDI-P
RDI-V
REBE

REI

REI-L

REI-P

REI-V
RFI-V
RS
RS-BIP
RSOH
RSTE
RS-TIM
RX

S/N
S-BIP
SCPI

Remote Alarm Indication.
Loss of Multiframe Remote Alarm Indication.
Remote Defect Indication.

Line Remote Defect Indication.

Synchronous Transport Signal Path Remote Defect Indication.

Virtual Tributary Path Remote Defect Indication.
Remote End Block Error.

Remote Error Indication.

Line Remote Error Indication, also CV-LFE.

Synchronous Transport Signal Path Remote Error Indication,
also CV-PFE.

Virtual Tributary Path Remote Error Indication, also CV-VFE.
Virtual Tributary Path Remote Failure Indication.
Regenerator Section.

Regenerator Section Bit Interleaved Parity error.
Regenerator Section OverHead.

Regenerator Section Terminating Equipment.

Regenerator Section Trace Identifier Mismatch.

Receiver

Signal to Noise Ratio.
Section Bit Interleaved Parity error, also CV-S.

Standard Commands for Programmable Instrumentation.
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SDH
SEF
SEP
SEPI
SES
SESR
SF
SFD
SLA
SMF
SNMP
SOH
SONET
SPE
STM
STS

TC
TC-APId
TC-BIP

TC-IAIS or
TC-INCAIS

TC-IEC
TC-00M
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Synchronous Digital Hierarchy.
Severely Errored Frame.

Severely Errored Period.
Severely Errored Period Intensity.
Severely Errored Seconds.
Severely Errored Seconds Ratio.
Super Frame.

Start Frame Delimiter.

Service Level Agreement.

Single Mode Fiber.

Simple Network Management Protocol.
Section OverHead.

Synchronous Optical Network.
Synchronous Payload Envelope.
Synchronous Transport Module.

Synchronous Transport Signal.

Tandem Connection.
Tandem Connection Access Point Identifier.
Tandem Connection Bit Interleaved Parity error.

Tandem Connection Incoming Alarm Indication Signal.

Tandem Connection Incoming Error Count.

Tandem Connection Out of Multiframe.
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TCI
TCP/IP
TC-RDI
TC-REI
TC-UNEQ
TDM
TDMA
TE

TIM
TIM-P

TIM-V
™
TMN
TOH
TPID
TU
TU-AIS
TUG
TU-LOM
TU-LOP
TU-NDF

X

468

Tag Control Information.

Transmission Control Protocol/Internet Protocol.
Tandem Connection Remote Defect Indication.
Tandem Connection Remote Error Indication.
Tandem Connection Unequipped.

Time Division Multiplexing.

Time Division Multiple Access.

Terminal Equipment.

Trace Identifier Mismatch.

Synchronous Transport Signal Path Trace Identifier
Mismatch.

Virtual Tributary Path Trace Identifier Mismatch.
Terminal Multiplexer

Telecommunications Management Network.
Transport OverHead.

Tag Protocol Identifier.

Tributary Unit.

Tributary Unit Alarm Indication Signal.
Tributary Unit Group.

Tributary Unit Loss Of Multiframe.

Tributary Unit Loss Of Pointer.

Tributary Unit Pointer New Data Flag.

Transmitter.
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UAS

ul
UNEQ
UNEQ-P
UNEQ-V
uTP
uuT

V-BIP
VBR
VC
VC-AIS
VC-n
VID
VLAN
VP

VT

VT PTE

WAN
WDM

Telecoms Concepts

UnAvailable Second.

Unit Interval.

Unequipped.

Synchronous Transport Signal Path Unequipped.
Virtual Tributary Path Unequipped.

Unshielded Twisted Pair.

Unit Under Test.

Virtual Tributary Path Bit Interleaved Parity error, also CV-V.

Variable Bit Rate.

Virtual Channel (ATM).

Virtual Container Alarm Indication Signal.
Virtual Container.

VLAN Identifier.

Virtual Local Area Network.

Virtual Path (ATM).

Virtual Tributary.

Virtual Tributary Path Terminating Equipment.

Wide Area Network.

Wave Division Multiplexing.
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WIS

WWDM

X-Connect

X-bits

Y/Z

Yellow

WAN Interface Sublayer.

Wide Wave Division Multiplexing.

Cross-Connect.

DS3 bits, X1 and X2.

Yellow Alarm.
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Numerics

1000BASE-LX

Ethernet notation, 396
1000BASE-SX

Ethernet notation, 396
100BASE-TX

Ethernet notation, 396
10BASE-T

Ethernet notation, 396

A

A1, A2 framing byte
SONET (Concepts), 378
Accessories, 20
additional documentation, 20
carrying cases, 20
optical adapters and cables, 20
Advertisement Register
Ethernet, 297
Alarms
adding (DSn), 244
adding (PDH), 196
adding (SONET), 133
definition, 440
monitoring (DSn), 277
monitoring (PDH), 223
monitoring (SONET), 169
APS messages
generating (SONET), 111
APS messages (Concepts)
linear (SONET), 381
ring (SONET), 383
Arrow navigation buttons, 22
Automatic Protection Switching
monitoring (SONET), 143
Auto-negotiation, Ethernet, 296

B1 byte
SONET (Concepts), 378
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B2 byte

SONET (Concepts), 379
B3 byte

SONET (Concepts), 386
Basic user interface operations, 45
BIP Labelling, SignalWizard, 343
Bring into service (M.2110)

(Concepts), 435

C

C2 signal label byte

SONET (Concepts), 386
CD-ROM resources, 368
Checkboxes, 50
Clock ports, 32
Clock source

selecting (DSn), 233

selecting (PDH), 185

selecting (SONET), 105
Concatenated payloads

generating (SONET), 123

monitoring (SONET), 149
Confidence Test (Self Test), 345
Connectors

DCC, 33

electrical test ports, 34

ethernet ports, 35

external protective earth, 36

GPIB, 36

keyboard, 37

LAN, 37

left side, 36

mouse, 37

optical in, 31

optical out, 30

right side, 37

RJ45, 37

RS232, 37

top panel, 29

USB, 37

VGA, 38
Context-sensitive help, 54
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Coupling

receiver to transmitter (DSn), 232
receiver to transmitter (PDH), 184
receiver to transmitter

(SONET), 104
transmitter to receiver (DSn), 252
transmitter to receiver (PDH), 200
transmitter to receiver

(SONET), 139

D

Date/time settings, 334
DCC
dropping messages (SONET), 145
inserting messages (SONET), 115
DCC bytes (D4 to D12)
SONET (Concepts), 379
DCC channel (D1 to D3)
SONET (Concepts), 378
Drop
DSn payload (from SONET), 156
PDH payload (from SONET), 158
Drop-down list box, 45

E

Edit field, 46

Electrical signals
receiving (SONET), 138
transmitting (SONET), 103

End-to-end test mode
Ethernet, 287

Enhanced RDI, 343
monitoring (SONET), 169

Errors
adding (DSn), 243
adding (PDH), 195
adding (SONET), 133
definition, 441
monitoring (DSn), 273
monitoring (PDH), 219
monitoring (SONET), 170
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Ethernet
Auto-negotiation, 296
Negotiation status, 296
ports, 35

Ethernet Capability, 15

Ethernet frame type selection, 296

Ethernet Notation
1000BASE-LX, 396
1000BASE-SX, 396
100BASE-TX, 396
10BASE-T, 396

Ethernet White paper, 393

Expert Mode
Ethernet, 291

F

F1 user channel byte
SONET (Concepts), 378
F2 user channel byte
SONET (Concepts), 386
FAQs (Frequently Asked
Questions), 368
FEAC messages
monitoring (DS3), 262
transmitting (DS3), 245
File management, 357
copying files to a floppy disk, 358
deleting files from a floppy
disk, 360
deleting files from the
instrument, 361
file types, 357
importing files from a floppy
disk, 359
Fixed stuffing bytes, overwriting, 343
Floppy disk drive (location), 36
Floppy disk drive, using, 357
Folder selector, 47
Frame type selection
Ethernet, 296
Framed signal
monitoring (DSn), 253
monitoring (PDH), 201
transmitting (DSn), 235
transmitting (PDH), 187
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Frequency
measuring (DSn), 270
measuring (PDH), 216
measuring (SONET), 166
Frequency offset
adding (DSn), 234
adding (PDH), 186
adding (SONET), 106
Front panel soft recovery (cold
start), 367
Front panel tour, 21
Function controls, 21

G

G.821 (Concepts), 429
G.826 (Concepts), 430
(.826/G.828 analysis
errors/alarms (SONET), 179
G1 path status byte
SONET (Concepts), 386
Glossary, 456
Graphs, 335
GUI
checkboxes, 50
Drop-down list box, 45
Folder selector, 47
Graphical User Interface, using, 39
live edit /edit field, 46
Mapping diagram, 49
modal window, 48
More button, 49
numeric entry box, 46
summary window/diagram, 41
text entry box, 47

H

H1 to H3 bytes
SONET (Concepts), 380

H4 position indicator byte
SONET (Concepts), 386

Help
accessing the online index, 54
context-sensitive help, 54
using online help, 53

Help function keys, 26
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Index, accessing the online, 54
Insert
external DSn payload (to
SONET), 130
external PDH payload (to
SONET), 132
Instrument cold start/reboot, 367

ITU performance analysis (Concepts),

G or M series, 428

J

J0 trace byte
SONET (Concepts), 378
J1 path trace byte
SONET (Concepts), 386
J2 path trace identifier
SONET (Concepts), 389
Jitter due to pointer adjustments
SONET, 116

K

K1, K2 bytes

SONET (Concepts), 379
Keyboard, 22
Keyboard connector (location), 57
Keyboard lock, 344
Keyboard, using an external, 57

L

LEDs, status and alarm, 27

Live edit, 46

Logging measurement results, 331

Loop codes
monitoring (DS1), 265
transmitting (DS1), 246

Loopback test mode
Ethernet, 288

Loopthru test mode
Ethernet, 290

LP Ability Register
Ethernet, 297
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M.2100 (Concepts), 433
M.2101 (Concepts), 432
M.2110 (Concepts), 434
M.2120 (Concepts), 436
MO0 remote error indication byte
SONET (Concepts), 379
M1 byte
SONET (Concepts), 379
Mainframe test rate capability, 17
Manufacturing data, 344
Mapping diagram, 49
MDIX Status Bit
Ethernet, 297
Measurement gating
Ethernet, 326
Measurement logging, 331
Measurement Record System, 335
Measurement timing control, 332
Measurement tutorial
Ethernet, 1 port loopback
testing, 87
Ethernet, 2 ports loopback
testing, 89
Ethernet, end to end testing, 85
Ethernet, loopthru testing, 92
Ethernet, VLAN tagging, 94
SONET, 73
Modal window, 48
More button, 49
Mouse connector (location), 57
Mouse, using an external, 57

Navigation controls, 22
Negotiation status, Ethernet, 296
Network standard

SDH/SONET operation, 342
Numbering scheme, 1-to-N, 343
Numeric entry box, 46
Numeric entry keys, 22
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0

Online help, using, 53
Operator maintenance
general, 365
Optical cables
connecting, 59
disconnecting, 59
Optical connector safety
information, 59
Optical connectors, 18
alternatives, 19
cleaning, 365
types, 18
Optical connectors (location), 29
Optical interfaces, 18
Optical power
measuring (SONET), 164
Optical receiver overload, avoiding, 60
Options
certificate of calibration, warranty,
service plans, 19
enhanced testing upgrades, 19
Ethernet, 19
guide, 17
other, 19
system options, 341
UK®6, 19
Orderwire byte (E1)
SONET (Concepts), 378
Orderwire byte (E2)
SONET (Concepts), 379
Overhead bytes
editing (SONET), 113
monitoring (SONET), 144
Overwriting STS-1 fixed stuffing
bytes, 343
Own help files, 353

P

Path allocation (ITU
recommendations), 428
Path overhead (STS) (Concepts), 386
Path signal labels
generating (SONET), 110
monitoring (SONET), 142

ﬁ%

Payload dropping
2 Mb/s payload (from PDH), 209
DS1 payload (from DS3), 260
Payload inserting
external signal into DSn, 242
external signal into PDH, 194
Payload monitoring
DSn payload (SONET), 155
PDH payloads (SONET), 157
SONET, 146
Payload transmitting
DSn payloads (SONET), 129
PDH payloads (SONET), 131
SONET, 120
Performance analysis
monitoring (DSn), 283
monitoring (PDH), 228
Performance events (ITU
recommendations), 428
Pointer adjustment
burst (SPE), 117
new (SPE), 118
Pointer offset
selecting (SONET), 119
Pointer values
adjusting (SONET), 116
monitoring (SONET), 175
Pre-set mode
Ethernet, 291
Print Control key, 28
printer setup, 362
saving/printing screendumps, 363
Printer setup, 362
Printers, recommended, 363
Product description, 14
Pulse mask
viewing (DSn), 271
viewing (PDH), 217
viewing (SONET), 167

Q

Questions, frequently asked, 368
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RDI, enhanced, 343
Receiving signals
DSn, 251
PDH, 199
SONET, 136
Remote control
GPIB, 349
LAN, 349
RS232, 349
Results summary
monitoring errors and alarms
(Ethernet), 325
RFC 2544
Conformance tests (Ethernet), 304
Frame loss test (Ethernet), 309
Latency test (Ethernet), 308
Throughput test (Ethernet), 307
Rocket Diagram (Mapping
Diagram), 49
Round trip delay
measuring (DSn), 282
measuring (PDH), 227
measuring (SONET), 178
Run/Stop
Ethernet, 326

S

S1 sync status byte
SONET (Concepts), 379
Sa bits
monitoring (DSn), 263
monitoring (PDH), 210
Safety information, 58
Screendumps
saving/printing, 363
Section overhead (SOH)
(Concepts), 378
Self Test
Confidence Test, 345
Service disruption time
measuring (DSn), 279
measuring (PDH), 225
measuring (SONET), 176
Service plans, 20
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Show More key, 28
Si bits
monitoring (DSn), 263
monitoring (PDH), 210
Signal label (V5)
SONET (Concepts), 389
Signal level
measuring (DSn), 269
measuring (PDH), 215
Signaling bits
monitoring (DSn), 264
monitoring (PDH), 211
SignalWizard
all channel testing, 64
BIP labelling, 343
exiting, 65
in-service monitoring, 71
monitoring path trace
messages, 69
out-of-service testing, 72
Smart Test, 62
reset instrument, 63
shortcuts, 63
Software/firmware revision, 341
SONET/SDH Capability, 14
Spare bits
monitoring (DSn), 263
monitoring (PDH), 210
SPE pointer
adjustment (burst), 117
new, 118
offset, 119
selecting a burst, 117
Storing/recalling settings
DSn, 267
PDH, 213
SONET, 162
STS path overhead (POH)
(Concepts), 386
STS pointer
adjustments, 116
STS-1 numbering, 343
Summary window/diagram, 41
Sync status byte (S1)
SONET (Concepts), 379
Synchronization status messages
generating (SONET), 109
monitoring (SONET), 141
System options, 341
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System preferences, 342

enhanced RDI, 343

G.826 collect ES, SES, BBE while
path unavailable, 343

laser clears on power up, 343

MS-AIS/AIS-L alarm monitor, 343

MS-REI/REI-L result monitor, 343

MS-REI/REI-LMO, M1 byte usage
(STM-64.0C192), 342

overwriting STS-1 bulk filled stuff
column, 343

SONET operation, 100

T

Technical Specifications (on
CD-ROM), 368
Test Functions
switching off (DSn), 249
switching off (PDH), 197
switching off (SONET), 134
Test mode
Ethernet, 286
Text entry box, 47
Text entry keys, 24
THRU mode
DSn, 266
PDH, 212
SONET, 160
Time/date settings, 334
Trace messages
generating (SONET), 108
monitoring (SONET), 141
Transceiver Coupling
Ethernet, 326
Transmit interface
setting up (SONET), 101
Transmitting signals
DSn, 231
PDH, 183
Trouble Scan
error monitoring (SONET), 173
monitoring errors and alarms
(DSn), 278
monitoring errors and alarms
(PDH), 224
Tx eye clock
Ethernet, 302
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Tx/Rx Coupling
Ethernet, 326

U

Unframed signal
monitoring (DSn), 259
monitoring (PDH), 207
transmitting (DSn), 241
transmitting (PDH), 193

User’s own help files, 353
accessing your files, 356
creating an index, 353
creating new files, 353

vV

Voice channel
dropping to internal speaker (from
DSn), 261
dropping to internal speaker (from
PDH), 208
dropping to internal speaker
(SONET), 159
VT POH (VT path overhead)
(Concepts), 389

W

White Paper
Ethernet, 393

z

Z7 Interpretation, 391
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